Window list entries colored in white instead of dark (GNOME Classic / Ambiance theme)

Bug #981289 reported by Benjamin Drung on 2012-04-14
256
This bug affects 53 people
Affects Status Importance Assigned to Milestone
light-themes (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

In GNOME Classic (with gnome-panel) with the Ambiance (default) theme, the window list and the show desktop icon are colored in white instead of the dark color (see attached screenshot).

[Test Case]
1) sudo apt-get install gnome-panel
2) Close your current session and start Gnome-Classic Session in LightDM.
3) Select 'Ambiance' as theme (in case you changed the default theme).
4) Open a nautilus window or any other application and look at the Panel

[Regression Potential]
The fix can lead to a regression in the visual appearance of the GNOME panel in the Classic session. Other sessions could not be affected.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: light-themes 0.1.9.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic i686
ApportVersion: 2.0.1-0ubuntu2
Architecture: i386
Date: Sat Apr 14 02:24:56 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
SourcePackage: light-themes
UpgradeStatus: Upgraded to precise on 2012-03-06 (38 days ago)

Related branches

Benjamin Drung (bdrung) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Zon Saja (zonsaja) wrote :

From what I've found and experiment by editing the original Ambiance theme in latest Ubuntu 12.04 beta, it seems that the problem is a non-existence of the " :backdrop " (unfocused) statement in the css file (gnome-panel.css).

The bug is found not only in Window List and Show Desktop buttons, but also in the Menubar applet on GNOME panel in GNOME classic session on Precise. See this screenshot:
http://dl.dropbox.com/u/36251983/zontesAmbiance-screenshot-original.jpg

I have already fix this issue for my own use and quite happy with the result. What I did was adding :backdrop statements to several css selector, like you can see in the attachment (gnome-panel.css). This is the result:
http://dl.dropbox.com/u/36251983/zontesAmbiance-screenshot-modified.jpg

I also made modifications for Ubuntu based on the original Ambiance theme. If anyone interested using it or anything, you can download here:
http://dl.dropbox.com/u/36251983/zonModAmbiance-20120418.tar.gz

I hope this bug can be fixed before the final release of Ubuntu 12.04 on April 26th.

Thank you.

.

Andrea Cimitan (cimi) on 2012-04-29
Changed in light-themes (Ubuntu):
status: Confirmed → Fix Committed
Felix Moreno (felix-justdust) wrote :

Thanks for fixing it Zon Saja, we are lot of users that still use this gnome 2 stye, bests!

Hello everybody!

I'm suffering the same bug, but I don't know how to apply this fix. If someome tells me how to apply the solution step by step I would be highly grateful.

Thank you!

Bob Bib (bobbib) wrote :

japenaisern,
as for now, if you wish to fix it manually, you need to edit the 'gnome-panel.css' style file;
IMHO, it's better to wait until this fix is released as a regular package update.

Ok, I'll wait for an update. Somebody knows when the fix will be released?

I couldn't wait for an update and I decided to apply the changes for my own. Now it looks different and fine. Thank you everybody!

Felix Moreno (felix-justdust) wrote :

It's seems to be fixed, but since them the 3d effects are not working in gnome panel mode...

@ Felix Moreno

Can you be more specific? Do you mean that the complete compiz effects are not working anymore (just as the fallback without effects mode)?

Felix Moreno (felix-justdust) wrote :

Exactly, unity 3d works, but gnome 3d doesn't. could be due to this fix? bests

Bob Bib (bobbib) wrote :

felix-justdust,
you seem to be wrong: the fix is not released yet, it's just pushed into repository and waiitng for merge.

Felix Moreno (felix-justdust) wrote :

I didn't do anithing but normal updates and now, the color of the text of Aplications and Places is right, and the background of the desktop icon acces is transparent ... something changed... and i didn't apply any special patch, and my 3d is not working on gnome classic but in unity works.

Dmitry Shachnev (mitya57) wrote :

This bug seems to occur only when using Compiz, so the temporary workaround is using "GNOME Classic (no effects)" session.

Bob Bib (bobbib) wrote :

mitya57,
sometimes it even happens with "GNOME Classic (no effects)" session.

Any chance we could get the fix pulled into a new package in precise-proposed?

Julian Clark (julian.clark) wrote :

I can confirm that the fixes from revision 225 resolve the issues with the combination of Compiz and GNOME Classic. (For a desktop deployment, I created a session type that has GNOME Classic as the base, and Compiz running on top of it.) Now, it's just a matter of waiting for the Ubuntu Artwork Packagers to create a new package...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.9.2-0ubuntu1

---------------
light-themes (0.1.9.2-0ubuntu1) quantal; urgency=low

  * New upstream snapshot
    - Add backdrop option, fixes Ambiance theming for menu bar & window
      list (LP: #955376, LP: #981289)
    - Enable the Ubuntu icon for the Applications menu (LP: #986988)
 -- Ken VanDine <email address hidden> Wed, 30 May 2012 14:51:05 -0400

Changed in light-themes (Ubuntu):
status: Fix Committed → Fix Released
Bob Bib (bobbib) wrote :

> light-themes (0.1.9.2-0ubuntu1) quantal; urgency=low

And what about Precise?

Any release of this package for Precise? I don't understand this...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu Precise):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

This bug is missing information detailed in https://wiki.ubuntu.com/StableReleaseUpdates#Procedure for it to comply with Stable Release Updates process. Please add information regarding the impact of the bug, a test case for recreating and the regression potential. Once this information is added to all the bugs addressed by the package in -proposed we will approve the upload. Thanks!

S.Rey (s.rey) wrote :

I think the bug description is very clear, but just in case...

[Test Case]
1) Install ubuntu (Precise)
2) sudo apt-get install gnome-panel
3) Close your current session and start Gnome-Classic Session in LightDM.
4) Open a nautilus window or any other application and look at the Panel

I don't know about Regression Pottential, so I leave it for some developer willing to help.

I hope this is solved soon, as having this kind of cosmetic glitches in a LTS, in the Classic Desktop default theme doesn't give a good impression about the stability of the distribution. (This adds to some compiz bugs which would need some attention).

Benjamin Drung (bdrung) wrote :

Thanks Rey, I added your test case to the bug description. The regression potential is quite small, because only the theme could be effected.

description: updated
Mark Jackson (mpfj) wrote :

I also have this problem, and know how to recreate it under 12.04 + Gnome Classic.

The bottom taskbar colours are wrong, but if you repeatedly minimise / restore a window, they eventually sort themselves out.

But on the next click, the colours go wrong again.

Hope that helps ...

Jarvis Schultz (schultzjarvis) wrote :

I get these weird vertical gradient striations on one of my 12.04 machines when I apply zonsaja's patch. My other machines it fixed the problem... any idea what could be causing this?

See attached image.

Whoopie (whoopie79) wrote :

Please find a debdiff for precise-proposed

Whoopie (whoopie79) wrote :

Sorry, debdiff doesn't work, the build dependencies for quilt are missing.

Whoopie (whoopie79) wrote :

Please find attache the correct debdiff for precise-proposed.

Hi Whoopie,

Is it an official update or just your personal fix? Could you add an screenshot to see how this works?

Thank you!

Benjamin Drung (bdrung) wrote :

Whoopie, thanks for the patch. There are a few things that should be discussed before I upload it to precise-proposed:

1) Bug #955376 and #986988 need a test case.
2) All three bugs need a regression potential analysis. I guess that regression could only affect the visual appearance of the GNOME panel in the Classic session.
3) Is this package a native package or not?

If this package is a native package, then please drop all patches, apply the changes directly, and get rid of the revision in the package version. In the other case, please change the source format to "3.0 (quilt)" and provide a orig source tarball.

Whoopie (whoopie79) wrote :

Juan, the proposed debdiff is a diff between light-themes 0.1.9.1 and 0.1.9.2.

We could also just backport the version 0.1.9.2 to precise. This would perhaps be the best solution.

Whoopie, I have been waiting for the release of this fix since last April, but nothing has been done. I think that this issue should has already been solved for Precise.

Now I'm using Kubuntu, because the only way to use Ubuntu in my old laptop is with gnome-panel. I hope this to be solved as soon as possible.

Benjamin Drung (bdrung) wrote :

I switched the dpkg source format from 3.0 (native) to 3.0 (quilt) and added a DEP3 header to your fix-ambiance-in-gnome-panel.patch. The attached patch is the uploaded version.

Changed in light-themes (Ubuntu Precise):
status: Confirmed → Fix Committed
description: updated

Hello Benjamin, or anyone else affected,

Accepted light-themes into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/light-themes/0.1.9.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
pcworld (pcworld) wrote :

I confirm that light-themes 0.1.9.1-0ubuntu1.1 from proposed fixes this bug as well as several others.

The only glitch I've noticed so far:
When a window is focused or you hover above a window item, the background color of the window icon isn't entirely correct.

Screenshot of proposed version: http://www.abload.de/img/proposedx3dxe.png
The second window is currently focused. When you take a close look at the window icon, you see that the icon background color doesn't entirely match the rest of the window item.

This doesn't happen in 0.1.9.1-0ubuntu1 (no matter if the window panel is currently dark or white): see http://www.abload.de/img/stock-when-darkvge9d.png and http://www.abload.de/img/stock-when-whitejydwd.png

Though considering how many serious bugs the proposed version fixes this little glitch shouldn't really matter, so I vote for the proposed version to go into updates!

Benjamin Drung (bdrung) wrote :

pcworld, can you open a new bug report for that background color bug?

Felix Moreno (felix-justdust) wrote :

It works! Thanks!

Dmitry Shachnev (mitya57) wrote :

Marked as verification-done per comments 36 and 38.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.9.1-0ubuntu1.1

---------------
light-themes (0.1.9.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/fix-ambiance-in-gnome-panel.patch:
    - Add backdrop option, fixes Ambiance theming for menu bar & window
      list (LP: #955376, LP: #981289)
    - Enable the Ubuntu icon for the Applications menu (LP: #986988)
  * debian/patches/greeter-white-border.patch:
     - dropped, applied upstream and the patch wasn't applied
  * Switch dpkg source format from 3.0 (native) to 3.0 (quilt).
 -- Whoopie <email address hidden> Sat, 04 Aug 2012 07:46:14 +0200

Changed in light-themes (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers