Menus built with dbusmenu-gtk on Cairo-Dock are unreadable only with Ambiance GTK theme

Bug #968133 reported by Michal Voců
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
light-themes (Ubuntu)
Undecided
Unassigned

Bug Description

Menu shown by nm-applet is very hard to read in Ambiance theme, because it has light background and light foreground. The submenus, on the other hand, have correct (dark) background (see the attached picture). This happens when using cairo-dock session. I have fully updated (as of today) precise 12.04 packages.

Revision history for this message
Michal Voců (michal-vocu) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Revision history for this message
Matthieu Baerts (matttbe) wrote :

I only have this bug with the Ambiance GTK theme, no problem with Radiance or Adwaita, Adwaita Dark, OMG, etc.
Note that I only have this bug with the Status Notifier menu which simply displays the gtk menu (by using dbusmenu-gtk and Ubuntu's indicator-applications daemon).

Revision history for this message
lylambda (lylambda) wrote :

That didn't concern just nm-applet. The sound controller is impacted too (see attachment)

summary: - network manager's menu is unreadable in Ambiance in cairo-dock session
+ Menus build with dbusmenu-gtk on Cairo-Dock are unreadable only with
+ Ambiance GTK theme
summary: - Menus build with dbusmenu-gtk on Cairo-Dock are unreadable only with
+ Menus built with dbusmenu-gtk on Cairo-Dock are unreadable only with
Ambiance GTK theme
Revision history for this message
Matthieu Baerts (matttbe) wrote :

As I said on IRC (#ubuntu-artwork), I can fix this bug by adding '.menu,' just before "Genericmenuitem .menu, DbusmenuGtkMenu .menu," on gtk-widgets.css:1045 but of course, this is a problem for other apps.

Submenu's background is dark: http://uppix.net/7/4/4/5faa54d41169abdaddfec60169a73.png

It's a bit strange because the menu is normal and the text is made for a dark menu...
It seems for the menu it doesn't use:
    Genericmenuitem .menu,
    DbusmenuGtkMenu .menu,
    .menubar .menu,
    .primary-toolbar .menu {
    (...)
    }

But for menu items, it uses the configuration set in:
     Genericmenuitem .menuitem,
     DbusmenuGtkMenu .menuitem,
     .menubar .menuitem,
     .primary-toolbar .menuitem {
    (...)
    }

I see that Unity has its own .css file. Is maybe Cairo-Dock needs that too?

Or is it maybe a bug in Cairo-Dock?

PS: on the gtk-widgets.css file of the Radiance theme, I think there is a mistake at the line 1282: there is a dot at the end of the line instead of a comma.
        Genericmenuitem .menuitem .accelerator:hover,
=> DbusmenuGtkMenu .menuitem .accelerator:hover.
        .menubar .menuitem .accelerator:hover,

Revision history for this message
Quentin Horlay (quintus89) wrote :

I also have this annoying bug, how can I fix it?

Revision history for this message
Matthieu Baerts (matttbe) wrote :

For those with the bug, I uploaded a new version of this light-themes package on my ppa (ppa:matttbe/ppa). It includes the previous workaround mentioned on comment #5. (but it's a workaround...)

Revision history for this message
Baudoin Thierry (baudoin-thierry) wrote :

I had the same bug!
Now I use the matttbe's theme and it work correctly.
Thanks

Revision history for this message
Matthieu Baerts (matttbe) wrote :

I can confirm that I still have this bug with the latest version of light-themes 0.1.10 on Ubuntu Quantal

Revision history for this message
Coeur Noir (coeur-noir) wrote :

Ubuntu 12.04

Bug still present

Revision history for this message
Matthieu Baerts (matttbe) wrote :

Hello,

This bug seems to be fixed on Ubuntu Quantal, thanks!

Changed in light-themes (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
chris (ign-christian) wrote :

Hello..

This bug still present on Ubuntu 12.04.2 (full system update today)

Revision history for this message
Matthieu Baerts (matttbe) wrote :

Yes, it's only fixed on Ubuntu Quantal, too bad.

Note that you can also use the version from my ppa: https://launchpad.net/~matttbe/+archive/ppa/+files/light-themes_0.1.9.2-0ubuntu3%7Eprecise_all.deb
But it should be much better to fix this bug on Precise repositories.

Revision history for this message
johnkjaer (johnnielsen100) wrote :

Thanks Matthieu

Your PPA works.

Revision history for this message
chris (ign-christian) wrote :

Thanks Matthieu...excellent

Now my Cairo dock menu looks like Unity..:)

Revision history for this message
gcc (chris+ubuntu-qwirx) wrote :

Thanks Matthieu, I can confirm that your updated light-themes package makes the menus readable again on Precise LTS ( https://launchpad.net/~matttbe/+archive/ppa/+files/light-themes_0.1.9.2-0ubuntu3%7Eprecise_all.deb).

I consider this quite a serious bug in the version of Cairo-Dock available in LTS. It's one of several bugs that give me a bad feeling about using Cairo in a "stable" release. Is there anything you can do to push this update towards the next LTS update and/or warn users downloading Cairo following the "simple" installation path (on the Cairo-Dock website) that they need to download your updated light-themes as well? I'm sure this would give many new users a much better impression. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers