Wishlist: move to 0px borders _when_ Unity and Unity-2D/Metacity can cope

Bug #740579 reported by Paul Sladen on 2011-03-22
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
light-themes (Ubuntu)
Wishlist
Paul Sladen

Bug Description

Note: Re-implementation of zero-pixel borders is blocked on needing changes to Metacity; see:

  https://bugs.launchpad.net/ayatana-design/+bug/733431/comments/14
  https://code.launchpad.net/~dashua/light-themes/border-less.metacity.and.fixes/+merge/54439

For clarity the required changes were not made.

Further to:

  Bug #733431 ("Windows lack borders: visually unpleasant and leaves only one option to resize") and originally:
  Bug #733233 ("Increase shadow area to 45 pixels (but not grip area)")

it would (apparently) be excellent to deploy zero-pixel borders again. The people at OMG Ubuntu managed to sway Mark's mind over this:

  https://bugs.launchpad.net/ubuntu/+source/light-themes/+bug/733233/comments/17
  "Oh alright, let's fix the issues for Unity-2D and get the 0px theme
looking stunning for release ;-)"

which appears to now have been done!

Related branches

Paul Sladen (sladen) on 2011-03-22
Changed in light-themes (Ubuntu):
importance: Undecided → Wishlist
milestone: none → ubuntu-11.04
status: New → Triaged
assignee: nobody → Paul Sladen (sladen)
Paul Sladen (sladen) on 2011-03-22
tags: added: sladen-natty-ui-freeze
Paul Sladen (sladen) on 2011-03-23
description: updated
Paul Sladen (sladen) on 2011-03-23
summary: - Wishlist: move to 0px borders now that Unity and Unity-2D/Metacity can
+ Wishlist: move to 0px borders _when_ Unity and Unity-2D/Metacity can
cope
Revision history for this message
James Schriver (dashua) wrote :

@Paul, if we can't get border-less metacity themes working for Natty, I propose at least darkening the frame and bottom and edge. See attached screenshot. I'll push a branch on this if this could work. We have to elimate the frame and bottom edge using shades of gtk:bg[NORMAL]. Ubiquity, Ubuntuone-Control-Panel, Eye of Gnome, Terminal, all look quite unappealing with the whitish frame along the black toolbars and edges. This seems a sensible aesthetic compromise absent the 2D fixes for 0 pixel borders.

Revision history for this message
James Schriver (dashua) wrote :

Ugly white border / frames in Ubiquity, a first impression / look for some installing Ubuntu for the first time.

Revision history for this message
James Schriver (dashua) wrote :
Revision history for this message
James Schriver (dashua) wrote :

Another distinct example of the frame.

Revision history for this message
Paul Sladen (sladen) wrote :

James: that's the proposed solution for Radiance at the same time?

Revision history for this message
James Schriver (dashua) wrote :

Radiance doesn't exhibit such a distinct behavior because it is already light. The only noticeable frame should be the terminal which is already themed dark in /apps/terminal.rc. This is prevalent on Ambiance (default) because if the dark appearance.

Revision history for this message
Martin Pitt (pitti) wrote :

Closing manually due to a typo in the changelog:

 light-themes (0.1.8.12) natty; urgency=low
 .
   [James Schriver]
   * Ambiance/metacity-1/metacity-theme-1.xml
     - Darken frame and bottom edge fix for (LP:740579)
   * Radiance/apps/chromium.rc
     - Fix incognito theming in Radiance (LP: #697854)
   * Radiance/metacity/metacity-theme-1.xml
     - Revert fix borderless overlap (LP: #733504) as this is a fix
       for "0" pixel borders"

Changed in light-themes (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Lucazade (lucazade) wrote :

There is too much contrast with this new fix, before the border was not so visible.

Revision history for this message
Paul Sladen (sladen) wrote :

Lucazade: groovy,ta. Cimi has now filed that as bug #769487 ("[Regression] Ambiance Dark borders around window decorations are too dark"), would you be able to suggest a solution.

Revision history for this message
Owais Lone (loneowais) wrote :

Can we land this before freeze for Quantall now that Unity2d has been dropped?

Revision history for this message
Andrea Cimitan (cimi) wrote :

Good point - wodnering about the installer though

Revision history for this message
James Schriver (dashua) wrote :

@cimi Too late?

James Schriver (dashua) on 2012-09-03
tags: added: sladen-quantal-ui-freeze
removed: sladen-natty-ui-freeze
Revision history for this message
Andrea Cimitan (cimi) wrote :

Ciao James, unfortunately that will break GNOME Classic session (fallback without compiz).

Revision history for this message
James Schriver (dashua) wrote : Re: [Bug 740579] Re: Wishlist: move to 0px borders _when_ Unity and Unity-2D/Metacity can cope

@cimi Ok no problem. Maybe we'll fix this someday.
On Sep 3, 2012 10:21 AM, "Andrea Cimitan" <email address hidden>
wrote:

> Ciao James, unfortunately that will break GNOME Classic session
> (fallback without compiz).
>
> --
> You received this bug notification because you are subscribed to light-
> themes in Ubuntu.
> https://bugs.launchpad.net/bugs/740579
>
> Title:
> Wishlist: move to 0px borders _when_ Unity and Unity-2D/Metacity can
> cope
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/light-themes/+bug/740579/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers