Password required twice returning from suspend

Bug #1631715 reported by Kev Bowring on 2016-10-09
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
light-locker (Ubuntu)
Undecided
Unassigned

Bug Description

Clean install - no updates available.

Suspend machine and restart.

Lock screen requiring password - enter password and return to suspended desktop.

Within a few seconds machine locks and password is required once more.

Appears to depend on how fast I enter the password the first time.

Using the same hardware I've installed nvidia 340.96 and tried to reproduce the issue without success.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: light-locker 1.7.0-2ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-21.23-generic 4.8.0
Uname: Linux 4.8.0-21-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Oct 9 09:15:38 2016
InstallationDate: Installed on 2016-10-09 (0 days ago)
InstallationMedia: Xubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20161008)
SourcePackage: light-locker
UpgradeStatus: No upgrade log present (probably fresh install)

Kev Bowring (flocculant) wrote :
summary: - Passowrd required twice returning from suspend
+ Password required twice returning from suspend
tags: added: xubuntu
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1631715

tags: added: iso-testing
Kev Bowring (flocculant) wrote :

reported against nouveau at bug 1631964

Changed in light-locker (Ubuntu):
status: New → Invalid
Kev Bowring (flocculant) wrote :

Noted that if I wait a few seconds at login password dialogue I don't get the double password requirement.

Changed in light-locker (Ubuntu):
status: Invalid → New
tuxayo (tuxayo) wrote :

If it can't, I have the same bug on Arch Linux (precisely Antergos XFCE).

It happens with both the gtk and webkit2 greeters.

tuxayo (tuxayo) wrote :

Maybe it's related to bug 1284918 https://bugs.launchpad.net/ubuntu/+source/xubuntu-default-settings/+bug/1284918

I solved it on Arch Linux by going in Light Locker Settings → Automatically lock the session → Never.
It's still locked because Xfce Power Manager has a redundant setting (in Security), maybe this is the cause in my case.

If you are still affected by this bug, please obtain a debug log:

killall light-locker; light-locker --debug

Changed in light-locker (Ubuntu):
status: New → Incomplete
Kev Bowring (flocculant) wrote :
Changed in light-locker (Ubuntu):
status: Incomplete → Confirmed

Thanks. I am not quite sure yet how to interpret the log.

I suggest attaching a log for the second test case also (comment #4).

Kev Bowring (flocculant) wrote :
Jarno Suni (jarnos) wrote :

Does it work better, if you turn off automatic locking on suspend via power manager settings and run 'xflock4 && xfce4-session-logout --suspend' in terminal, instead?

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.