light-locker: screen always automatically locked

Bug #1306917 reported by Wybo Dekker on 2014-04-12
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
light-locker-settings
Undecided
Unassigned
light-locker-settings (Ubuntu)
Medium
Unassigned

Bug Description

light-locker always locks my screen, even if I set "Automatically lock the session" to "Never"

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: light-locker-settings 1.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Apr 12 12:13:42 2014
InstallationDate: Installed on 2014-03-26 (16 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140325.1)
PackageArchitecture: all
SourcePackage: light-locker-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Wybo Dekker (wybo) wrote :

I cannot confirm this behavior. Changing "Automatically lock the session" to "Never" works as expected.

summary: - light-locker: screen always locked
+ light-locker: screen always automatically locked
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-locker-settings (Ubuntu):
status: New → Confirmed
Simon Steinbeiß (ochosi) wrote :

As light-locker-settings works in a very trivial way (by creating a launcher in ~/.config/autostart/light-locker.desktop), could you please check whether this launcher is there and not possibly overridden by something else?

Also, you can restart your session to be sure the settings got applied (it shouldn't be necessary though).

Tim (tzakharov) wrote :

I posted a duplicate of this bug, so was redirected here. If it matters, I am on Xubuntu 14.04 64-bit. Strangely, after experiencing this bug multiple times yesterday, when I woke up this morning and moved the mouse, I did NOT get a lock screen. More testing is needed.

To reply to Simon's comment, I can confirm that the launcher you speak of is there. Here is its current config:
Exec=light-locker --lock-after-screensaver=0 --no-lock-on-suspend --no-late-locking
NoDisplay=true

Simon Steinbeiß (ochosi) wrote :

Hey Tim, thanks for posting the contents of the desktop-file.

That one looks ok, so we'd have to look whether it's being overridden by e.g. a second desktop-file in the same directory if the bug re-occurs. However, it *should* work.

Tim (tzakharov) wrote :

Well, it's behaving itself now. Not sure if there was a background update that fixed it, or maybe a session restart got it going. I did notice the problem on two different systems, though, upon clean install. Perhaps toggling the setting back and forth got it fixed...?

Simon Steinbeiß (ochosi) wrote :

It's not impossible that the desktop-file was buggy or something earlier and that it was written correctly when you tried again (depending on when you switched to using 14.04, there were also a few updates/fixes to the light-locker-settings app).

Tim (tzakharov) wrote :

Some new info. On the other system that I installed Xubuntu 14.04 on, I confirmed that Light Locker was activating even though "Automatically lock the session" is set to "Never". BTW, "Never" is the default configuration on a clean install of Xubuntu 14.04. I next turned Light Locker off, then immediately turned it back on and waited 10 minutes for the monitor to blank. I found that Light Locker did not activate when I woke the monitor up! So apparently Light Locker is in a false state of "Never" after a fresh install, and simply turning Light Locker off and back on again restores the correct state of "Never".

In both installs I am referring to, Xubuntu 14.04 was a clean install, not an upgrade install.

I can confirm that.
Clean install, clean profile.

The lighlocker always locks session even when configured to not do so.

Sean Davis (bluesabre) wrote :

Please provide the output of the following commands so we can further debug the issue.

grep Exec ~/.config/autostart/light-locker.desktop

grep Exec ~/.config/autostart/screensaver-settings.desktop

ps ux | grep light-locker

xfconf-query -c xfce4-session -l -v | grep Lock

xfconf-query -c xfce4-power-manager -l -v | grep "dpms\|lock"

For this command, we're only interested in the "Screen Saver" and "DPMS" sections:
xset q

Tim (tzakharov) wrote :

Sean,
I have had two installs on two different sets of hardware indicating this behavior only occurs right after a clean install and Marcelo confirmed this is a behavior on a clean install. The behavior disappears after turning Lightlocker off and back on. So once this is done, I don't know if the output of the commands you listed above would be meaningful. I respectfully ask that you do a fresh install on real hardware, then run the commands. Then, turn lightlocker off and back on and run your commands again. Unfortunately, I do not have time to do a clean install, nor the hardware to do it on without impacting my production system.

@Sean, Tim

OK, let's go.

I'm trying on a Virtual Machine here, fresh installed.
I let it for 10 minutes and then the session was locked.
Checked the options and Light Locker is set to lock the session to "Never"

---------------
grep Exec ~/.config/autostart/light-locker.desktop
grep Exec ~/.config/autostart/screensaver-settings.desktop

There is no "autostart" inside .config

marcelo@marcelo-VirtualBox:~/.config$ ll
total 40
drwx------ 8 marcelo marcelo 4096 Mai 16 09:21 ./
drwxr-xr-x 14 marcelo marcelo 4096 Mai 16 10:02 ../
drwxrwxr-x 2 marcelo marcelo 4096 Mai 16 09:21 dconf/
drwx------ 2 marcelo marcelo 4096 Mai 16 09:21 pulse/
drwx------ 2 marcelo marcelo 4096 Mai 16 09:23 Thunar/
drwx------ 2 marcelo marcelo 4096 Mai 16 09:21 update-notifier/
drwx------ 2 marcelo marcelo 4096 Mai 16 09:21 upstart/
-rw------- 1 marcelo marcelo 632 Mai 16 09:21 user-dirs.dirs
-rw-rw-r-- 1 marcelo marcelo 5 Mai 16 09:21 user-dirs.locale
drwxrwxr-x 6 marcelo marcelo 4096 Mai 16 09:21 xfce4/
marcelo@marcelo-VirtualBox:~/.config$

---------------
ps ux | grep light-locker

marcelo@marcelo-VirtualBox:~/.config$ ps ux | grep light-locker
marcelo 1562 0.0 1.2 247456 13016 ? Sl 10:02 0:00 light-locker
marcelo 2310 0.0 0.0 18936 944 pts/0 S+ 10:15 0:00 grep --color=auto light-locker

---------------
marcelo@marcelo-VirtualBox:~/.config$ xfconf-query -c xfce4-session -l -v | grep Lock
/shutdown/LockScreen false

---------------
marcelo@marcelo-VirtualBox:~/.config$ xfconf-query -c xfce4-power-manager -l -v | grep "dpms\|lock"
/xfce4-power-manager/dpms-enabled true
/xfce4-power-manager/dpms-on-ac-off 15
/xfce4-power-manager/dpms-on-ac-sleep 10
/xfce4-power-manager/dpms-on-battery-off 10
/xfce4-power-manager/dpms-on-battery-sleep 5
/xfce4-power-manager/lock-screen-suspend-hibernate false

After setting the "Enable Light Locker" to OFF, clicking in "Apply", closing the window, opening again, setting "Enable Light Locker" to ON, clicking in "Apply" and closing the window again the directory "autostart" was created in .config.

marcelo@marcelo-VirtualBox:~/.config$ grep Exec ~/.config/autostart/light-locker.desktop
Exec=light-locker --lock-after-screensaver=0 --no-lock-on-suspend --no-late-locking
marcelo@marcelo-VirtualBox:~/.config$ grep Exec ~/.config/autostart/screensaver-settings.desktop
Exec=xset s 600 dpms 900 0 0

And the output of this command changed:
marcelo@marcelo-VirtualBox:~/.config$ ps ux | grep light-locker
marcelo 2358 0.0 0.6 225548 6824 ? Sl 10:18 0:00 light-locker --lock-after-screensaver=0 --no-lock-on-suspend --no-late-locking
marcelo 2374 0.0 0.0 18932 940 pts/0 S+ 10:21 0:00 grep --color=auto light-locker

xconf-query had the same output as before.

The problem is clear here. the autostart directory is never created unless the user manually disables and then enables Light Locker.

Tim (tzakharov) wrote :

Well done, Marcelo! I appreciate your time and effort. Let's hope this gives the developers what they need to fix.

experiencing the same issue

enrico (enricofranceschi) wrote :

My workaround
    leafpad ~/.config/autostart/light-locker.desktop

replace "Exec=light-locker" with " Exec=light-locker --lock-after-screensaver=0 --no-lock-on-suspend --60-late-locking"

RESTART

Do not touch more light-locker, nor light-locker-settings

Changed in light-locker-settings:
status: New → Confirmed

I think the interaction between light-locker, xfce4-power-manager and X is quite confusing.

Please see https://bugs.launchpad.net/ubuntu/+source/light-locker/+bug/1315898/comments/9

Changed in light-locker-settings (Ubuntu):
importance: Undecided → Medium

I rebuild light-locker-settings package with this patch to make "Enable lock-locker: ON/OFF" work.
Since it restarts light-locker when "Apply" is clicked, it should fix this problem too.

The attachment "91_fix_enable_on_off.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Juha Lehti (juha-lehti) wrote :

I noticed the same problem. NOT a clean install, but update. First installed on Wed Jan 28 22:35:51 2015 according to the commit log. Now using up-to-date Xubuntu 17.04.
$ lsb_release -rd
Description: Ubuntu 17.04
Release: 17.04

Set "Automatically lock the session" to "Never"
Log out
Immediately log in
Observe "Automatically the lock session" is set to "When the screensaver is activated"

I'm running Xubuntu 17.10, "Automatically lock the session" is set to "Never", but whenever my screen goes blank, it locks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers