libzeitgeist SIGSEGV when reinstalling ZeitgeistMonitors

Bug #742438 reported by steveacab on 2011-03-25
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Mikkel Kamstrup Erlandsen
Unity Foundations
Medium
Mikkel Kamstrup Erlandsen
libzeitgeist
Medium
Mikkel Kamstrup Erlandsen
unity-lens-files
Medium
Mikkel Kamstrup Erlandsen
libzeitgeist (Ubuntu)
Medium
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity-place-files

crash after click on dash icon

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity-place-files 0.5.46-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
Architecture: i386
Date: Fri Mar 25 14:06:30 2011
ExecutablePath: /usr/lib/unity-place-files/unity-files-daemon
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
ProcCmdline: /usr/lib/unity-place-files/unity-files-daemon
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb750ffc2 <g_type_check_instance_cast+34>: mov (%eax),%ecx
 PC (0xb750ffc2) ok
 source "(%eax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-place-files
StacktraceTop:
 g_type_check_instance_cast () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 zeitgeist_events_to_variant () from /usr/lib/libzeitgeist-1.0.so.1
 ?? () from /usr/lib/libzeitgeist-1.0.so.1
 ?? () from /usr/lib/libzeitgeist-1.0.so.1
 g_simple_async_result_complete () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
Title: unity-files-daemon crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: Upgraded to natty on 2011-03-22 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

steveacab (antonio.chiurazzi) wrote :
steveacab (antonio.chiurazzi) wrote :
visibility: private → public

StacktraceTop:
 g_type_check_instance_cast (type_instance=0x8, iface_type=157010704) at /build/buildd/glib2.0-2.28.4/./gobject/gtype.c:3989
 zeitgeist_events_to_variant (events=0x95b1ac8) at zeitgeist-event.c:854
 _zeitgeist_log_install_monitor (self=<value optimized out>, monitor=0x95bf840) at zeitgeist-log.c:1193
 _zeitgeist_log_on_zg_proxy_acquired (source_object=0x95aedb0, res=0x95b9ef0, user_data=0x95a9af0) at zeitgeist-log.c:1029
 g_simple_async_result_complete (simple=0x95b9ef0) at /build/buildd/glib2.0-2.28.4/./gio/gsimpleasyncresult.c:747

Changed in unity-place-files (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

@steveacab: Is this something you get every time you try to search for files or was this a one-off?

steveacab (antonio.chiurazzi) wrote :

@Mikkel

not ever, but sometimes crash

Marking confirmed since we now have a dupe. I still have no idea on how to reproduce this or what the cause is though...

Changed in unity-place-files:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
status: New → Confirmed
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
status: New → Confirmed
Changed in unity-place-files (Ubuntu):
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
status: New → Confirmed

I got this error when I gave zeitgeist-daemon - replace in terminal

@hellojoker: Awesome! I can reproduce with 'zeitgeist-daemon --replace' thanks a bunch :-)

This was do to a refcounting bug when reinstating any ZeitgeistMonitors because of a zeitgeist-daemon restart inside libzeitgeist.

revno: 205
fixes bug(s): https://launchpad.net/bugs/742438
committer: Mikkel Kamstrup Erlandsen <email address hidden>
branch nick: MASTER
timestamp: Wed 2011-03-30 10:58:43 +0200
message:
  Fix ref counting when reinstating ZeitgeistMonitors because of a zeitgeist-daemon restart

Changed in unity-place-files:
status: Confirmed → Invalid
Changed in libzeitgeist:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → 0.3.10
status: New → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity-place-files (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity-foundations:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → unity-3.8.2
status: New → Fix Committed
summary: - unity-files-daemon crashed with SIGSEGV in g_type_check_instance_cast()
+ libzeitgeist SIGSEGV when reinstalling ZeitgeistMonitors
Changed in unity-foundations:
status: Fix Committed → Fix Released
Changed in libzeitgeist:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-03-31
affects: unity-place-files (Ubuntu) → libzeitgeist (Ubuntu)
Changed in unity:
milestone: none → 3.8.2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libzeitgeist - 0.3.10-0ubuntu1

---------------
libzeitgeist (0.3.10-0ubuntu1) natty; urgency=low

  * New upstream release
    - Fix ref counting when reinstating ZeitgeistMonitors because of a
      zeitgeist-daemon restart (LP: #742438)
    - some documentation fix
 -- Didier Roche <email address hidden> Thu, 31 Mar 2011 15:08:19 +0200

Changed in libzeitgeist (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-01
Changed in unity-place-files:
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers