unable to setup ALT+PrtSc (alt + printscreen) in keyboard applications shortcuts settings menu

Bug #1081599 reported by crysman on 2012-11-21
34
This bug affects 10 people
Affects Status Importance Assigned to Milestone
libxfce4ui
Unknown
Unknown
libxfce4ui (Ubuntu)
Undecided
Unassigned

Bug Description

After I noticed ALT+PrtSc had stopped working, I tried to set it up manually via xfce keyboard settings, but I am unable to do so. When the dialogue with new shortcut pops up and I press ALT and PrtSc, nothing happens. When I press e.g. CTRL and PrtSC, it works!

Where is the problem? :(

McZ

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xfce4-settings 4.10.0-1ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Wed Nov 21 14:03:44 2012
ExecutablePath: /usr/bin/xfce4-settings-manager
InstallationDate: Installed on 2012-06-29 (144 days ago)
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
SourcePackage: xfce4-settings
UpgradeStatus: Upgraded to quantal on 2012-10-28 (23 days ago)

crysman (crysman) wrote :
Oskar Wallgren (oskar.wallgren) wrote :

I don't think you can assign <Alt><PrtSc> as the combination is spoken for by the kernel.
This is by default. The option to have this interaction is in the kernel and the desicion to
have it enabled by default is with the Ubuntu developers. See bug #642792.

Unless you disable it:
http://en.wikipedia.org/wiki/Magic_SysRq_key#Configuration
http://ubuntuforums.org/showthread.php?t=1890355&p=11511510#post11511510

Also see answer 7 in this thread:
https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/642792

To avoid confusion xfce4-settings-manager should issue a clear warning about why it doesn't accept the combination or at least a generic message on failure like "cobination not allowed".

thank you for the comperhensive answer! :)
McZ

--
Martin crysman Zahradník
www: http://crysmanovo.blogspot.com
e-mail: <email address hidden>
jabber: <email address hidden>
gtalk: <email address hidden>
Skype: no way! using Ekiga - SIP:<email address hidden>
running GNU/Linux Xubuntu

On 1.3.2013 05:59, Oskar Wallgren wrote:
> I don't think you can assign <Alt><PrtSc> as the combination is spoken for by the kernel.
> This is by default. The option to have this interaction is in the kernel and the desicion to
> have it enabled by default is with the Ubuntu developers. See bug #642792.
>
> Unless you disable it:
> http://en.wikipedia.org/wiki/Magic_SysRq_key#Configuration
> http://ubuntuforums.org/showthread.php?t=1890355&p=11511510#post11511510
>
> Also see answer 7 in this thread:
> https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/642792
>
> To avoid confusion xfce4-settings-manager should issue a clear warning
> about why it doesn't accept the combination or at least a generic
> message on failure like "cobination not allowed".
>

affects: xfce4-settings (Ubuntu) → libxfce4ui (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libxfce4ui (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1081599

tags: added: package-qa-testing

According to the status of the linked upstream bug report, this bug should be fixed in Xubuntu 14.04 and up.

Changed in libxfce4ui (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.