Comment 12 for bug 87947

This is a regression in hardy. Nearly all graphical java programs will fail due to this. Early releases of gutsy had this problem but it was fixed before the release such that a default installation of gutsy did not experience the problem for java programs. Yes, technically it's a bug in Java, but it's been there for quite a while and isn't likely to be fixed in time for 8.04. Please make the necessary corrections for hardy, whether it be turning off this assertion in xcb-xlib, or adding the appropriate env var to the default /etc/bash.bashrc