gnome-settings-daemon fails with libgstlibvisual.so error

Bug #287448 reported by Niall Creech
186
This bug affects 14 people
Affects Status Importance Assigned to Milestone
libvisual-plugins (Ubuntu)
Critical
Loïc Minier
Intrepid
Critical
Loïc Minier

Bug Description

gnome-settings-daemon and gst-launch/gstreamer apps crashes since libvisual-0.4-plugins 0.4.0.dfsg.1-2ubuntu1.

Workaround: sudo rm -f /usr/lib/libvisual-0.4/actor/actor_nastyfft.so

Fixed package 0.4.0.dfsg.1-2ubuntu4 available soon in intrepid or now from https://launchpad.net/~lool/+archive.

Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :
Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :
Revision history for this message
plun (plun) wrote :

Confirmed and a libvisual-0.4-plugins removal solves this seg fault.

Changed in libvisual-plugins:
status: New → Confirmed
Revision history for this message
scottuss (scottuss) wrote :

Confirmed, removing libvisual-0.4-plugins restores correct theme settings and allows gnome-settings-daemon to load

Revision history for this message
tankdriver (stoneraider-deactivatedaccount) wrote :

Confirmed as well. (8.10 beta amd64)

Revision history for this message
Marco (0m3g4) wrote :

removing /usr/lib/gstreamer-0.10/libgstlibvisual.so fix problem.

Revision history for this message
raggar (mbaart) wrote :

Confirmed as well. (8.10 beta), removing /usr/lib/gstreamer-0.10/libgstlibvisual.so fixed problem.

Revision history for this message
Chris Jones (cmsj) wrote :

This is a regression since libvisual-0.4-plugins_0.4.0.dfsg.1-2_i386.deb

Changed in libvisual-plugins:
importance: Undecided → High
Changed in libvisual-plugins:
milestone: none → ubuntu-8.10
Revision history for this message
bazookatooth (destroydieattack) wrote :

confirmed... removed libvisual-0.4-plugins & all is well. wish i could remember why it was installed in the first place, as no one i know had it on their system.

Revision history for this message
James Westby (james-w) wrote :

Hi,

This is pretty odd. The problem seems to be with the nastyfft plugin.
It seems to be corrupting the info object at initialisation time.

The -2 version still works, but recompiling it under Intrepid breaks it
again.

Thanks,

James

Revision history for this message
Martin Pitt (pitti) wrote :

I built 0.4.0.dfsg.1-2 on current intrepid and get the crash, too, so it's not a regression in the recently changed source bits, but due to building to newer libraries.

Revision history for this message
Martin Pitt (pitti) wrote :

BTW, it's quicker to debug this with calling "gst-inspect-0.10" instead of gnome-session-daemon.

Revision history for this message
Martin Pitt (pitti) wrote :

I verified that building with --disable-nastyfft works around the crash, so that would be an acceptable solution for intrepid release.

I'm going to debug the actual crash now.

Revision history for this message
Daniel DeGroff (djdalias-misc) wrote :

I have encountered this bug as well, and verified removing libvisual plugins fixed.
I'm running Ubuntu 8.10 on x86 32bit. (Thinkpad T61).

gnome-settings-daemon worked fine until the last reboot due to a slew of updates for Ubuntu 8.10.
I had restarted this morning due to those fixes, and then had this problem.
Sounds like there is a good handle on the problem.

Revision history for this message
Loïc Minier (lool) wrote :

Hey there, pushed the fix in libvisual-plugins 0.4.0.dfsg.1-2ubuntu4 in intrepid (pending review) and my ppa (still being built). https://launchpad.net/~lool/+archive

Changed in libvisual-plugins:
assignee: nobody → lool
importance: High → Critical
status: Confirmed → Fix Committed
Loïc Minier (lool)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvisual-plugins - 0.4.0.dfsg.1-2ubuntu4

---------------
libvisual-plugins (0.4.0.dfsg.1-2ubuntu4) intrepid; urgency=low

  * New patch, 60_no-const-vispluginfo-in-nastyfft, the static VisPluginInfo
    in nastyfft was declared as const, but libvisual write to its refcount
    when it visual_object_unref()s it (nasty!). This is broken at various
    levels: libvisual shouldn't be writing to this static plugin which is
    allocated by a dlopen()ed plugin, and it should also honor the "const
    VisPluginInfo" API... Anyway, nastyfft was the only occurrence and this
    fixes the crash for now; LP: #287448.

 -- Loic Minier <email address hidden> Wed, 22 Oct 2008 21:15:53 +0200

Changed in libvisual-plugins:
status: Fix Committed → Fix Released
Revision history for this message
David Wilde (dave-wilde) wrote :

This breaks pidgin as well BTW:

$ pidgin

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstlibvisual.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.

Moved libgstlibvisual.so out of the way and pidgin starts up.

Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :

Loïc's ppa libvisual-0.4-plugins_0.4.0.dfsg.1-2ubuntu4_amd64.deb
fixes this bug for me, cheers

Revision history for this message
plun (plun) wrote :

Echo > "Nema problema" also on 32 bit, ppa version

Thanks ! ;)

Revision history for this message
Jonathan Lumb (jonolumb) wrote :

I was having a similar bug in Songbird and simply did sudo apt-get remove libvisual-0.4-plugins and everything was fine again!

Revision history for this message
mr_step (step-step) wrote :

Issue is occurring on Ubuntu 10.4 (as of today, was working fine yesterday)

$ pidgin

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstlibvisual.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.

Moved or removing libgstlibvisual.so out of the way and pidgin starts up.

Revision history for this message
Reuben Firmin (reubenf) wrote :

This started happening after I upgraded to Ubuntu 10.10. Previously, pidgin was working.

pidgin
ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstlibvisual.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.

Revision history for this message
Eemil Lagerspetz (eemil-lagerspetz) wrote :

Removal of /usr/lib/gstreamer-0.10/libgstlibvisual.so worked for me as a workaround. Interestingly this does not happen on my likewise 64-bit Ubuntu 10.10 laptop, likewise with Pidgin 2.7.5, only the desktop. Also, it did not happen for Pidgin 2.7.3 on either machine.

Revision history for this message
the designer (alberto1988m) wrote : Fw: gorgeous

Hey!

That stuff is just gorgeous, you have to read about it more at http://tekky.net/attend.php?d8da

Warmest, lberto Magno

Revision history for this message
the designer (alberto1988m) wrote : ☢new restaurant opening

Hey,

I've heard about a new fish restaurant opening next Saturday, are you planning to go there? Here is some info about that http://www.kop2001.com/guess.php?7879

lberto Magno

From: Bug 287448 [mailto:<email address hidden>]
Sent: Monday, July 31, 2017 9:41 PM
To: <email address hidden>
Subject: ^^fat^^

This is actually a fantastic idea for camping kits, emergency preparedness supplies, etc. It seems like every time I need a flashlight, the batteries are dead. Pair some of these with an 2 or 4xAA LED flashlight, and you're golden.

Of course, the shake-lights and crank-lights are nice, too, and they work without needing to sit all day in the sun. But this'll power anything that takes AA. Sweet find, OP.

Sent from Mail for Windows 10

Revision history for this message
the designer (alberto1988m) wrote : ☁new message

I've just written an assessment öf a böök and I just wanted yöu tö learn it and tell me yöu thöughts, please take a löök http://bookeahoteles.com/costume.php?UE8yODc0NDhAYnVncy5sYXVuY2hwYWQubmV0

Pardon my monkey thumbs, lberto Magno

Revision history for this message
the designer (alberto1988m) wrote : Re: omg day filled with surprises

Greetings,

I'm so excited to tell you about yesterday that was packed with enjoyable surprises, just take a look at that http://www.swingfever.nl/rental.php?UE8yODc0NDhAYnVncy5sYXVuY2hwYWQubmV0

Sent from a prehistoric stone tablet, lberto Magno

-

This email and any attachments to it may be confidential and are intended solely for the use of the individual to whom it is addressed. Any views or opinions expressed are solely those of the author and do not necessarily represent those of US. If you are not the intended recipient of this email, you must neither take any action based upon its contents, nor copy or show it to anyone. Please contact the sender if you believe you have received this email in error.

Revision history for this message
the designer (alberto1988m) wrote : Re: Merry Christmas to All and to All a Good Flight

Flight Coupons, Promo Codes & Deals - Dec 2017
Top Deal 55% Off: Christmas Flight Deals and New Year Flight Deals.

Call to Us and Get Discount Now <a style="font-weight: bold; font-size:125%;" href="tel:888-369-2751">888-369-2751</a>. <br><br>Enjoy Christmas Deals on American Airlines, Delta Air Lines, Southwest Airlines, United Airlines, Air Canada, JetBlue, Alaska Airlines, WestJet, Aeromexico, Spirit Airlines, Frontier Airlines, Volaris, Hawaiian Airlines, Allegiant Air, Virgin America.

Don't Miss These Handpicked Fares
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.46</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.95</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.39</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.34</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.63</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.62</td></tr><tr><td width="40%">Newark</td><td width="10%">-</td><td width="40%">Toronto</td><td width"10%">$299.00</td></tr><tr><td width="40%">Boston</td><td width="10%">-</td><td width="40%">Miami</td><td width"10%">$189.02</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Kingston</td><td width"10%">$461.40</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">Manila</td><td width"10%">$654.27</td></tr><tr><td width="40%">San Francisco</td><td width="10%">-</td><td width="40%">Tokyo</td><td width"10%">$690.72</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Casablanca</td><td width"10%">$825.00</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">Johannesburg</td><td width"10%">$1016.23</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Minneapolis</td><td width"10%">$95.87</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">New York</td><td width"10%">$225.82</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Orlando</td><td width"10%">$90.74</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Paris</td><td width"10%">$545.16</td></tr></tbody></table>

Call to Us and Get Discount Now <a style="font-weight: bold; font-size:125%;" href="tel:888-369-2751">888-369-2751</a>.

Revision history for this message
the designer (alberto1988m) wrote : ✈Re: The end of the year typically entails some last-minute Christmas shopping
Download full text (7.9 KiB)

The end of the year typically entails some last-minute Christmas shopping, finalizing plans to see family and friends, and — if you're marketers like us — prepping for next year's campaigns. It also means we get to enjoy some of the most heartwarming and humorous marketing efforts we'll see all year.
From commercials, to interactive websites, to social media contests, there's always a fair share of top-notch marketing going on in November and December — and this year proved as much.<br><br>Check our free holiday marketing guide here to learn about the trends shaping this 2017 holiday season.<br><br>Check out some of this season's memorable and unique campaigns from both sizable brands and small ones that epitomize how to do holiday marketing right.

8 Great Holiday Marketing Campaigns of 2017
<br>1) 23 Secrets To Booking Cheap Flights (Flight Coupons, Promo Codes & Deals - Dec 2017) - Business Insider.<br>Top Deal 55% Off: Christmas Flight Deals and New Year Flight Deals.
Primary. You can reach us at <span style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</span>. <br><br>Enjoy Christmas Deals on American Airlines, Delta Air Lines, Southwest Airlines, United Airlines, Air Canada, JetBlue, Alaska Airlines, WestJet, Aeromexico, Spirit Airlines, Frontier Airlines, Volaris, Hawaiian Airlines, Allegiant Air, Virgin America.
Don't Miss These Handpicked Fares<br>
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.71</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.45</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.36</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.95</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.32</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.66</td></tr><tr><td width="40%">Boston</td><td width="10%">-</td><td width="40%">Miami</td><td width"10%">$189.71</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">Manila</td><td width"10%">$654.93</td></tr><tr><td width="40%">San Francisco</td><td width="10%">-</td><td width="40%">Tokyo</td><td width"10%">$690.47</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Casablanca</td><td width"10%">$825.81</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">Johannesburg</td><td width"10%">$1016.14</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Minneapolis</td><td width"10%">$95.58</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Paris</td><td width"10%">$545.80</td></tr></tbody></table>
At the time of Christmas, Every airline is offering fabulous discounts on airfare tickets. So, take a rest from work deadlines and family commitments, and ...

Read more...

Revision history for this message
the designer (alberto1988m) wrote : ✈Fw: The world's travel search engine Skyscanner compares millions of flights to find you the cheapest deal, fast.
Download full text (3.3 KiB)

Whether you want to go to Tenerife or Tokyo, we'll find low cost flights to get you there.
We also find the cheapest hotels and car hire deals.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:+1 (888) 369-2751">+1 (888) 369-2751</a>.
Skyscanner is free! When you find your flights and dial (888) 369-2751, we redirect your call through directly to the airline or travel agent.<br>We never charge you commission. Nor do we add hidden fees. See more ways we put you first.
Acclaimed flight comparison Skyscanner is an award winning site recommended by: The Independent, The Guardian, Which? Travel, BBC Radio 1 and more!<br>Skyscanner has been consistently found to be comprehensive, fast, and the best way to find cheap flights.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:+1 (888) 369-2751">+1 (888) 369-2751</a>.
Let’s get social! Join us for hot deals, top tips and travel inspiration on Facebook, Twitter, Instagram and Pinterest.
Find the perfect place to stay
The Trip by Skyscanner community has reviewed tens of thousands of hotels around the world so you can always find the perfect place to stay, based on your tribe and your price range.
Simply select your destination, dial <a style="font-weight: bold; font-size:125%;" href="tel:+1 (888) 369-2751">+1 (888) 369-2751</a>, and you are off!
And now Trip by Skyscanner searches all the top booking sites to make sure to always find you the lowest price.
Check out some of our most popular destinations:<br>
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.80</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.27</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.01</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.55</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.48</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.89</td></tr><tr><td width="40%">Boston</td><td width="10%">-</td><td width="40%">Miami</td><td width"10%">$189.51</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Minneapolis</td><td width"10%">$95.94</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">New York</td><td width"10%">$225.54</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Orlando</td><td width"10%">$90.58</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Paris</td><td width"10%">$545.12</td></tr></tbody></table><br>Top Deal 55% Off: Skyscanner's Flight Deals.
Primary: +1 (888) 369-2751. 24/7 Support.
Enjoy Skyscanner's Hot Deals on American Airlines, Delta Air Lines, Southwest Airlines, United Airlines, Air Canada, JetBlue, Alaska Airlines, WestJet, Aeromexico, Spirit Airlines, Frontier Airlines, Volaris, Haw...

Read more...

Revision history for this message
the designer (alberto1988m) wrote : ✈The world's travel search engine Skyscanner compares millions of flights to find you the cheapest deal, fast.
Download full text (3.3 KiB)

Whether you want to go to Tenerife or Tokyo, we'll find low cost flights to get you there.
We also find the cheapest hotels and car hire deals.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</a>.
Skyscanner is free! When you find your flights and dial (888) 369-2751, we redirect your call through directly to the airline or travel agent.<br>We never charge you commission. Nor do we add hidden fees. See more ways we put you first.
Acclaimed flight comparison Skyscanner is an award winning site recommended by: The Independent, The Guardian, Which? Travel, BBC Radio 1 and more!<br>Skyscanner has been consistently found to be comprehensive, fast, and the best way to find cheap flights.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</a>.
Let’s get social! Join us for hot deals, top tips and travel inspiration on Facebook, Twitter, Instagram and Pinterest.
Find the perfect place to stay
The Trip by Skyscanner community has reviewed tens of thousands of hotels around the world so you can always find the perfect place to stay, based on your tribe and your price range.
Simply select your destination, dial <a style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</a>, and you are off!
And now Trip by Skyscanner searches all the top booking sites to make sure to always find you the lowest price.
Check out some of our most popular destinations:<br>
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.99</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.23</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.28</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.76</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.03</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.75</td></tr><tr><td width="40%">San Francisco</td><td width="10%">-</td><td width="40%">Tokyo</td><td width"10%">$690.61</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">Johannesburg</td><td width"10%">$1016.54</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Minneapolis</td><td width"10%">$95.73</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">New York</td><td width"10%">$225.96</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Paris</td><td width"10%">$545.78</td></tr></tbody></table><br>Top Deal 55% Off: Skyscanner's Flight Deals.
Primary: (888) 369-2751. 24/7 Support.
Enjoy Skyscanner's Hot Deals on American Airlines, Delta Air Lines, Southwest Airlines, United Airlines, Air Canada, JetBlue, Alaska Airlines, WestJet, Aeromexico, Spirit Airlines, Frontier Airlines, Volaris, Hawaiian Airlines,...

Read more...

Revision history for this message
the designer (alberto1988m) wrote : ✈Re: The world's travel search engine Skyscanner compares millions of flights to find you the cheapest deal, fast.
Download full text (3.4 KiB)

Whether you want to go to Tenerife or Tokyo, we'll find low cost flights to get you there.
We also find the cheapest hotels and car hire deals.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:888-369-2751">888-369-2751</a>.
Skyscanner is free! When you find your flights and dial (888) 369-2751, we redirect your call through directly to the airline or travel agent.<br>We never charge you commission. Nor do we add hidden fees. See more ways we put you first.
Acclaimed flight comparison Skyscanner is an award winning site recommended by: The Independent, The Guardian, Which? Travel, BBC Radio 1 and more!<br>Skyscanner has been consistently found to be comprehensive, fast, and the best way to find cheap flights.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:888-369-2751">888-369-2751</a>.
Let’s get social! Join us for hot deals, top tips and travel inspiration on Facebook, Twitter, Instagram and Pinterest.
Find the perfect place to stay
The Trip by Skyscanner community has reviewed tens of thousands of hotels around the world so you can always find the perfect place to stay, based on your tribe and your price range.
Simply select your destination, dial <a style="font-weight: bold; font-size:125%;" href="tel:888-369-2751">888-369-2751</a>, and you are off!
And now Trip by Skyscanner searches all the top booking sites to make sure to always find you the lowest price.
Check out some of our most popular destinations:<br>
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.48</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.57</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.42</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.73</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.60</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.28</td></tr><tr><td width="40%">Boston</td><td width="10%">-</td><td width="40%">Miami</td><td width"10%">$189.74</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Kingston</td><td width"10%">$461.03</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Casablanca</td><td width"10%">$825.95</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">New York</td><td width"10%">$225.92</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Orlando</td><td width"10%">$90.17</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Toronto</td><td width"10%">$119.10</td></tr></tbody></table><br>Top Deal 55% Off: Skyscanner's Flight Deals.
Primary: 888-369-2751. 24/7 Support.
Enjoy Skyscanner's Hot Deals on American Airlines, Delta Air Lines, Southwest Airlines, United Airlines, Air Canad...

Read more...

Revision history for this message
the designer (alberto1988m) wrote : ✈The world's travel search engine Skyscanner compares millions of flights to find you the cheapest deal, fast.
Download full text (3.6 KiB)

Whether you want to go to Tenerife or Tokyo, we'll find low cost flights to get you there.
We also find the cheapest hotels and car hire deals.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:888-369-2751">888-369-2751</a>.
Skyscanner is free! When you find your flights and dial (888) 369-2751, we redirect your call through directly to the airline or travel agent.<br>We never charge you commission. Nor do we add hidden fees. See more ways we put you first.
Acclaimed flight comparison Skyscanner is an award winning site recommended by: The Independent, The Guardian, Which? Travel, BBC Radio 1 and more!<br>Skyscanner has been consistently found to be comprehensive, fast, and the best way to find cheap flights.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:888-369-2751">888-369-2751</a>.
Let’s get social! Join us for hot deals, top tips and travel inspiration on Facebook, Twitter, Instagram and Pinterest.
Find the perfect place to stay
The Trip by Skyscanner community has reviewed tens of thousands of hotels around the world so you can always find the perfect place to stay, based on your tribe and your price range.
Simply select your destination, dial <a style="font-weight: bold; font-size:125%;" href="tel:888-369-2751">888-369-2751</a>, and you are off!
And now Trip by Skyscanner searches all the top booking sites to make sure to always find you the lowest price.
Check out some of our most popular destinations:<br>
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.61</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.84</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.94</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.06</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.52</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.91</td></tr><tr><td width="40%">Boston</td><td width="10%">-</td><td width="40%">Miami</td><td width"10%">$189.79</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Las Vegas</td><td width"10%">$248.16</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Kingston</td><td width"10%">$461.92</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">Johannesburg</td><td width"10%">$1016.66</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Minneapolis</td><td width"10%">$95.42</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Orlando</td><td width"10%">$90.93</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Washington DC</td><td width"10%">$195.92</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">London</td><td width"10%">...

Read more...

Revision history for this message
the designer (alberto1988m) wrote : Re: The world's travel search engine Skyscanner compares millions of flights to find you the cheapest deal, fast.
Download full text (3.9 KiB)

Whether you want to go to Tenerife or Tokyo, we'll find low cost flights to get you there.
We also find the cheapest hotels and car hire deals.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:+1 888-369-2751">+1 888-369-2751</a>.
Skyscanner is free! When you find your flights and dial (888) 369-2751, we redirect your call through directly to the airline or travel agent.<br>We never charge you commission. Nor do we add hidden fees. See more ways we put you first.
Acclaimed flight comparison Skyscanner is an award winning site recommended by: The Independent, The Guardian, Which? Travel, BBC Radio 1 and more!<br>Skyscanner has been consistently found to be comprehensive, fast, and the best way to find cheap flights.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:+1 888-369-2751">+1 888-369-2751</a>.
Let’s get social! Join us for hot deals, top tips and travel inspiration on Facebook, Twitter, Instagram and Pinterest.
Find the perfect place to stay
The Trip by Skyscanner community has reviewed tens of thousands of hotels around the world so you can always find the perfect place to stay, based on your tribe and your price range.
Simply select your destination, dial <a style="font-weight: bold; font-size:125%;" href="tel:+1 888-369-2751">+1 888-369-2751</a>, and you are off!
And now Trip by Skyscanner searches all the top booking sites to make sure to always find you the lowest price.
Check out some of our most popular destinations:<br>
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.05</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.78</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.57</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.42</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.10</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.12</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Las Vegas</td><td width"10%">$248.62</td></tr><tr><td width="40%">San Francisco</td><td width="10%">-</td><td width="40%">New York City</td><td width"10%">$293.81</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">Manila</td><td width"10%">$654.41</td></tr><tr><td width="40%">San Francisco</td><td width="10%">-</td><td width="40%">Tokyo</td><td width"10%">$690.73</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Casablanca</td><td width"10%">$825.64</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">Johannesburg</td><td width"10%">$1016.21</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Minneapolis</td><td width"10%">$95.12</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td widt...

Read more...

Revision history for this message
the designer (alberto1988m) wrote : ✈The world's travel search engine Skyscanner compares millions of flights to find you the cheapest deal, fast.
Download full text (4.0 KiB)

Whether you want to go to Tenerife or Tokyo, we'll find low cost flights to get you there.
We also find the cheapest hotels and car hire deals.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</a>.
Skyscanner is free! When you find your flights and dial (888) 369-2751, we redirect your call through directly to the airline or travel agent.<br>We never charge you commission. Nor do we add hidden fees. See more ways we put you first.
Acclaimed flight comparison Skyscanner is an award winning site recommended by: The Independent, The Guardian, Which? Travel, BBC Radio 1 and more!<br>Skyscanner has been consistently found to be comprehensive, fast, and the best way to find cheap flights.<br>
Just dial: <a style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</a>.
Let’s get social! Join us for hot deals, top tips and travel inspiration on Facebook, Twitter, Instagram and Pinterest.
Find the perfect place to stay
The Trip by Skyscanner community has reviewed tens of thousands of hotels around the world so you can always find the perfect place to stay, based on your tribe and your price range.
Simply select your destination, dial <a style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</a>, and you are off!
And now Trip by Skyscanner searches all the top booking sites to make sure to always find you the lowest price.
Check out some of our most popular destinations:<br>
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.38</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.58</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.37</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.25</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.38</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.76</td></tr><tr><td width="40%">Boston</td><td width="10%">-</td><td width="40%">Miami</td><td width"10%">$189.04</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Las Vegas</td><td width"10%">$248.44</td></tr><tr><td width="40%">San Francisco</td><td width="10%">-</td><td width="40%">New York City</td><td width"10%">$293.57</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Kingston</td><td width"10%">$461.18</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">Manila</td><td width"10%">$654.48</td></tr><tr><td width="40%">San Francisco</td><td width="10%">-</td><td width="40%">Tokyo</td><td width"10%">$690.97</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Casablanca</td><td width"10%">$825.90</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">N...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers