Ubuntu

system-config-samba.py fails to start due to missing /etc/libuser.conf in Hardy

Reported by Martin Olsson on 2008-04-10
32
Affects Status Importance Assigned to Milestone
libuser (Ubuntu)
Medium
Unassigned
Hardy
Medium
Soren Hansen

Bug Description

Repro steps:

1. sudo apt-get install system-config-samba
2. sudo system-config-samba

Expected results:
Program should start.

Actual results:
mnemo@gutsyT5:~$ sudo system-config-samba
[sudo] password for mnemo:
Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 41, in <module>
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 118, in __init__
    self.basic_preferences_win = basicPreferencesWin.BasicPreferencesWin(self, self.xml, self.samba_data, self.samba_backend, self.main_window)
  File "/usr/share/system-config-samba/basicPreferencesWin.py", line 93, in __init__
    self.admin = libuser.admin()
SystemError: could not open configuration file `/etc/libuser.conf': No such file or directory
mnemo@gutsyT5:~$

Johan Zaxmy (johan-zaxmy) wrote :

I have the same problem. I installed system-config-samba after that i recieved messages in .xsession-errors about a missing /var/lib/samba/usershares

The package libuser (was not installed) does not provide a /etc/libuser.conf

Dependency and package problem ?

Johan Zaxmy (johan-zaxmy) wrote :

Temporary fix:

sudo touch /etc/libuser.conf

Saivann Carignan (oxmosys) wrote :

I also confirm this bug and the workaround.

Changed in system-config-samba:
importance: Undecided → Medium
status: New → Confirmed
Saivann Carignan (oxmosys) wrote :

This bug is caused by libuser1 package which should install /etc/libuser.conf . This file is properly installed in Gutsy but missing in Hardy.

Saivann Carignan (oxmosys) wrote :

Here's a debdiff that fixes that packaging mistake. Subscribing universe sponsors to review the patch.

Changed in libuser:
status: Confirmed → In Progress
Saivann Carignan (oxmosys) wrote :

Here's a debdiff that fixes that packaging mistake. Subscribing universe sponsors to review the patch.

Changed in libuser:
importance: Undecided → Medium
status: New → Triaged
Brian Murray (brian-murray) wrote :

The patch in this bug report should resolve bug 224599.

Changed in libuser:
status: In Progress → Triaged
Saivann Carignan (oxmosys) wrote :

This patch only fixes a regression that has been introduced in Hardy. Adding "/etc" in libuser1.install like it was in Gutsy fixes that problem.

Soren Hansen (soren) wrote :

Patch looks great. I'll take care of this.

Changed in libuser:
assignee: nobody → soren
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libuser - 1:0.56.9.dfsg.1-1ubuntu1

---------------
libuser (1:0.56.9.dfsg.1-1ubuntu1) intrepid; urgency=low

  [ Saïvann Carignan ]
  * debian/libuser1.install: Add "etc/" again to fix missing
    /etc/libuser.conf file (LP: #214959)

  [ Soren Hansen ]
  * Per SRU policy, this patch needs to land in Intrepid first, hence
    this upload.

 -- Soren Hansen <email address hidden> Wed, 14 May 2008 10:37:45 +0200

Changed in libuser:
status: Triaged → Fix Released
tminton (tomminton) wrote :

"sudo touch /etc/libuser.conf" fixed it on my machine.

Martin Pitt (pitti) wrote :

Subscribed ~motu-sru for an ack from them.

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in libuser:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Since the patch is trivial and obvious, and it's so exceptionally visible (238 dups on the other bug 224599), I just assumed ~motu-sru ack. Please retroactively ack it, though (and flame me for breaking the policy).

Saivann Carignan (oxmosys) wrote :

patch in -proposed works for me, creates /etc/libuser.conf if it doesn't already exist. system-config-samba starts without any problem.

Luke Yelavich (themuso) wrote :

Retroactive ACK.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in libuser:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches