system-config-samba.py fails to start due to missing /etc/libuser.conf Utopic

Bug #1387274 reported by Sergio Schneider on 2014-10-29
134
This bug affects 29 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
libuser (Ubuntu)
High
Mattia Rizzolo
system-config-samba (Ubuntu)
High
Unassigned

Bug Description

system-config-samba.py fails to start due to missing /etc/libuser.conf
"sudo touch /etc/libuser.conf" as suggested above fix it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libuser (Ubuntu):
status: New → Confirmed
Changed in system-config-samba (Ubuntu):
status: New → Confirmed
Etienne URBAH (eurbah) wrote :

Reference = bug #214959

Changed in hundredpapercuts:
status: New → Confirmed
Changed in system-config-samba (Ubuntu):
importance: Undecided → High
Changed in libuser (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
importance: Undecided → High

system-config-samba
Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 45, in <module>
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 121, in __init__
    self.basic_preferences_win = basicPreferencesWin.BasicPreferencesWin(self, self.xml, self.samba_data, self.samba_backend, self.main_window)
  File "/usr/share/system-config-samba/basicPreferencesWin.py", line 97, in __init__
    self.admin = libuser.admin()
SystemError: could not open configuration file `/etc/libuser.conf': Arquivo ou diretório não encontrado

Guys, just created the configuration file (libuser.conf) in / etc / folder
and then returned to work the system-config-samba

raydar (raydar) wrote :

To confirm what Flavio found, executing the following fixed the problem for me:

sudo touch /etc/libuser.conf

Etienne URBAH (eurbah) wrote :

This bug is still present in system-config-samba version 1.2.63-0ubuntu6 from 'Ubuntu 15.10 Wily Beta1'.

tags: added: vivid wily

This problem is affecting the project Ginger:
 https://github.com/kimchi-project/ginger

It uses "python-libuser", which is failing because libuser , or libuser1, misses libuser.conf

Reference:
https://github.com/kimchi-project/ginger/issues/22

bugproxy (bugproxy) on 2015-09-17
tags: added: architecture-all bugnameltc-130684 severity-medium targetmilestone-inin1510
Zero (zerofossilfuel) wrote :

Performed a clean install of Wily. Ref 214959, this bug is back. 'sudo touch /etc/libuser.conf' corrects the problem. This bug report is over a year old?

Yes, it is. And it would be so easy to fix!

pst007x (turone) wrote :

Still an issue in 15.10

 :(

It's been a problem since 2008!
https://answers.launchpad.net/ubuntu/+question/31292
@zerofossifuel 's solution worked on 15.10.

Still an issue in 16.04 LTS! :(

This is utterly ridiculous. It's now been *eight years* and system-config-samba still does not install properly under Ubuntu 16.04 LTS!

@zerofossifuel 's workaround worked on 16.04 too.

Mattia Rizzolo (mapreri) on 2016-05-27
Changed in libuser (Ubuntu):
assignee: nobody → Mattia Rizzolo (mapreri)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libuser - 1:0.62~dfsg-0.1ubuntu1

---------------
libuser (1:0.62~dfsg-0.1ubuntu1) yakkety; urgency=medium

  * Build-depend on hardening-wrapper to support the 'hardening' build flag.

 -- Steve Langasek <email address hidden> Sat, 09 Jul 2016 22:42:44 -0700

Changed in libuser (Ubuntu):
status: In Progress → Fix Released
Matteo Seclì (matteosecli) wrote :

Confirmed in Ubuntu 16.04.1. libuser1 1:0.62~dfsg-0.1ubuntu1 does not fix the problem for me.

Leipero (lei-pero) wrote :

Also Ubuntu 16.04.1, problem is still there.

The old solution of "sudo touch /etc/libuser.conf" as others mentioned solves the problem.

------- Comment From <email address hidden> 2016-10-03 14:00 EDT-------
The solution given by Steve Langasek was applied to 16.10

------- Comment From <email address hidden> 2016-10-03 14:01 EDT-------
I have just tested this on 16.10 with libuser 1:0.62~dfsg-0.1ubuntu1, and it worked.

tags: added: targetmilestone-inin---
removed: targetmilestone-inin1510
bugproxy (bugproxy) on 2016-10-04
tags: added: targetmilestone-inin1610
removed: targetmilestone-inin---
Bruno Nova (brunonova) on 2016-10-04
tags: added: xenial
Bruno Nova (brunonova) wrote :

Here's a patch to fix this bug in system-config-samba.
It's in quilt format, so you should be able to just "quilt import" it into the package.

The patch is just a workaround that will modify /usr/sbin/system-config-samba to create the missing file automatically if it doesn't exist.

I hope this bug (which is marked as **High** importance!) is fixed soon.

The attachment "07_libuser.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

I hope a patched version will soon be present in the repositories for all supported Ubuntu versions. I wonder how such an easy thing could take such a long time!

Bruno Nova (brunonova) wrote :

It's probably because system-config-samba is in the "universe" repository, and thus community maintained. It's still sad, though.
If the patch doesn't reach the official repositories, I'll put it in a PPA.

Jack Howarth (jwhowarth) wrote :

Why not take the path of least resistance here? Just make the system-config-samba have an dependency on the installation of the libuser package and the problem goes away, no? It certainly worked for me tonight with a fresh installation of 16.10.

Note from...

http://packages.ubuntu.com/yakkety/system-config-samba

and

http://packages.ubuntu.com/yakkety/python-libuser

I see a dependency on libusr1 in python-libuser, but no dependencies on libusr which seems absurd.

Scott Moore (scottbomb) wrote :

Is this bug EVER going to be fixed?

Changed in system-config-samba (Ubuntu):
assignee: nobody → Sirgienko Nikita (mmmm98)
Changed in system-config-samba (Ubuntu):
assignee: Sirgienko Nikita (mmmm98) → nobody
Pavlos Kairis (kairis) wrote :

bug exists in 18.04 (bionic) as well. touch /etc/libuser.conf fixes it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers