vlc broken with latest libupnp

Bug #1571199 reported by Oliver Grawert on 2016-04-16
242
This bug affects 60 people
Affects Status Importance Assigned to Milestone
VLC media player
Unknown
Unknown
libupnp (Debian)
Fix Released
Unknown
libupnp (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

with the addition of debian/patches/24-miniserver_IPV4_INADDR_ANY.patch vlc can not connect to the local UPNP socket anymore, reverting this patch makes everything work fine again.

this is handled in debian as https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=813249
and upstream as https://sourceforge.net/p/pupnp/bugs/127/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libupnp (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) wrote :

rebuild of teh binary with the patch removed ... for testing purposes (install with dpkg -i )

Changed in libupnp (Ubuntu):
importance: Undecided → Medium
Oliver Grawert (ogra) on 2016-04-16
description: updated
Changed in libupnp (Debian):
status: Unknown → Confirmed
Vojtěch Drábek (vojta-drabek) wrote :

I am not sure where to post this as the Ubuntu bug is marked as duplicate and I am not sure if this is the same bug:

The same or similar problem on Ubuntu 16.04 (Xenial), VLC 2.2.5:

core debug: adding services_discovery upnp{longname="Universal Plug'n'Play"}...
core debug: looking for services_discovery module matching "upnp": 14 candidates
upnp info: Initializing libupnp on '(null)' interface
upnp error: Initialization failed: UPNP_E_SOCKET_BIND
core debug: no services_discovery modules matched
core error: no suitable services discovery module

Matthias Niess (mniess) wrote :

Can't we just revert the patch and put the new package in ubuntu-updates?

Eugenio Tampieri (eutampieri) wrote :

VLC gives to me this:

core debug: adding services_discovery upnp{longname="Universal Plug'n'Play"}...
core debug: looking for services_discovery module matching "upnp": 14 candidates
upnp info: Initializing libupnp on '(null)' interface
upnp error: Initialization failed: UPNP_E_SOCKET_BIND
core debug: no services_discovery modules matched
core error: no suitable services discovery module

EricDHH (ericdhh) wrote :

#2 lib works as solution here.

Tim Ritberg (xpert-reactos) wrote :

#2 does not work with Xubuntu 16.10

EricDHH (ericdhh) wrote :

Tried latest VLC stable build from ppa 2.2.5 Weatherwax (revision 2.2.2+git20161207+r58887+56~ubuntu16.04.1

Here #2 lib does not work, give this in a loop. VLC must be forced terminated.

[00007f4d78563ad8] upnp services discovery: Initializing libupnp on '(null)' interface
[00007f4d78563ad8] upnp services discovery error: UPNP_E_OUTOF_BOUNDS when trying the send() action with URL: http://192.168.1.225:8200/ctl/ContentDir
[00007f4d78563ad8] upnp services discovery error: No response from browse() action
total jobs = 100, too many jobstotal jobs = 100, too many jobstotal jobs = 100, too many jobstotal jobs = 100, too many jobstotal jobs = 100, too many jobstotal jobs = 100, too many jobstotal jobs = 100, too many jobstotal jobs = 100, too many jobstotal jobs = 100, too many jobstotal jobs = 100

Please repair, the 2.2.4 weatherwax for win64 works pretty well with the same upnp server. This must be some kind of client fault.

Changed in libupnp (Debian):
status: Confirmed → Fix Released
kikito (cma54) wrote :

same:

VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[0000000000af7148] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
[00007f8b8c2120e8] upnp services discovery: Initializing libupnp on '(null)' interface
[00007f8b8c2120e8] upnp services discovery error: Initialization failed: UPNP_E_SOCKET_BIND
[00007f8b8c2120e8] core services discovery error: no suitable services discovery module

Tim Ritberg (xpert-reactos) wrote :

Will this bug ever be fixed?

I have a similar issue on Ubuntu 16.04 with the most recent version from repositories (2.2.2 Weatherwax).

I have a similar issue on Ubuntu 16.04 with the most recent version from repositories (2.2.2 Weatherwax).

upnp services discovery: Initializing libupnp on '(null)' interface
upnp services discovery error: Initialization failed: UPNP_E_SOCKET_BIND
core services discovery error: no suitable services discovery module

Hansen (moteprime) wrote :

It have 'some sort of luck' with version 1.2 from Zesty.
VLC stops erroring but doesn't shine at finding the servers all the time. :-/

Package:
http://packages.ubuntu.com/zesty/amd64/libupnp6/download
(mind the build)

Core Ghost (coreghost) wrote :

A dirty workaround is to disable the beloved ipv6 temporally:

echo 1 | sudo tee /proc/sys/net/ipv6/conf/all/disable_ipv6

You can also create a virtual interface without ipv6 support in an ad-hoc namespace and spawn vlc within it.

Ack in 16.04. Unless install the package from #2 upnp doesn't work in VLC. Even in VLC 3 (from ppa:videolan/master-daily) so it's definitely a upnp issue.

Vlad Orlov (monsta) on 2017-08-01
tags: added: xenial
EricDHH (ericdhh) wrote :

Ubuntu 16.04-3

No change for that situation, so today Ubuntu is unable to play from UPNP. Something that every smartphone, tablet, gaming console or windows computer can do with ease. Spend two days to figure this out.

- VLC: destroyed libupnp
- Rhythmbox: Crashes every few seconds by playing from grilo UPNP
- eezUPNP: Unable to play from pulseaudio changes
- Amarok: No kio UPNP slave since 2015
- Banshee: no more development
- Exaile: UPNP not supported now
- Kodi: Plugin unable to discover servers
- Totem: Plugin lost but 10 years back there was one
- Clementine: No UPNP support

Overall status, no player for Ubuntu and that's ridiculous.

DH (dave-higherform) wrote :

Confirm fix in #2 worked in Ubuntu 16.04.3 with VLC 4.0.0-dev . I suggest this patched .deb be put in the repositories.

Dave Hartley (lp0w) wrote :

Confirm fix in #2 worked in Ubuntu 16.04.4 with VLC 2.2.2

hellslinger (jhemsing) wrote :

Still not working in Xenial Lubuntu (fully upgraded as of yesterday, Oct 23, 2018). Disabling ipv6 as suggested had no effect. My connection is through USB Wifi adapter. libupnp6 version: 1:1.6.19+git20160116-1 amd64

hellslinger (jhemsing) wrote :

snap version of VLC not working on Lubuntu Xenail either (3.0.4 stable)

Mauro Rossi (maurossi) wrote :

apt installed version not working on Ubuntu 18.10,
but why was expecting something to work on Ubuntu ?!

Just saying Ubuntu guys you can do much better than this.
Mauro

Rudy Vissers (rudy-vissers) wrote :

On a 16.04 LTS I managed to render Synology videos on the Google Chromecast.
You must use a VLC 3 to render the videos to Chromecast but unfortunately you cannot browse the network (upnp).
sudo dpkg -i libupnp6_1.6.19+git20160116-1_amd64.deb
This will enable VLC 2 to browse the network.
As soon as you located the video you want to play then RC the video and a click on 'information' and a popup is displayed. Then below the URL of the video is displayed like http://192.168.0.25:50002/v/NDLNA/1.avi.
You can open this URL from VLC 3 and render to Chromecast.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.