Ubuntu

Nautilus crashing/freezing when opening folder with svg file

Reported by Eric Amundson on 2008-12-05
152
This bug affects 31 people
Affects Status Importance Assigned to Milestone
librsvg
Invalid
Critical
Debian
Invalid
Undecided
Unassigned
librsvg (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Strange thing started happening a few days ago: When I access nautilus from the Places menu and open my home directory (named eric) nautilus always freezes.

I can open subdirectories and other bookmarks such as Documents, Pictures, etc and browse files, but the second I browse to my main home directory, nautilus freezes. I can click any icons for sub-folders in my home folder, but nautilus will hang and, within a few seconds, turn grey and stay that way.

The only way to get nautilus to close is by forcing a quit.

I can access any of the files and folders by CLI, or by using emelFM2.

After much searching, I found an old bug report at:
https://bugs.launchpad.net/ubuntu/+source/librsvg/+bug/30010

. . . which seemed to blame the crashiness on folders containing an svg image.

Interestingly enough, I was messing around in Inkscape the other day trying to create a business card and saved my work into my home folder as an svg. As soon as I deleted or moved that file Nautilus no longer crashes.

description: updated
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace of the freeze http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Eric Amundson (sewmyheadon) wrote :

Hi Pedro,

I'm having a hard time getting a full backtrace. I'll keep trying, but here's what I've got so far.

Pedro,

Here's a copy of the file that's causing the Nautilus crash. I've
renamed it to have a .old file extension as this will allow Nautilus to
browse it's directory without crashing, except in one instance:

When I try to attach this file to the bug report, even if it is renamed,
 Nautilus will always hang and even cause Firefox to hang. They must be
forcibly closed and restarted.

Eric

Pedro Villavicencio (pedro) wrote :

not here, the file gets displayed in the right way and there's no hang or crash, could you get another backtrace ? the one you submitted doesn't have any crash on it, thanks.

Eric Amundson (sewmyheadon) wrote :

Pedro,

Finally I was able to do a backtrace, but only with the sudo command. If I ran it as my regular user, it would exit before I could trace.

Here's the file - let me know if you have any questions.

Eric Amundson (sewmyheadon) wrote :

Pedro,

To clarify, I can open the file without problems using Inkscape, but just browsing the directory that contains the file using Nautilus will cause Nautilus to hang indefinitely.

Thanks for your help!

Eric Amundson (sewmyheadon) wrote :

Hi Pedro,

Please let me know if you need any more information to investigate this bug. I tried to reproduce this bug on my laptop, which is also running Intrepid and wasn't able to get it to lock up.

Sebastien Bacher (seb128) wrote :

the issue seems to be a librsvg one rather, what ubuntu do you use on the system having the issue? are you sure it's due to the example you added there?

Eric Amundson (sewmyheadon) wrote :

Hi Sebastien,

Thanks for the response.

I'm running Ubuntu Intrepid on this machine. Interestingly, I run Intrepid on my laptop as well and I can't seem to reproduce the issue there.

To double-check, I tried again on this machine and it's completely reproducible. Please let me know what other info I can provide to help out.

Thanks!

Sebastien Bacher (seb128) wrote :

could you get a valgrind log as described on https://wiki.ubuntu.com/Valgrind?

Eric Amundson (sewmyheadon) wrote :

Here you go Sebastien. Let me know if you need anything else.

Sebastien Bacher (seb128) wrote :

the valgrind log seems to indicate that nautilus was already running and it used this version rather than the one ran under valgrind, could you try if that's still an issue in jaunty and get an updated log?

Eric Amundson (sewmyheadon) wrote :

Hi Sabastien,

I upgraded the affected desktop to Jaunty on Saturday and have found that the issue is still happening.

To verify, I simply downloaded the nautilusCrashTest.old file listed above, renamed it to .svg and then went to Places/Home and it Nautilus hung again.

Here's another valgrind log.

Changed in nautilus (Ubuntu):
status: Incomplete → New
Phil Colbourn (philcolbourn) wrote :

I have a similar fault: Nautilus crashes with this SVG file in my home directory.

The attachment has a txt extension that should be removed for testing.

I am running Jaunty 9.04.

Pedro Villavicencio (pedro) wrote :

it looks like a librsvg issue, got the same with eog, reassigning.

affects: nautilus (Ubuntu) → librsvg (Ubuntu)

I am affected by the same problem. Nautilus hangs when entering a folder with svg files and ff hangs as well if I try to upload the file. I can open it without any problems in Inkscape. The bug started manifesting yesterday, I didn't have any problem before that. I'm using 9.10 (fresh install).

akolahi (akolahi) wrote :

I have the exact same problem. browsing a folder with svg causes the system to crash, though i can open the svg's directly from a program.

Glaurung (glorund) wrote :

I have experienced this issue with both Ubuntu and Debian and seems to not be corrected along the various updates of them.

I have exactly, i think, the same behavior, when I'm nautilus-exploring a dir conatining some svg, it hangs. Is not about all svg files, is only with the ones that have several and big images, specially, or complex gradient effects and so.

Only trying to be lucky, i installed librsvg2-2.18-cil and librsvg2-bin with no success. I'm in Debian Lenny, but i test periodically Ubuntu releases and i remember to have the same problem.

I'm sad to say this, but this kind of things are a hard brake to sell anyone Inkscape capabilities in GNU/Linux. I've almost learned to live with this bug for more than a year or two from the first time, but really it's a complete shame.
Thanks anyway for your work;
Raimon

Glaurung (glorund) wrote :

Comment elongation:
Living with this bug supposes to me compress affected file in a zip or something like this when I'm no more using it. Only saying this to propose a provisional solution about, and to ask for other workarounds. Renaming to "old" the svg extension doesn't work for me. Any way to disable some extensions or particular files from being preview?
thanks,
Raimon

Sebastien Bacher (seb128) wrote :

The bug should be sent upstream to http://bugzilla.gnome.org by somebody having the issue

Glaurung (glorund) wrote :

Hi,

bug submitted here
https://bugzilla.gnome.org/show_bug.cgi?id=604525
and perhaps this one is related too, or not:
https://bugzilla.gnome.org/show_bug.cgi?id=366532

Hope this helps to solve it...
thanks,
Raimon

Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME, you should perhaps assign it to librsvg though, nautilus maintainer don't cope with the number of bugs there and mostly don't read those, you might get a reply if you open the issue on librsvg which is likely the library which has the issue there

Pedro Villavicencio (pedro) wrote :

I've reassigned the bug to librsvg on the upstream bts, thanks for sent it there.

Changed in librsvg (Ubuntu):
status: New → Triaged
Edgar Castelo (edgarinventor) wrote :

Just solved this one:

After seeing this,
"In particular, I would like to prevent thumbnail generation for images on CD/DVD.
Is there a way? TIA.

Open Nautilus. Goto Edit -> Preferences. In one of the tabs, there is an option to disable preview selectively. See if that helps."

I went and done that, only to find,

A) No .SVG thumbnail setting;
B) A nasty Evince command for Thumbnailing, get this, .EPS files...

Disabled that one, and not only Nautilus won't crash, but .SVG files thumbnail fine!

nico (romano-nicola) wrote :

I can confirm the bug on Fedora 12.
Edgar, could you please explain where did you find those options? I don't seem to have them...

imobomi (imoody-uoregon) wrote :

Been having this same problem since Intrepid -- Nautilus freezes when previewing a folder with svg files in it. Using Lucid Alpha 2 now, and it's the same story. I use Inkscape a lot, and would really appreciate someone figuring out how to fix this. I've had to bury my svg files in obscure folders so I don't happen to accidentally browse them and have a freeze.

yy2kk (kangyu29) wrote :

To disable preview selectively can solve this problem, but that also means no preview for any other none text files(including image files). Only if there is a way to disable preview for svg files.

sabacon10 (sabacon10) wrote :

If i try to view the contents of this folder /usr/share/inkscape/examples Nautilus crashes and
all desktop icons disappear, right clicking on the desktop does nothing, I got the following from /var/log/syslog, seem to be related to a long standing bug in the svg library used by nautilus viewing some .svg files,

I know this may be an upstream problem but still this makes for a very poor quality desktop, if this were in other operating systems we would be up in arms about it and there would be much argument about how things got fixed quickly in the open source community, does not seem to be the case now, I have this problem a long long time ago and it is still there after much bug reporting.

I think some of the problems we report here can be replicated easily I do it with the three Linux machines I have and the same thing happens, it is time for the developers who read bug reports to stop asking people to do all kinds of unnecessary things, all they have to do is bloody try for themselves, they will see, I am quite sure most of these problems are not specific to one computer.

If this is of any use here is something from syslog:

kernel: [ 58.509498] nautilus[1979] general protection ip:e23545 sp:b4f2fa00 error:0 in librsvg-2.so.2.26.0[e0b000+36000]

sabacon10 (sabacon10) wrote :

Oh forgot to mention that i am using Karmic, Ubuntu 9.1 I have a feeling that this will still be in Lucid.

And SVG thumbnails art still dragging the entire file browser down, sometimes without it given the ability to restart itself.

This is as of _Lucid_ 14th April.

I'd say that it is fair to suggest that there are likely zero audience members that expect standard thumbnailing activity to drag down their entire desktop. Symptoms of this _exact_ bug include:

1) Crashing Nautilus. As of Lucid, Nautilus attempts to restart on its own now.

2) Freezing Nautilus requiring a pkill on the CLI.

3) Freezing the entire system. This requires switching to a virtual terminal and pkill'ing Nautilus.

This is a default thumbnailer on the system so one could only hope that this bug gets the proper attention it requires.

@Nico: If I had to wager, I'd suggest he likely found them in gconf-editor. In /schemas. You can also find all of the actual schema files in /usr/share/gconf/schemas.

Changed in librsvg:
status: Unknown → Invalid
Changed in librsvg:
status: Invalid → Unknown
Changed in debian:
status: New → Invalid
Changed in librsvg:
status: Unknown → New
bert struik (bstruik) wrote :

This problem arose today with Nautilus on the 9.04 version.
It appears to have been caused by an inkscape svg file linked to several imbedded bitmaps.
It started when I moved the images into a new subdirectory, separating them from the svg file.
Moving all the files back together in original directory and removing the introduced subdirectory corrected the problem.

Inkscape appears to automatically create a link between an image that is copied into one of its vector files and the vector file (unlike Adobe Illustrator which only links the two if the image is "placed" into a vector file).

Why Nautilus hangs because of this is beyond me.

matez (mates-fendrych) wrote :

Hello there!
I am experiencing the same problem with Lucid - some .svg files make Nautilus crash.
I tried to use other file managers - Thunar, PCMan but after a while both show the same behaviour, so probably the problem is not Nautilus specific.

Rafael Laguna (rafaellaguna) wrote :

Lubuntu (Lucid based) crashes too. When opening any GTK application and having a window open with an SVG (yes, with bitmaps) it crashes every app. But it seems the rendering engine of pcmanfm2 is a bit more resistent than Thunar or Nautilus ones.

So, is it a gnome-thumbmnailer problem?

Stephan Saalfeld (saalfeld) wrote :

I confirm this bug on an up-to-date Lucid Lynx amd64. Nautilus, and so the whole Desktop, hangs on trying to thumbnail some SVG files (that contain broken links to images). Until this may be fixed, does anybody know how to selectively switch off thumbnail generation for SVG (all the rest works fine and is very helpful)? I did not get it from the previous comments though Edgar sounds like if there is something. The mime-type of SVG (image/svg-xml or image/svg+xml) is not present in the gconf settings for thumb-nailers.

Thank you very much in advance for any help.

Covi (j.a.cobo) wrote :

BUMP!
Me too on Lucid Lynx (32bits) but processor too AMD64.

PD: Can be when SVG have externals references?? ( <image xlink:href="http://external.site"/> ) ...or too big archive (near 300Kb or more).

steba (ste-ba) wrote :

Same here with Lucid AMD64. I created a very simple image with OpenOffice and exported to SVG. I can see a preview in Nautilus, when I try to open it in EOG the whole GNOME desktop freezes. When I try to drag&drop the image, desktop freezes. When I select it in Firefox for upload, desktop freezes. Therefore I had to gzip it.

Matt Fivash (matt-5ash) wrote :

Same problem using a dell desktop and 64 bit lucid and a 64 bit lucid system76 laptop. Also the "Image Viewer" (EOG I think) application locks up when a *.svg file is attempted. This bug showed up after installing Ubuntu Updates.

Lars (larsmednosen) wrote :

We must fix this somehow, but to get access to a frozen home folder:

edit--->preferences---->views----->'view new folders using:' and change from 'icon view' to 'list view'
(of course do this in a folder that are not frozen eg 'pictures' or something)

this will NOT solve anything else than that the home folder doesnt freeze. until you do something with the SVG file...

I DONT want to go back to Windows, please!

Changed in librsvg:
importance: Unknown → Critical

I'm on Karmic because my hardware isn't supported by higher versions - ATi 4250 which kills booting on later versions. .svg preview kills nautilus and it really needs fixing. Non-techs here can't understand why their desktop background suddenly disappears! I have set my Nautilus preview option to not display files > 500k in preview because it seems to be the bigger Inkscape files that cause problems. Its a work around but not a satisfactory fix. I'd fix it myself if I knew how! Disable preview for .svg should not be that hard and it is better to display a generic icon for one filetype than crash the whole system. Another workaround if you can use samba is to put the files on a smb share because then icons are not displayed.

My 10.04 nautilus crashes with the SVG file I attach, generated with Inkscape. The same file is practically impossible to print (printing last ages).

Syslog message when happening:

pern kernel: [85128.811792] nautilus[11914]: segfault at 0 ip b328faca sp b3168bc0 error 4 in librsvg-2.so.2.26.3[b3275000+32000]

Bug#438484 is very similar, it is marked fixed, but I have a librsvg2-common 2.26.3-0ubuntu1 installed, and it still crashes.

I supposed it was the shading that creates the problem, but it's not. Here his another file, without fancy patterned background, that crash nautilus.

Covi (j.a.cobo) wrote :

@Lars , yes, but this is a dirty "hack", or anyway a solution that degenerate your experience with Nautilus, specially with images.

I still think the problem is the large files, elements as <use/> and support xlink.
*Almost every browsers based on webkit (and Firefox) have problems with use element and xlink; ...so, I think that maybe Nautilus as filebrowser too.

PS: Plz, excuse my poor English :(

I just want to add one thought to this bug:
Might this be related to the x64 version of Ubuntu? I am now running Ubuntu 10.04.1 AMD64.
I first experienced this bug when I mounted my old home directory from my Ubuntu 9.10 which was a 32bit install. On the 32bit Ubuntu 9.10 I never had any problems with svg files in nautilus (They were some svg stored in the home directory so, it previewed them every time I accessed nautilus). Now when I access my former home directory in the old home partition (I bought new hard disks, they old ones are still inside the machine) nautilus crashes immediately (unless I turn previews off). Dolphin, the KDE-file manager does not crash but it does not preview svg files.

Is there a possibility to turn just the svg preview off in nautilus? Could nautilus be compiled without this svg support?

Covi (j.a.cobo) wrote :

mmm... Franz, I think disabling preview of large files (e.g. 500Kb) can be a temporary solution.
I don't know if nautilus preview can accept any kind of regexp in gconf editor :(

Still here with Maverick. Really "nice".

@Covi: no, the file that crash my nautilus is this:

-rw-r--r-- 1 romano romano 70010 2010-09-29 16:51 organigrama.svg

I prefere not to think what could happen to an unexpert user if someone send him this file in email. Just trying to preview it will crash. It took me quite a time to understand what was happening, and I am a Unix/Linux users since 20 years.

I think that a fix is badly needed, or at least a way to disable svg preview at all.

I just observed the following behaviour:

I copied an svg-file which crashes nautilus when preview is not turned off, to a sub folder of my desktop. If I open this folder with nautilus, it doesn't crash.
Might there be a relation to the pathname?

if the file is stored in this pathname:
/home/franz/durchsehen/franz/Diplomarbeit-muster/kraftwerk/bilder/wasserdampf3.svg
nautilus crashes immediately
output of /var/log/kern.log:
nautilus[32290]: segfault at 0 ip 00007f9efb88a626 sp 00007f9ef37eb778 error 4 in libc-2.11.1.so[7f9efb809000+17a000]

Copied to this location
/home/franz/Desktop/svg-bug/wasserdampf3.svg
nautilus doesn't crash and generates the correct preview.

librsvg2-2 version 2.26.3-0ubuntu is installed

I attached the svg which is causing problems (created with dia, inksape and the textext-plugin for inkscape)

I am sorry - forget about comments #47 an #48. (can I somehow delete them?)
There where other svg-files in the first folder which caused the crashes.

I just want to confirm that svg files are causing problems on ubuntu 10.10 as well. I have tested several files with a clean and updated install of ubuntu 10.10 amd64 inside virtualbox. When opening the folder which contains the attached svg-file nautilus crashes immediately.

Jan 10 22:36:10 franz-VirtualBox kernel: [ 255.979369] show_signal_msg: 24 callbacks suppressed
Jan 10 22:36:10 franz-VirtualBox kernel: [ 255.979382] nautilus[1451]: segfault at 0 ip 00007fb82534b426 sp 00007fb80e8b0638 error 4 in libc-2.12.1.so[7fb8252ca000+17a000]

I have several other svg files which are much bigger (15MB) stored in the same folder which don't cause any problems. The attached svg has been created by a friend using with inkscape and the textext plugin (which enables to embed LaTeX rendered formulas). I remember that this file caused problems when trying to print the created pdf as well.

When I try to open this svg in firefox:
   - it crashes immediately when using the File-Open File dialog (I think firefox is trying to create a preview although previews are switched off in the nautilus preferences)
  - it opens properly when lauched from the command line:
$ firefox ~/testsvg/fgfg2.svg

As segfaults are sometimes connected with faulty memory: I am using ecc-memory (which should at least reduce the some bit-flipping errors)

This bug is limiting my experience with ubuntu and I think that I could try to ask friends to help sponsor to solve this bug, although means are limited. Let me know if you know how much is needed to resolve this bug. (At least a way to disable just the svg preview in nautilus).
(Using dolphin as filemanager is another solution, but it doesn't integrate well with the standard ubuntu desktop)

I have more crashes in the log, tipically (but I do not know if it's related) when tracker is indexing.

Jan 10 09:54:42 pern kernel: [ 169.417385] giosrc0:src[1929]: segfault at 0 ip b4c9e44a sp b4c4f790 error 4 in librsvg-2.so.2.32.0[b4c85000+30000]
Jan 10 09:54:42 pern kernel: [ 169.604031] giosrc0:src[1933]: segfault at 0 ip b4bba44a sp b4b6b790 error 4 in librsvg-2.so.2.32.0[b4ba1000+30000]

Hmm, by the way, I so not think that the upstream bug (https://bugzilla.gnome.org/show_bug.cgi?id=590788) is the same. That case is a freeze, this case is an hard crash.

I think that. until the problem is fixed, SVG icon preview should be disabled. And the priority of the ubuntu bug raised to Critical, too.

BTW, I tried (in the hope that the gconf setting took precedence on implicit ones) to do

(0)pern:~/software/bugs/nautilus/Boom% gconftool-2 -s /desktop/gnome/thumbnailers/image@svg+xml/enable -t boolean false

But had an error:

Error setting value: Bad key or directory name: "/desktop/gnome/thumbnailers/image@svg+xml/enable": `+' is an invalid character in key/directory names

...hmm. And

(0)pern:~/software/bugs/nautilus/Boom% xdg-mime query filetype organigrama.svg
image/svg+xml

So, I am blocked here. I can rename the file with the shell, set the directory to be shown as list-only, rename the file again and I can browse safely, but this works until some application try to do a preview on the #½@¡ file when opening a file, and the crash is again here.

Please: this crash is *two* years old. Would an apport-generated trace be useful? I can set up to try to generate one.

You have a fresh apport trace in bug #701820.

NULL dereference in rsvg_get_url_string():

StacktraceTop:
 rsvg_get_url_string (str=0x0) at rsvg-mask.c:91
 rsvg_marker_parse (defs=0x8c79970, str=0x0)
 rsvg_parse_style_pair (ctx=<value optimized out>,
 rsvg_parse_style (ctx=0x8c51a88, state=0x8d57358,
 rsvg_parse_style_attrs (ctx=0x8c51a88, state=0x8d57358

Mahendra Tallur (mahen) wrote :

I also experience this issue (Ubuntu 10.10, up to date, amd64) when opening a directory containing a svg file embedding many big jpeg pictures. (no tiff at all)

Actually, it occurs with 2 similar svg files. The 1st one does embed all jpeg files and the preview doesn't even have the time to be generated. The second one only contains links to the jpeg pictures, so a blank preview is generated.

However, *In both cases*, Nautilus eventually quits responding and I have to kill it. In the first case, during the preview calculation, in the second case, shortly after selecting the svg file.

Mahendra Tallur (mahen) wrote :

FYI, after double checking, the very same issue also occurs under Ubuntu Natty (today's daily) and under the latest Gnome 3 preview liveCD (based on OpenSUSE).

Seem fixed in Natty (11.04). The rendering of the "killer" svg is not correct, but nautilus do not crash.

rechengehirn (kai-pixelsucht) wrote :

Happens again in Ubuntu 11.10

Hmmm... not for me. Can you post the "killer" file? With mu old tests, Nautilus in 11.10 works ok. (Well, it doesn't crash)

Rafael Laguna (rafaellaguna) wrote :

Seems to be solved

Changed in librsvg (Ubuntu):
status: Triaged → Fix Released
Phil Colbourn (philcolbourn) wrote :

I disagree.

I downloaded my svg file that I attached in July 2009. It still crashes Nautilus.

It also killed Chrome when I tried to re-attach it!

rsvg-view also segfaults on this file. rsvg-view uses librsvg2-2

Phil Colbourn (philcolbourn) wrote :

More info: It crashes in my home directory, but not my Downloads or Desktop directory.

It does not crash when I turn off preview. Opening it with gnome image viewer from Nautilus crashes gnome image viewer.

But in my Desktop, gnome image viewer will open this file!

Nautilus preview works in Desktop as well.

So, seems to be specific to my home directory!?!

I can confirm the apparently crazy behavior that Phil reported. The file from Phil, when put in the home directory, crashes nautilus with the following error (NOTICE: it's a crash in glibc!)

Jan 2 12:09:40 romano-asus kernel: [307815.741994] nautilus[10155]: segfault at b6ad7fd8 ip 073fad89 sp b6ad7fdc error 6 in libc-2.13.so[738b000+176000]
Jan 2 12:10:05 romano-asus kernel: [307839.937064] nautilus[10186]: segfault at b6b09fd8 ip 036afd89 sp b6b09fdc error 6 in libc-2.13.so[3640000+176000]

If I put it in a subdir, the thumbnail is not generated, but nautilus do not crash. I can open the svg in eog, it just uses a lot of resources, and so much memory that the system is sluggish after doing it, and need a while to come back to normal behavior.

Error #6 is ENXIO? Invalid device or address?

Evidently the problem is still here, and quite severe too. Put that file in your home dir and a non-technical user will be unable to open Nautilus again.

Phil Colbourn (philcolbourn) wrote :

Thanks Romano

A friend noted that this SVG does not validate, so I have removed errors and warnings and it now validates as SVG 1.1.

Still same behaviour.

My friend's Chrome also crashed when attaching this file.

Phil Colbourn (philcolbourn) wrote :

Firefox dies too when attaching this file from home directory.

Changed in librsvg:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.