[Upstream] Writer cursor focus on "paste special"goes to Styles and Formatting window

Bug #999269 reported by Mitch Claborn on 2012-05-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Low
libreoffice (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu 12.04 LTS (64 bit)
libreoffice-writer:
  Installed: 1:3.5.3-0ubuntu1

With the "Styles and Formatting" dialog open as a separate window, when I do a "Paste Special" into the current document, immediately after the paste, cursor focus goes to the "Styles and Formatting" window, instead of remaining in the document. A recording of this problem may be found at https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/999269/+attachment/3161034/+files/focus_prob.ogv .

+ Not reproducible in Xubuntu.

 lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.3-0ubuntu1
  Candidate: 1:3.5.3-0ubuntu1
  Version table:
 *** 1:3.5.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Mon May 14 13:39:28 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Mitch Claborn, thank you for reporting this and helping make Ubuntu better. Could you please provide a recording of this problem via the package recordmydesktop?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Mitch Claborn (mitch-news) wrote :

Mitch Claborn, thank you for the helpful recording. Do you have any Ubuntu repo extensions (ex. lo-menubar) or externally downloaded extensions installed? If so, which one(s)?

description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
Mitch Claborn (mitch-news) wrote :

I do not have any extneions installed for Libre Office.

Changed in libreoffice (Ubuntu):
status: Incomplete → New

With the "Styles and Formatting" dialog open as a separate window, when
I do a "Paste Special" into the current document, immediately after the
paste, focus goes to the "Styles and Formatting" window. Seems to me
that focus should return to the document.

A recording of this problem may be found at
ttps://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/999269/+attachment/3161034/+files/focus_prob.ogv

Ubuntu bug https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/999269

Mitch Claborn, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about the status. Thanks in advance.

description: updated
Changed in libreoffice (Ubuntu):
status: New → Triaged
summary: - Libre office writer focus on "paste special"
+ Writer cursor focus on "paste special"goes to Styles and Formatting
+ window
Changed in df-libreoffice:
status: New → Incomplete
Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
summary: - Writer cursor focus on "paste special"goes to Styles and Formatting
- window
+ [Upstream] Writer cursor focus on "paste special"goes to Styles and
+ Formatting window

possibly fixed with:
https://bugs.freedesktop.org/show_bug.cgi?id=48096
on upstream master

Paddy Landau (paddy-landau) wrote :

This bug is still present in Libre Office 4.0.0.3 (tested on Ubuntu 12.04 64-bit fully updated; LO 4.0.0.3 deb files downloaded from the Libre Office website and installed using dpkg).

I can elaborate on the original bug report:

1) It affects not only the Styles dialogue, but also the Navigator dialogue.

2) It happens not only with Paste Special, but also other actions such as F7 (spell check) or adding an image.

This bug is still present in Libre Office 4.0.0.3 (tested on Ubuntu 12.04 64-bit fully updated; LO 4.0.0.3 deb files downloaded from the Libre Office website and installed using dpkg).

I can elaborate on the original bug report:

1) It affects not only the Styles dialogue, but also the Navigator dialogue.

2) It happens not only with Paste Special, but also other actions such as F7 (spell check) or adding an image.

Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19

Reproduced on Linux, not Windows.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI

Ubuntu 14.10 64-bit
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug

3. Leave a comment with your results.

4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16

I confirm that this bug is still present.
LibreOffice 5.1.2.2
Ubuntu 14.04 64-bit

Changed in df-libreoffice:
status: Confirmed → Invalid
Changed in libreoffice (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.