Ubuntu

Visio files not associated with LibreOffice Draw

Reported by Evan Huus on 2012-02-05
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Low
Björn Michaelsen
mime-support (Ubuntu)
Undecided
Unassigned
shared-mime-info (Ubuntu)
Low
Unassigned

Bug Description

Since 3.5 (planned for Precise), LO has an import filter for MS Visio files (.VSD) [1]. Those files currently have no default association with any application, so it would be a major usability improvement to have them open in LO by default.

Filing against LO because I'm not sure what package controls default file associations.

[1] http://wiki.documentfoundation.org/ReleaseNotes/3.5#Filters

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CheckboxSubmission: e049aa43e015d38fc2b288a8a60db142
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Sat Feb 4 17:46:40 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
SourcePackage: libreoffice
UpgradeStatus: Upgraded to precise on 2012-01-14 (21 days ago)

Evan Huus (eapache) wrote :
Jack Leigh (leighman) wrote :

Let's try mime-support

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Changed in mime-support (Ubuntu):
status: New → Confirmed
Chris B (billington-chris) wrote :

The first time a user unaware of the ability of Libreoffice to open .vsd files tries to double-click on the .vsd file, a Nautilus dialog 'searching for application to open file' appears, and concludes with 'Visio document is not supported'.

However, if user forces opening with Libreoffice (in my case Writer, first of all) then an association to .vsd is created to Writer (but the file is opened directly in Draw). Files can then be double-clicked and opened correctly in LO Draw.

Further attempts to open with other application (right-click, open with other application, 'find applications online' results in the same message 'Visio Document is not supported'.

If 'cancel' is then clicked (the only option) then a dialog
'Failed to look for applications online'
GDBus.Error:org.Packagekit.Modify.Cancelled:
is displayed.

Well worth fixing this as the ability to reliably open Visio documents removes a major blocker for business users migrating from Windows to Ubuntu/Libreoffice/Linux

Chris B (billington-chris) wrote :

Further, .vss files do not seem to be supported by Libreoffice. Some business documents seem to be distributed as 'Visio Stencils' so if support can be added by changing MIME type assignments this would be beneficial

Felix Möller (felix-derklecks) wrote :

I just wanted to report this. In addition to opening the vsd files with LO they should get an appropriate icon.

Sebastien Bacher (seb128) wrote :

nautilus seems to display the correct mimetype, i.e the properties show "application/vnd.visio" here on a .vsd, what is missing is for libreoffice-draw.desktop to list application/vnd.visio in its MimeType= list

Changed in libreoffice (Ubuntu):
importance: Undecided → Low
Changed in shared-mime-info (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Björn, could you add the mimetype to the libreoffice-draw desktop for the next upload?

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

fix was released with 3.5.2

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Charles Plessy (plessy) wrote :

Closing in mime-support as /etc/mime.types contains application/visio since 3.51-1.

Changed in mime-support (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments