[Upstream] Duplex options do not print duplex

Bug #894763 reported by karaluh on 2011-11-25
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)

Bug Description

When you try to set up duplex printing in both calc and writer, the only options you get is <ignore> and Off. Neither works.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice-calc 1:3.4.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Fri Nov 25 15:02:34 2011
 PATH=(custom, user)
SourcePackage: libreoffice
UpgradeStatus: Upgraded to oneiric on 2011-10-18 (38 days ago)


I try to print in duplex mode but there are no settings to do it.

In OpenOffice there is into the V3.3 a option into the printer dialogue to set the printer to duplex.


But in Libreoffice 3.4.2 and also 3.3.3 the settings are missed:


So it would be fine to implement it also in LibreOffice. Before that option is not implemented for me (I'm sorry to say) it's a no go, because I need it very often.

*** Bug 38758 has been marked as a duplicate of this bug. ***

karaluh (karaluh) wrote :

Confirmed in Ubuntu 11.10 LibreOffice 3.4.4. When one clicks File -> Print -> highlight the printer -> Properties -> Paper tab duplex has options for either <ignore> or Off.

lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

apt-cache policy libreoffice-writer
  Installed: 1:3.4.4-0ubuntu1
  Candidate: 1:3.4.4-0ubuntu1
  Version table:
 *** 1:3.4.4-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - Duplex printing doesn't work
+ [Upstream] Duplex options do not print duplex
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

Thanks for bugreport
Please, verify: in last version of LibreOffice problem remains?
If available, try on another OS and tell result
On the same computer, but from another program, duplex works?

May be related:
Bug 33639 - doesn't remember duplex settings
Bug 42926 - Duplex options are ignored
Bug 45630 - : Printer Driver Options do not Work with LO Documents (Duplex, Pages per Sheet)
Bug 32841 - Printing multiple copies outputs full duplex
Bug 35096 - Bug: printing sides + multiples pages per sheet
Bug 43932 - PRINTING: Paper tray setting not accepted from "File -> Print..."


additional info now.:

Like you see in the screenshot (first one) the duplex option works in OpenOffice.
The Screenshot of course was made on the same computer (else it makes no sense).

Because LibreOffice is based on OpenOffice that option was missed.

When you have also a look here at LibreOffice 3.5.0 into the printing dialogue:


you see nothing also in 3.5 will be changed.

In opposite of OpenOffice:


or NeoOffice:


you see there the duplex Options work. All programs are running on OSX 10.7.3.

At windows 7 the option is there also if it will be hidden:

http://www.glomme.de/snaggit/2012-03-01_17-39-50.snagproj.jpeg <- Option

http://www.glomme.de/snaggit/2012-03-01_17-41-09.snagproj.jpeg <- Duplex

So only here at osx (not tester here at linux) the option will be missed.

Thanks for additional tests

possibly related: bug 872873

The posted Problem its different from my one.
The Problem https://bugs.freedesktop.org/show_bug.cgi?id=44638 describes a Problem with empty pages, when using duplex. My Problem is that I can't print duplex because the function is missing.

The Problem in the bug is also regarding Ubuntu, my Problem occurs in OSX (ok also unix working in the background).

So I think the Problems are different.

With that additional info, I also change the Platform to my one. (x86-64 / Mac OS X)

Also change the version of LO, because the Problem also still exit in the Version


Hans Glomme, please do not toggle the version. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version

Changed in df-libreoffice:
status: Incomplete → Confirmed

Bug 42926 "Duplex options are ignored" - This appears to be the same problem and the solution of setting the "Printer Language Type" to "PostScript" certainly works on my system.

If more people can confirm this solution perhaps the status should be changed to RESOLVED, but being new to bug reporting I am not sure how this is done.

When using the "PDF" language setting and setting the printer "preferences" to duplex mode, the printer will operate in duplex mode, i.e. to re-feed the paper, but there is nothing printed on the reverse side. What should have been printed on the reverse side it printed on the next new sheet feed into the printer, i.e. the end result is the same at setting duplex mode to "none", but slower due to the re-feed of the paper.

Problem exists on versions 3.5 (Build ID: 350m1(Build:413)) and 3.6 (Build ID: 360m1(Build:303)) under openSuSE 12.1 i586 and 12.2 x86_64 repectively printing to Kyocera FS-C5100DN.

Tried various printer driver options, but manufacturer's PPD offers best results and control of paper input.

Work round: output as PDF and print using Acrobat reader

Bug 33639 "doesn't remember duplex settings if modifying with LO-windows" - Not the same issue.

Bug 45630 "Printer Driver Options do not Work with LO Documents" - Don't think this is the same issue.

Hi Richard,

Bug 42926 : You look at the date? Maybe that case must be closed. Because it was after my one.

"If more people can confirm this solution perhaps the status should be changed to RESOLVED, but being new to bug reporting I am not sure how this is done."

Well so you think a not solved problem has to been solved? Because at me the problem still exist.

Work round: output as PDF and print using Acrobat reader

Of course you can do it like that. But please forgive me: What does it have to do with the problem that I can't print duplex (doesnt matter if I use a ink printer or a laser printer, so also not a Postscript Problem) out of LO?

So for me the problem still exist and isn't solved. And BTW in oOO and also in NeoOffice it works only LO don't have any option for Duplex printing.

*** Bug 42926 has been marked as a duplicate of this bug. ***

Setting OS to ALL since fdo#42926 was reported against Linux and fdo#39809 here OS X.

*** Bug 49591 has been marked as a duplicate of this bug. ***

Tested on :
Version (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)

on OSX 10.8.4

This worksforme with a Kyocera FS-C5150DN networked printer.
1) Load multi-page document in Writer
2) Press Cmd-P to open OSX print dialog.
3) Select "Double-sided printing" checkbox next to "Number of Copies" in the OSX print dialog.
4) Press "Print" to print


*** Bug 68612 has been marked as a duplicate of this bug. ***

On pc Debian x86-64 with 4.1 sources updated 1 week ago, I see a duplex options in Print dialog.
- File/Print
- Properties
- Duplex

Hans: could you give a try to a recent version? (last one is 4.1.3)

Created attachment 89023
Main Tab Printing dialogue

The Main dialogue where I choose the printer

Created attachment 89024
The properties dialogue

Here I can't find anything about duplex

I try it out under windows and can't find any duplex option under the way :
- File/Print
- Properties (here is not option "Duplex")
- Duplex

Created attachment 89025
duplex screenshot

I attached a screenshot. The problem I have is it's always grayed, but that's another story.

Hans: seeing your first screenshot, could you then click on "Eigenschaften"?

(In reply to comment #23)
> Hans: seeing your first screenshot, could you then click on "Eigenschaften"?


then the printer tool open and I can set the settings. Then it also works.
Only thought that LO did it.
But so it's ok, also if I expect something other.

Hans: Thank you for your feedback. I'm not sure to have well understood your last comment.
1) Do you mean you found duplex option + been able to print in duplex?
2) What other scenario did you expect?

(In reply to comment #25)
> Hans: Thank you for your feedback. I'm not sure to have well understood your
> last comment.
> 1) Do you mean you found duplex option + been able to print in duplex?
> 2) What other scenario did you expect?


sorry that I don't write it more clear.
Ok at this comment I will try to bring a little bit light into the dark ;)

When I press on "Eigenschaften" then the printer settings from HP (in my case) comes up:


The same I could do with my Samsung printer but then comes up the samsung software.


What I was expecting was somthing like in Microsoft Word / Excel etc.
Where I can direct say into the settings that all my documents are printed out Duplex. I also can remember (but they also changed now) that it was like that some versions before into OpenOffice.

I made a screenshot what I mean


Something like in the screenshot I would expected. Like it also will be into work see screenshot below:


Changed in df-libreoffice:
status: Confirmed → Incomplete

I put it back at NEW since I got no more questions. Sorry for the delay to respond.

mabab (mabab) wrote :

Go to /usr/lib/libreoffice/program/spadmin and deactivate support for cups. Go to new printer and import your ppd-file from /etc/cups/ppd. In my case it works with Printer language Type postscript and pdf.

please retest with current LibO and give an update of the bug status (still present or resolved)

Changed in df-libreoffice:
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.