Horizontal Scrollbar in kde dont work (default theme)

Bug #856210 reported by Unco New on 2011-09-22
96
This bug affects 17 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Unassigned
Precise
Medium
Unassigned

Bug Description

When using libreoffice in kunbuntu 11.10 beta, the horizontal scrollbar seems too large and cannot be moved (see screenshot in attachement). I've seen this bug in calc and impress.

Thanks for your help !

WORKAROUND: remove libreoffice-kde (but you lose KDE integration - but it becomes useable)

Unco New (unconew) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Ian Turner (vectro) wrote :

Note that horizontal scroll wheels (or touchpad equivalent) serve as a workaround to this issue.

Ian Turner (vectro) wrote :

KDE has closed the bug as DOWNSTREAM (i.e., they are blaming libreoffice folks)

affects: df-libreoffice → oxygen-transparent

Unco New, thank you for reporting this and helping make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 856210
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.
As well, are you referring to resizing the horizontal scrollbar or moving the bar to the left/right to move the view of the sheet?

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
ronny (ronny-standtke) wrote :

Shouldn't this bug get a higher importance?
At least for me this issue is an absolute blocker that prevents any upgrades of our systems to Kubuntu 11.10.

Unco New (unconew) wrote :

Hello,

I'm referring to moving the bar to move the view.

I precise that I've experienced this bug today with libreoffice draw.

And I'm okay with ronny. Without fix, libreoffice is quite unusable in kubuntu 10.10 !

Regards,
Unco

Ian Turner (vectro) wrote :

Another workaround to this issue (possibly suitable for Ronny) is to run libreoffice with OOO_FORCE_DESKTOP=gnome, which will force it to use GTK instead of QT, like so:
OOO_FORCE_DESKTOP=gnome libreoffice

Not sure but I think there is an soffice RC file someplace where you could stick this, too.

Ian Turner (vectro) wrote :

Also, I can't seem to set this, but I think the bug should be on the libreoffice-kde package, not libreoffice itself. Removing the former package is also a workaround for this bug (but loses all KDE integration).

Unco New (unconew) wrote :

I've added OOO_FORCE_DESKTOP=gnome into /usr/bin/libreoffice , it work for me but I loose kde look'n'feel...

It's a temporary workaround, but for me it cannot be let like this for Kubuntu 10.10.

Changed in oxygen-transparent:
importance: Unknown → Medium
Dave Gilbert (ubuntu-treblig) wrote :

Medium: It's a toss up between Medium/High
I'm hitting it myself.

I'm using oxygen theme; (kde-workspace 4.7.2-0ubuntu1) libreoffice 3.4.3-3ubuntu2 (with libreoffice-kde installed).

Dave

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
Murz (murznn) wrote :

Also have this issue. If I change KDE widget style from oxygen to another (for example, plastique), all works normally, so problem is in KDE Oxygen widget style, that is active as default.

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
description: updated

With Libreoffice 3.4.3 horizontal scrollbar seems too large and cannot be moved (see screenshot in attachement). I've seen this bug in calc and impress.

https://launchpadlibrarian.net/80592985/capture%20d%27%C3%A9cran1.png

This only happens with:
- libreoffice-kde
- KDE widget style oxygen (other KDE styles like plastique are fine)

@Lubos Lunak: Could you have a look?

936d19e606cbf29d41bff42db559a01f5deb240c

Feel free to ack and backport.

*** Bug 42738 has been marked as a duplicate of this bug. ***

#42749 is also a duplicate

*** Bug 42816 has been marked as a duplicate of this bug. ***

Hello Unco, or anyone else affected,

Accepted libreoffice into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libreoffice (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Changed in libreoffice (Ubuntu Precise):
status: Confirmed → Triaged
Tony Middleton (ximera) wrote :

Just installed new version. Seems to solve problem in both Calc and Base.

Martin Pitt (pitti) on 2011-11-15
tags: added: verification-done
removed: verification-needed

*** Bug 42801 has been marked as a duplicate of this bug. ***

Also works here with plain Ubuntu (smoketesting with ODF spec)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:3.4.4-0ubuntu1

---------------
libreoffice (1:3.4.4-0ubuntu1) oneiric-proposed; urgency=low

  [ Bjoern Michaelsen ]
  * patch only update to upstream 3.4.4.2
    - Perhaps it could be simplified {{fdo|38286}} [Julien Nabet]
    - fix building of the 64-bit Windows Explorer extension {{fdo|36950}} [Tor Lillqvist]
    - fix recalculate matrix formula dimension correctly {{fdo|39485}} [Eike Rathke]
    - mark all formula cells dirty when appending a new sheet {{fdo|35965}} [Kohei Yoshida]
    - speed up range name lookup by index. {{bnc|715104}} [Kohei Yoshida]
    - get testtool working {{fdo|37164}} [Noel Power]
    - move init that depends on parent to post-parent avail {{fdo|36678}} [Caolán McNamara]
    - toggling grammar checkbox deletes sentence {{fdo|39348}} [Caolán McNamara]
    - fix handling of SAFEARRAY(s) returned as variant in olebridge {{fdo|38441}} [Noel Power]
    - libreoffice doesn't build with poppler-0.17.3 {{rhbz|735182}} [Caolán McNamara]
    - fix : Auto fit text VIEWING too small in PPT {{fdo|41245}} [Arnaud Versini]
    - don't crash while dropping texture {{fdo|38391}} [Ivan Timofeev]
    - fix hang in slideshow. {{fdo|32861}} [Thorsten Behrens]
    - backport collection of operator= fixes {{fdo|37403}} [Caolán McNamara]
    - createProcessServiceFactory can't happen before sync {{fdo|37195}} [Caolán McNamara]
    - dbGridControl::RemoveColumn even if no corresponding Model column {{fdo|40701}} [Lionel Elie Mamane]
    - fix fallout - recognize .svg in odf container {{fdo|41995}} [Thorsten Behrens]
    - fmXGridPeer::getByIndex: Error checking of pGrid->GetModelColumnPos(nId) call {{fdo|40701}} [Lionel Elie Mamane]
    - get testtool working {{fdo|37164}} [Noel Power]
    - load Dialog library before trying to get embedded images {{fdo|40079}} [Lionel Elie Mamane]
    - fix the drawing of dotted and dashed borders in Calc {{fdo|37129}} [Tomofumi Yagi]
    - reenable "use typedefs and endianess from sal" patch hunk {{fdo|39355}} [Lionel Elie Mamane]
    - activation order crashes address database {{fdo|41022}} [julien2412]
    - let Qt call XInitThreads(), so that it knows it's been called {{fdo|40298}} [Luboš Luňák]
    - fix the drawing of dotted and dashed borders in Calc {{fdo|37129}} [Tomofumi Yagi]
    - comment added {{fdo|39510}} [Bjoern Michaelsen]
    - crash on closing document with footnotes {{fdo|39510}}, {{lp|854626}} [Bjoern Michaelsen]
    - fix for avoid crash while processing incorrect range of pages {{fdo|35513}} [Ivan Timofeev]
    - fix leak in pdf export. {{i|116448}} [Andor Ertsey]
    - hide 'math baseline alignment' unless available {{fdo|40341}} [Takeshi Abe]
    - fix fallout - recognize .svg in odt container {{fdo|41995}} [Thorsten Behrens]

  [ Lubos Lunak ]
  * fix for "Libreoffice-kde breaks with kde oxygen theme on scrollbars" (LP: #856210)
 -- Bjoern Michaelsen <email address hidden> Fri, 11 Nov 2011 15:13:24 +0100

Changed in libreoffice (Ubuntu Precise):
status: Triaged → Fix Released
Changed in libreoffice (Ubuntu Oneiric):
status: Fix Committed → Fix Released
ronny (ronny-standtke) wrote :

While the scrollbars now work (applause for that), it still seems to be impossible to sort the slides in Impress. It this a (closely) related bug or should I open a new one?

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Fix Released
ruswatson (ruswatson) wrote :

Thanks guys for fixing the slidebar in Calc. It is really appreciated. Have a good Xmas.

Hi Rus,

Great team work all around and thanks for reporting the bug. Amazing
what we can achieve as a community team :D

Regards,

Peter Dam (SwitchDK)

Launchpad: https://launchpad.net/~switchdk
Ubuntu Wiki: https://wiki.ubuntu.com/switchdk

On 06/12/11 01:42, ruswatson wrote:
> Thanks guys for fixing the slidebar in Calc. It is really appreciated.
> Have a good Xmas.
>

avlas (avlas) wrote :

I'm suffering it in natty. Could the fix ported back to natty, please?

Caro,

Ho avuto una giornata folle ieri e ho voluto condividere la storia con voi, si può trovare qui <http://leandro.griable.com/mxbq>

Grazie per la tua considerazione,FBIO ROSSI

Fabio Rossi (rossi-f) wrote : ✉Hi

Hello friend,

I just wanted to say Hi and also show you something really cool, just take a look http://zik-et-dance.com/makeup/aa2u1j/yvsdbh35/twist.php?4445

FBIO ROSSI

Sent from Mail for Windows 10

Dear friend!

When a raging wildfire destroyed Mark Orsillo’s home and prized movie collection, strangers from http://sparktuition.com/bitex.php?7a7b

Yours faithfully, FBIO ROSSI

From: Bug 856210 [mailto:<email address hidden>]
Sent: Wednesday, July 19, 2017 12:51 AM
To: <email address hidden>
Subject: What's a water ramp?

This comment needs to be higher up. I've been in Japan for a few years and it's the country I've made my home. I always heard stories about the work/school life of people here but finally coming here and seeing it was mind-boggling. I don't like the stereotypes to be spread further but things like overtime work, drinking with coworkers and after school activities (e.g. cram school, club activities, etc.) are ridiculous. Moderation is not a word many Japanese people are familiar with.

Hey!

I found some new stuff for you, i think you're going to like it, more info at http://vdv-kavkaz.ru/networkx.php?1415

Sincerely, FBIO ROSSI

Sent from Mail for Windows 10

Greetings!

I know that you were looking for that kind of information, just look at that https://is.gd/9eSjbo

Very truly yours, FBIO ROSSI

From: Bug 856210 [mailto:<email address hidden>]
Sent: Monday, August 07, 2017 7:54 PM
To: <email address hidden>
Subject: Thank you

Wanna hear how it could be worse? ?? You could think just the opposite! Don't believe me? Everything you do matters, no matter what, and no matter what, you can't predict all the consequences! So you analyze yourself into paralysis, and then feel trapped, wishing for the consequence free life you could have had. Oh... Happy new year!

Sent from Mail for Windows 10

Yo!

I've just found the thing you were looking for, I am hoping it is. Take a look here http://www.dammans.com/drag.php?UE84NTYyMTBAYnVncy5sYXVuY2hwYWQubmV0

FBIO ROSSI

-

A cookie is a small file which asks permission to be placed on your computer's hard drive. Once you agree, the file is added and the cookie helps analyse web traffic or lets you know when you visit a particular site. Cookies allow web applications to respond to you as an individual. The web application can tailor its operations to your needs, likes and dislikes by gathering and remembering information about your preferences.

Dear,

I just wished to give out some of my thoughts, please read them here http://www.sujiapartment.com/will.php?UE84NTYyMTBAYnVncy5sYXVuY2hwYWQubmV0

FBIO ROSSI

From: Bug 856210 [mailto:<email address hidden>]
Sent: Tuesday, October 31, 2017 4:51 PM
To: <email address hidden>
Subject: You hate Thierry Henry

Stunning photos... yes.

Tree growth connected with celestial movement and astral cycles... no.

Can tree growth be affected by our sun, the moon, and possibly power lines? Yes.

Can a distant star affect a tree? Not much (sure, there is some light).

Do *astral cycles* affect trees? Fuck no... what a bunch of hog wash.

Money quote from the posted article that lets you know it is nothing but bullshit...

*I believe energies inside the earth are transmuted and transmitted into the cosmos by the trees, so the trees are like antennas, senders and receivers of earth energies and stellar energies.*

Jeebus fuck - what a load of nonsense.

Sent from Mail for Windows 10

Have you already seen all that cool stuff ? I'm sure you're going to love it ! Check it out http://www.samtekintl.com/bjwgx.php?UE84NTYyMTBAYnVHUy5sYVVOY2hwYWQubmV0

Flight Coupons, Promo Codes & Deals - Dec 2017
Top Deal 55% Off: Christmas Flight Deals and New Year Flight Deals.

Call to Us and Get Discount Now <a style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</a>. (24/7 Support.)<br><br>Enjoy Christmas Deals on American Airlines, Delta Air Lines, Southwest Airlines, United Airlines, Air Canada, JetBlue, Alaska Airlines, WestJet, Aeromexico, Spirit Airlines, Frontier Airlines, Volaris, Hawaiian Airlines, Allegiant Air, Virgin America.

Don't Miss These Handpicked Fares
<table width="350px"><tbody><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.97</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">San Francisco</td><td width="10%">$103.46</td></tr><tr><td width="40%">Los Angeles</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$175.91</td></tr><tr><td width="40%">Chicago</td><td width="10%">-</td><td width="40%">Los Angeles</td><td width="10%">$325.31</td></tr><tr><td width="40%">Miami</td><td width="10%">-</td><td width="40%">New York</td><td width="10%">$96.52</td></tr><tr><td width="40%">Atlanta</td><td width="10%">-</td><td width="40%">Chicago</td><td width="10%">$100.50</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Las Vegas</td><td width"10%">$248.48</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Kingston</td><td width"10%">$461.79</td></tr><tr><td width="40%">San Francisco</td><td width="10%">-</td><td width="40%">Tokyo</td><td width"10%">$690.31</td></tr><tr><td width="40%">New York City</td><td width="10%">-</td><td width="40%">Toronto</td><td width"10%">$119.25</td></tr></tbody></table>

Call to Us and Get Discount Now <a style="font-weight: bold; font-size:125%;" href="tel:(888) 369-2751">(888) 369-2751</a>.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.