[Upstream] Writer: if reduce size of inserted picture, crops picture

Bug #831785 reported by Elmar Roberg on 2011-08-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Medium
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.3-1ubuntu2
  Candidate: 1:3.3.3-1ubuntu2
  Version table:
 *** 1:3.3.3-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/831785/+attachment/2312919/+files/R12%20Close%20%20Build%20Capacity.odt -O inf.odt && lowriter -nologo inf.odt

on page 1 primary click and hold the bottom left of the image, bring it to the center, and the resize should preserve the image.

4) What happens instead is the left side of the image is cropped ~5%.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libreoffice-core 1:3.3.3-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-11.48-generic-pae 2.6.38.8
Uname: Linux 2.6.38-11-generic-pae i686
NonfreeKernelModules: wl
Architecture: i386
Date: Tue Aug 23 06:57:30 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=en_ZA:en
 LANG=en_ZA.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Elmar Roberg (roberg) wrote :

Elmar Roberg, thank you for reporting this and helping make Ubuntu better. Could you please attach the Writer file that when resized, demonstrates this problem?

Changed in libreoffice (Ubuntu):
status: New → Incomplete

Attached is the document that has a number of such diagrams where the
lhs is not visible.

with kind regards,

*Elmar Roberg*

Cell: +27 82 651 5138
Fax: +27 86 672 3998
<email address hidden> <mailto:<email address hidden>>
<mailto:<email address hidden>>/doulos Iesous/

Without prejudice. The contents and attachments of this mail are
intended for selected recipients as intended by the author. If you have
received it in error, privacy laws require that you may not in any way
disclose or rely on the contents. Sometimes mails are misdirected and if
this should be the case, we apologise for the inconvenience and
request that the recipient delete the mail and if possible notify the
sender of this error. This communication further is intended for
discussion and should not be considered to be final unless specifically
stated so. Also note that this form of communication is not secure, it
can be intercepted, and may not necessarily be free of errors and
viruses in spite of reasonable efforts to secure this medium.

On 23/08/2011 10:10, Christopher M. Penalver wrote:
> Elmar Roberg, thank you for reporting this and helping make Ubuntu
> better. Could you please attach the Writer file that when resized,
> demonstrates this problem?
>
> ** Changed in: libreoffice (Ubuntu)
> Status: New => Incomplete
>

Elmar Roberg, which picture on which page did you resize, and how did you specifically resize it to demonstrate this problem?

The following Illustrations all demonstrate the problem:
1, 2, 4, 5

The issue seems to be that if the image in the jpg goes right up to the
left edge, then the first 1/2cm is not cut off / displayed.

Try it with the attached image.

thank you.

with kind regards,

*Elmar Roberg*

Cell: +27 82 651 5138
Fax: +27 86 672 3998
<email address hidden> <mailto:<email address hidden>>
<mailto:<email address hidden>>/doulos Iesous/

Without prejudice. The contents and attachments of this mail are
intended for selected recipients as intended by the author. If you have
received it in error, privacy laws require that you may not in any way
disclose or rely on the contents. Sometimes mails are misdirected and if
this should be the case, we apologise for the inconvenience and
request that the recipient delete the mail and if possible notify the
sender of this error. This communication further is intended for
discussion and should not be considered to be final unless specifically
stated so. Also note that this form of communication is not secure, it
can be intercepted, and may not necessarily be free of errors and
viruses in spite of reasonable efforts to secure this medium.

On 25/08/2011 15:15, Christopher M. Penalver wrote:
> Elmar Roberg, which picture on which page did you resize, and how did
> you specifically resize it to demonstrate this problem?
>

Elmar Roberg, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

description: updated
tags: added: lo33
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in df-libreoffice:
status: New → Incomplete

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/831785

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/831785/+attachment/2312919/+files/R12%20Close%20%20Build%20Capacity.odt -O inf.odt && lowriter -nologo inf.odt

on page 1 primary click and hold the bottom left of the image, bring it to the center, and the resize should preserve the image.

4) What happens instead is the left side of the image is cropped ~5%.

Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
summary: - Writer: if reduce size of inserted picture, crops picture
+ [Upstream] Writer: if reduce size of inserted picture, crops picture
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Elmar Roberg (roberg) wrote :

To assist:
I have attached the source jpg
Will add a Writer doc where it displays INcorrectly (LO 3.5.2)
An Impress doc where it display correctly.

Elmar Roberg (roberg) wrote :

To assist:
I have attached the Writer doc where it displays INcorrectly (LO 3.5.2)
An Impress doc where it display correctly.

Elmar Roberg (roberg) wrote :

To assist:
I have attached an Impress doc where it display correctly.

Elmar Roberg (roberg) wrote :

To assist:
I have attached a Calc doc that displays correctly

Hi,

I'm seeing this bug in LibreOffice 3.5.4.2, has there been any progress? It appears to have been reported at Ubuntu on 2011-08-23

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.4-3

In my case, the percentage of the image that is lost varies. The more you reduce the image size the more it is cropped. I thought at first that the effect was only a display issue, but converting to pdf produces a cropped image too.

Cropping occurs even at the original size, but to the best of my very short tests, it occurs only on the top, left and bottom parts of the image. The right size doesn't appear to crop. I tested png and svg images.

A small workaround I found is to crop (i.e., Format->Picture->Crop) the image at between -1 and -1/2 cm to recover the lost parts of the image.

Regards

Hello.
I reproduce the bug with LibreOffice 3.5.4 from Debian Wheezy. I can not reproduce it with LibreOffice 4.2.5 from Debian Wheezy backports and 4.3.0.2.
I do not know which patch solves the problem hence I set bugstatus to RESOLVED WORKSFORME. Feel free to reopen it if you can reproduce the issue with LibreOffice 4.2.5 or later.

Changed in df-libreoffice:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.