[Libreoffice] Mnemonics do not work in Unity

Bug #739184 reported by Luke Yelavich on 2011-03-21
608
This bug affects 138 people
Affects Status Importance Assigned to Milestone
LibreOffice
Won't Fix
Medium
Unity
Fix Released
High
Unassigned
indicator-appmenu (Ubuntu)
High
William Hua
libreoffice (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

When lo-menubar is installed and LibreOffice is open with a document, the keyboard shortcuts to access menus like Alt + F for file etc do not work. Menu keyboard shortcuts are working for other apps via indicator-menu.

WORKAROUND: Disable the global menu by removing the package "libreoffice-gtk".

Luke Yelavich (themuso) on 2011-03-25
tags: added: a11y
Waldir Leoncio (wleoncio) wrote :

Reproduced on Ubuntu Natty alpha 3, LibreOffice3.3.2 OOO330m19 (Build:202) and lo-menubar 0.1.0-0ubuntu1.

Changed in lo-menubar (Ubuntu):
status: New → Confirmed
Changed in lo-menubar:
status: New → Confirmed
papukaija (papukaija) on 2011-04-11
tags: added: natty
Martin Pitt (pitti) on 2011-09-21
tags: added: lo-menubar-p-default
Changed in lo-menubar (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Changed in libreoffice (Ubuntu Precise):
status: Confirmed → Triaged
Changed in lo-menubar (Ubuntu Precise):
status: Confirmed → Triaged
Changed in libreoffice (Ubuntu Precise):
importance: Undecided → High
summary: - Keyboard shortcuts to menus do not work.
+ Keyboard shortcuts to menus do not work
summary: - Keyboard shortcuts to menus do not work
+ Keyboard shortcuts to menus do not work.
Chris Sadler (chris-g-sadler) wrote :

I'm using Oneiric and I have the same problem.

Using 11.10
Linux chris-laptop 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
LibreOffice 3.4.5
OOO340m1 (Build:502)
lo-menubar 0.1.0-0ubuntu3

Cheers,
Chris

John Pye (jdpipe) wrote :

Confirmed with LibreOffice 3.5.0 (build 350m1(Build:13)) and lo-menubar_0.1.0-0ubuntu3_i386.deb from the LibreOffice 'ppa:libreoffice/ppa' PPA on Ubuntu 11.10 (32 bit).

not a bug in libreoffice, but in lo-menubar => not high in libreoffice

no longer affects: libreoffice (Ubuntu Precise)
Changed in libreoffice (Ubuntu):
importance: High → Undecided
papukaija (papukaija) on 2012-03-20
tags: added: oneiric precise
tags: added: rls-mgr-p-tracking
Moppers (moppers) wrote :

for me this bug still exists in precise in 3d mode --- in 2d mode it does not manifest

no longer affects: libreoffice (Ubuntu)

i am still facing this problem in libreoffice. I just installed fresh 12.04 yesterday

Elmar Roberg (roberg) wrote :

I am also having this problem in 12.04 Unity 2D. LO. Installed 2 days ago.
LibreOffice 3.5.2.2
Build ID: 350m1(Build:202)

Omer Akram (om26er) on 2012-06-13
Changed in unity:
status: New → Confirmed
mohican (mohican) wrote :

Hi Ken,
As already stated Alt+letter and Alt (long hit) work fine in other applications (eg Firefox) : it gives access to the global menu,
wereas Alt (short hit) gives the HUD.

Here it's a problem specific to the integration of LibreOffice (lo-menubar). Should be investigated in relation to other bugs related to lo-menubar https://bugs.launchpad.net/ubuntu/+source/lo-menubar

Good luck :)

Ken Clive (ken.clive) on 2012-08-03
Changed in lo-menubar (Ubuntu):
assignee: nobody → Ken Clive (ken.clive)
papukaija (papukaija) on 2012-08-03
Changed in lo-menubar (Ubuntu):
assignee: Ken Clive (ken.clive) → nobody
Sebastien Bacher (seb128) wrote :

That seems to still be happening with quantal beta1 and the libreoffice integrated menu work

affects: lo-menubar (Ubuntu) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: Triaged → Invalid
status: Invalid → Triaged
Changed in libreoffice (Ubuntu Precise):
status: Triaged → Invalid
tags: added: lovclmenubar
Jon Hanna (jonhanna) wrote :

I don't understand why it's invalid in precise because the bug is in the beta for quantal.

Sebastien Bacher (seb128) wrote :

it's invalid in precise for libreoffice because lo-menubar has nothing to do with libreoffice

summary: - Keyboard shortcuts to menus do not work.
+ Mnemonics do not work on Unity.
tags: added: quantal
Omer Akram (om26er) on 2012-10-15
no longer affects: lo-menubar
no longer affects: libreoffice (Ubuntu Precise)
summary: - Mnemonics do not work on Unity.
+ [Libreoffice] Mnemonics do not work in Unity
Changed in unity:
importance: Undecided → High
status: Confirmed → Triaged
Lance Eck (lance.eck) wrote :

Having same problem with Ubuntu 12.10 (quantal quetzal) on fresh install of LibreOffice 3.6.2 RC2 (from Ubuntu install) WITHOUT lo-menubar.

To reproduce: open any of Calc, Writer, Base, Draw, Impress, keyboard shortcuts do not work.

lance@supergrover:~$ uname -a
Linux supergrover 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

lance@supergrover:~$ dpkg-query --list libreoffice
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===========================-==================-==================-===========================================================
ii libreoffice 1:3.6.2~rc2-0ubunt amd64 office productivity suite (metapackage)

lance@supergrover:~$ dpkg-query --list lo-menubar
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===========================-==================-==================-===========================================================
un lo-menubar <none> (no description available)

Marius B. Kotsbak (mariusko) wrote :

lo-menubar is just a transitional package in Ubuntu 12.10, so it does not affect this bug.

Raymond Wells (rfw2nd) wrote :

Confirmed on quantal release in Libreoffice impress. Any way to disable the global menu for LibreOffice in the meantime?

Jon Hanna (jonhanna) wrote :

This has gotten so much worse with quantal. Before we had the workaround of uninstalling lo-menubar and putting up with the menu not visually matching the rest of the shell. Now there's no longer that in-between option (it's quite literally "quantal").

I haven't tried installing libre office from their site rather than the ppa. Has anyone tried that yet?

Marius B. Kotsbak (mariusko) wrote :

You can remove package libreoffice-gtk as a workaround, but then you loose some other gtk integrations as well, e. g. open dialog.

Jon Hanna (jonhanna) wrote :

Thanks Marius, that did the trick. It does ruin a lot of the integration as you say, but not as much as having to boot into windows to get some writing done does.

joehill (joseph-hill) wrote :

I second that this is extremely important. In Precise, I could just disable lo-menubar, and it made no difference that the menu appeared in the window instead of at the top of the screen. Now I have to choose between using keyboard shortcuts (by uninstalling libreoffice-gnome/libreoffice-gtk) and integrating LibreOffice with my work environment, both of which are pretty critical.

Austriaco (lanieves) wrote :

nice way to make a person lose 2 hours of productive time. Keep improving....

na ja, fresh upgrade from 12.04 to 12.10:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

$ apt-cache policy libreoffice-calc unity
libreoffice-calc:
  Installiert: 1:3.6.2~rc2-0ubuntu3
  Kandidat: 1:3.6.2~rc2-0ubuntu3
  Versionstabelle:
 *** 1:3.6.2~rc2-0ubuntu3 0
        500 http://debian.charite.de/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status
unity:
  Installiert: 6.10.0-0ubuntu2
  Kandidat: 6.10.0-0ubuntu2
  Versionstabelle:
 *** 6.10.0-0ubuntu2 0
        500 http://debian.charite.de/ubuntu/ quantal-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     6.8.0-0ubuntu2 0
        500 http://debian.charite.de/ubuntu/ quantal/main amd64 Packages

As others have pointed out, uninstalling libreoffice-gtk kind of solves the problem at the cost of some lost integration into the desktop.

How a product like this can be released to the public is beyond any reasonable decision making. Please fix this as soon as possible.

description: updated

Problem description:

Steps to reproduce:
1. Press Alt-F
2. Fail to see File menu items expand
3. Use mouse to accomplish same while cursing Apple-centric testing...

Current behavior: No UI access to top-level menu when installed in Ubuntu 12.10

Expected behavior: Alt-F would open File menu items for deeper selection

Platform (if different from the browser):

Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.19 (KHTML, like Gecko) Chrome/25.0.1323.1 Safari/537.19

John D Marsden (jdmarsden) wrote :

Still happening for me after the upgrade released to fix bug #1064962 https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1064962. Using a 64-bit system upgraded from Precise to Quantal with all latest updates installed.

Please release a fix soon as without it all the fancy work to make a HUD is fruitless for the type of work where being able to stick with the keyboard is most useful - i.e. office applications.

Liam Proven (lproven) wrote :

Confirmed. This was previously a problem with ``lo-menubar'' in 11.04/11.10/12.04. Now in 12.10 the problem has been transferred from the additional/not-installed-by-default ``lo-menubar'' package into Libreoffice's GTK integration and thus this bug now affects everyone.

Removing ``libreoffice-gtk'' does effectively fix it, but breaks other things.

This is a showstopper bug for some of us who use the keyboard as our primary method of interacting with the apps. It is also a complete showstopper for blind/disabled users who cannot use a mouse or other pointing device.

No, the HUD is not an alternative.

Same here:

The menu appears in the app panel but dissapears when trying a mnemonic like Alt-f. The keystroke results in no activity other than causing the menu to dissapear.

Mouseover and Alt-f10 make the menu re-appear and function except for the mnemonics.

It occurs always.

Benjamin

Peter Harvey (pdqharvey) wrote :

Just confirming this affect me as well on 12.10, 64 bit.

Removing libreoffice-gtk leaves such an unappealing environment to work in I choose to remove all global menus (sudo apt-get remove indicator-appmenu).

I use menemonics in all applications - especially in LibreOffice. THe HUD is a nice idea, and one I was looking forward to, but in practice I have never once used it. A fully working menu with mnemonics is absolutely essential, and would be my #1 priority.

Confirmed here after upgrading to Ubuntu 12.10, LibreOffice 3.6.2.2. None of the Alt+key combinations that are supposed to open top-level menus do anything.

jura (zinlun) on 2013-01-07
Changed in unity:
status: Triaged → Fix Released
Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Omer Akram (om26er) wrote :

come on, please don't change bug status without any reason.

Changed in libreoffice (Ubuntu):
status: Fix Released → Triaged
Changed in unity:
status: Fix Released → Triaged
Adolfo Jayme (fitojb) wrote :

Disregard the previous change. Someone decided it was fun to mess with bug reports.

Paddy Landau (paddy-landau) wrote :

This seems to be still present in 13.04.

John Pye (jdpipe) wrote :

I have just installed LibreOffice 4.0.1 on Ubuntu 12.04 LTS (1:4.0.1~rc1-2ubuntu1~precise1~ppa7) from the LibreOffice PPA.

This bug is still present, but with this upgrade, the default is for the lo-menubar functionality to be included by default, which is intensely annoying as it breaks all my intuitive-level keyboard use in LibreOffice and is a major hit on productivity.

Please fix this urgently! Unity integration should absolutely NOT be incorporated into the default packaging until this issue is fixed (yes, I realise I am using a PPA version currently).

note as per:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/739184/comments/22
you can get a albeit ugly libreoffice experience without unity integration by uninstalling libreoffice-gnome.

mohican (mohican) wrote :

About the workaround as stated in comment #32 : I think it's libreoffice-gtk that needs to be uninstalled (or both).

Regarding the newest LibreOffice version 4.0.1-rc2, you may also be interested in other bugs related to Unity's global menu integration (at least in Ubuntu 12.04 precise ) and that can be worked around in the same way :

- no icons, check signs and highlight in the menus #1153350
- broken menus after use or equation editor in Writer bug #1073266

this one you cannot work around this way :
- no HUD (at least in Writer) bug #1045353

Liam Proven (lproven) wrote :

This is still a problem in Quantal and Raring. It is more of an issue than ever with Raring because there is no libreoffice-gtk package to remove. Some other workaround is urgently needed!

Karl Brand (brandk) wrote :

Comment #31 : me too! I.e., on precise 12.04.2, LO version: 4.0.1~rc2-0ubuntu1~precise1~ppa1 the all important alt key is useless.

Peter Harvey (pdqharvey) wrote :

For those who need menemonics (alt+...) but are not fussed about the HUD, this might be an acceptable workaround (on Quantal, certainly; might well work on Precise and Raring). It's the best solution I have found.

Removed/purged LibreOffice, and then installed LibreOffice4 from http://www.libreoffice.org/download, NOT a version packaged for Ubuntu/Unity. This is how things stand now:

DO work:
- Looks as intended! Since this version is (I presume) unaware of Unity, there is no global menu integration attempted, so libreoffice-gtk does not need to be removed (which ruined the appearance and broke things)
- Mnemonics work perfectly!

DON'T work:
- HUD does not work for LO4 (of course, but works for other applications)
- Yet another version of incorrect icons appearing in the Unity Launcher bar ('XSLT-based filters' with a '?' icon appears in place of specific LO icons)

I now use the Compiz Ring Switcher in place of the Unity application switcher, so am less dependent on the icons being meaningful (though I did change the XSLT-based filters icon for a default LO one, which is a subtle improvement).

Hope someone finds that helpful.

Peter Harvey (pdqharvey) wrote :

A footnote to my comment #36 above:

Just installed LO4.0.1 from http://www.libreoffice.org/download as before, and can report that the icons which appear in the Unity launcher and the Application Switcher are much improved. Not perfect, though - successive programs of whatever filetype are marked as being of the same type as the first file to be opened, but it seems functional. A bonus: my custom 'address book' icon for my addresses spreadsheet now works for the first time in a year or so.

Peter Harvey (pdqharvey) wrote :

Footnote 2: Scrap last comment re. 'bonus' - that only works if it is the first document opened... But at least if fits the pattern.

Looks like the same symptoms as described here:
http://ask.libreoffice.org/en/question/14003/menu-shortcuts-in-lo-4/

Works for me in (LO 4.0.0.3 + Ubuntu 12.04.2), however does NOT work for Pansmanser:

---
I am running LO 4.0.1.1 on Ubuntu 12.04 (32 bit Kernel Linux 3.2.0-38-generic-pae.)

The top menubar does not have underlined letters, and none of the former shortcut keys work.
---

There is also another error on Pansmanser's system (unknown if related):

---
I would also like to be able switch off the global menu. This version of LibreOffice seems to ignore the switch in SystemSettings-Unsettings-Windows.
---

John Pye (jdpipe) wrote :

Hi Björn,

What are your thoughts on where this problem is arising? I can see that you worked on this code together with Michael Meeks and Antonio Fernandez.
http://gitorious.org/libreoffice/core/commits/feature/unitymenus-master

Am I write in understanding that "libvclplug_gtklo.so" is a plugin/extension to LibreOffice being provided by Ubuntu for the purposes of Unity/GTK integration, and that somewhere in that code must be missing something to do with registration of keyboard shortcuts for the top-level menus?

I have a PyGTK-based application that I maintain which includes GTK menus. They get integrated into Unity totally automatically. So could it be just as simple as converting a "File" and "Edit" into "_File" and "_Edit" somewhere, so that GTK/Unity picks up the key bindings?

Cheers
JP

Ken Clive (ken.clive) wrote :

John,

I am trying to implement the underscore in glomenu.cxx, where the menu labels are generated. If you look at gtksalmenu.cxx, where all the menu items are generated, there is code in the NativeSetItemText function that converts the tilde (~) character to an underscore. This is what I am trying to implement, but so far, I am having troubles with the build, since I've never built libreoffice before.

If someone could take my modified source and incorporate it into a build, that would be very helpful.

Also, I will try a second implementation with libvclplug_gtklo.so included; simply converting characters is a bit clunky of an implementation.

Thanks!

- Ken.

Marius B. Kotsbak (mariusko) wrote :

Ken, you could just let Launchpad build it for you, by uploading it to a PPA or setting up a recipe on a bzr branch.

Changed in unity:
status: Triaged → Fix Released
Marius B. Kotsbak (mariusko) wrote :

Abdur, any reference to where it was fixed?

papukaija (papukaija) wrote :

Marius, I just tested this in Raring and this bug is definitely not fixed.

Abdur, please don't change bug statuses without an explanation. Thanks.

John Pye (jdpipe) wrote :

Ken: where can we find your code?

All: I found instructions for building LibreOffice at
https://wiki.ubuntu.com/BuildingLibreOffice

Abdur: did you succeed in trying Ken's code somehow? Or what...?

Ken Clive (ken.clive) wrote :

John,

I have not yet succeeded in building LibreOffice 3.6 with Unity menu support using the instructions provided in the Ubuntu Wiki, nor can I do it with Ubuntu packages. I have attached my code here, which should go under core/vcl/unx/gtk/window in the LO sources.

Sorry for the delay in this bug. I would like to eventually learn how to build LO properly for Ubuntu/Unity, but to speed things along, I would rather let someone more experienced package this bug and test it.

- Ken.

Max Barry (max-maxbarry) wrote :

The bug description says, "This might be solved if bug #1064962 is solved." However, bug #1064962 is now fixed in 13.04 beta, but this problem remains.

Also, as mentioned in earlier comments, the workaround mentioned in the bug description (remove "libreoffice-gtk") is no longer really viable in 13.04.

So it's quite the problem in Raring.

LibreOffice Version 4.0.2.2 (Build ID: 400m0(Build:2)).

tags: added: raring
description: updated

This seems to be partially fix with the fix for bug 1085169 in test upload 1:4.0.2-0ubuntu2~raring1~ppa3 to the LibreOffice PPA at https://launchpad.net/~libreoffice/+archive/ppa, mnemonics work in the submenus, but not yet in the topmenu -- so the menu cant be opened with e.g. Alt-F yet.

Changed in libreoffice (Ubuntu):
status: Triaged → In Progress

Hmm, Alt-F doesnt work even with some extra changes, however I noted it doesnt work in Nautilus (though e.g. Softwarecenter works here) either. Maybe a general issue (read: indicator-appmenu issue)?

John Pye (jdpipe) wrote :

Mnemonics work in Gedit, don't know what's going on with Nautilus. Tested with current 12.04 system. Mnemonics also work in 'dumb' (nothing special for Unity) PyGTK applications, so something automatic about GTK on Unity is working correctly, at least in some cases.

Björn, did you take a look at the changes from Ken Clive? Can you describe the "extra changes" you are making??

isn't this a problem with Unity?
I never have problems with 'parallel' installed versions of LibreOffice (thus without sys integration).

Into a Loonix bin.

Ken Clive (ken.clive) wrote :

Still working on this fix. I figured out how to make the string conversions simpler so that replacing the '~' character with an underscore is quicker when opening menus. However, I still don't see mnemonic underlines for menu headers (File, Edit, etc.), so maybe my code is only affecting items within menus.

@John Pye: I talked to Ted Gould about this one yesterday, it seems to be a generic issue in indicator-appmenu for applications using the new and recommened GMenuModel way to communicate the menu to the indicator.
@Ken Clive: I dont think this is an issue in LibreOffice at this point, so I am curious what you are trying to do actually.

Chelmite (steve-kelem) wrote :

My solution is:
run synaptic,
delete all the libreoffice packages. (not the fonts or uno-related packages)
Go to libreoffice.org and download the latest.
Unpack it
% cd <topdir>/DEBS
% dpkg -i *.deb desktop*/*.deb

LibreOffice runs! ALT works! and, best of all, the menu bar is on the window so that I don't have to run my mouse carefully through the minefield of other windows to get to the far-removed menu bar on the unity toolbar!

MarianoAbsatz (el-baby) wrote :

@Björn Michaelsen is there a bug for this problem raised against indicator-appmenu?

Comment 42 was never answered, readding unity.

no longer affects: unity
Changed in unity (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Raimondo Giammanco (rai) wrote :

just to confirm the bug with LibreOffice 4.0.2.2 from the LibreOffice PPA on ubuntu 12.04 LTS.
@Björn Michaelsen on 12.04 mnemonics work as usual in Gedit, in Nautilus and in every other application I tested

nicolas kleinklaus (nknico) wrote :

I confirm the bug with LibreOffice 4.0.2.2 from Ubuntu 13.04

It does not work for me as well.

Pressing "alt+f" does not open menu. Also in menu bar there is no shurtcuts indicator ("there is File" and not "_F_ile").

LibreOffice Version 4.0.2.2 (Build ID: 400m0(Build:2))
x86_64 GNU/Linux, ubuntu 12.04

Not reproducible on LO 3.6.6.2, installed from LibreOffice ppa (Ubuntu 12.04.2 32bit, kernel 3.2.0-41-generic-pae), Alt-F works as expected.

As Cor Nouws said, probably it's related to Unity. Or related with any tweaking utility?

(In reply to comment #6)
> Not reproducible on LO 3.6.6.2, installed from LibreOffice ppa (Ubuntu
> 12.04.2 32bit, kernel 3.2.0-41-generic-pae), Alt-F works as expected.
>
> As Cor Nouws said, probably it's related to Unity. Or related with any
> tweaking utility?

I can confirm that Alt-F not functioning when I enable Unity. Result on comment #6 is happen because I'm using Cairo-Dock (Gnome+Effects) & disable Unity.

Could you test that with Unity disabled?

I am experiencing the same issue with LibreOffice/Unity. I use two installations of LibreOffice 4.0.x:

1) Windows Vista Enterprise - LibreOffice 4.0.2.2 - this installation allows the menu shortcut keys (eg. Alt + F --> Open File Menu)

2) Ubuntu 13.04 - LibreOffice 4.0.x - this installation DOES NOT ALLOW the menu shortcut keys

This bug also appears (and has been better investigated) at https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/739184.

It appears to be an integration issue with Unity/Ubuntu and a workaround (with limitations) is offered:

 'WORKAROUND: Disable the global menu by removing the package "libreoffice-gtk".'

Tom Colley (tcolley) wrote :

This bug is also being investigated at https://bugs.freedesktop.org/show_bug.cgi?id=57104.

I can also confirm that the bug occurs with my installation - Ubuntu 13.04, LibreOffice 4.0.x - this installation DOES NOT ALLOW the menu shortcut keys.

Paijo (paijo-iseng) wrote :

I confirm the mnemonics didn't work on Ubuntu 13.04 with LO Version 4.0.2.2 (Build ID: 400m0(Build:2)).
Shortcut keys still appear on SUB-menu after delay, but the main menu still lost the sortcut mnemonics
Pressing 'Alt' key brings the HUD to appear.
I try to replace default keyboard for HUD with something else. I'm using "Ctrl+]" for temporary replacement to enable Alt key, but still didn't work.

Talking with Ted Gould at the last Client Sprint, I remember this being an general GMenuModel issue, so not LibreOffice specific. Setting this to "Incomplete" in LibreOffice, unless there is a clear indication that this is LibreOffices fault.

Changed in libreoffice (Ubuntu):
status: In Progress → Incomplete
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Won't Fix
Paul Stadler (paul-stadler) wrote :

Is there an associated bug for this opened against GMenuModel as per the link above that can be added here? I'm wondering where I can now track this issue if it's closed here.

papukaija (papukaija) wrote :

@Paul: I think it's already covered by the indicator-appmenu task.

Paijo (paijo-iseng) wrote :

Workaround to fix is:
=> Install other desktop environment (e.g. Mate, KDE/plasma, Gnome, xfce, or something else), and work without unity.
It works. I did it and install gnome-shell.

arakelov (nabadvin) wrote :

Please solve this bug, it's unbelievable that still remains open...

Liam Proven (lproven) wrote :

LibreOffice 4.1.1.2 in the latest pre-release build of Saucy is still affected by this.

Liam Proven (lproven) wrote :

I should have added - this is under XMir using the FOSS AMD/ATI drivers:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]

Andy Whitcroft (apw) on 2013-09-30
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → High
Max Barry (max-maxbarry) wrote :

I don't understand how this bug can persist throughout several Ubuntu releases. It means Ubuntu doesn't have a functional office suite. You have to choose between the Alt key or the windowing: only one will work. (Without libreoffice-gtk, you can't maximize properly.) Is that not seen as a major issue?

see bug 1113008 for related symptoms -- although in a different implementation, so unlikely to be directly related. Still, if that is solved, it might be worth a look at the fix for inspiration.

Eric TF Bat (bat-flurf) wrote :

Confirming that the workaround from comment #52 works, making the Alt+key shortcuts ("mnemonics", if you must abuse the English language) work happily in Unity in Ubuntu 13.04.

To recap and update slightly, do this:

1. Completely remove LibreOffice: sudo apt-get purge libreoffice*
2. Go to www.libreoffice.org and download the correct .deb.tar.gz for your OS, either 32 or 64 bit.
3. Unzip the file.
4. Change to the DEBS directory in the unzipped archive: cd [name of newly-created directory]/DEBS
5. Install every one of the sebs as superuser: sudo dpkg -i *.deb

To test, at the prompt type libreoffice and press Tab. As of 10 November 2013, the above process installs a program called libreoffice4.1, but presumably the name will change with the version.

I can report that:
- unlike the standard LO, this one responds when you press Alt+F, Alt+E and so on;
- it also handles the defined shortcuts as expected, for example Ctrl+D is fill down (which it isn't in OpenOffice, unless you change it - I hated that!);
- unlike standard LO with the libreoffice-gtk package removed, this does allow the window to work properly (eg maximise, minimise, etc) and uses the proper Open dialog box and so on;
- unlike OpenOffice, this doesn't have the irritating display bug where every item you select from a dropdown or type in an edit field remains and the fields get steadily darker as they're used because, apparently, the function to clear the rectangle before updating it is broken -- this may be an NVIDIA issue, but it's irritating nonetheless and I'm glad it's gone.
- the menus aren't integrated with the Macintosh-like top bar of Unity, which I don't care about but YMMV.

Only downside appears to be the icons for the software, which look like a standard Windows 3.1-era "text file" icon. Meh, I can live with a little ugliness.

Max Barry (max-maxbarry) wrote :

Comment #79 works for me, thanks.

So right now the options for users are:

(a) Use the default Ubuntu install of LibreOffice: Your Alt+? keys don't work, so you can't open the File menu by pressing Alt+F, etc.

(b) Remove "libreoffice-gtk": Your Alt+? keys work, but it looks very different to every other application on your system, and has lots of minor but disruptive bugs like being unable to maximize the window fully.

(c) Remove the Ubuntu version of LibreOffice and install the one from the libreoffice.org: Everything works, but it lacks some minor Unity integration, as mentioned above.

watabi (zvoker) wrote :

Comment #79 doesn't work for me. But it guided me to my (working) solution!

First of all I didn't found any .deb package at www.libreoffice.org. Just .rpm was avaliable.

So I found old (and magically also most new) versions at:
http://downloadarchive.documentfoundation.org/libreoffice/old/

I downloaded and installed libreoffice 4.2.0.1 with #80 's instructions and alt + <hotkey> worked!!

Hope it helps!

Goyo (goyodiaz) wrote :

The download page tries to guess what your operating system is and display big buttons to download the most suitable installers for the recommended version of LibreOffice. If you want a different version or installers for a different OS, see "Change the version" and "Change OS" some pixels below. There are rpms and debs for x86 and x86_64.

Ken Clive (ken.clive) wrote :

I suspect there is something wrong with the libreoffice-gtk package if removing it enables the Alt key shortcuts to work. I have been looking at the libreoffice source to try to see where libreoffice-gtk is causing this to not work.

Joseph Harold (jfxh) wrote :

Using 13.10 64b Unity.
Found this fix to regain use of Menu Bar Hot Keys (Mnemonics):
Remove indicator-appmenu via Synaptic or
via Terminal: sudo apt-get remove indicator-appmenu.
Log out/in.

Not certain yet if this creates any other limitations or causes any buggy behavior, but it does allow for Alt+letter to pull down menus.

Closing as wontfix in "libreoffice (ubuntu)" as comment 84 shows this clearly needs to be fixed in indicator-appmenu and indicator-appmenu only.

Changed in libreoffice (Ubuntu):
status: Incomplete → Won't Fix
Sebastien Bacher (seb128) wrote :
Changed in unity (Ubuntu):
importance: Undecided → High
status: Triaged → Fix Released
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Fix Released

Assigning to Will in indicator-appmenu who deserves all the kudos and karma for fixing this in trusty. ;)

Changed in indicator-appmenu (Ubuntu):
assignee: nobody → William Hua (attente)
Changed in unity:
importance: Undecided → High
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.