LibreOffice Writer has no icon in Unity and is labeled "LibreOffice Small Device Format Importer"

Bug #732412 reported by Brewster Malevich on 2011-03-10
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
Unity
Invalid
Medium
Jason Smith
unity-2d
Medium
Unassigned
bamf (Ubuntu)
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

With lowriter version 1:3.3.1-1ubuntu5.

In natty (AMD64), if I start LibreOffice Writer (through any means), with Unity, the icon for the process in Unity is a question mark which is labeled "LibreOffice Small Device Format Importer" in the Unity mouse-over widget.

I would expect the usual LibreOffice Writer icon to appear (instead of the generic question mark), and for this to be labeled "LibreOffice Writer".

tags: added: natty
description: updated
David D. (daviddarts) wrote :

I'm experiencing this issue as well in natty (AMD64) beta 1

I'm having the same problem on 11.04 (dev branch).

Adding bamf, not really an LO issue.

Alex Launi (alexlauni) wrote :

interestingly this is working normally for me. what's the output of ps aux |grep writer?

Changed in unity:
status: New → Incomplete
Changed in bamf:
status: New → Incomplete
Changed in bamf (Ubuntu):
status: New → Incomplete
Jason (jaseeverett) wrote :

Hi Alex. The output from the command is below.

jason@zoop:~$ ps aux |grep writer
jason 22567 0.0 0.0 4156 864 pts/0 S+ 08:52 0:00 grep --color=auto writer
jason 27773 0.1 2.0 218328 79980 ? Sl 06:57 0:07 /usr/lib/libreoffice/program/soffice.bin -writer -splash-pipe=5

Rafy (rafy) wrote :

mine is:

rafy@rafy's Lappy~$ ps aux |grep writer
rafy 3943 0.9 2.4 247700 100148 ? Sl 13:21 0:01 /usr/lib/libreoffice/program/soffice.bin -writer /LOCATIONOFDOC/test.doc -splash-pipe=5
rafy 4065 0.0 0.0 4160 880 pts/1 S+ 13:24 0:00 grep --color=auto writer

This issue is triggered by the /usr/share/applications/libreoffice-javafilter.desktop file from package libreoffice-filter-mobiledev which has the same Exec line as writer.

having only LO-writer installed => no issue
installing LO-filter-mobiledev => no issue
restarting session => issue
removing LO-filter-mobiledev => issue
restarting session => no issue

Neil J. Patel (njpatel) on 2011-04-12
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → High
milestone: none → 3.8.8

Since it is assigned in unity, I will not workaround it in LO by not shipping the second desktop file.
Closing as invalid in LibreOffice.

Changed in libreoffice (Ubuntu):
status: New → Invalid
Rafy (rafy) wrote :

Thanks...removing libreoffice-filter-mobiledev does fix the problem.
What was that package supposed to do?

Seems like there is plenty of informatoin here to start debugging this. Should the desktop team be working on this?

Changed in unity:
status: Incomplete → Confirmed
David Barth (dbarth) wrote :

This other issue can be related https://bugs.launchpad.net/unity/+bug/741995

Didier Roche (didrocks) on 2011-04-14
Changed in unity (Ubuntu):
status: New → Confirmed

Reopening in LibreOffice as this was not fixed in unity 3.8.8. Considered for the workaround solution in 3.3.2-1ubuntu3.

Changed in libreoffice (Ubuntu):
status: Invalid → Confirmed
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
status: Confirmed → Fix Committed

Please reopen the issue in LibreOffice once this is fixed in bamf, I will remove the workaround then.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:3.3.2-1ubuntu3

---------------
libreoffice (1:3.3.2-1ubuntu3) natty; urgency=low

  * make build dep on xulrunner-dev alternatively depend on firefox-dep (LP: #740815)
  * cherry-pick from debian:
     - enable is (icelandic) l10n (LP: #751746)
  * add unity quicklist support (LP: #720716)
  * workaround for unity icon issue (LP: #732412)
  * regenerated control file and refresh patch queue
 -- Bjoern Michaelsen <email address hidden> Fri, 15 Apr 2011 10:01:19 +0200

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
David Barth (dbarth) wrote :

THe Desktop team made a workaround for the release, but this is still worth fixing in an SRU.

Changed in unity:
milestone: 3.8.10 → 3.8.12
David Barth (dbarth) on 2011-04-22
Changed in unity:
milestone: 3.8.12 → 3.8.14
importance: High → Medium
milestone: 3.8.14 → backlog

How is the status on this for Oneiric? Should I remove the workaround?

Sebastien Bacher (seb128) wrote :

the bug is not fixed but you should probably drop the workaround and we should get dx to look at the issue this cycle, we can still add the workaround back later if needed

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-07-22
Changed in bamf:
status: Incomplete → Confirmed
Changed in bamf (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
status: Confirmed → Invalid
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in libreoffice (Ubuntu):
assignee: Björn Michaelsen (bjoern-michaelsen) → Marco Trevisan (Treviño) (3v1n0)
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in bamf:
status: Confirmed → Invalid
Changed in bamf (Ubuntu):
status: Confirmed → Invalid
Omer Akram (om26er) on 2011-12-13
Changed in unity:
milestone: backlog → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers