Ubuntu

Please add unity Quicklist support

Reported by Didier Roche on 2011-02-17
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
libreoffice (Ubuntu)
Undecided
Björn Michaelsen
Natty
Undecided
Unassigned
libreoffice-l10n (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

Quoting from bug #676886, the quicklist menu entry should have:
1) LibreOffice word processor - "New Document"
2) LibreOffice spreadsheet - "New Spreadsheet"
3) LibreOffice presentation - "New Presentation"

I'll update the bug report with detail guideline later on on how adding quicklist

Didier Roche (didrocks) wrote :

The doc is there: https://wiki.ubuntu.com/Unity/LauncherAPI#Static Quicklist entries

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
John Lea (johnlea) on 2011-03-10
tags: added: udt
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → John Lea (johnlea)

I assume this should be:
"New Document" only on Writer
"New Spreadsheet" only on Calc
and not all types on all applications.

And I also assume additionally "New Database" for Base, "New Drawing" for Draw and "New Formula" for Math.

Should the "Startcenter" contain all quicklist entries, a subset (for example: Document, Spreadsheet, Presentation, Drawing) or none? I will go with "none" for now.

El dj 07 de 04 de 2011 a les 10:59 +0000, en/na Björn Michaelsen va
escriure:
> Dear Translators,
> please provide l10n on these pages:
> https://wiki.ubuntu.com/Translations/Wanted/LibreOfficeBase
> https://wiki.ubuntu.com/Translations/Wanted/LibreOfficeCalc
> https://wiki.ubuntu.com/Translations/Wanted/LibreOfficeDraw
> https://wiki.ubuntu.com/Translations/Wanted/LibreOfficeImpress
> https://wiki.ubuntu.com/Translations/Wanted/LibreOfficeMath
> https://wiki.ubuntu.com/Translations/Wanted/LibreOfficeStartcenter
> https://wiki.ubuntu.com/Translations/Wanted/LibreOfficeWriter
>
> I will merge them into the package then.
>

Thanks Björn!

I've forwarded this info to the ubuntu-translators list.

It would be great if they would have time to provide translations until
the NonLanguagePackTranslationDeadline milestone in the release
schedule.

See also the last comment on bug 512395 for a proposal on how to best
handle this in the future.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Martin Pitt (pitti) wrote :

We are getting a reasonable amount of translations for these, approved.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

Current state of the translations upstreamed to master as:

 http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=726c8b4d4c322229f8c93e35a55737ffb42e83c4

(The unity quicklist stuff is not yet in that commit, we are patching that in in packaging for natty anyway.)

Changed in libreoffice (Ubuntu):
status: Confirmed → In Progress

wiki pages merge status updated.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:3.3.2-1ubuntu3

---------------
libreoffice (1:3.3.2-1ubuntu3) natty; urgency=low

  * make build dep on xulrunner-dev alternatively depend on firefox-dep (LP: #740815)
  * cherry-pick from debian:
     - enable is (icelandic) l10n (LP: #751746)
  * add unity quicklist support (LP: #720716)
  * workaround for unity icon issue (LP: #732412)
  * regenerated control file and refresh patch queue
 -- Bjoern Michaelsen <email address hidden> Fri, 15 Apr 2011 10:01:19 +0200

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-04-19
tags: added: udo
Changed in ayatana-design:
importance: Medium → Low
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released

Hello Didier, or anyone else affected,

Accepted libreoffice into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libreoffice-l10n (Ubuntu):
status: New → Fix Released
Changed in libreoffice (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Changed in libreoffice-l10n (Ubuntu Natty):
status: New → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello Didier, or anyone else affected,

Accepted libreoffice-l10n into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Gabor Kelemen (kelemeng) wrote :

Hi Clint

I see that this update is supposed to contain the translations added to the wiki pages, so I pinged bug #784081 #774020 and #774024 which are about problems with these translations.

Cheng-Chia Tseng (zerng07) wrote :

Hi, Clint!

Draw of zh-TW still not fixed in proposed repository.

Because zh-TW is typo as zn-TW! Please fix that! Thanks! :)

Cheng-Chia Tseng (zerng07) wrote :

Plus, Math of zh-TW is fixed now. Thank you! (bug 774024)

Marc Deslauriers (mdeslaur) wrote :

NACK: Package that is currently in -proposed regresses the icon theme. See LP: #813148.

tags: added: verification-failed
removed: verification-needed

version 1:3.3.3-1ubuntu2 uploaded to natty-proposed fixing LP: #813148.

tags: added: verification-needed
removed: verification-failed
Cheng-Chia Tseng (zerng07) wrote :

Hi everyone.

The Math desktop file for zh_TW has not been fixed yet. Because zh-TW is typo as zn-TW!

Gabor Kelemen (kelemeng) asked me to report problem here instead of Bug #774020.

However, this bug has been marked as "Fix Released". And in fact, it is not.

Could anyone help with Chinese (Traditional)?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:3.3.3-1ubuntu2

---------------
libreoffice (1:3.3.3-1ubuntu2) natty-proposed; urgency=medium

  * move icons back to 3.3 location after unpacking (LP: #813148)
  * minor changelog fixes

libreoffice (1:3.3.3-1ubuntu1) natty-proposed; urgency=medium

  * merge from Debian:
    - debian/rules: make multiarch changes conditional and skip them
      for squeeze (Daniel Baumann)
    - rules: move evolocal.odb into -evolution proper
    - debian/libreoffice-filter-binfilter.links.in:
      actually create symlink for libbindet*so in registered-components
  * regenerate control file
  * update patch queue
  * remove lp709778.diff as it has been picked up as
    disable-optional-outplace-ole.diff by debian
  * remove desktop-templates.diff, those templates are unused
  * remove desktop-translations.diff, those templates are unused
  * remove fix-lo-desktop-pot.diff, those templates are unused
  * remove lp775608.diff, has been integrated upstream
  * update human icon theme to a 2011-06-24 checkout from master
  * update fixes for desktop file entries from ubuntu wiki (LP: #720716)
  * reenable sdbc_postgresql for natty even though it is broken,
    to prevent NBS in natty

libreoffice (1:3.3.3-1) unstable; urgency=medium

  * new upstream release

  [ Rene Engelhard ]
  * debian/patches/disable-optional-outplace-ole.diff: as name says; makes
    toolbars work in e.g. Base edit forms (closes: #617319)

  * debian/rules:
    - disable -sdbc-postgresql until fixed (closes: #620100)
    - stop moving vbaevents*.uno.so to -calc. Move libvbaswobj*uno.so
      to -writer
    - make -l10n-sw (if enabled) depend on locales (>= 2.13-5)
    - adapt GCJ_JAWT_DIR handling for new multiarch dirs and explicitly
      give -l to the libgcj_bc.so.1 multiarch dir to dh_shlibdeps...
  * debian/control.in:
    - build-conflict against libmdds-dev (>= 0.4.0)
  * debian/rules, debian/*lintian-overrides:
    fix/override (some) new Java related lintian warnings
  * debian/rules, debian/libreoffice-filter-binfilter*.in:
    oops, we forgot to do (de-)registering for libbindet*.so

  [ Björn Michaelsen ]
  * debian/patches/jurt-soffice-location.diff: add the fallback
    /usr/lib/libreoffice/program/soffice to jurts NativeLibraryLoader;
    we know where it is

libreoffice (1:3.3.2-1ubuntu6~ppa1) natty; urgency=high

  * removing patch optional-outplace-ole.diff (LP: #709778)
  * this might cause a regression as per OpenOffice.org Bug 98970
 -- Bjoern Michaelsen <email address hidden> Wed, 20 Jul 2011 17:41:56 +0200

Changed in libreoffice (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice-l10n - 1:3.3.3-1ubuntu1

---------------
libreoffice-l10n (1:3.3.3-1ubuntu1) natty-proposed; urgency=low

  * merged all changes up to 3.3.3-1ubuntu1
  * regenerate control

libreoffice (1:3.3.3-1ubuntu1) natty; urgency=medium

  * merge from Debian:
    - debian/rules: make multiarch changes conditional and skip them
      for squeeze (Daniel Baumann)
    - rules: move evolocal.odb into -evolution proper
    - debian/libreoffice-filter-binfilter.links.in:
      actually create symlink for libbindet*so in registered-components
  * regenerate control file
  * update patch queue
  * remove lp709778.diff as it has been picked up as
    disable-optional-outplace-ole.diff by debian
  * remove desktop-templates.diff, those templates are unused
  * remove desktop-translations.diff, those templates are unused
  * remove fix-lo-desktop-pot.diff, those templates are unused
  * remove lp775608.diff, has been integrated upstream
  * update human icon theme to a 2011-06-24 checkout from master
  * update fixes for desktop file entries from ubuntu wiki (LP: #720716)
  * reenable sdbc_postgresql for natty even though it is broken,
    to prevent NBS in natty

libreoffice (1:3.3.3-1) unstable; urgency=medium

  * new upstream release

  [ Rene Engelhard ]
  * debian/patches/disable-optional-outplace-ole.diff: as name says; makes
    toolbars work in e.g. Base edit forms (closes: #617319)

  * debian/rules:
    - disable -sdbc-postgresql until fixed (closes: #620100)
    - stop moving vbaevents*.uno.so to -calc. Move libvbaswobj*uno.so
      to -writer
    - make -l10n-sw (if enabled) depend on locales (>= 2.13-5)
    - adapt GCJ_JAWT_DIR handling for new multiarch dirs and explicitly
      give -l to the libgcj_bc.so.1 multiarch dir to dh_shlibdeps...
  * debian/control.in:
    - build-conflict against libmdds-dev (>= 0.4.0)
  * debian/rules, debian/*lintian-overrides:
    fix/override (some) new Java related lintian warnings
  * debian/rules, debian/libreoffice-filter-binfilter*.in:
    oops, we forgot to do (de-)registering for libbindet*.so

  [ Björn Michaelsen ]
  * debian/patches/jurt-soffice-location.diff: add the fallback
    /usr/lib/libreoffice/program/soffice to jurts NativeLibraryLoader;
    we know where it is

libreoffice (1:3.3.2-1ubuntu6~ppa1) natty; urgency=high

  * removing patch optional-outplace-ole.diff (LP: #709778)
  * this might cause a regression as per OpenOffice.org Bug 98970
 -- Bjoern Michaelsen <email address hidden> Tue, 05 Jul 2011 11:26:41 +0200

Changed in libreoffice-l10n (Ubuntu Natty):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed

Desktop files are now translated upstream at:
https://translations.documentfoundation.org/*/libo35x_ui/sysui/desktop/share.po/translate/

(replace * with your locate)

Al 15/12/11 13:52, En/na Björn Michaelsen ha escrit:
> Desktop files are now translated upstream at:
> https://translations.documentfoundation.org/*/libo35x_ui/sysui/desktop/share.po/translate/
>
> (replace * with your locate)
>

Thanks for the pointer, Björn.

However, the upstream POT templates do not seem to include the quicklist
strings, which would be a good candidate to translate in Launchpad, as
they are Ubuntu-specific.

Regards,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Michael Hall (mhall119) wrote :

I do not get a quicklist for libreoffice or libreoffice-writer in Precise, is this a regression?

nathan@loki:~$ cat /usr/share/applications/libreoffice* | egrep -i "(action|ayatana)"
nathan@loki:~$

both the earlier Ayatana reference & the new XDG standard seem to be absent from libreoffice*.desktop files

Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udo udp udt
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers