[upstream] [hardy] RTF: frame contents (graphics & text) missing when imported

Bug #227895 reported by Asraniel on 2008-05-07
8
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/227895/+attachment/2146818/+files/narrateur.rtf && lowriter -nologo narrateur.rtf

is the text and image in frames look as they do in Word ( https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/227895/+attachment/2336246/+files/screenshot.png ).

4) What happens instead is they disappear.

Chris Cheney (ccheney) wrote :

Confirmed on 2.4.1rc2 and upstream's 3.0beta.

Changed in openoffice.org:
status: New → Confirmed
Chris Cheney (ccheney) on 2008-06-14
Changed in openoffice.org:
status: Confirmed → Triaged

I've sent this upstream at http://www.openoffice.org/issues/show_bug.cgi?id=94499 ; thanks for reporting.

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice.org:
importance: Undecided → Low
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2010-05-13
tags: added: hardy
summary: - [upstream] [hardy] RTF file is not rendered correctly in OOo
+ [upstream] [hardy] RTF: frame contents (graphics & text) missing when
+ imported
description: updated
tags: added: lo33
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Created attachment 47273
narrateur.rtf

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/227895

OOo bug may be found at:
http://qa.openoffice.org/issues/show_bug.cgi?id=94499

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/227895/+attachment/2146818/+files/narrateur.rtf && lowriter -nologo narrateur.rtf

the text and image in frames remain.

4) What happens instead is they disappear.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

Screenshot in Microsoft Office Word 2003 (11.5604.6505).

description: updated
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Still there with LO 3.5.0 beta-1 under Ubuntu 10.04 x86_64.

Best regards. JBF

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

In LO 3.5.0 beta2+ (LibreOffice 3.5.0beta2+ Version ID : 8f03437-7f15fca-1fc8c06-ca8e46d-b96fade) the frames are there but with zero height: I can see two fine lines which can be expanded as frame when I select them.

Miklos: I don't know if you are aware of this bug report. So feel free to reassign if you can't handle it.

Best regards. JBF

Reproduced, will take a look.

Changed in df-libreoffice:
status: Incomplete → Confirmed

Some frames in the document had exact (and not just minimal) height, this the import of those is fixed in master http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0328096dc21ce12d15db2045074e7860872570f (also got backported to -3-5).

Not closing yet, since this is not the only problem in the attached document.

I just checked this again, frames are still wrapped as \nowrap is not imported, the rest looks reasonable.

Which actually worked in LO 3.4, marking as a regression.

Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9c06d2bd253ad6a50141a5b51409dbdffcfd9e6d

fdo#37716 implement import of RTF_NOWRAP

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aef51dc739737440c07c11c8cd88015335c5bb8c&h=libreoffice-4-0

fdo#37716 implement import of RTF_NOWRAP

It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Changed in df-libreoffice:
status: Confirmed → Fix Released

Hello Asraniel, or anyone else affected,

Accepted libreoffice into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libreoffice/1:4.0.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

Fixed in upstream 4.1.0, thus shipping with saucy, which has 4.1.2

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
tags: added: verification-failed
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.