[snap] shell looses track of currently running app when snapd updates it to a newer revision

Bug #1736525 reported by Olivier Tilloy on 2017-12-05
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

This has been reported by at least two users for the libreoffice and chromium snaps.

See https://forum.snapcraft.io/t/call-for-testing-libreoffice-5-4-3/2935/6:

  « My LO just refreshed…I had a document open and the Ubuntu Dock seems to think it’s no longer open even though it is (no orange pip)
    Also when I tried to open that file it said I had it open and it was ‘locked for editing’, rather than just refocusing on the window I have open.
    I then got this error when trying to close/save the file:
        saving the document
        file:///home/adam/snap/libreoffice/43/.config/libreoffice/4/user/basic/script.xlc:
        General Error.
        General input/output error.
    Presumably this is because the instance I have open is revision 43 and the new one is 44 that Ubuntu Dock is trying to launch from, but LO should ‘just work’ on refreshes. Given refreshes are effectively silent, ordinary users will be confused as to what’s going on here. How could the experience be made better? How can the system recognize that revision 43 is the one that’s open and therefore not try and launch revision 44 whilst revision 43 is open? »

Apparently, apps that register as a gapplication don't have the issue.

Olivier Tilloy (osomon) on 2017-12-05
tags: added: snap

I've tried this, but I can't reproduce here...

Manually refreshing from stable to edge, for example, it works as expected. Both with chromium and lo.

Olivier Tilloy (osomon) wrote :

I was able to reproduce the issue with the chromium snap, by ensuring that the chromium icon was pinned (favourited) to the dock first.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Changed in libreoffice (Ubuntu):
status: New → Confirmed
Ads20000 (ads20000) wrote :

See bug 1762354 for a generic snapd bug that's been filed on this issue :)

Ads20000 (ads20000) wrote :

In fact, it might make sense to file this bug against snapd and mark bug 1762354 as a duplicate (since that bug was filed later)?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers