LibreOffice kde file dialog integration broken (not working) in 14.04

Bug #1369673 reported by Nikola Snele
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Confirmed
Undecided
Unassigned
qt4-x11 (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Screenshot: http://www.dodaj.rs/f/22/pb/1Vu8cW0n/snapshot58.png

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libreoffice-kde (not installed)
Uname: Linux 3.16.2-031602-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.4
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Sep 15 19:17:48 2014
InstallationDate: Installed on 2014-02-02 (224 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140202)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Nikola Snele (n-schnelle) wrote :
Revision history for this message
Adolfo Jayme Barrientos (fitojb) wrote :

> Package: libreoffice-kde (not installed)

Install it.

Changed in libreoffice (Ubuntu):
status: New → Invalid
Revision history for this message
Nikola Snele (n-schnelle) wrote :

@Adolfo Jayme (fitojb)

With installed libreoffice-kde this bug appears.

I have removed libreoffice-kde and installed libreoffice-gtk to workaround this bug (to get decent file dialog).

So I don't think this bug is invalid.

Revision history for this message
Nikola Snele (n-schnelle) wrote :

I just checked my other pc.

Kde file dialog worked in LO 4.2.4. Update to 4.2.6 broke it.

Changed in libreoffice (Ubuntu):
status: Invalid → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Revision history for this message
Mads Bondo Dydensborg (mads-dydensborg) wrote :

Same problem here, recent upgrade introduced this problem (ubuntu 14.04). Libreoffice version:

Version: 4.2.6.3
Build ID: 420m0(Build:3)

libreoffice-kde:
ii libreoffice-kde 1:4.2.6.3-0ubuntu1 amd64 office productivity suite -- KDE integration

This bug is, to the best of my knowledge a valid bug.

If a workaround exists, please post it. (I have tried removing/purging libreoffice-kde to no avail. Its still some default file dialog that opens).

Revision history for this message
Nikola Snele (n-schnelle) wrote :

You can remove libreoffice-kde and install libreoffice-gtk. That way you will get gnome file dialog which is better than generic one which now pops up with libreoffice-kde installed.

Revision history for this message
Mads Bondo Dydensborg (mads-dydensborg) wrote :

Thanks, Nikola!

Regrettably, I despise the gnome file dialog. How this dialog can even be part of a modern desktop environment is beyond me.

Revision history for this message
Mads Bondo Dydensborg (mads-dydensborg) wrote :

I have been able to downgrade my libreoffice installation to the previous version, using these commands:

0) First, check all libreoffice related packages you have into a file:

dpkg -l | grep libreoffice | tee libreoffice-packages

1) Then, purge all libreoffice packages

sudo apt-get remove --purge libreoffice-core libreoffice-common libreoffice-style-oxygen

2) Then install the bulk of the previous version:

sudo apt-get install libreoffice-core=1:4.2.3~rc3-0ubuntu2 libreoffice-common=1:4.2.3~rc3-0ubuntu2 libreoffice-style-oxygen=1:4.2.3~rc3-0ubuntu2 libreoffice-kde=1:4.2.3~rc3-0ubuntu2 libreoffice=1:4.2.3~rc3-0ubuntu2 libreoffice-base=1:4.2.3~rc3-0ubuntu2 libreoffice-calc=1:4.2.3~rc3-0ubuntu2 libreoffice-draw=1:4.2.3~rc3-0ubuntu2 libreoffice-impress=1:4.2.3~rc3-0ubuntu2 libreoffice-math=1:4.2.3~rc3-0ubuntu2 libreoffice-writer=1:4.2.3~rc3-0ubuntu2 python3-uno=1:4.2.3~rc3-0ubuntu2 libreoffice-base-core=1:4.2.3~rc3-0ubuntu2 libreoffice-base-drivers=1:4.2.3~rc3-0ubuntu2

3) Now, manually add as many of the packages that you had additionally (check the contents of the libreoffice-packages file you created in the 0) step), as you can. In my case:

sudo apt-get install libreoffice-l10n-da=1:4.2.3~rc3-0ubuntu1 libreoffice-help-da=1:4.2.3~rc3-0ubuntu1 libreoffice-help-en-us=1:4.2.3~rc3-0ubuntu1

I now have a working libreoffice installation that uses the KDE file dialog.

One problem is left: that any apt-get upgrade will want to upgrade my libreoffice installation, but I think you can mark them as "hold" for the package system, if you want to avoid this. I'll handle it manually for now.

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

note that 4.2.6 is a security update fixing:
http://www.libreoffice.org/about-us/security/advisories/cve-2014-3524/
http://www.libreoffice.org/about-us/security/advisories/cve-2014-3575/

At least one of those seems to affect Linux too.

Revision history for this message
Mads Bondo Dydensborg (mads-dydensborg) wrote :

Thanks, Björn.

That is highly relevant information.

I will personally run the risk, as the file dialog is really important to me, but others may not want to.

Revision history for this message
Mads Bondo Dydensborg (mads-dydensborg) wrote :

Libreoffice has been updated in the ubuntu reps, but the problem persists with version:
libreoffice 1:4.2.7-0ubuntu1 amd64
libreoffice-kde 1:4.2.7-0ubuntu1 amd64

Any hints on how to fix this would be great.

(Downgrading to 4.3.2~rc3-0ubuntu1 still works, but obviously is not a good solution).

Revision history for this message
Arran (bruno13) wrote :

I think this is a bit a nuisance but not really a problem. The fileopening Dialog in LO is not really difficult to understand. I'd prefer full force to debug first the important bugs and not such a luxury bug like this one.

Revision history for this message
Mads Bondo Dydensborg (mads-dydensborg) wrote :

On the other hand, Arran, this is most likely a minor build/integration issue, as it has been working for years. The effort to fix this may be neglible.

And, do not underestimate the value of integration - I work *a lot* with libre-office and KDE, and really, the integration with the KDE file dialog is a huge timesaver in daily work for me.

(Also, I resent you calling this a "luxury bug" - really, that is unnecessarily condescending).

Revision history for this message
Cruiz (cruiz) wrote :

It seems to be also a problem in Qt. See Debian Bug #752230

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752230

Revision history for this message
cleary (bernard-gray) wrote :

I reported this against the Libreoffice PPA packages, but it's now affecting the main packages in ubuntu:

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1359486

I'm currently in the process of preparing some workaround packages for the ppa listed in that thread.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.