Libreoffice quicklist doesn't work says "label empty"

Bug #1231799 reported by bwat47 on 2013-09-27
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Low
libreoffice (Ubuntu)
High
Björn Michaelsen
Saucy
High
Björn Michaelsen

Bug Description

Unity quick list for libreoffice apps in ubuntu 13.10 beta 2 just says "label empty" this is because in the .desktop files it incorrectly says "Unityquicklist= New Document" instead of "Name=New Document". If I edit the .desktop files to say "Name=New Document" the unity quick list works fine.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
Date: Fri Sep 27 00:48:13 2013
InstallationDate: Installed on 2013-09-27 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Beta amd64 (20130925.1)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

bwat47 (bwat47) wrote :
Adolfo Jayme (fitojb) on 2013-09-27
Changed in libreoffice (Ubuntu):
status: New → Triaged
importance: Undecided → High
Adolfo Jayme (fitojb) on 2013-10-04
tags: added: rls-s-incoming
Changed in libreoffice (Ubuntu):
milestone: none → ubuntu-13.10
Changed in libreoffice (Ubuntu Saucy):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
tags: removed: rls-s-incoming

A quick comparison of the (in this case: calc) .desktop files shows they are unchanged between raring and saucy. So a regression in dash, or whatever reads the .desktop file?

Changed in libreoffice (Ubuntu Saucy):
status: Triaged → Incomplete

Desktop files in sysui/desktop/menus still use an old unity quickstart action:

[X-New Shortcut Group]
UnityQuicklist=New Document
Exec=libreoffice --base %%FILE%%
TargetEnvironment=Unity

Instead it should use a new style quicklist entry as per https://help.ubuntu.com/community/UnityLaunchersAndDesktopFiles:

Actions=NewDocument;

[Desktop Action NewDocument]
Name=New Document
Exec=libreoffice --writer %%FILE%%
OnlyShowIn=Unity;

no longer affects: dash
no longer affects: dash (Ubuntu)
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Saucy):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2013-10-17
affects: dash (Ubuntu Saucy) → unity (Ubuntu Saucy)

AFAIK .desktop files are in /core/sysui/desktop/menus/
Not sure if it is enough to modify these files.

Best regards.

Changed in libreoffice (Ubuntu):
milestone: ubuntu-13.10 → saucy-updates
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Saucy):
status: New → Confirmed

Created attachment 88144
proposed patch

Here is a patch that updates desktop files.
Proposed changes are:
- reactivate StartCenter and Math desktop file: NoDisplay keyword set to false
- add "New Document" menu for each module in StartCenter desktop file
- make desktop files more standard conforming (hopefully) :
  a- removed X-Ayatana-Desktop-Shortcuts keyword
  b- %U parameter is useless when creating a new document
  c- use OnlyShowIn keyword instead of TargetEnvironment

@Jean-Baptiste Faure: There is no need to set NoDisplay=false, you just need to remove this line completely.

(In reply to comment #3)
> @Jean-Baptiste Faure: There is no need to set NoDisplay=false, you just need
> to remove this line completely.

I know, the idea was to keep track of the hidden state of the StartCenter and the Math module in previous version.

Best regards. JBF

Changed in df-libreoffice:
status: Confirmed → In Progress
Paul Greindl (paul-greindl) wrote :

This is still present in the stable release of 13.10 which obviously isn't that good! Anything that can be done to get this fixed?

Should be fixed with the version 1:4.1.3~rc2-0ubuntu1~saucy1~ppa2 in:
 https://launchpad.net/~libreoffice/+archive/libreoffice-4-1
 https://launchpad.net/~libreoffice/+archive/ppa

Please test and report any issues, so this can be SRUed soon.

Changed in libreoffice (Ubuntu Saucy):
status: Incomplete → Fix Committed

FWIW, I had a vendor patch for this in on 4.1, but will of course push _your_ changes as soon as I am back home.

Pushed, Thanks Jean-Baptiste!

Jean-Baptiste Faure committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=78e4c8a925f4735a7e9a4c32a29b19fd2b77670d

fdo#70553: Fix Unity Quicklists

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Changed in df-libreoffice:
status: In Progress → Fix Released

Thank you Björn :-)

Could this patch be backported to 4.1 ? If I am not wrong, before this change desktop files were identical in 4.1 and the master.

Best regards. JBF

(In reply to comment #8)
> Thank you Björn :-)
>
> Could this patch be backported to 4.1 ?

Perhaps not so good idea because this would imply to add translatable strings.

Best regards. JBF

I vendorpatched that independently on 4.1 for Ubuntu. The PPA versions should already have this patched and this should also go into the archive with the next SRU, so TBH I dont want to backport that patch (just to kick out the vendor patch there).

Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Committed
Changed in unity (Ubuntu Saucy):
status: Confirmed → Invalid
Paul Greindl (paul-greindl) wrote :

@Björn Are there any plans to push this change to saucy anytime soon?

@Paul Greindl: see comment 11

Adolfo Jayme (fitojb) on 2013-11-12
no longer affects: unity (Ubuntu Saucy)
Adolfo Jayme (fitojb) wrote :

The update from the PPA fixes the quicklist for me. It appears in English, though — but that may be an unrelated issue.

Hello bwat47, or anyone else affected,

Accepted libreoffice into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libreoffice/1:4.1.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of libreoffice from saucy-proposed was performed and bug 1256819 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1256819 "bot-stop-nagging". Thanks!

tags: added: verification-failed
tags: removed: verification-failed

Label looks good with the version in saucy-proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.1.3-0ubuntu2

---------------
libreoffice (1:4.1.3-0ubuntu2) trusty; urgency=low

  * temporary use internal mdds for trusty
 -- Bjoern Michaelsen <email address hidden> Sat, 07 Dec 2013 21:41:08 +0100

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.1.3-0ubuntu1

---------------
libreoffice (1:4.1.3-0ubuntu1) saucy; urgency=low

  [ Bjoern Michaelsen ]
  * new upstream release
  * add upstream patch for fdo#70201, review missed the tag
  * backport upsteam patch for fdo#70741 from libreoffice-4-1 branch
    (fixes RTL)
  * fix desktop files for unity quicklists (LP: #1231799)
  * no source change vs. the ~rc2 version in the PPA
    (but full l10n for the archive)
  * fix quicklist patch to add Actions too
  [ Rene Engelhard ]
  * debian/scripts/gid2pkgdirs.sh: use new gid for
    ScriptProviderFor{JavaScript,Beanshell}.jar install (fdo#71317)
 -- Bjoern Michaelsen <email address hidden> Wed, 20 Nov 2013 16:55:22 +0100

Changed in libreoffice (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

(In reply to comment #2)
> Created attachment 88144 [details] [review]
> proposed patch
>
> Here is a patch that updates desktop files.
> Proposed changes are:
> - reactivate StartCenter

Why? What good does it do to the user, when there are already separate records for the applications?

> and Math desktop file: NoDisplay keyword set to
> false

This is a regression from bug 41681. IIRC the consensus of most distro maintainers was not to show it. (And yes, there is no way to please users anyway. We have got bugs in Fedora asking for both.)

David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=12546c8511f0cc8eec0ca7e8cb86ff00dfd429e6

regression since fdo#70553

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

(In reply to comment #11)
> (In reply to comment #2)
> > Proposed changes are:
> > - reactivate StartCenter
>
> Why? What good does it do to the user, when there are already separate
> records for the applications?
Hi David,

What the point of having a "Start" center if no one will ever see it when he "starts" the application?

(In reply to comment #13)
> (In reply to comment #11)
> > (In reply to comment #2)
> > > Proposed changes are:
> > > - reactivate StartCenter
> >
> > Why? What good does it do to the user, when there are already separate
> > records for the applications?
> Hi David,
>
> What the point of having a "Start" center if no one will ever see it when he
> "starts" the application?

I doubt anyone just wants to start the application. One wants to create a document or presentation or...

(In reply to comment #14)
> I doubt anyone just wants to start the application. One wants to create a
> document or presentation or...
Or to open recently edited document. The new start center allows to do that in a convenient way, instead of opening the file browser and navigating through endless folders...

(In reply to comment #14)
> [...]
> I doubt anyone just wants to start the application. One wants to create a
> document or presentation or...

So, to be consistent, you should commit a patch to remove the StartCenter, including for the MS-Windows version. Very strange idea to remove the visibility of the StartCenter when we create a new one.

If Linux distributions maintainers do not want give the access to the StartCenter and the Math module, they can do that in their distro build without deciding for all Linux users.

Best regards. JBF

(In reply to comment #16)
> (In reply to comment #14)
> > [...]
> > I doubt anyone just wants to start the application. One wants to create a
> > document or presentation or...
>
> So, to be consistent, you should commit a patch to remove the StartCenter,
> including for the MS-Windows version. Very strange idea to remove the
> visibility of the StartCenter when we create a new one.

To be honest, I do not care much either way. And _if_ this was changed as a result of a discussion (or a bug) that said: "Hey, we have a shiny new start center. Let's all the users see it!", I would not say anything. But it was not, so I see it as a regression.

>
> If Linux distributions maintainers do not want give the access to the
> StartCenter and the Math module, they can do that in their distro build
> without deciding for all Linux users.

Well, we tend to assume the majority of linux users gets libreoffice through their distribution. And the last time this come up, more distro maintainers were for disabling than against it. If that has changed, so be it. We patched it in Fedora before; we can do it again...

Note that math has been hidden since 3.5 and nobody has protested. Startcenter was only hidden in 4.1, but I do not remember any bugs related to that either...

Well, I don't think the start center is of great use for Linux users.
For Windows it's ok, you need to put something on their desktop so they can find the program they installed.
But I doubt there are many Linux users who use the start center. I have it there since 4.1 but have never opened it.

But I'm not sure what's the reason Math is hidden.

(In reply to comment #17)
> Startcenter was only hidden in 4.1, but I do not remember any bugs related
> to that either...
There is Bug 70133. Also keep in mind that Debian/Ubuntu patched 4.1 to re-enable the start center, and that might be the reason we don't have many reports about it.

(In reply to comment #19)
> (In reply to comment #17)
> > Startcenter was only hidden in 4.1, but I do not remember any bugs related
> > to that either...
> There is Bug 70133.

... where the reporter does not say why he needs it, just that it is missing. Cue http://xkcd.com/1172/ .

> Also keep in mind that Debian/Ubuntu patched 4.1 to
> re-enable the start center, and that might be the reason we don't have many
> reports about it.

But that does not supports the "generic unix" case. Reciprocally, keep in mind that Fedora has had it disabled for at least 4 releases and we have not had any bug reports concerning that either.

> Or to open recently edited document. The new start center allows to do
> that in a convenient way, instead of opening the file browser and
> navigating through endless folders...

And only allows to do that one document at a time, because as soon as you have opened one, the only way to go back to the start center is to close the document. So the user needs to remember two ways to access recently opened documents. (Three, actually, because the desktop typically offers one as well.)

But whatever... I have had enough of this discussion. I will revert my earlier commit and just handle it in Fedora.

David, don't give up! This is just getting fun.

David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2b2f2d5194313f6a53d35eee39357dbca5f0bd4

Revert "regression since fdo#70553"

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.