libreoffice menu not working

Bug #1182082 reported by cochisebt on 2013-05-20
136
This bug affects 30 people
Affects Status Importance Assigned to Milestone
LibreOffice
Won't Fix
Medium
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Since update to libreoffice 4.0.3, all the menu are blank.
---
ApportVersion: 2.0.1-0ubuntu17.2
Architecture: amd64
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 10.04.2 LTS "Lucid Lynx" - Release amd64 (20110211.1)
MarkForUpload: True
Package: libreoffice 1:4.0.3-0ubuntu1~precise1 [origin: LP-PPA-libreoffice-libreoffice-4-0]
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.2.0-43.68-generic 3.2.42
Tags: precise running-unity third-party-packages
Uname: Linux 3.2.0-43-generic x86_64
UnreportableReason: Ce paquet n'est pas officiellement pris en charge par Ubuntu. Veuillez désinstaller tout paquet tiers et réessayer.
UpgradeStatus: Upgraded to precise on 2012-08-23 (270 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

Problem description:

I've just update my libreoffice 4.0.2.2 to 4.0.3.3.... When I start Writer, Impress or Calc, the first time I click on any main menu it does not show submenus automatically (I recorded problem using RecordMyDesktop and uploaded to http://www.youtube.com/watch?v=uNQ0r4YVITU).

I heard that menu issues are realted to Unity. So is it Ubuntu or LibreOffice problem? And any idea how to fix it?

I am using Ubuntu 13.04 and Libre Office 4.0.3.3. (this didn't happen in 4.0.2.2.)..

Operating System: Ubuntu
Version: 4.0.3.3 release
Last worked in: 4.0.2.2 release

Which LibreOffice version do you use _exactly_? Full version number and source please (official repo? ppa? upstream? full debian version in case of a packaged version please)

Trying this with 4.0.3.2 from the ppa, I see this ... somewhat: When I create a new table and directly go immediately to the table->delete menu it is still disabled, but not when doing it slower or when rolling to another menu, so this is likely just a latency issue: the menu just isnt updated quick enough.

whops, last comment was for bug 64560, which is likely related.

Version 4.0.3.3 (Build ID: 400m0(Build:3))

I run in cmd "sudo add-apt-repository ppa:libreoffice/libreoffice-4-0"

and then went to Software Updater... 87 MB was downloaded and installed...

how can I try to reinstall it?

@Ljijan: On which Ubuntu version?

Ubuntu 13.04

I had Ubuntu 12.10 and when 13.04 was released, I updated to 13.04.

Some additional info (if it matters?)

In Ubuntu 12.10 I used LibreOffice 4.0 (installed from official LO PPA), but it didn't integrate well with Unity launcher... (all programs were grouped under the one icon)... then removed it using Synaptic Package Manager (I marked all LibreOffice Packages for Complete Removal) and then reinstalled it using Ubuntu Software Center... when new version of Ubuntu was relased, I update my Ubuntu to 13.04 and new Libre Office 4.0.2.2 was already there... no problems intead of menu hover problem that is already reported. And few days ago I updated my Libre Office to 4.0.3.3. using LO PPA.

Will it help to reinstall LO?

This is a sideeffect of the fix for:

 https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1085169

because exporting the menu to unity the first time takes time. Note that the menu shows up after a short delay even in your video.

Same fix is also on master and will be released with 4.1.x. The question is still open if this will be SRUed to raring though.

updating bug summary.

closing as WONTFIX for now upstream.

cochisebt (cochisebt) wrote :

Uninstalling the following packages make the menu reappear, but make libreoffice ugly

libreoffice-gtk
libreoffice-gnome

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
cochisebt (cochisebt) wrote :

Hi,

As a temporary solution, it is better to uninstall this package:

indicator-appmenu

Instead of libreoffice-gtk and libreoffice-gnome.

Arup (arup-chowdhury) wrote :

This bug affects me as well since I upgraded to the latest Libre office. Was working fine till now with the earlier version 4.

any suggestion what should I do? should I unistall 4.0.3.3 and install 4.0.2.2.?

Milodovi'c (miloud-rashid) wrote :

This bug affects me as well since I upgraded to the latest Libre office 4.0.3

Claude Boussard (cboussard) wrote :

Hi,

I am also affected with this bug since I upgraded to the latest Libre office 4.0.3

Assuming all reporters are on 12.04 where 4.0 is an unsupported backport:
https://lists.launchpad.net/libreoffice/msg00054.html
closing as invalid.

Changed in libreoffice (Ubuntu):
status: Confirmed → Invalid
aguy (aguytech) wrote :

I'm using Libreoffice 4.0.3 on ubuntu 13.04 and I have the same problem : blank text in global menu for libreoffice only.

aguy (aguytech) wrote :

Sorry I'm not in 13.04 on this computer !

Milodovi'c (miloud-rashid) wrote :

this is a problem for me !!!! i can't work without libreoffice

Changed in libreoffice (Ubuntu):
status: Invalid → Confirmed

Same problem here in Ubuntu 12.04. Submenus do not appear at all. In Ubuntu 13.04, submenus appear after a while.

Both machines are using PPA. Upgraded to the latest version.

@aguy: Does the menu stay blank, or is it just that it takes a moment before the menu is populated for the first time?

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
frenchy82 (cartes) wrote :

Hi,

Just to add that with libreoffice 4.0.2 from this same PPA globalmenu works just fine

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Won't Fix
Milodovi'c (miloud-rashid) wrote :

 the menu stay blank

Rico Tzschichholz (ricotz) wrote :

As stated it (kind of) worked before.
The related sources were only touched by lp-1085169-we-overactivate-here-as-it-does-not-seem-.diff.
So I will rebuild the precise backport with that patch disabled.

Milodovi'c (miloud-rashid) wrote :

Thanks

apport information

tags: added: apport-collected precise running-unity third-party-packages
description: updated

apport information

See https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1182082/comments/25

Rico will rebuild the 12.04 build without the patch. I will likely do the same and not SRU this to 13.04. Still this will be released with upstream LibreOffice 4.1 (introducing the delay and but fixing the 'menus dead after print preview').

cochisebt (cochisebt) on 2013-05-21
Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed

Still incomplete: Does it stay blank _on 13.04/raring_?

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
cochisebt (cochisebt) wrote :

According to Ljiljan Veselinović (lilicus), it seems to affect 13.04 also.

However it seems that the menu reappear after a while (see his comment above).

On my computer using 12.04, the menu don't reappear, they just stay blank.

cochisebt (cochisebt) wrote :

It seems to be some issue of integration of libreoffice in Unity with 13.04

http://ubuntuforums.org/showthread.php?t=2147064&page=2

for 12.04 precise see comment 25.
for 13.04 I will not SRU this change as it is in the current ppa version given the feedback. I will update the PPA to not have the backport of the fix in the next days too.
It will be in 13.10 with upstream LibreOffice 4.1.x anyway.

The bug is exhibited in no offically released version of LibreOffice in Ubuntu versions -- thus closing as Invalid.

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
Changed in libreoffice (Ubuntu):
status: Invalid → Confirmed

please dont change the bug state, the rationale is in comment 33.

Changed in libreoffice (Ubuntu):
status: Confirmed → Invalid

I'm using Libreoffice 4.0.3 on ubuntu 12.04.2 64bits and I have the same problem : blank text in menus

Marek Wrzosek (marek-wrzosek) wrote :

I'm using Libreoffice 4.0.3.3 on ubuntu 12.04.2 64-bit with 3.2.0 kernel (if it matters) and I reported a bug https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1182768
Menus are not blank but useless (there is only one submenu working - File -> New -> *). Menus are populated, but not working at all (even using dash). This bug is in every LibO window, not only in writer, calc and impress. Is it duplicate?

13.04 raring update removing the vendor patch for the 4.0.x branch is pushed to the PPAs now.

cochisebt (cochisebt) wrote :

It works. Thank you very much.

Chris Spencer (headscratcher) wrote :

libreoffice - 1:4.0.3-0ubuntu1~precise2

Working on my 12.04 install.

Menus behaving as expected.

Many thanks Rico and team!!

Gitty K (jkleres) wrote :

same problem with quantal, in fact menus are not only empty, but LO actually crashes after opening one of the menus. No update yet.

I don't have problems any more. Ubuntu updated Libre Office to 4.0.3.3 again (even though it already was 4.0.3.3.) and now no delays to submenus. Update was provided today.

I don't understand what happened, but the problem is solved...

John Perez (perez-johnangelo) wrote :

The menus are now working on Ubuntu 12.04.2 with the recently pushed *-precise2 update. Thanks for the hard work, guys!

It was very fast. Thank you for your work!

Marek Wrzosek (marek-wrzosek) wrote :

*-precise2 update works like a charm. Thanks!

som (drsoumalya-blog) wrote :

just adding that with recent updates, libreoffice 4.0.3 is again working in ubuntu 12.04. had to install libreoffice-gtk again.uninstalled it few days back. thank you devs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.