libreoffice 3.6.2 crash clicking on charts/formulas

Bug #1062812 reported by flux on 2012-10-06
74
This bug affects 11 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Critical
Björn Michaelsen
Quantal
Critical
Björn Michaelsen

Bug Description

Hi, I opened some spreadsheets with libreoffice 3.6.1 on Ubuntu Quantal Beta 2 but when I clicked on a chart libreoffice crashed instantly. I opened libreoffice with gdb and this was message on crash:

Program received signal SIGSEGV, Segmentation fault.
0x00007fffea91fd06 in ?? ()
   from /usr/lib/libreoffice/program/libvclplug_gtklo.so

what happened? I tried to update to version 3.6.2 but Calc still crash.

ps. On Windows, with 3.6.2, there were non problems.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
barnimg (barnim-g) wrote :

I have the same problem with formulas and charts in writer. It is impossible to add them or to change them in an old document. Every time LibreOffice crashes.

summary: - Calc 3.6.2 crash clicking on charts
+ libreoffice 3.6.2 crash clicking on charts/formulas
Jack Leigh (leighman) wrote :

Please could you provide a file which demonstrates this crash

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
flux (luigimarco) wrote :

for me is impossible to provide a file, because libreoffice crash before that I can save it... I'm sorry

ps. I also noticed that writer crash when I attempt to add an index

Is this running in unity or without unity?

Also please install libreoffice-dbg and provide a full stacktrace.

flux (luigimarco) wrote :

with unity... ok, but how can I use libreoffice-dbg to obtain a stacktrace? I'm sorry, but I've never installed it

flux (luigimarco) wrote :

unfortunately I haven't 3gb to install libreoffice-dbg, I hope someone else can do it :(

Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Committed
importance: Undecided → Critical
Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
milestone: none → ubuntu-12.10

FFE documentation:

proposed changes:
Checking for a NULL-pointer before derefing. Changes are restricted to libreoffice-gtk package.

rationale:
Leaving out this fix would lead to crashes in a lot of cornercases and lead to dataloss (losing unsaved documents).

addendum:
Testing performed on the package with the changes against 0ubuntu1: No ppa upload, time doesnt allow that. The usual local amd64 pbuilder build and locally installed those packages to verify the crash to be gone when inserting a formula.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:3.6.2~rc2-0ubuntu3

---------------
libreoffice (1:3.6.2~rc2-0ubuntu3) quantal-proposed; urgency=high

  * packaging shouldnt try to move stuff it doesnt build on armel/armhf
 -- Bjoern Michaelsen <email address hidden> Mon, 08 Oct 2012 13:19:24 +0200

Changed in libreoffice (Ubuntu Quantal):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

libreoffice (1:3.6.2~rc2-0ubuntu2) quantal-proposed; urgency=high

  * do not build extensions on armel, armhf for bug 1062448
  * update to unitymenus patch Change-Id
    Ia8f82024e56ad83c8979d60df3c94e8209fe2552 (LP: #1062757) (LP: #1062812)

 -- Bjoern Michaelsen <email address hidden> Sun, 07 Oct 2012 10:18:24 +0200

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers