[Precise on VirtualBox] "Fatal server error: no screen found" in Xorg.0.log

Bug #1122072 reported by Giovanni Tornatore on 2013-02-11
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
libpciaccess (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]
Without this libpciaccess fix xserver-xorg-video-vesa will not function correctly in virtualbox or on Intel GPUs when vesa is forced (i915 not loaded in the kernel, as can happen on newer hardware without kernel support) when using the Quantal X backport stack that is in 12.04.2.

This requires 3 commits from upstream libpciaccess git, all contained in 0.13.1 that is in quantal, which is why the bug never manifested there.
http://cgit.freedesktop.org/xorg/lib/libpciaccess/commit/?id=f550c1347d3518874fe1c1d417a57322ee6b52db
http://cgit.freedesktop.org/xorg/lib/libpciaccess/commit/?id=b16336c0b389ace07f7418f5a021bfbc68fec2b6 (which fixes the previous commit on ARM)
http://cgit.freedesktop.org/xorg/lib/libpciaccess/commit/?id=d2dc9f9daa45504f035b169aba94d0b154fd29f0

[Test Case]
Try to boot 12.04.2 in a virtualbox VM without guest extensions so vesa is used.
If working, X will start and the desktop will come up normally.

[Original Subject]

Hello!

I have tested Edubuntu amd64 (5d76226ca924f5c5b4e683c4ac177a6b *precise-dvd-amd64.iso 20130210), on VirtualBox.

1) I have started the system.
2) I have chosen the language.
3) I have clicked on "Try Edubuntu ..."
4) This system is started no graphics.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg (not installed)
ProcVersionSignature: Ubuntu 3.5.0-23.35~precise1-generic 3.5.7.2
Uname: Linux 3.5.0-23-generic x86_64
.tmp.unity.support.test.1:

ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
CasperVersion: 1.315.1
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Mon Feb 11 12:04:20 2013
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes,
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
LiveMediaBuild: Edubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130210)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=it keyboard-configuration/layoutcode?=it
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.7.12-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu0.1
version.libgl1-mesa-dri: libgl1-mesa-dri N/A
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Mon Feb 11 12:28:13 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Sleep Button KEYBOARD, id 7
 input VirtualBox USB Tablet TOUCHSCREEN, id 8
 input AT Translated Set 2 keyboard KEYBOARD, id 9
 input ImExPS/2 Generic Explorer Mouse MOUSE, id 10
xserver.errors:
 Failed to load module "vboxvideo" (module does not exist, 0)
 Failed to load module "vboxvideo" (module does not exist, 0)
 open /dev/dri/card0: No such file or directory
 open /dev/dri/card0: No such file or directory
 open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.13.2-0ubuntu1

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1122072

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Para Siva (psivaa) wrote :

Confirmed with ubuntu-desktop-amd64 and ubuntu-desktop-i386 when using VirtualBox. Did not see this issue on virt-manager using KVM and on hardware.

summary: - [Precise amd64 on VirtualBox] "Fatal server error: no screen found" in
+ [Precise on VirtualBox] "Fatal server error: no screen found" in
Xorg.0.log
Paul Larson (pwlars) wrote :

Seems to be a regression from 12.04.1. Tried this with 12.04.1 and it works fine with that release, but on the same setup it fails with current isos.

Robert Hooker (sarvatt) wrote :

Can you please enable this ppa

https://launchpad.net/~mlankhorst/+archive/ppa

update, and only upgrade libpciaccess0 from it to see if it fixes the problem?

Robert Hooker (sarvatt) on 2013-02-12
description: updated
Paul Larson (pwlars) wrote :

Yes, that fixes it for me.

Robert Hooker (sarvatt) wrote :

debdiff which fixes the bug

libpciaccess (0.12.902-1ubuntu0.1) precise-proposed; urgency=low

  * Enable patch system in package build
  * Add libpciaccess-dev-port.patch, backport from upstream git to fix
    x-x-v-vesa usage in virtualbox. (LP: #1122072)

 -- Robert Hooker <email address hidden> Tue, 12 Feb 2013 11:50:52 -0500

affects: xorg (Ubuntu) → libpciaccess (Ubuntu)
tags: added: patch
Changed in libpciaccess (Ubuntu):
importance: Undecided → High

Hello Giovanni, or anyone else affected,

Accepted libpciaccess into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libpciaccess/0.12.902-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libpciaccess (Ubuntu):
status: Confirmed → Fix Released
Changed in libpciaccess (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
milestone: none → ubuntu-12.04.2
status: In Progress → Fix Committed
tags: added: verification-needed

Package from proposed works for me.

Tested installing 'libpciaccess0' into 12.04.2 installed VM. 'startx' subsequently worked as expected.

Hello!

Test #1

1) I have started the system.
2) I have chosen the language.
3) I have clicked on "Try Edubuntu ..."
4) This system is started no graphics.
5) I have launched on the terminal this command "lightdm start", and the system has been stopped on this screen attached.

Test #2

1) I have started the system.
2) I have chosen the language.
3) I have clicked on "Try Edubuntu ..."
4) This system is started no graphics.
5) I have enabled the repository precise-proposed on the sources.list (deb http://archive.ubuntu.com/ubuntu/ precise-proposed restricted main multiverse universe).
6) I have launched on the terminal "apt-get update" "apt-get upgrade" "apt-get dist-upgrade" and I have checked that package "libpciaccess0" had been updated.
7) I have launched on the terminal this command "lightdm start": the graphics is started.
8) I have access on the desktop.

I confirm this fix.

thanks

Gianni

Paul Larson (pwlars) wrote :

nak
Colin built an iso with what's currently in proposed for me to try and I'm still having problems getting to the live session. I get further than before - to the graphical screen that asks me to choose to try ubuntu or install. Choosing to install seems to go along ok, but if I choose the live session it takes me to a blank screen with a dialot saying """
The system is running in low-graphics mode
Your screen, graphics card, and input device settings could not be detected correctly. You will need to configure these yourself.
"""

When I press ok, I get the following options:
* Run in low-graphics mode for just one session
* Reconfigure graphics
* Troubleshoot the error
* Exit to console login

Choosing to run in low graphics mode tells me to "Stand by one minute while the display restarts..." then goes to a black console screen with no X as before the fix.
Choosing to reconfigure graphics doesn't get me to a running desktop either.
Here's the Xorg.0.log from the session: http://paste.ubuntu.com/1641492/
It seems to be unhappy about not having the vboxvideo module at the moment.

Paul Larson (pwlars) wrote :

I also tried installing an alternate image under virtualbox rather than on actual hardware and noticed that after the system boots, I see the same issues as noted in comment #13. I tried installing virtualbox-ose-guest-dkms to see if it would help and got a build error on the module:
http://paste.ubuntu.com/1641967/

Test #3 (On VirtualBox. Also the test #1 #2 has been performed on VirtualBox).

1) I have started the system.
2) I have chosen the language.
3) I have clicked on "Try Edubuntu ..."
4) This system is started no graphics.
5) I have enabled the repository precise-proposed on the sources.list (deb http://archive.ubuntu.com/ubuntu/ precise-proposed restricted main multiverse universe).
6) I have launched on the terminal "apt-get update" "apt-get upgrade" and I have checked that package "libpciaccess0" had been updated.
7) I have launched on the terminal this command "lightdm start": the graphics is started.
8) I have access on the desktop.
9) I have launched ubiquity and installed Edubuntu.
10) Reboot: this system started no graphic.
11) I have enabled the repository precise-proposed on the sources.list (deb http://archive.ubuntu.com/ubuntu/ precise-proposed restricted main multiverse universe).
12) I have launched on the terminal "apt-get update" "apt-get upgrade" and I have checked that package "libpciaccess0" had been updated.
13) Reboot: this system started with graphics.

Thanks!

Gianni

Colin Watson (cjwatson) wrote :

I'm going to release this despite Paul's comments because i915 hardware is common enough to be worthwhile. I've asked Paul to file a separate bug for the continuing virtualbox problems.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libpciaccess - 0.12.902-1ubuntu0.1

---------------
libpciaccess (0.12.902-1ubuntu0.1) precise-proposed; urgency=low

  * Enable patch system in package build
  * Add libpciaccess-dev-port.patch, backport from upstream git to fix
    x-x-v-vesa usage in virtualbox. (LP: #1122072)
 -- Robert Hooker <email address hidden> Tue, 12 Feb 2013 11:50:52 -0500

Changed in libpciaccess (Ubuntu Precise):
status: Fix Committed → Fix Released

Hello Giovanni, or anyone else affected,

Accepted xorg-server into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server/2:1.13.0-0ubuntu6.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Maarten Lankhorst (mlankhorst) wrote :

Not 100% sure why this bug was mentioned, but outputless xorg-server works correctly now.

tags: added: verification-done
removed: verification-needed
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in libpciaccess (Ubuntu Quantal):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers