[FFe] Sync libpano13-1 (universe) from Debian unstable (main)

Bug #440177 reported by Artur Rona on 2009-10-01
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libpano13 (Ubuntu)
Wishlist
Unassigned

Bug Description

It's needed by hugin 0.8.0 which is planned sync to karmic. libpano13 2.9.14 has got some small upstream bug fixes. It built fine on my-ppa.
https://launchpad.net/~ari-tczew/+archive/ppa/+build/1270421/+files/buildlog_ubuntu-karmic-i386.libpano13_2.9.14-2~ppa0_FULLYBUILT.txt.gz

libpano13 (2.9.14-2) unstable; urgency=low

   * Stop shipping la file in -dev package. (Squeeze release goal).
   * debian/patches/20_libpano13+kbsd.diff - Fix FTBFS on GNU/kFreeBSD. Patch
     by Cyril Brulebois. Closes: #543998

 -- Andreas Metzler <email address hidden> Sat, 29 Aug 2009 14:36:20 +0200
libpano13 (2.9.14-1) unstable; urgency=low

   * Upload to unstable.
   * [Lintian] Fix typo in debian control: s/algorithmical/algorithmic/.
   * Standards-Version: 3.8.2, no changes required.
   * Improve on watchfile to handle rc and beta versions.

 -- Andreas Metzler <email address hidden> Sun, 09 Aug 2009 14:01:24 +0200
libpano13 (2.9.14~rc1-1) experimental; urgency=low

   * New upstream prerelease.
     + New soname due to ABI breakage (new member in public struct). Change
       package name of library package.
     + Does not contain non-free files PixMap.c PixMap.h, no need for .dfsg
       version anymore. Also does away with the need for a complex
       get-orig-source
       target.
     + debian/manpages/* now shipped in upstream-tarball. Adapt build-system
       accordingly.
   * [lintian] Add ${misc:Depends}.
   * Standards version 3.8.1.
     + [debian/control] Add Homepage field.
     + Add rudimentary debian/README.source, basically pointing to quilt
       documentation.

 -- Andreas Metzler <email address hidden> Sun, 03 May 2009 19:56:34 +0200

Related branches

Artur Rona (ari-tczew) on 2009-10-01
summary: - [FFe] Sync libpano13 (universe) from Debian unstable (main)
+ [FFe] Sync libpano13-1 (universe) from Debian unstable (main)
description: updated
tags: added: sync upgrade
description: updated
Fabrice Coutadeur (fabricesp) wrote :

Hi,

As ABI has changed, you should follow the full FFe process (described at https://wiki.ubuntu.com/FreezeExceptionProcess ) and provided all the information required.

If the FFe get approved, subscribe then ubuntu-universe-sponsors.

Thanks,
Fabrice

Changed in libpano13 (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
Artur Rona (ari-tczew) wrote :

Changes from 2.9.12 to 2.9.14.

StefanPotyra (sistpoty) wrote :

imho this make only sence in conjuction with a new hugin release (bug #439396). Subscribing motu-release for that bug as well.

Artur Rona (ari-tczew) on 2009-10-03
Changed in libpano13 (Ubuntu):
status: Incomplete → New
StefanPotyra (sistpoty) wrote :

If hugin get's in this looks like a non-brainer to me (only hugin as rdepends). So +1 given that hugin is accepted.

Darxus (darxus) wrote :
Scott Kitterman (kitterman) wrote :

Ack #2 confirmed for FFe

Artur Rona (ari-tczew) on 2009-10-05
Changed in libpano13 (Ubuntu):
status: New → Confirmed
Fabrice Coutadeur (fabricesp) wrote :

sync request ACK'd

Changed in libpano13 (Ubuntu):
assignee: nobody → fabrice_sp (fabricesp)
status: Confirmed → In Progress
assignee: fabrice_sp (fabricesp) → nobody
status: In Progress → Confirmed
Scott Kitterman (kitterman) wrote :

Sync'ed.

Changed in libpano13 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments