[FFe] Merge hugin 0.8.0.dfsg-2 (universe) from Debian unstable (main)

Bug #439396 reported by Artur Rona on 2009-09-30
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
hugin (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: hugin

Hugin is out-of-dated and needs updating. For more details see bug #405234
0.8.0 needs to build libpano13 2.9.14, requested already - see bug #440177
So for the first step please sync libpano from Debian unstable, then hugin.

 hugin (0.8.0.dfsg-2) unstable; urgency=low

   * Upload to unstable.
   * Use dversionmangle in watchfile.

 -- Andreas Metzler <email address hidden> Wed, 09 Sep 2009 20:11:43 +0200
hugin (0.8.0.dfsg-1) experimental; urgency=low

   [ Andreas Metzler ]
   * New upstream version. Closes: #537542
     + Uses correct default value for enfuse/enblend if the option is not
       already saved. Closes: #504296
   * [lintian] Stop invoking dh_desktop.
   * Standards-Version 3.8.2, no changes required.
   * Add minimal manpage for matchpoint.
   * Add get-orig-source target to debian/rules
   * Add minimal README.source.

   [ Cyril Brulebois ]
   * debian/watch: Follow upstream's move from bz2 to gz for the tarballs,
     thanks to Fabrice Coutadeur (Closes: #539243). Finally support both
     extensions, just to make sure.

 -- Andreas Metzler <email address hidden> Sun, 06 Sep 2009 11:33:55 +0200

Related branches

Artur Rona (ari-tczew) wrote :

Now package needs more tests, not yet sync.

Changed in hugin (Ubuntu):
status: New → Incomplete

We needs wait for 2009.2.0 (stable version) in Debian.

description: updated
summary: - [FFe] Sync hugin 0.8.0.dfsg-2 (universe) from Debian unstable (main)
+ [FFe] Sync hugin 2009.2.0+dfsg~rc1-1 (universe) from Debian unstable
+ (main)
tags: added: sync upgrade
removed: apport-bug i386
Artur Rona (ari-tczew) wrote :

Hugin 2009.2.0 has got too big changes, so it's not for karmic in FFe. Back request to hugin 0.8.0 because it's stable release.

summary: - [FFe] Sync hugin 2009.2.0+dfsg~rc1-1 (universe) from Debian unstable
- (main)
+ [FFe] Sync hugin 0.8.0.dfsg-2 (universe) from Debian unstable (main)
Artur Rona (ari-tczew) on 2009-10-01
description: updated

Changes from 0.7.0 to 0.8.0.

Darxus (darxus) wrote :

I tested the packages from Artur Rona's ppa under an up to date karmic install. They work beautifully. The packages were:

hugin-tools 0.8.0.dfsg-2~ppa0 [3,051kB]
hugin-data 0.8.0.dfsg-2~ppa0 [8,248kB]
libpano13-1 2.9.14-2~ppa0 [207kB]
hugin 0.8.0.dfsg-2~ppa0 [1,201kB]

And for anybody else who wants to test them, all you have to do is add this line to your /etc/apt/sources.list:

deb http://ppa.launchpad.net/ari-tczew/ppa/ubuntu karmic main

And run "aptitude update && aptitude install hugin".

Be sure to remove that new line from your sources.list afterward so you don't accidentally install other development packages you don't want, and re-run aptitude update.

Darxus (darxus) wrote :

This sync requires four packages, hugin and three dependancies.

The md5sums of the packages I tested from Artur's ppa do *not* match debian unstable:

ppa:
da236f6fb64c207a7b21e1ea92970298 hugin_0.8.0.dfsg-2~ppa0_i386.deb
ff839ff9d471d0a71fecc3e4a7a7a325 hugin-tools_0.8.0.dfsg-2~ppa0_i386.deb
48b9074544753e359a90fb108a20be6f hugin-data_0.8.0.dfsg-2~ppa0_all.deb
600011c9edc21477f664fd67b2e28cc3 libpano13-1_2.9.14-2~ppa0_i386.deb

debian unstable:
543b1eb7fd3250db25b25a5c6126fcc6 hugin_0.8.0.dfsg-2_i386.deb
6547d7a2b09383332a9aae42f7447a3f hugin-tools_0.8.0.dfsg-2_i386.deb
a80b7d9b80c8d549a686a1735227da6d hugin-data_0.8.0.dfsg-2_all.deb
f344ad93271e9a0c73cb695e5d5e53a2 libpano13-bin_2.9.14-2_i386.deb

Artur: Why did you ask me to test your ppa instead of debian unstable, and why don't the md5s match?

Artur Rona (ari-tczew) wrote :

Because it's procedure. Changed only debian/changelog. PPA because packages are compiled for karmic.
Thanks a lot for test and your time!
Waiting for MOTU ACK...

Changed in hugin (Ubuntu):
status: Incomplete → New
Darxus (darxus) wrote :

Okay, thanks. I'll stop trying to test the debian unstable packages now.

StefanPotyra (sistpoty) wrote :

@Darxus, thanks for testing. The md5sums of the *deb* files cannot match, since these were rebuilt with the ubuntu toolchain. The md5sum of the orig.tar.gz however should match (and it does). It's important to test the packages as compiled with the Ubuntu toolchain, since a different compiler version (we have 4.4, debian's default is 4.3) can produce different code (I've seen a breakage there recently).

Artur Rona (ari-tczew) wrote :

StefanPotyra, is there ACK from you?

Artur Rona (ari-tczew) wrote :

Ah, I forget about libpano... libpano13-1 first.

StefanPotyra (sistpoty) wrote :

No, that wasn't an ACK yet (as I didn't look deeply at hugin yet).

I'm ok with bringing the new hugin in. +1 from me.

Darxus (darxus) wrote :

Merged hugin.
Uploaded to my ppa:
deb http://ppa.launchpad.net/darxus/hugin-0.8.0/ubuntu karmic main

debdiffs attached.

I tested one stitch. No problems.

Darxus (darxus) wrote :

This *will* require syncing libpano from sid:
libpano13-dev (build dep)
libpano13-1
libpano13-bin

I don't know the right way to get those into my ppa.

Darxus (darxus) wrote :

Removed a couple files I accidentally added.

Darxus (darxus) wrote :

hugin_0.8.0.dfsg-2ubuntu2 in my ppa matches the last pair of debdiffs. Couldn't upload with the same version.

Darxus (darxus) on 2009-10-04
summary: - [FFe] Sync hugin 0.8.0.dfsg-2 (universe) from Debian unstable (main)
+ [FFe] Merge hugin 0.8.0.dfsg-2 (universe) from Debian unstable (main)
Fabrice Coutadeur (fabricesp) wrote :

Hi Darxus,

And thanks to work on this! :-)

Your debdiff with Debian is way too big: it should only contain debian files, as there is a patch system, and here, you have translation, changes in source, ...
I think you should begin again with a clean working environment (the Debian 0.8.0 version), and apply the changes manually: they are not so many.
Also, in the changelog, please respect the format of the others merge, and remember to close the LP bug, and I think you can delete the 52_... patch.

Thanks!
Fabrice

Changed in hugin (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Artur Rona (ari-tczew) on 2009-10-04
Changed in hugin (Ubuntu):
assignee: nobody → Artur Rona (ari-tczew)
status: Incomplete → In Progress
Artur Rona (ari-tczew) wrote :

I'll take fix this merge, so please someone else not working on this.

Artur Rona (ari-tczew) wrote :
Artur Rona (ari-tczew) wrote :
Artur Rona (ari-tczew) wrote :
Darxus (darxus) wrote :

Tested stitching two images together with the three debs Artur just attached, worked beautifully.

I also have these packages installed:
libpano13-1 2.9.14-2
libpano13-bin 2.9.12.dfsg-2
libpano13-dev 2.9.14-2

Artur Rona (ari-tczew) wrote :
Changed in hugin (Ubuntu):
assignee: Artur Rona (ari-tczew) → nobody
status: In Progress → New
Darxus (darxus) on 2009-10-04
Changed in hugin (Ubuntu):
status: New → Confirmed
Artur Rona (ari-tczew) wrote :

Waiting for review by developers...

Changed in hugin (Ubuntu):
status: Confirmed → New
Artur Rona (ari-tczew) wrote :
Fabrice Coutadeur (fabricesp) wrote :

Hi,

I've been able to create a panorama with the assistant, so it seems safe to do the merge.
Waiting for the second motu-release ack to upload.

Thanks both for your work,
Fabrice

Scott Kitterman (kitterman) wrote :

Ack from me too. Approved.

Changed in hugin (Ubuntu):
status: New → Confirmed
Changed in hugin (Ubuntu):
assignee: nobody → fabrice_sp (fabricesp)
status: Confirmed → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Uploaded.
Thanks for your contributions to both of you :-)

Fabrice

Changed in hugin (Ubuntu):
assignee: fabrice_sp (fabricesp) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hugin - 0.8.0.dfsg-2ubuntu1

---------------
hugin (0.8.0.dfsg-2ubuntu1) karmic; urgency=low

  [ Darxus ]
  * Merge from Debian unstable, remaining changes (LP: #439396):
    - Depends on autopano-sift

  [ Artur Rona ]
  * debian/patches/51_ubuntu-autopano-sift:
    - Add refreshed patch to fix default config

 -- Artur Rona <email address hidden> Sun, 04 Oct 2009 19:34:01 +0200

Changed in hugin (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers