Comment 56 for bug 1511735

Saji Nediyanchath (saji89) wrote :

Looks like the fix is in place, I had downloaded the following packages manually from packages.ubuntu.com, trusty-updates:

- libnl-3-200_3.2.21-1ubuntu1.1_amd64.deb
- libnl-genl-3-200_3.2.21-1ubuntu1.1_amd64.deb
- libnl-route-3-200_3.2.21-1ubuntu1.1_amd64.deb

Has to install it using sudo dpkg -i, as Ubuntu software center was not allowing it due to the dependency relation between these packages. Anyhow after installing these packages and doing a
sudo service network-manager restart

enabled my network manager, previously with the broken packages, it was resulting in network-manager crashing, if I tried to restart the service, but after these packages were installed the network-manager worked normally.

Though technically a apt-get upgrade and reboot should work, it won't work; as without the network-manager there is no easy way to connect to the internet, so for most users they'll have to download the packages manually and install like I had to do.