weather.noaa.gov was shut down - MATE unable to retrieve weather forecasts

Bug #1616533 reported by Jeremy Bicha on 2016-08-24
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
libmateweather (Ubuntu)
High
Martin Wimpress
Trusty
Undecided
Unassigned
Xenial
High
Martin Wimpress

Bug Description

The provider which libmateweather was using was shut down in August.

We need to update libmateweather in Xenial to new upstream micro release, 1.12.2, which switched to a new METAR data provider.

Impact: this affects all libmateweather-using applications, makes them unable to retrieve weather data.

Test Case: make sure Weather applet in mate-applets is able to display weather information.

Jeremy Bicha (jbicha) on 2016-08-24
Changed in gnome-weather (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: trusty xenial yakkety
Jeremy Bicha (jbicha) on 2016-08-24
tags: added: iso-testing
Changed in libgweather:
importance: Unknown → High
status: Unknown → Confirmed
Changed in libmateweather (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in libmateweather (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in libmateweather (Ubuntu):
status: Triaged → Fix Committed
Changed in libmateweather (Ubuntu Xenial):
milestone: none → xenial-updates
Vlad Orlov (monsta) wrote :

For libmateweather, issue is fixed in 1.14.1, but I think I'll apply the patch from https://bugzilla.gnome.org/770321 (by Frank Dana) as well. It enables https and switches to the recommended method of data retrieval (as described in http://www.aviationweather.gov/dataserver/bestpractices).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-weather (Ubuntu Xenial):
status: New → Confirmed
Changed in libgweather (Ubuntu Xenial):
status: New → Confirmed
tags: added: precise
Vlad Orlov (monsta) wrote :

Ok, Frank's patch is in libgweather 3.18.2 & 3.20.3 and in libmateweather 1.14.1 now.

Vlad Orlov (monsta) wrote :

Oops... libmateweather 1.14.2 of course.

Changed in libgweather:
status: Confirmed → Fix Released
Changed in gnome-weather (Ubuntu Xenial):
importance: Undecided → High
Changed in libgweather (Ubuntu Xenial):
importance: Undecided → High
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package libgweather - 3.20.3-1

---------------
libgweather (3.20.3-1) unstable; urgency=medium

  * New upstream release.

 -- Andreas Henriksson <email address hidden> Wed, 31 Aug 2016 18:08:49 +0200

Changed in libgweather (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) on 2016-09-01
no longer affects: gnome-weather (Ubuntu)
no longer affects: gnome-weather (Ubuntu Xenial)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmateweather - 1.14.1-1

---------------
libmateweather (1.14.1-1) unstable; urgency=high

  [ Martin Wimpress ]
  * New upstream release. (LP: #1616533).
  * debian/copyright:
    + Update copyright attributions.
  * debian/changelog:
    + Update urgency to high.

  [ Mike Gabriel ]
  * debian/control:
    + Bump Standards: to 3.9.8. No changes needed.

  [ Vangelis Mouhtsis ]
  * debian/{control,rules}:
    + dbgsym: Don't build dbg:packages anymore.
      See https://wiki.debian.org/AutomaticDebugPackages.

 -- Mike Gabriel <email address hidden> Thu, 25 Aug 2016 12:57:42 +0200

Changed in libmateweather (Ubuntu):
status: Fix Committed → Fix Released
Dmitry Shachnev (mitya57) wrote :

I have uploaded a fix to SRU queue, but unfortunately I did not notice this bug, so I filed a new one: bug 1620557.

Martin Wimpress (flexiondotorg) wrote :

I've just released libmateweather 1.12.2 upstream. The only change is the inclusion of the following patch:

  * http://paste.ubuntu.com/23149947/

summary: - "Forecast not available" error in GNOME Weather app
+ weather.noaa.gov was shut down - MATE unable to retrieve weather
+ forecasts
no longer affects: libgweather (Ubuntu)
no longer affects: libgweather (Ubuntu Xenial)
Jeremy Bicha (jbicha) wrote :

Hi, apologies to the bug subscribers but we're going to use this bug to track the libmateweather SRU and use 1620557 to track the libgweather (and GNOME Weather fix) SRU.

This is because the verification for the two packages is different even though the patches are very similar and the SRU was already started for libgweather in bug 1620557.

As discussed in #ubuntu-devel with jbicha on September 8th @ 15:22:18, I am adopting this bug specifically to SRU libmateweather since libgweather has now ben SRU'd against #1620557.

<flexiondotorg> jbicha, How to proceed with SRUs for libgweather and libmateweather?
<jbicha> flexiondotorg: yes, the libgweather xenial sru is already in the unapproved queue
<flexiondotorg> OK, So no problem for me to remove libgweather from #1616533 then?
<jbicha> flexiondotorg: sure, go ahead
<flexiondotorg> jbicha, Thanks.

tags: removed: precise trusty
description: updated

Hello Jeremy, or anyone else affected,

Accepted libmateweather into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libmateweather/1.12.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libmateweather (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
affects: libgweather → ubuntu-translations
Changed in ubuntu-translations:
importance: High → Undecided
status: Fix Released → New
no longer affects: ubuntu-translations
Mathew Hodson (mathew-hodson) wrote :

I assume this also affects libmateweather on Trusty, but I don't know how possible an SRU would be.

tags: added: trusty
Jeremy Bicha (jbicha) on 2016-09-09
Changed in libmateweather (Ubuntu Trusty):
importance: Undecided → High
status: New → Triaged
tags: added: verification-done
removed: verification-needed

I've tested Ubuntu MATE 16.04.1 with rc-proposed. Weather applets now function correctly.

I'm removing Trusty from the affected versions.

MATE Desktop in Trusty is incomplete, due to the fact no one in the Ubuntu community was supporting it at that time and not all the MATE packages made it into the Ubuntu archive prior to feature freeze. For example, Caja is missing in Trusty, which is a critical component and MATE can't function without it.

Changed in libmateweather (Ubuntu Trusty):
status: Triaged → Won't Fix
importance: High → Undecided
tags: removed: trusty
Vlad Orlov (monsta) wrote :

These packages should be removed from Trusty repos then. That is, if that's allowed to do for the repos of stable releases.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmateweather - 1.12.2-0ubuntu1

---------------
libmateweather (1.12.2-0ubuntu1) xenial; urgency=high

  * New upstream release. (LP: #1616533)

 -- Martin Wimpress <email address hidden> Thu, 08 Sep 2016 13:48:25 +0100

Changed in libmateweather (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libmateweather has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers