libio-socket-ssl-perl: FTBFS: Test failures

Bug #20235 reported by Debian Bug Importer
4
Affects Status Importance Assigned to Milestone
libio-socket-ssl-perl (Debian)
Fix Released
Unknown
libio-socket-ssl-perl (Ubuntu)
High
Adam Conrad

Bug Description

Automatically imported from Debian bug report #324590 http://bugs.debian.org/324590

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #324590 http://bugs.debian.org/324590

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 22 Aug 2005 14:26:09 -0700
From: Daniel Schepler <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: libio-socket-ssl-perl: FTBFS: Test failures

Package: libio-socket-ssl-perl
Severity: serious
Version: 0.97-1

From my build log (reproduced using pbuilder in an i386 chroot):

...
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01loadmodule.....ok
t/02settings.......Use of uninitialized value in getprotobynumber at /usr/share/perl/5.8/IO/Socket/INET.pm line 133.
Use of uninitialized value in socket at /usr/lib/perl/5.8/IO/Socket.pm line 80.
Use of uninitialized value in socket at /usr/lib/perl/5.8/IO/Socket.pm line 80.
FAILED--Further testing stopped: Setup of test IO::Socket::INET server failed: Socket type not supported. All the rest of the tests in this suite will fail also unless you change the values in ssl_settings.req in the t/ directory.
make[1]: *** [test_dynamic] Error 255
make[1]: Leaving directory `/tmp/buildd/libio-socket-ssl-perl-0.97'
make: *** [install-stamp] Error 2

If I add netbase to the Build-Depends, the package builds fine.

-- System Information:
Debian Release: testing/unstable
Architecture: amd64 (x86_64)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-1-amd64-k8
Locale: LANG=en, LC_CTYPE=en (charmap=UTF-8) (ignored: LC_ALL set to en_US.UTF-8)

--
Daniel Schepler "Please don't disillusion me. I
<email address hidden> haven't had breakfast yet."
                                 -- Orson Scott Card

Revision history for this message
In , Florian Ragwitz (florian-ragwitz) wrote :

Hello Daniel,

I just created a new chroot using pbuilder and I see that netbase is
installed by default. Why isn't it in your chroot?

Anyway, the package producing the warning is IO::Socket which calls
getprotobyname, a perl builtin, which returns undef is netbase isn't
installed. So I think perl or at least IO::Socket should depend on it,
shoudn't it?

Regards,
Flo

--
BOFH excuse #46:
waste water tank overflowed onto computer

Revision history for this message
In , Florian Ragwitz (florian-ragwitz) wrote :

Hello,

you haven't replied to my mail for a while, so I asked some people on
#debian-mentors if they can reproduce the bug. They couldn't. So as
3 persons with a newly created pbuilder chroot can't reproduce it I
close this bug now. Feel free to reopen it if I missed something.

Regards,
Flo

--
BOFH excuse #357:
I'd love to help you -- it's just that the Boss won't let me near the
computer.

Revision history for this message
Fabio Massimo Di Nitto (fabbione) wrote :

breezy is not affected. we have an older upstream version.

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 26 Aug 2005 17:32:49 +0200
From: Florian Ragwitz <email address hidden>
To: <email address hidden>
Subject: libio-socket-ssl-perl: FTBFS: Test failures

--9amGYk9869ThD9tj
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hello Daniel,

I just created a new chroot using pbuilder and I see that netbase is
installed by default. Why isn't it in your chroot?

Anyway, the package producing the warning is IO::Socket which calls
getprotobyname, a perl builtin, which returns undef is netbase isn't
installed. So I think perl or at least IO::Socket should depend on it,
shoudn't it?

Regards,
Flo

--=20
BOFH excuse #46:
waste water tank overflowed onto computer

--9amGYk9869ThD9tj
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFDDzYgdC8qQo5jWl4RAgVrAKCD0CQqvrIu62RkMjekvw1QEvFJMQCghh6V
4hWsBOv9LMiYxBgLiU3o2oE=
=W01P
-----END PGP SIGNATURE-----

--9amGYk9869ThD9tj--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 30 Aug 2005 00:57:02 +0200
From: Florian Ragwitz <email address hidden>
To: <email address hidden>
Subject: libio-socket-ssl-perl: FTBFS: Test failures

--i9LlY+UWpKt15+FH
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hello,

you haven't replied to my mail for a while, so I asked some people on
#debian-mentors if they can reproduce the bug. They couldn't. So as
3 persons with a newly created pbuilder chroot can't reproduce it I
close this bug now. Feel free to reopen it if I missed something.

Regards,
Flo

--=20
BOFH excuse #357:
I'd love to help you -- it's just that the Boss won't let me near the
computer.=20

--i9LlY+UWpKt15+FH
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFDE5K+dC8qQo5jWl4RAr2ZAJ44miA64jHEV2jM37zYQU35Xp5ihACdFsQk
bMih19h2kmTPIawo75XpTts=
=OoK0
-----END PGP SIGNATURE-----

--i9LlY+UWpKt15+FH--

Revision history for this message
In , Niko Tyni (ntyni) wrote :

reopen 324590
thanks

Hi,

this bug (libio-socket-ssl-perl FTBFS due to /etc/protocols missing
from a pbuilder chroot) can be reproduced in a newly created chroot of
a 'buildd' or 'minimal' flavour:

pbuilder create --debootstrapopts --flavour=buildd [...]

These chroots don't contain netbase, because it's neither essential nor
build-essential, and not a dependency of them either. Thus it should be
in Build-Depends.

I suppose another proper fix would be for perl-base to depend on
netbase, as its IO::Socket::INET needs /etc/protocols for the default
value of 'proto'. OTOH, people could use IO::Socket::INET without
netbase by explicitly supplying the protocol by number...

I'm CCing the 2-year old perl bug #185244 about this.

(Another missing build-dependency for libio-socket-ssl-perl
seems to be makedev, which is needed for /dev/random but
is missing from the minimal and buildd chroots too.)

Cheers,
--
Niko Tyni <email address hidden>

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 30 Sep 2005 01:07:48 +0300
From: Niko Tyni <email address hidden>
To: <email address hidden>
Cc: <email address hidden>
Subject: Re: libio-socket-ssl-perl: FTBFS: Test failures

reopen 324590
thanks

Hi,

this bug (libio-socket-ssl-perl FTBFS due to /etc/protocols missing
from a pbuilder chroot) can be reproduced in a newly created chroot of
a 'buildd' or 'minimal' flavour:

pbuilder create --debootstrapopts --flavour=buildd [...]

These chroots don't contain netbase, because it's neither essential nor
build-essential, and not a dependency of them either. Thus it should be
in Build-Depends.

I suppose another proper fix would be for perl-base to depend on
netbase, as its IO::Socket::INET needs /etc/protocols for the default
value of 'proto'. OTOH, people could use IO::Socket::INET without
netbase by explicitly supplying the protocol by number...

I'm CCing the 2-year old perl bug #185244 about this.

(Another missing build-dependency for libio-socket-ssl-perl
seems to be makedev, which is needed for /dev/random but
is missing from the minimal and buildd chroots too.)

Cheers,
--
Niko Tyni <email address hidden>

Revision history for this message
In , Blars Blarson (blarson) wrote : now has other test problems

Looking into this for a potiential NMU, I found adding netbase was not
sufficient. It appears that this package is not compatable with the
current perl in unstable.

/usr/bin/make test
make[1]: Entering directory `/tmp/buildd/libio-socket-ssl-perl-0.97'
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01loadmodule.....^M ^Mt/01loadmodule.....ok 1/4^M
                                            ^Mt/01loadmodule.....ok
t/02settings.......^M ^Mt/02settings.......ok 1/1^M ^Mt/02settings.......ok
t/compatibility....^M ^Mt/compatibility....ok 1/9^M ^Mt/compatibility....NOK 2^M ^Mt/compatibility....NOK 3Can't locate object method "issuer_name" via package "IO::Socket::INET" at t/compatibility.t line 49.
^M
^Mt/compatibility....NOK 4^M ^Mt/compatibility....FAILED tests 2-4, 7-9
        Failed 6/9 tests, 33.33% okay
t/core.............^M ^Mt/core.............ok 1/53^M ^Mt/core.............NOK 8^M ^Mt/core.............NOK 9^M ^Mt/core.............FAILED tests 8-53
        Failed 46/53 tests, 13.21% okay
t/sessions.........skipped
        all skipped: Net::SSLeay version less than 1.26
Failed Test Stat Wstat Total Fail Failed List of Failed
-------------------------------------------------------------------------------
t/compatibility.t 9 6 66.67% 2-4 7-9
t/core.t 53 46 86.79% 8-53
1 test skipped.
Failed 2/5 test scripts, 60.00% okay. 52/67 subtests failed, 22.39% okay.
make[1]: *** [test_dynamic] Error 255

Revision history for this message
In , Florian Ragwitz (rafl) wrote : Re: Bug#324590: now has other test problems

On Fri, Jan 13, 2006 at 09:36:40PM -0800, Blars Blarson wrote:
> Looking into this for a potiential NMU, I found adding netbase was not
> sufficient. It appears that this package is not compatable with the
> current perl in unstable.

Yes. I'm already aware of that. It's caused by either openssl or
libnet-ssleay-perl, which I also maintain in Debian and upstream.

libnet-ssleay-perl linked against openssl 0.9.7 works fine. Linked
against 0.9.8 it breaks with the above messages. I tried to debug it a
but and turned tracing in Net::SSLeay on. The error message you'll get
is pretty confusing and you can find it in various places on the net as
an unresolved issue with openssl.

Regards,
Flo

--
BOFH excuse #2:
solar flares

Revision history for this message
In , Florian Ragwitz (rafl) wrote :

tag 324590 +pending
thanks

The problem has been caused by openssl and should be fixed with the next
upload tomorrow. I'll upload a new libio-socket-ssl-perl version after
the new openssl upload is in sid.

-Flo

--
BOFH excuse #440:
Cache miss - please take better aim next time

Revision history for this message
In , Florian Ragwitz (rafl) wrote : Bug#324590: fixed in libio-socket-ssl-perl 0.97-2

Source: libio-socket-ssl-perl
Source-Version: 0.97-2

We believe that the bug you reported is fixed in the latest version of
libio-socket-ssl-perl, which is due to be installed in the Debian FTP archive:

libio-socket-ssl-perl_0.97-2.diff.gz
  to pool/main/libi/libio-socket-ssl-perl/libio-socket-ssl-perl_0.97-2.diff.gz
libio-socket-ssl-perl_0.97-2.dsc
  to pool/main/libi/libio-socket-ssl-perl/libio-socket-ssl-perl_0.97-2.dsc
libio-socket-ssl-perl_0.97-2_all.deb
  to pool/main/libi/libio-socket-ssl-perl/libio-socket-ssl-perl_0.97-2_all.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Florian Ragwitz <email address hidden> (supplier of updated libio-socket-ssl-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 8 Nov 2005 16:17:38 +0100
Source: libio-socket-ssl-perl
Binary: libio-socket-ssl-perl
Architecture: source all
Version: 0.97-2
Distribution: unstable
Urgency: low
Maintainer: Florian Ragwitz <email address hidden>
Changed-By: Florian Ragwitz <email address hidden>
Description:
 libio-socket-ssl-perl - Perl module implementing object oriented interface to SSL sockets
Closes: 324590
Changes:
 libio-socket-ssl-perl (0.97-2) unstable; urgency=low
 .
   * Added netbase to Build-Depends-Indep and Depends (Closes: #324590).
   * Changed Maintainer field to my new maintainer address.
Files:
 29f9ecfaa7201a84409a4e0d45ad2bc7 691 perl optional libio-socket-ssl-perl_0.97-2.dsc
 980d3a5afb871624180eb5843511cd3c 2436 perl optional libio-socket-ssl-perl_0.97-2.diff.gz
 05631e1fca3132627d248c4524b5f2c5 35848 perl optional libio-socket-ssl-perl_0.97-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFD0ooQdC8qQo5jWl4RAh0oAJ4ke8RGK4kVXQ/qOUdt/A1fiSb5JQCfcf+O
uPmHEerS6wvBUE/QJeCVXUA=
=PcrM
-----END PGP SIGNATURE-----

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.