Weather forecasts are incomplete/invalid for Montreal, Quebec, Canada

Bug #404616 reported by Philippe Gauthier on 2009-07-25
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libgweather
Fix Released
Low
libgweather (Ubuntu)
Low
Mathieu Trudel-Lapierre

Bug Description

The clock applet will display a sunny icon with "Unknown" weather when Montreal, Quebec, Canada is selected as a location. This seems to be caused by libgweather using a small automated weather station CWTA (McTavish) instead of the expected Trudeau Intl Airport station CYUL. I think libgweather is sorting the stations by distance from the entered coordinates, so a possible solution would be to change Montreal coordinates to the same ones as the Trudeau airport.

Changing the CWTA code for CYUL in gconf and restarting the panel will "fix" the weather display.

This is a excerpt of the Locations.xms database:

<city>
  <name>Montreal</name>
  <coordinates>45.500000 -73.583333</coordinates>
  <location>
    <name>McTavish Automated Reporting Station</name>
    <code>CWTA</code>
    <coordinates>45.500000 -73.583333</coordinates>
  </location>
  <location>
    <name>Pierre Elliot Trudeau International Airport</name>
    <code>CYUL</code>
    <radar>cxx</radar>
    <coordinates>45.466667 -73.750000</coordinates>
   </location>
</city>

Related branches

Apteryx (maxco) wrote :

This bug has been around since at least Ubuntu 9.04 and after an upgrade to Ubuntu 9.10, it still lives.
I confirm this bug.

@Philippe : Could you please tell me where is this "Locations.xms" file located? I tried a "find ~ -name Locations.xms" but it returned no result.

Thanks

That is /usr/share/libgweather/Locations.xml. Sorry for the typo.

Marking as confirmed as this was confirmed in post #1, and I could reproduce it.

Changed in libgweather (Ubuntu):
status: New → Confirmed
Changed in libgweather (Ubuntu):
assignee: nobody → Matt Trudel (mathieu-tl)

Confirming the fix from Matt's PPA package (version 2.28.0-1ubuntu2). Removing and adding back the weather applet, and selecting the location refreshes the choice of the weather station.

Changed in libgweather (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgweather - 2.28.0-1ubuntu2

---------------
libgweather (2.28.0-1ubuntu2) karmic; urgency=low

  * debian/patches/lp404616_default_station_for_montreal.patch: modify
    coordinates for Montreal, Quebec, in Locations.xml to change default
    weather station. (LP: #404616)

 -- Mathieu Trudel <email address hidden> Mon, 05 Oct 2009 12:03:48 -0400

Changed in libgweather (Ubuntu):
status: Fix Committed → Fix Released
Changed in libgweather:
status: Unknown → Confirmed
Changed in libgweather:
status: Confirmed → Fix Released
Changed in libgweather:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.