gvfs-mount doesn't always work. gvfsd-smb starts using 100% cpu.

Bug #530605 reported by DarrenShare on 2010-03-02
616
This bug affects 178 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Critical
dobey
desktopcouch
Critical
Chad Miller
gvfs
Invalid
High
desktopcouch (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
gvfs (Fedora)
Fix Released
Medium
gwibber (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
libgnome-keyring (Ubuntu)
High
Sebastien Bacher
Lucid
High
Sebastien Bacher
ubuntuone-client (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: gvfs

Trying to mount a samba share using "gvfs-mount smb://server/home". Works fine in Ubuntu 9.10. In the latest 10.04 alpha release this command just hangs about 75% of the time and gvfsd-smb starts using 100% CPU until killed. Once I kill the process I get a dialogue about the server not responding.

I have also tried using "gvfs-mount smb://server.local/home" and get the same results.

This is also reproducible using the menu Places | Connect to Server, but browsing directly to the share in Nautilus via the Network bookmark seems to work all the time.

The share I am connecting to is on a Debian server running samba and I have no problems connecting to this share in Windows or Ubuntu 9.10.

Description: Ubuntu lucid (development branch)
Release: 10.04

gvfs:
  Installed: 1.5.4-0ubuntu1
  Candidate: 1.5.4-0ubuntu1
  Version table:
 *** 1.5.4-0ubuntu1 0
        500 http://gb.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: i386
CheckboxSubmission: d6a9fb5d438b37af50efc2e4853fca15
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Tue Mar 2 11:11:29 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
NonfreeKernelModules: nvidia
Package: gvfs 1.5.4-0ubuntu1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic-pae
SourcePackage: gvfs
Uname: Linux 2.6.32-14-generic-pae i686

[EDIT] I forgot to mention, I can't find anything in any log file that would explain why this is happening.

Related branches

DarrenShare (darren-moorstreet) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gvfs (Ubuntu):
importance: Undecided → Low
Changed in gvfs (Ubuntu):
status: New → Triaged
axoin (axoin) wrote :

i can confirm that on 10.04 alpha 3

DarrenShare (darren-moorstreet) wrote :

Hey axion, can you also add your +1 to the bug on Bugzilla? The more the merrier (and the more attention it will get).

82 comments hidden view all 120 comments

Description of problem:
Not possible to see samba share in Nautilus.
Write smb: into location.
Then "Windows Network" appears in header. Wait over 10 seconds and then
error window comes.

Version-Release number of selected component (if applicable):
samba-3.5.1-58.fc13.x86_64
system-config-samba-1.2.86-1.fc13.noarch
samba-winbind-clients-3.5.1-58.fc13.x86_64
samba-common-3.5.1-58.fc13.x86_64

selinux-policy-3.7.11-1.fc13.noarch
libselinux-2.0.90-5.fc13.x86_64
libselinux-utils-2.0.90-5.fc13.x86_64
selinux-policy-targeted-3.7.11-1.fc13.noarch
libselinux-python-2.0.90-5.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open Nautilus and Ctrl+l
2. Write smb: into Lotstion
3. Wait over 10 seconds
and error window
The folder contents could not be displayed.

Actual results:
Error window
The folder contents could not be displayed.
Sorry, could not display all the contents of "Windows Network": DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Expected results:
To see enabeld samba shares
There is local sama share

Additional info:
Just rebooted to reapply selinux policy
There is no message in /var/log/messages
It is possible to see local samba share form another computer ( F12 )

Created attachment 399847
messages after settin selinux in permissive mode

When setting selinux in permissive mode then it possible to see local samba share
but not open it.

Can you check your firewall settings are not blocking samba client packetes ?

>Can you check your firewall settings are not blocking samba client packetes ?

samba and samba client are marked as trusted.
Fierwall disabled
The folder contents could not be displayed.
Sorry, could not display all the contents of "Windows Network": DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

no message i /var/log/messages

--------------------------------
If seleinux in permissive
Mar 13 18:15:25 flokic dbus: avc: received setenforce notice (enforcing=0)
Mar 13 18:15:25 flokic dbus: avc: received setenforce notice (enforcing=0)
Mar 13 18:15:25 flokic dbus: Can't send to audit system: USER_AVC avc: received setenforce notice (enforcing=0)#012: exe="?" sauid=81 hostname=? addr=? terminal=?

and error window
Unable to mount location
Sorry, could not display all the contents of "Windows Network": DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Sorry but this looks like a nautilus or gnome-vfs problem to me.

Reassigning.

85 comments hidden view all 120 comments
MichaelB (mrbou) wrote :

I have the same problem (Lucid Alpha 3). Work with share folder "without authentication" BUT fail with authentication (gvfsd-smb 100% cpu). I have only shared smb folder (NAS) with authentication.. I really hope this bug will be fixed for Lucid release.

86 comments hidden view all 120 comments

I see in top that gvfsd-smb-brows is with cpu over 90%

85 comments hidden view all 120 comments
Sebastien Bacher (seb128) wrote :

is that a duplicate of bug #532024?

Changed in gvfs (Ubuntu Lucid):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
DarrenShare (darren-moorstreet) wrote :

@Sebastien. It Seems to the same bug. This one was raised first though so technically it's a duplicate of this one ;)

I am concerned by the lack of official response to any of these bugs by the Gnome team. Given that mounting shares is pretty much gvfs' sole function you'd think they'd be looking at it by now. This is a total showstopper for me with regard to using Lucid.

85 comments hidden view all 120 comments

Can you please post you gvfs, gnome-keyring and libgnome-keyring package versions? Also, would it be possible to grab a backtrace and post it here? I'm not seeing this on my machine, though other people reported the same issue.

84 comments hidden view all 120 comments
Sebastien Bacher (seb128) wrote :

Could you try to get a stacktrace of gvfsd-smb while it's using cpu?

Thomas Poulsen (thomas-lha66) wrote :

I'm having the same problem as reported in Bug #536790.

A stacktrace of gvfsd-smb while it is using 100% CPU looks like the following:

$ pstack 5191

5191: /usr/lib/gvfs/gvfsd-smb --spawner :1.8 /org/gtk/gvfs/exec_spaw/8
(No symbols found)
0x0057d422: ???? (938d400, 7, ffffffff, 37dff4, 931add0, 37dff4)
0x0030539b: ???? (938d400, 7, ffffffff, 938d400, 7, bfb6ede4) + 60
0x002f7eff: ???? (1, 93123f0, 1, 0, 1, 804a914) + 30
0x002f861f: ???? (931b4c8, 0, 8066aab, 31fafe, 9311b40, 806a57c) + 50
0x080530ba: ???? (4, bfb6ef94, 1, 8066aab, 0, 8066aab) + 10
0x080533c6: ???? (4, bfb6ef94, bfb6efa8, b773d830, bfb6ef50, ffffffff) + 60
0x00c54bd6: ???? (8053370, 4, bfb6ef94, 8066570, 8066560, 45e0b0) + 40491078

The gvfsd-smb process was started by opening a bookmarked samba-share in
Nautilus.

84 comments hidden view all 120 comments

>Also, would it be possible to grab a backtrace and post it here?
I am not sure how do do this.
I will try

[floki@flokic ~]$ rpm -qa | grep gvfs
gvfs-fuse-1.5.5-1.fc13.x86_64
gvfs-fuse-1.5.3-2.fc13.x86_64
gvfs-obexftp-1.5.5-1.fc13.x86_64
gvfs-archive-1.5.5-1.fc13.x86_64
gvfs-obexftp-1.5.3-2.fc13.x86_64
gvfs-1.5.5-1.fc13.x86_64
gvfs-afc-1.5.5-1.fc13.x86_64
gvfs-gphoto2-1.5.5-1.fc13.x86_64
gvfs-1.5.3-2.fc13.x86_64
gvfs-smb-1.5.5-1.fc13.x86_64
[floki@flokic ~]$

[floki@flokic ~]$ rpm -qa | grep gnome-keyring
libgnome-keyring-2.29.4-4.fc13.x86_64
gnome-keyring-pam-2.29.92-1.fc13.x86_64
gnome-keyring-2.29.92-1.fc13.x86_64
[floki@flokic ~]$

Martin Pitt (pitti) on 2010-03-16
Changed in gvfs (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)

libgnome-keyring-2.29.92-git20100317.1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libgnome-keyring-2.29.92-git20100317.1.fc13

(In reply to comment #7)
> >Also, would it be possible to grab a backtrace and post it here?
> I am not sure how do do this.
> I will try
Please see http://fedoraproject.org/wiki/StackTraces#gdb, this wiki should provide you all information necessary.

> [floki@flokic ~]$ rpm -qa | grep gvfs
> gvfs-fuse-1.5.5-1.fc13.x86_64
> gvfs-fuse-1.5.3-2.fc13.x86_64
> gvfs-obexftp-1.5.5-1.fc13.x86_64
> gvfs-obexftp-1.5.3-2.fc13.x86_64
> gvfs-1.5.5-1.fc13.x86_64
> gvfs-1.5.3-2.fc13.x86_64
This is quite mess in your system. Be sure to run yum-complete-transaction or manually remove the old packages. It shouldn't make a difference though.

Also, I've built new libgnome-keyring snapshot, please test it. I still can't reproduce the problem on my machine.

85 comments hidden view all 120 comments
Geoffrey Pursell (geoffp) wrote :

I'm getting this when trying to load up a bookmark of an ssh server, which is a very common use case for me.

86 comments hidden view all 120 comments

I reinstalled F13 form live x86_64. updated and updated libgnome-keyring form kojoi.
I is possible to see samba share from F12 computer.
( off to shares one wans opend with gedit from nautilus when clicked ).
I sama was opend from nautilus using network and select windows share and giving local ipv4 number then samba share was seen and ok.
I have not yet given permanent password fore windows share.

Usung smb: was not possible.
I shaw gvfsd-smb-brows with high cpu.
I was statting to bactrace when f13 freaze.

85 comments hidden view all 120 comments

Stacktrace of gvfsd-smb:
1923: /usr/lib/gvfs/gvfsd-smb --spawner :1.6 /org/gtk/gvfs/exec_spaw/3
(No symbols found)
0x003d4422: ???? (93f81f0, 7, ffffffff, 587ff4, 93cbec0, 587ff4)
0x0050f32b: ???? (93f81f0, 7, ffffffff, 93f81f0, 7, bfff6794) + 60
0x00501e5c: ???? (1, 93c3978, 1, 0, 1, 804a914) + 30
0x005025c7: ???? (93cc5c8, 0, 8066aab, 5299ee, 93c33b8, 806a57c) + 50
0x080530ba: ???? (4, bfff6944, 1, 8066aab, 0, 8066aab) + 10
0x080533c6: ???? (4, bfff6944, bfff6958, b7798830, bfff6900, ffffffff) + 60
0x0059fbd6: ???? (8053370, 4, bfff6944, 8066570, 8066560, 3880b0) + 400096c8

danbuntu (danattwood) wrote :

I can confirm as well that I am seeing the same problem. 2 out of three of my gvfs share will mount though the 3rd won't. All three cause 100% cpu usage.

apinunt (apinunt) wrote :

I found that Samba was no longer installed, and after installing it everything now seems to work properly, and no high cpu usage.

84 comments hidden view all 120 comments

I am afraid that I will not be able to get backtrace.
The computer was freezing when I was trying. I have seen that also in chases not related to samba.
It might be related to hardware problem.

From upstream bug report it looks like dbus might be guilty for some problems, can you please post versions of your dbus and dbus-glib packages?

Also, I've built gnome-keyring-2.29.92-2.fc13 and libgnome-keyring-2.29.92-git20100322.1.fc13, can you give them a shot too?

Created attachment 401882
top rpm -q gdb try

Still same problem.
This is F13 fully updated.
I am not good at backtraces.

>versions of your dbus and dbus-glib packages?

[floki@flokic ~]$ rpm -qa | grep dbus
dbus-x11-1.2.22-1.fc13.x86_64
dbus-libs-1.2.22-1.fc13.x86_64
dbus-1.2.22-1.fc13.x86_64
eggdbus-0.6-2.fc13.x86_64
dbus-python-0.83.0-6.fc12.x86_64
dbus-glib-debuginfo-0.84-3.fc13.x86_64
dbus-c++-0.5.0-0.11.20090203git13281b3.fc13.x86_64
python-slip-dbus-0.2.8-1.fc13.noarch
dbus-debuginfo-1.2.22-1.fc13.x86_64
dbus-glib-0.84-3.fc13.x86_64
[floki@flokic ~]$

>Also, I've built gnome-keyring-2.29.92-2.fc13 and
>libgnome-keyring-2.29.92-git20100322.1.fc13, can you give them a shot too?
[
floki@flokic ~]$ rpm -qa | grep gnome-keyring
libgnome-keyring-2.29.92-git20100322.1.fc13.x86_64
libgnome-keyring-debuginfo-2.29.92-git20100317.1.fc13.x86_64
gnome-keyring-pam-2.29.92-2.fc13.x86_64
gnome-keyring-2.29.92-2.fc13.x86_64

floki@flokic ~]$ rpm -q libgnome-keyring
libgnome-keyring-2.29.92-git20100322.1.fc13.x86_64

Created attachment 401887
valgrind nautilus smb:

valgrind nautilus smb:

Oh, I should've mentioned that gvfsd-smb (or gvfsd-smb-browse) is the right process to debug, nautilus acts here just as a frontend. Sorry for that. Also see your comment 5.

If the process is still running, you can attach to it by doing `gdb /usr/libexec/gvfsd-smb-browse <PID>`. Entering "t a a bt" should give you the backtrace I'm looking for. Probably it would look like this: http://bugzilla-attachments.gnome.org/attachment.cgi?id=156584 hopefully with less number of question marks.

This works now.

libgnome-keyring-2.29.92-git20100317.1.fc13 has been pushed to the Fedora 13 stable repository. If problems still persist, please make note of it in this bug report.

*** Bug 576504 has been marked as a duplicate of this bug. ***

My stack:

(gdb) bt
#0 0x00007f5b97bfa283 in poll () from /lib64/libc.so.6
#1 0x00007f5b980e68f9 in ?? () from /lib64/libglib-2.0.so.0
#2 0x00007f5b980e70a5 in g_main_loop_run () from /lib64/libglib-2.0.so.0
#3 0x000000000040c0de in dbus_message_append_args ()
#4 0x000000000040c36c in dbus_message_append_args ()
#5 0x00007f5b97b3dd2d in __libc_start_main () from /lib64/libc.so.6
#6 0x0000000000407d49 in dbus_message_append_args ()
#7 0x00007fff58023728 in ?? ()
#8 0x000000000000001c in ?? ()
#9 0x0000000000000004 in ?? ()
#10 0x00007fff58023c0f in ?? ()
#11 0x00007fff58023c26 in ?? ()
#12 0x00007fff58023c30 in ?? ()
#13 0x00007fff58023c35 in ?? ()
#14 0x0000000000000000 in ?? ()
(gdb) t
[Current thread is 1 (Thread 0x7f5b9a3d77c0 (LWP 5950))]

-----------------------------------------------
rpm -q libgnome-keyring
libgnome-keyring-2.29.92-git20100322.1.fc13.x86_64

---------------------------------
top info:
5950 iranzo 20 0 273m 4972 3964 S 79.3 0.2 1:18.94 gvfsd-smb

Pablo, can you please install missing debuginfo packages and try catching a better backtrace? Please see http://fedoraproject.org/wiki/StackTraces, either way gdb should give you hint what's needed.

Download full text (9.8 KiB)

SMB connection is started choosing from Gnome's 'places' a bookmark with remembered password to connect.

stack trace doing gdb --pid=$PID, and then:
thread apply all bt full

---------------------------------------------------------------
Thread 2 (Thread 0x7fb0d0c5f710 (LWP 20557)):
#0 dbus_pending_call_block (pending=0x7fb0cc075cd0) at dbus-pending-call.c:703
        __FUNCTION__ = "dbus_pending_call_block"
#1 0x0000003b65408a03 in gkr_operation_block (op=0x7fb0cc078040) at gkr-operation.c:372
        __PRETTY_FUNCTION__ = "gkr_operation_block"
#2 0x000000000041b975 in g_vfs_keyring_lookup_password (username=0x1b5fa70 "nmt", host=0x1b5f3f0 "192.168.2.4", domain=0x0,
    protocol=<value optimized out>, object=0x0, authtype=<value optimized out>, port=0, username_out=0x7fb0d0c5e2e8, domain_out=0x7fb0d0c5e2e0,
    password_out=0x7fb0d0c5e2f0) at gvfskeyring.c:61
        pwd_data = 0x1b5fa70
        result = <value optimized out>
        plist = <value optimized out>
#3 0x00000000004098a0 in auth_callback (context=<value optimized out>, server_name=<value optimized out>, share_name=<value optimized out>,
    domain_out=0x7fb0d0c5e580 "MYGROUP", domainmaxlen=<value optimized out>, username_out=0x7fb0d0c5e480 "nmt", unmaxlen=256,
    password_out=0x7fb0d0c5e380 "", pwmaxlen=256) at gvfsbackendsmb.c:203
        in_keyring = 0
        backend = 0x1b5e020
        ask_password = <value optimized out>
        ask_user = <value optimized out>
        ask_domain = <value optimized out>
        handled = <value optimized out>
        abort = <value optimized out>
#4 0x00007fb0d755419a in SMBC_call_auth_fn (ctx=0x7fb0cc030ea0, context=<value optimized out>, server=<value optimized out>, share=<value optimized out>,
    pp_workgroup=0x7fb0d0c5ebe0, pp_username=0x7fb0d0c5ebf0, pp_password=0x7fb0d0c5ebe8) at libsmb/libsmb_server.c:115
        workgroup = "MYGROUP\000\200\071@S;\000\000\000\240MPװ\177\000\000`\226\327װ\177\000\000\250\001\000\000\001\000\000\000\377\377\377\377\000\000\000\000\005\000\000\000\000\000\000\000\005\000\000\000\000\000\000\000x`b", '\000' <repeats 13 times>"\360, .\a̰\177\000\000\220\067\a̰\177\000\000\000\000\000\000\000\000\000\000\341\345\200P;\000\000\000\005", '\000' <repeats 15 times>, "\005\000\000\000\260\177\000\000\240MPװ\177\000\000\030\350\305а\177\000\000\360.\a̰\177\000\000`/\a̰\177\000\000PG\a̰\177\000\000`/\a̰\177\000\000\245R\201P;\000\000\000p\224@\000\000\000\000\000PG\a̰\177\000\000`/\a̰\177\000\000\360.\a̰\177\000\000`[\a̰\177\000\000\220\067\a̰\177\000\000\360\353\305а\177\000\000\350 \242P;"...
        username = "nmt", '\000' <repeats 252 times>
        password = '\000' <repeats 255 times>
        auth_with_context_fn = <value optimized out>
#5 0x00007fb0d7554400 in SMBC_find_server (ctx=0x7fb0cc030ea0, context=0x7fb0cc075b60, server=0x7fb0cc072ef0 "192.168.2.4", share=0x7fb0cc072f60 "share",
    pp_workgroup=0x7fb0d0c5ebe0, pp_username=0x7fb0d0c5ebf0, pp_password=0x7fb0d0c5ebe8) at libsmb/libsmb_server.c:175
        srv = <value optimized out>
        auth_called = <value optimized out>
#6 0x00007fb0d75544ed in SMBC_server_internal (ctx=<value optimized out>, context=0x7fb0cc075b60, connect...

Great, thanks. While you are in the debugger, can you please add breakpoint on auth_callback and see how many times does it break? Use "c" to continue the running process after you set up the breakpoint by "break auth_callback".

The lock happens even with the target machine not responding to ping....

attempting connection with target IP powered off, gvfs started eating all cpu as usual.

gdb --pid=$PID
break auth_callback
c

just keep 'quiet' for a long period, after killing $PID it displays:

(gdb) break auth_callback
Breakpoint 1 at 0x409600: file gvfsbackendsmb.c, line 155.
(gdb) c
Continuing.

Program received signal SIGTERM, Terminated.
0x0000003b50cdb283 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
87 int result = INLINE_SYSCALL (poll, 3, CHECK_N (fds, nfds), nfds, timeout);

95 comments hidden view all 120 comments
Sebastien Bacher (seb128) wrote :

could somebody getting the issue get a stracktrace of gvfsd-smb while it's eating cpu

Sebastien Bacher (seb128) wrote :

Changing the settings, quite some users get the issue, could be due to gnome-keyring I emailed upstream about it now

Changed in gvfs (Ubuntu Lucid):
importance: Low → High
Martin Soto (soto255) wrote :

I already posted to Bug #532024 with my symptoms. I'm attaching a backtrace of the running gvfsd-smb process. It seems to hang while trying to contact gnome-keyring-daemon. I tried to make the backtrace as complete as possible symbol-wise, but let me know if I can provide more info. The issue is 100% reproducible here.

Martin Soto (soto255) wrote :

Here is a backtrace of gnome-keyring-daemon taken while the gvfsd-smb process was hanging. I don't see anything strange here, though.

Majestyx (majestyx) wrote :

no smb, no usb, but a (not really existent) fd0 ;)

Sebastien Bacher (seb128) wrote :

The issue is rather a libgnome-keyring one and there is a change to try on bugzilla.gnome.org now which I will upload to lucid today

affects: gvfs (Ubuntu Lucid) → libgnome-keyring (Ubuntu Lucid)
Changed in libgnome-keyring (Ubuntu Lucid):
assignee: Martin Pitt (pitti) → Sebastien Bacher (seb128)
Sebastien Bacher (seb128) wrote :

the lucid version has been updated with the change to try now, could the users having the issue update to this new version, restart their session and comment on the bug to say if that solves the issue or not

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnome-keyring - 2.29.4git20100322-0ubuntu3

---------------
libgnome-keyring (2.29.4git20100322-0ubuntu3) lucid; urgency=low

  * debian/patches/01_upstream_gvfsd_cpu_use.patch:
    - upstream change which could be solving the gvfsd eating cpu issue
      (lp: #530605)
 -- Sebastien Bacher <email address hidden> Mon, 29 Mar 2010 13:46:46 +0200

Changed in libgnome-keyring (Ubuntu Lucid):
status: Triaged → Fix Released

@Sebastien

I'm still waiting for the update to come through here. I'm still on libgnome-keyring version 2.29.4git20100322-0ubuntu2.

Jean-Philippe Fleury (jpfle) wrote :

Sebastien Bacher wrote:
>the lucid version has been updated with the change to try now,
>could the users having the issue update to this new version,
>restart their session and comment on the bug to say if that
>solves the issue or not

I updated to libgnome-keyring 2.29.4git20100322-0ubuntu3 and it fixed the problem. Thanks!

timosha (timosha) wrote :

The bug is not completely resolved with the latest libgnome-keyring. I can open one (1) password protected samba share and are prompted for username and password. When I select "remember" forever gvfsd-smb hangs with 100% CPU load when I try to open another password protected samba share.

When I delete the key in Seahorse the whole thing starts all over again. In noticed in Seahorse that the password is stored as "use: Saved password or login" in Ubuntu 9.10 the password is store as "Network Credential" with a network icon in front of the password.

Tested this on 3 machines: Thinkpad R51 & R52 and HP dx2400.

Sebastien Bacher (seb128) wrote :

the new comment could be an another issue, could you get a stracktrace from this one, let's see how it works for the issue other users were having before and open a new one about this bug if the update works for some users

Martin Soto (soto255) wrote :

In my case, the problem persists after the update. I'm attaching a backtrace. Unfortunately, the symbols are incomplete because the -dbgsym package for gvfs-backends hasn't been updated to the current version in Lucid (1.6.0). If nobody beats me to it, I'll upload an updated backtrace when the debugging symbols become available.

axoin (axoin) wrote :

 the patch doesn't do anything for the problems with s/ftp. Version libgnome-keyring0:
  Installiert: 2.29.4git20100322-0ubuntu3
  Kandidat: 2.29.4git20100322-0ubuntu3
gvfs
 Installiert: 1.6.0-0ubuntu

However, I cannot get any libgnome-keyring0-dbgsym so I can't make a new stacktrace.
I also took a look in seahorse like timosha and I have the same behaviour. Credentials are only stored as "password" and not as "network credentials".

Sebastien Bacher (seb128) wrote :

did you restart your session before trying?

timosha (timosha) wrote :

@Sebastien

I did not only restart the session on 3 machines, I rebooted them after the updates. The problem persists.

Changed in libgnome-keyring (Ubuntu Lucid):
status: Fix Released → Triaged
81 comments hidden view all 120 comments

Thanks, so it's stuck in there. Any chance you can try the libgnome-keyring patch posted at https://bugzilla.gnome.org/show_bug.cgi?id=613399#c2 ?

80 comments hidden view all 120 comments
Sebastien Bacher (seb128) wrote :

> I did not only restart the session on 3 machines, I rebooted them after the updates. The problem persists.

seems you have some easy way to trigger the issue, could you share the steps and describe your scenario there? it could be useful to get the issue worked. do you use autologin or not? does that make a difference? is your keyring unlocking when using the share? ie did you run an application using it (seahorse, empathy, ...) before triggering the bug? do you get the issue when browsing smb shares too or only when connecting to one? do you need to add the password to the keyring before? is the issue specific to smb shares or to gvfs locations?

81 comments hidden view all 120 comments

There's any RPM package to install that patch?

Thanks
Pablo

80 comments hidden view all 120 comments
timosha (timosha) wrote :

1) Delete all keys for smb and ftp shares in Seahorse;
2) Connect to password protected samba share #1 - You are prompted for a username and password - Enter username and password and click "remember forever" - Password protected share #1 opens now;
3) Connect to password protected samba share #2 - gvfsd-smb sleeps now with 100% CPU load;
4) Unmount password protected share #1 - reconnect to password protected share #1 - another gvfsd-smb hangs with 100% CPU load;
5) Kill the two (2) gvfsd-smb processes - Delete the password in Seahorse;
6) Go to step 1) and the scenario starts again;

Ditto for ftp, in that case gvsfd-ftp hangs/sleeps with 100% CPU load;

I do not use autologin, but will try that;
The keyring is probably not unlocking as I don't see the key icon in the taskbar;
The keyring works fine in providing a WEP key for WLAN at login;
The keyring works fine in providing credentials for aMSN;
The keyring DOES NOT WORK providing credentials for Ubuntuone;

This issue is typical for PASWORD PROTECTED smb shares, non protected shares mount fine. Ditto for ftp.

I entered the password for the keyring the first time I used it after installing Lucid. I was prompted for it;

81 comments hidden view all 120 comments

(In reply to comment #25)
> There's any RPM package to install that patch?
I've made testing scratch build, please grab the packages directly from koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=2082001

80 comments hidden view all 120 comments
timosha (timosha) wrote :

Another test:

On exactly the same machine, a Thinkpad R51 - 2887, I inserted an UltrayBay with Ubuntu 9.10 on the hdd. On this installation the problem does not occur. I upgraded this installation to Lucid 10.04. The problem does not occur after the upgrade. The keys in Seahorse are stored as "Network Credentials" with the particular network icon.

axoin (axoin) wrote :

sebastien, I described the same steps to reproduce already in Bug #538764 which you marked as duplicate.
timosha, I confirm the steps to reproduce and I may add that it is the same for sftp shares too.
However, my system is an upgraded 9.10 to 10.04 and it is a Thinkpad T43 and I am still expieriencing this bug.
I have also problems with ubuntuone-login
If there were -dbgsyms I could add another stacktrace, when will they be available?

Jean-Philippe Fleury (jpfle) wrote :

Ok, I still have the bug. Here's how I can reproduce it:

1) Delete all keys for FTP locations in Seahorse.

2) Connect to a FTP location that is protected by password. Enter the username and the password and choose to remember forever. The location opens well.

3) I can open multiple FTP locations as described in the step 2. There's no problem. All FTP locations open well.

4) Unmount all previously open FTP locations.

5) Try to open again a FTP location previously accessed on the steps 2 or 3.

Actual result: gvfsd-smb starts using 100% CPU.

79 comments hidden view all 120 comments

Hi

"libgnome-keyring-2.29.92-git20100322.2.fc13.i686" still presents the problem on x86, will test at home with x86_64

Regards
Pablo

78 comments hidden view all 120 comments
axoin (axoin) wrote :

gvfs Version 1.6.0-0ubuntu1
libgnome-keyring 2.29.4git20100322-0ubuntu3
New gdb backtrace

axoin (axoin) wrote :

sorry, wrong attachment see new with
    *

gvfs Version 1.6.0-0ubuntu1
libgnome-keyring 2.29.4git20100322-0ubuntu3
New gdb backtrace

78 comments hidden view all 120 comments

With x86_64, problem persists too

77 comments hidden view all 120 comments
timosha (timosha) wrote :

I made another observation:

I have an UbuntuOne Token in my keyring. When I open Ubuntuone the process "ubuntuone-login" sleeps with 100% CPU load until I kill the process.

Garazi (garazi111) wrote :

Issue is not repared for me.
Here is a backtrace.
Tell me what to do if it is not enough explicit.

Andrew Fenn (andrewfenn) wrote :

I upgraded just now and confirmed I had the latest packages described further up in the report. I rebooted then tested however I am still getting the same issues. The CPU maxes out the moment I try to connect to a samba share. This happens even if I delete the keys in seahorse.

Changed in desktopcouch (Ubuntu Lucid):
importance: Undecided → High
Changed in gwibber (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
Changed in desktopcouch (Ubuntu Lucid):
status: New → Triaged
dobey (dobey) on 2010-03-30
tags: added: u1-lucid
Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Critical
status: New → In Progress
dobey (dobey) on 2010-03-30
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in libgnome-keyring (Ubuntu Lucid):
status: Triaged → Fix Released
Changed in libgnome-keyring (Ubuntu Lucid):
status: Fix Released → Confirmed
Chad Miller (cmiller) on 2010-04-05
tags: added: desktop+
Chad Miller (cmiller) on 2010-04-05
Changed in desktopcouch:
assignee: nobody → Chad Miller (cmiller)
importance: Undecided → Critical
status: New → Confirmed
dobey (dobey) on 2010-04-05
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Changed in ubuntuone-client (Ubuntu Lucid):
status: New → Fix Released
Changed in libgnome-keyring (Ubuntu Lucid):
status: Confirmed → Fix Released
tags: added: package
Changed in desktopcouch:
milestone: none → lucid-final
tags: added: iso-testing
Changed in desktopcouch (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Martin Pitt (pitti) on 2010-04-09
Changed in desktopcouch (Ubuntu Lucid):
milestone: ubuntu-10.04 → none
status: Triaged → Invalid
Changed in gwibber (Ubuntu Lucid):
status: Triaged → Invalid
Changed in desktopcouch:
status: Confirmed → Invalid
76 comments hidden view all 120 comments

smbclient can connect and works ok while gvfsd-smb keeps using 100% of CPU until killed or a long timeout

Changed in desktopcouch (Ubuntu Lucid):
status: Invalid → Fix Released
Changed in gvfs:
status: Unknown → Invalid

libgnome-keyring-2.30.0-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libgnome-keyring-2.30.0-2.fc13

libgnome-keyring-2.30.0-2.fc13 has been pushed to the Fedora 13 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update libgnome-keyring'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libgnome-keyring-2.30.0-2.fc13

libgnome-keyring-2.30.0-2.fc13 has been pushed to the Fedora 13 stable repository. If problems still persist, please make note of it in this bug report.

38 comments hidden view all 120 comments

Me too
 > this bug affects me too
>
> --
> gvfs-mount doesn't always work. gvfsd-smb starts using 100% cpu.
> https://bugs.launchpad.net/bugs/530605
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Desktop CouchDB: Invalid
> Status in GVFS: Invalid
> Status in Ubuntu One Client: Fix Released
> Status in “desktopcouch” package in Ubuntu: Fix Released
> Status in “gwibber” package in Ubuntu: Invalid
> Status in “libgnome-keyring” package in Ubuntu: Fix Released
> Status in “ubuntuone-client” package in Ubuntu: Fix Released
> Status in “desktopcouch” source package in Lucid: Fix Released
> Status in “gwibber” source package in Lucid: Invalid
> Status in “libgnome-keyring” source package in Lucid: Fix Released
> Status in “ubuntuone-client” source package in Lucid: Fix Released
> Status in “gvfs” package in Fedora: Unknown
>
> Bug description:
> Binary package hint: gvfs
>
> Trying to mount a samba share using "gvfs-mount smb://server/home". Works
fine in Ubuntu 9.10. In the latest 10.04 alpha release this command just
hangs about 75% of the time and gvfsd-smb starts using 100% CPU until
killed. Once I kill the process I get a dialogue about the server not
responding.
>
> I have also tried using "gvfs-mount smb://server.local/home" and get the
same results.
>
> This is also reproducible using the menu Places | Connect to Server, but
browsing directly to the share in Nautilus via the Network bookmark seems to
work all the time.
>
> The share I am connecting to is on a Debian server running samba and I
have no problems connecting to this share in Windows or Ubuntu 9.10.
>
> Description: Ubuntu lucid (development branch)
> Release: 10.04
>
> gvfs:
> Installed: 1.5.4-0ubuntu1
> Candidate: 1.5.4-0ubuntu1
> Version table:
> *** 1.5.4-0ubuntu1 0
> 500 http://gb.archive.ubuntu.com lucid/main Packages
> 100 /var/lib/dpkg/status
>
> ProblemType: Bug
> Architecture: i386
> CheckboxSubmission: d6a9fb5d438b37af50efc2e4853fca15
> CheckboxSystem: edda5d4f616ca792bf437989cb597002
> Date: Tue Mar 2 11:11:29 2010
> DistroRelease: Ubuntu 10.04
> EcryptfsInUse: Yes
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
> NonfreeKernelModules: nvidia
> Package: gvfs 1.5.4-0ubuntu1
> ProcEnviron:
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-14.20-generic-pae
> SourcePackage: gvfs
> Uname: Linux 2.6.32-14-generic-pae i686
>
> [EDIT] I forgot to mention, I can't find anything in any log file that
would explain why this is happening.
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/desktopcouch/+bug/530605/+subscribe

JPM (jpm) wrote :

I'm having the same issue with Ubuntu 10.10 beta 32bit, installed with Alternate install image. It happened directly after a full update, without any customizations.

Changed in gvfs:
importance: Unknown → High
status: Invalid → Unknown
Dimitrios Ntoulas (ntoulasd) wrote :

Having this problem with 10.10 Maverick.

2.6.35-25-generic #43-Ubuntu SMP Thu Jan 6 22:25:16 UTC 2011 i686 GNU/Linux

I have a server and 2 clients.

Server 10.04 Clients 10.10

One client works fine, the other has problem. Both clients updated.
Its must be some setting that cause the problem.

Changed in gvfs:
status: Unknown → Invalid
karl (karl-sebastian-liebich) wrote :

Well for this is a duplicate of Bug #551645 - I still encounter this bug.

Felix (apoapo) wrote :

Yes, same here. desktopcouch-service restarts every few secs and is using 100% cpu immediately.

edvar (edvar-f) wrote :

I had to uninstall Ubuntu One and all associated packages so my CPU Utilization went back to normal.
I reinstalled Ubuntu One and notice the package "desktopcouch-ubuntuone" wasn't installed this time. I suspect it was the one causing the high utilization.

Changed in gvfs (Fedora):
importance: Unknown → Medium
status: Unknown → Fix Released
Displaying first 40 and last 40 comments. View all 120 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.