Software rendering is forced after 18.04 upgrade (Intel Core 2 Duo P8600 / GMA 4500MHD)

Bug #1770913 reported by MegaBrutal on 2018-05-13
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libglvnd (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Timo Aaltonen

Bug Description

[Impact]

Upgrades to 18.04 can pull in only libnvidia-gl-390 which provides libegl-vendor and libglx-vendor, thus fulfilling the dependency for libegl1/libglx0. This will cause issues on machines which don't use the nvidia proprietary driver. To fix this libegl1/libglx0 should depend on libegl-mesa0/libglx-mesa0 to make sure that the Mesa stack gets used by default.

[Test case]

Test upgrading from 16.04/17.10 to 18.04, check that it installs the Mesa libraries.

[Regression potential]

None, these get already installed if 18.04 image is used.

[Original Description]
After upgrading to Ubuntu 18.04, my desktop uses software rendering, no matter what I do.
As far as I know, all necessary packages are installed.
Formerly I had oibaf installed, but suspecting that this may cause the problem, I removed it with ppa-purge. It didn't help.

First I noticed the problem when I tried to play HD videos.
It was fine before the upgrade. My hardware is capable for 3D acceleration, as it worked on 17.10.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xserver-xorg-video-intel 2:2.99.917+git20171229-1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
.tmp.unity_support_test.1:

ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sun May 13 06:13:09 2018
DistUpgraded: 2018-05-12 22:26:52,663 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Mobile 4 Series Chipset Integrated Graphics Controller [17aa:20e4]
   Subsystem: Lenovo Mobile 4 Series Chipset Integrated Graphics Controller [17aa:20e4]
InstallationDate: Installed on 2014-06-10 (1432 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: LENOVO 6474B84
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.15.0-20-generic root=/dev/mapper/thinkvg-rootlv ro rootflags=subvol=@
Renderer: Software
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to bionic on 2018-05-12 (0 days ago)
dmi.bios.date: 10/17/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET94WW (3.24 )
dmi.board.name: 6474B84
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET94WW(3.24):bd10/17/2012:svnLENOVO:pn6474B84:pvrThinkPadT400:rvnLENOVO:rn6474B84:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.family: ThinkPad T400
dmi.product.name: 6474B84
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.0~rc5-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.0~rc5-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Sun May 13 06:01:23 2018
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.6-1ubuntu4

MegaBrutal (qbu6to) wrote :
MegaBrutal (qbu6to) wrote :

I've made a live bootable pendrive to test the issue. I've found that it's not present when I boot a live OS, so something must have gone wrong during the upgrade. I've attached glxinfo outputs.

thinkpad-glxinfo-livecd.txt: How it looks like when I boot from USB drive. It's normal.

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset
OpenGL version string: 2.1 Mesa 18.0.0-rc5
OpenGL shading language version string: 1.20

thinkpad-glxinfo-normalboot.txt: How it looks like when I boot my usual system on the same hardware. Software rendering is enforced.

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 128 bits)
OpenGL version string: 3.0 Mesa 18.0.0-rc5
OpenGL shading language version string: 1.30

MegaBrutal (qbu6to) wrote :
MegaBrutal (qbu6to) wrote :

I don't know why, but apport attached wrong (outdate) Xorg logs to my report. Probably it's a gdm feature that it puts logs elsewhere instead of the usual /var/log/Xorg.0.log.

The actual logs made by my X11 server are located here:
/var/lib/gdm3/.local/share/xorg/Xorg.0.log
/home/megabrutal/.local/share/xorg/Xorg.1.log

I attach the correct logfiles.

MegaBrutal (qbu6to) wrote :
summary: - Software rendering is forced after 18.04 upgrade
+ Software rendering is forced after 18.04 upgrade (Intel Core 2 Duo P8600
+ / GMA 4500MHD)
no longer affects: xorg (Ubuntu)
no longer affects: xserver-xorg-video-intel (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

This looks relevant. Xorg is saying:

[ 2402.232] (II) AIGLX: Screen 0 is not DRI2 capable
[ 2402.232] (EE) AIGLX: reverting to software rendering

Are you able to log into Wayland sessions?

MegaBrutal (qbu6to) wrote :

How can I switch to Wayland? Contrary to the articles those tell otherwise, I have no option to select it on the login screen.

Anyway, 17.10 worked fine with Wayland, so switching back to Wayland might probably help.

Timo Aaltonen (tjaalton) wrote :

you are using the oibaf ppa

Changed in xorg-server (Ubuntu):
status: New → Invalid
Changed in mesa (Ubuntu):
status: New → Invalid
MegaBrutal (qbu6to) wrote :

I'm not using oibaf.
I used to use it, but uninstalled it with ppa-purge, but this problem is present regardless of oibaf is installed.

Changed in mesa (Ubuntu):
status: Invalid → New
Changed in xorg-server (Ubuntu):
status: Invalid → New
Timo Aaltonen (tjaalton) wrote :

what does 'apt-cache policy libnvidia-gl-390' say?

MegaBrutal (qbu6to) wrote :

# LANG=C apt-cache policy libnvidia-gl-390
libnvidia-gl-390:
  Installed: 390.48-0ubuntu3
  Candidate: 390.48-0ubuntu3
  Version table:
 *** 390.48-0ubuntu3 500
        500 http://hu.archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages
        100 /var/lib/dpkg/status

# LANG=C dpkg -l libnvidia-gl-390
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===============================-====================-====================-====================================================================
ii libnvidia-gl-390:amd64 390.48-0ubuntu3 amd64 NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD

Timo Aaltonen (tjaalton) wrote :

The problem is that lib{e,}gl1 let lib{egl,glx}-vendor to fulfil the dependency, which apparently will pull the nvidia versions in some cases. The alternative depends needs to be dropped.

no longer affects: xorg-server (Ubuntu)
affects: mesa (Ubuntu) → libglvnd (Ubuntu)
Changed in libglvnd (Ubuntu):
status: New → Triaged
Iain Lane (laney) on 2018-06-05
Changed in libglvnd (Ubuntu Bionic):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) on 2018-06-07
description: updated

Hello MegaBrutal, or anyone else affected,

Accepted libglvnd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libglvnd/1.0.0-2ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libglvnd (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
MegaBrutal (qbu6to) wrote :

It works, thanks! \o/

tags: added: verification-done-bionic
removed: verification-needed-bionic
To post a comment you must log in.