[regression] Missing Wayland login option and missing GL acceleration, after installing libegl1

Bug #1751414 reported by Daniel van Vugt on 2018-02-24
108
This bug affects 21 people
Affects Status Importance Assigned to Milestone
libglvnd (Ubuntu)
Critical
Unassigned
mesa-demos (Ubuntu)
Critical
Unassigned
mir (Ubuntu)
Critical
Unassigned
mutter (Ubuntu)
Critical
Unassigned

Bug Description

I just updated bionic and suddenly:
  * No 'Ubuntu on Wayland' login option.
  * The 'Ubuntu' login option is very slow -- glxinfo reports LLVMpipe (software rendering)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-shell 3.26.2-0ubuntu3
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
Date: Sat Feb 24 13:59:46 2018
DisplayManager: gdm3
InstallationDate: Installed on 2017-12-12 (73 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171211)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel van Vugt (vanvugt) wrote :
Daniel van Vugt (vanvugt) wrote :

I think the regression happened here:

Start-Date: 2018-02-24 13:52:14
Commandline: apt full-upgrade
Requested-By: dan (1000)
Install: libegl1:amd64 (0.2.999+git20170802-2, automatic), libglvnd0:amd64 (0.2.999+git20170802-2, automatic)
Upgrade: libwebp6:amd64 (0.6.0-4, 0.6.1-1), language-pack-gnome-en:amd64 (1:18.04+20180215, 1:18.04+20180222), publicsuffix:amd64 (20180125.0922-1, 20180218.2049-1), libgweather-3-15:amd64 (3.27.4-1ubuntu2, 3.27.4-1ubuntu3), lua-bitop:amd64 (1.0.2-4, 1.0.2-5), remmina-common:amd64 (1.2.0-rcgit.27+dfsg-2ubuntu1, 1.2.0-rcgit.27+dfsg-3ubuntu1), mesa-utils:amd64 (8.3.0-5, 8.4.0-1), language-pack-en:amd64 (1:18.04+20180215, 1:18.04+20180222), mesa-utils-extra:amd64 (8.3.0-5, 8.4.0-1), isc-dhcp-common:amd64 (4.3.5-3ubuntu3, 4.3.5-3ubuntu4), libwavpack1:amd64 (5.1.0-2, 5.1.0-2ubuntu1), geoclue-ubuntu-geoip:amd64 (1.0.2+14.04.20131125-0ubuntu3, 1.0.2+18.04.20180223-0ubuntu1), libgnome-todo:amd64 (3.27.90-1, 3.27.90-1ubuntu1), remmina:amd64 (1.2.0-rcgit.27+dfsg-2ubuntu1, 1.2.0-rcgit.27+dfsg-3ubuntu1), python3-distupgrade:amd64 (1:18.04.8, 1:18.04.9), libfreexl1:amd64 (1.0.4-1, 1.0.5-1), gir1.2-gweather-3.0:amd64 (3.27.4-1ubuntu2, 3.27.4-1ubuntu3), yelp-tools:amd64 (3.18.0-4, 3.18.0-5), ubuntu-release-upgrader-core:amd64 (1:18.04.8, 1:18.04.9), lua-socket:amd64 (3.0~rc1+git+ac3201d-3, 3.0~rc1+git+ac3201d-4), tk8.6:amd64 (8.6.8-2, 8.6.8-3), libwebpmux3:amd64 (0.6.0-4, 0.6.1-1), gnome-todo-common:amd64 (3.27.90-1, 3.27.90-1ubuntu1), lua-lpeg:amd64 (1.0.0-1, 1.0.0-2), remmina-plugin-rdp:amd64 (1.2.0-rcgit.27+dfsg-2ubuntu1, 1.2.0-rcgit.27+dfsg-3ubuntu1), ubuntu-release-upgrader-gtk:amd64 (1:18.04.8, 1:18.04.9), gnome-todo:amd64 (3.27.90-1, 3.27.90-1ubuntu1), remmina-plugin-secret:amd64 (1.2.0-rcgit.27+dfsg-2ubuntu1, 1.2.0-rcgit.27+dfsg-3ubuntu1), python-dbusmock:amd64 (0.17-1, 0.17.1-1), remmina-plugin-vnc:amd64 (1.2.0-rcgit.27+dfsg-2ubuntu1, 1.2.0-rcgit.27+dfsg-3ubuntu1), libtesseract4:amd64 (4.00~git2188-cdc35338-5, 4.00~git2207-766b7bd6-3.1), libtk8.6:amd64 (8.6.8-2, 8.6.8-3), isc-dhcp-client:amd64 (4.3.5-3ubuntu3, 4.3.5-3ubuntu4), libgweather-common:amd64 (3.27.4-1ubuntu2, 3.27.4-1ubuntu3), hdparm:amd64 (9.53+ds-1, 9.54+ds-1)
End-Date: 2018-02-24 13:52:41

Daniel van Vugt (vanvugt) wrote :

FIXED

sudo apt remove libegl1

affects: gnome-shell (Ubuntu) → libglvnd (Ubuntu)
Changed in libglvnd (Ubuntu):
status: New → Triaged
description: updated

Actually, the offending library seems to have come in as a dependency of this:

mesa-demos (8.4.0-1) unstable; urgency=medium

  * New upstream release.
  * Drop configure.ac-Auto-detect-wayland-support.diff, upstream.
  * Drop configure.ac-Fix-default-behavior-of-AC_ARG_WITH-glut.patch,
    upstream.
  * Update watch url.
  * Distribute eglinfo within mesa-utils-extra.
  * Bump debhelper compat to 11.
  * Bump standards version to 4.1.3.

 -- Andreas Boll <email address hidden> Fri, 23 Feb 2018 11:35:05 +0100

summary: - [regression] Missing Wayland login option and missing GLX acceleration
+ [regression] Missing Wayland login option and missing GL acceleration
Changed in libglvnd (Ubuntu):
status: Triaged → New
Changed in mesa-demos (Ubuntu):
importance: Undecided → Critical
summary: - [regression] Missing Wayland login option and missing GL acceleration
+ [regression] Missing Wayland login option and missing GL acceleration,
+ after installing mesa-utils-extra 8.4.0

I believe a transition might going on right now, but I would need to defer to Timo to be sure. There is ana newer libglvnd in bionic-proposed that might be worth testing.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libglvnd (Ubuntu):
status: New → Confirmed
Changed in mesa-demos (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Dropped severity. I suspect only people with `mesa-utils-extra` installed will ever hit this.

Changed in libglvnd (Ubuntu):
importance: Critical → High
Changed in mesa-demos (Ubuntu):
importance: Critical → High
Daniel van Vugt (vanvugt) wrote :

Bumped to critical again.

Today's new mutter and mir releases means everyone now hits this bug.

summary: [regression] Missing Wayland login option and missing GL acceleration,
- after installing mesa-utils-extra 8.4.0
+ after installing libegl1
Changed in libglvnd (Ubuntu):
importance: High → Critical
Changed in mesa-demos (Ubuntu):
importance: High → Critical
Changed in mir (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Changed in mutter (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Daniel van Vugt (vanvugt) wrote :

I think we just need to find a way to prioritize:
  /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1.0.0
over:
  /usr/lib/x86_64-linux-gnu/libEGL.so.1.0.0

Timo Aaltonen (tjaalton) wrote :

no, we need the bits from -proposed migrated already

Kent Ross (mumbleskates) wrote :

> sudo apt remove libegl1

This cascaded to what turned out to be the entirety of ubuntu-desktop for me. I would advise caution here, it can be a pain to get back.

exploder91 (d-cosner) wrote :

I tried removing the package from recovery mode as root, it would not remove libegl1.

Timo Aaltonen (tjaalton) wrote :

it's better to enable -proposed and install libgl1-mesa-glx after apt update (and not do full dist-upgrade to avoid unrelated updates)... not sure if just that is enough, might need some other packages too

the packages should migrate "soon", now that all the blockers have been sorted out

I just got the whole mesa stack updated, including libgl1-mesa-glx (ver 18.0.0~rc4-1ubuntu3) and I still don't have gl acceleration, only llvm pipe. Are there any other packages on hold?

Adding -proposed to sources works.

Sent via the BlackBerry Hub for Android

  Original Message
From: <email address hidden>
Sent: March 2, 2018 10:50 PM
To: <email address hidden>
Reply-to: <email address hidden>
Subject: [Bug 1751414] Re: [regression] Missing Wayland login option and missing GL acceleration, after installing libegl1

I just got the whole mesa stack updated, including libgl1-mesa-glx (ver
18.0.0~rc4-1ubuntu3) and I still don't have gl acceleration, only llvm
pipe. Are there any other packages on hold?

--
You received this bug notification because you are subscribed to a
duplicate bug report (1752343).
https://bugs.launchpad.net/bugs/1751414

Title:
  [regression] Missing Wayland login option and missing GL acceleration,
  after installing libegl1

Status in libglvnd package in Ubuntu:
  Confirmed
Status in mesa-demos package in Ubuntu:
  Confirmed
Status in mir package in Ubuntu:
  Confirmed
Status in mutter package in Ubuntu:
  Confirmed

Bug description:
  I just updated bionic and suddenly:
    * No 'Ubuntu on Wayland' login option.
    * The 'Ubuntu' login option is very slow -- glxinfo reports LLVMpipe (software rendering)

  WORKAROUND: sudo apt remove libegl1

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-shell 3.26.2-0ubuntu3
  ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
  Uname: Linux 4.15.0-10-generic x86_64
  ApportVersion: 2.20.8-0ubuntu10
  Architecture: amd64
  Date: Sat Feb 24 13:59:46 2018
  DisplayManager: gdm3
  InstallationDate: Installed on 2017-12-12 (73 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171211)
  SourcePackage: gnome-shell
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libglvnd/+bug/1751414/+subscriptions

Jeremy Bicha (jbicha) wrote :

Nicolás, yes, we're waiting on libglvnd which is waiting on nvidia-graphics-driver-390 to be straightened out. Even though it's late Friday, it's being worked on now.

Jeremy Bicha (jbicha) wrote :

This should be fixed now (or as soon as you get the pending updates).

Changed in libglvnd (Ubuntu):
status: Confirmed → Fix Released
Changed in mesa-demos (Ubuntu):
status: Confirmed → Invalid
Changed in mir (Ubuntu):
status: Confirmed → Invalid
Changed in mutter (Ubuntu):
status: Confirmed → Invalid

Fixed for me. Thank you for your hard work!!

Michael (3-ueuntu-4) wrote :

libgl1-mesa-glx version 18.0.0~rc4-1ubuntu3 did _not_ help for me (Intel Broadwell, upgraded yesterday)

This packages seems to be a dummy package? "This is a transitional dummy package, it can be safely removed."

But if I want to remove it, following packages get removed as well:
"
  abiword* abiword-plugin-grammar* caribou* caribou-antler* cheese* chrome-gnome-shell* empathy* eom* evolution* evolution-indicator* evolution-plugins* gdm3* gir1.2-champlain-0.12* gir1.2-clutter-1.0* gir1.2-clutter-gst-3.0*
  gir1.2-cogl-1.0* gir1.2-coglpango-1.0* gir1.2-gtkchamplain-0.12* gir1.2-gtkclutter-1.0* gir1.2-totem-1.0* gnome-contacts* gnome-control-center* gnome-games* gnome-maps* gnome-nibbles* gnome-session* gnome-shell*
  gnome-shell-extension-weather* gnome-shell-extensions* gnome-sushi* gstreamer1.0-clutter-3.0* gthumb* indicator-bluetooth* libabiword-3.0* libchamplain-0.12-0* libchamplain-gtk-0.12-0* libcheese-gtk25* libcheese8*
  libclutter-1.0-0* libclutter-gst-3.0-0* libclutter-gtk-1.0-0* libclutter-imcontext-0.1-0* libclutter-imcontext-0.1-bin* libcogl-pango20* libcogl-path20* libcogl20* libevolution* libgl1-mesa-glx* libtotem0* lightsoff*
  quadrapassel* swell-foop* totem* totem-plugins* ubuntu-desktop* ubuntu-session* unity-control-center*
"

Has that the same cause or something else?

Michael (3-ueuntu-4) wrote :

I forgot to add that I only have the Intel graphics, no dedicated.

Another trace what went wrong:
$ vdpauinfo
display: :1 screen: 0
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory

Daniel van Vugt (vanvugt) wrote :

Yes, the workaround "sudo apt remove libegl1" was only safe in February. Not safe after the mutter and mir updates in March :(

Thanks for fixing this.

description: updated
Daniel van Vugt (vanvugt) wrote :

Michael,

If you have any continuing problems then please log a new bug.

Eugene Romanenko (eros2) wrote :

After upgrading artful to bionic (debian way, replaced artful to bionic in sources.list) faced this issue.
Solved by installing libegl-mesa0 package.

Ernst Sjöstrand (ernstp) wrote :

Thanks Eugene, that finally solved it for me.

Happened when I upgraded my Intel-only system to Bionic just now.

Ernst Sjöstrand (ernstp) wrote :

apt-cache depends libegl1
libegl1
  Depends: libc6
  Depends: libglvnd0
 |Depends: libegl-mesa0
  Depends: <libegl-vendor>
    libegl-mesa0
    libnvidia-gl-390

For some reason libnvidia-gl-390 existed on my system (no nvidia hardware in this system).
That caused libegl-mesa0 to not be installed and that broke my system.

Daniel van Vugt (vanvugt) wrote :

This bug is closed, so please help us by opening new bugs to discuss any ongoing problems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers