[0a5c:5801] Broadcom fingerprint reader not working

Bug #602071 reported by Gargoulf on 2010-07-05
This bug affects 74 people
Affects Status Importance Assigned to Milestone
Won't Fix
libfprint (Fedora)
libfprint (Ubuntu)

Bug Description

Dell precision m6500 with internal swipe fingerprint reader - broadcom ush
ubuntu 10.04 32-bits

neither thinkfinger nor fprint find device.

sudo lsusb gives:
Bus 001 Device 004: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor

As per upstream, this device is not on the supported device list:

 Advanced Linux Sound Architecture Driver Version 1.0.23.
 Compiled on Jun 14 2010 for kernel 2.6.32-23-generic-pae (SMP).
Architecture: i386
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
 /dev/snd/controlC0: pnoterda 1170 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
 Card hw:0 'Intel'/'HDA Intel at 0xf6ffc000 irq 39'
   Mixer name : 'IDT 92HD81B1C5'
   Components : 'HDA:111d76d5,102802ef,00100104'
   Controls : 23
   Simple ctrls : 14
DistroRelease: Ubuntu 10.04
Frequency: I don't know.
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Dell Inc. Precision M6500
NonfreeKernelModules: nvidia wl
Package: linux (not installed)
 Socket 0:
   no product info available
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-23-generic-pae root=UUID=7c30bc95-d155-45f1-bf47-d2f250b8d6a8 ro quiet splash
 PATH=(custom, user)
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic-pae
Regression: No
RelatedPackageVersions: linux-firmware 1.34.1
Reproducible: No
Tags: lucid needs-upstream-testing
Uname: Linux 2.6.32-23-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 02/03/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 0R1203
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd02/03/2010:svnDellInc.:pnPrecisionM6500:pvr:rvnDellInc.:rn0R1203:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Precision M6500
dmi.sys.vendor: Dell Inc.

Leo Arias (elopio) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux.
(With many applications, you can report a future bug directly on the appropriate package by opening the application's "Help" menu and choosing "Report a Problem". https://wiki.ubuntu.com/ReportingBugs)

affects: ubuntu → linux (Ubuntu)
Leo Arias (elopio) wrote :

We need some more information from you before we can start working on this bug.

Please run the following command which will attach necessary information:

apport-collect 602071

For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies. Thanks in advance!

tags: added: needs-kernel-logs
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

tags: removed: needs-kernel-logs
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
invitu (invitu) wrote :

you can update your usb and pci ids using :
sudo update-usbids
sudo update-pciids

your lsusb and lspci commands should give better results

Gargoulf (pasquiernoterdaeme) wrote :

I did those updates. Still same error "device not found"

invitu (invitu) wrote :

I have same problem with my dell e6410

the goal of "update-usbids" was too show more details in "lsusb" command.
can you check for the model of your fingerprint reader by typing "sudo lsusb"

mine is :
Bus 002 Device 004: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor

For the moment, I did not find any driver for that device. I guess it's the reason why thinkfinger/fprint tools don't find the device

invitu (invitu) wrote :

I found this : http://natisbad.org/E4300/index.html
it speaks about the smart card reader but I think it can be useful

Gargoulf (pasquiernoterdaeme) wrote :

Seems I have exactly same device:
sudo lsusb gives:
Bus 001 Device 004: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor

Gargoulf (pasquiernoterdaeme) wrote :

invitu: In the link you gave, I found:

Fingerprint reader:
"There is currently no support for the device (neither via fprint, thinkfinger, or any other project). Considering that Broadcom does not provide the specs, this will probably require some reverse engineering. "

Gargoulf (pasquiernoterdaeme) wrote :

No progress for 11.10...

description: updated
summary: - dell fingerprint reader not working at all
+ 0a5c:5801 Broadcom fingerprint reader not working
affects: linux (Ubuntu) → libfprint (Ubuntu)
Changed in libfprint (Ubuntu):
status: Confirmed → New

Hi, is the device working now with the new libfprint?

Gargoulf (pasquiernoterdaeme) wrote :

just upgraded to 12.04 LTS. Still "no device found" when using fprint-demo

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libfprint (Ubuntu):
status: New → Confirmed
Changed in libfprint (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
summary: - 0a5c:5801 Broadcom fingerprint reader not working
+ [0a5c:5801] Broadcom fingerprint reader not working
spectre (spectre3brad) wrote :

Canonical can not work directly with Broadcom to offer a Linux driver has to leave even one as Nvidia proprietary driver?

When testing or no response Broadcom contact via email or through social networks.

Canonical may have more weight to the application.

Otherwise will have to harass them on social networks and email Lol.

description: updated
spectre (spectre3brad) wrote :

I sent requests on accounts Broadcom, Dell, Linux, Ubuntu via email and social networks.

And a forum post Dell [Fr]: http://fr.community.dell.com/forums_daide/logiciels_et_systme_dexploitation/f/76/p/161/288.aspx # 288

I invite you to do the same to get things done, because if we had to request several groups Dell, Linux, Ubuntu will demand has supported Broadcom and we may be I hope finally an answer favorably to our request for a Linux driver.

I provides more every time this thread to bug their offer to come who can give their opinion on the subject and thus transcribe all in the same place more than what is easy.

tags: added: hw-specific lucid oneiric precise

Gargoulf, thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of libfprint via https://bugs.freedesktop.org/enter_bug.cgi?product=libfprint . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Hello, I signal that the chip BCM5880 Broadcom supplied on multiple PCs in my case with the Dell Latitude E6530 and Ubuntu currently unusable because no driver provided by Broadcom for Linux. At the request of a developer Launchpad Linux / Ubuntu so I have to open an thread on the subject to try to get things done.

I invite you to come and read a first time in this thread to see what has been done on our side:

Bug Launchpad: https://bugs.launchpad.net/libfprint/+bug/602071

Thanking you in advance for your help.

spectre (spectre3brad) wrote :

I went created a bug report upstream as I am in the same case. Waiting for response.


Mike Simpson (mikie-simpson) wrote :

I think it is more complicated than the usual device that fprint is used for as it is not a straight fingerprint scanner but is a multimodality identity authenticator. As Broadcom joined the Linux foundation a while ago I had hoped that someone with enough clout could have asked them for the specs before now. It is like their wifi cards all over again. It is the only part of my dell E4200 that doesn't work in Linux

Changed in libfprint:
importance: Undecided → Unknown
status: New → Unknown

Is it available as standalone USB device?

spectre (spectre3brad) wrote :

I received an answer that day an employee responds Broadcom me this:

Thanks for your mail.
I Understand That this Dell machines only ships with Windows OS. If you want to mount other OSes, you'll Have to Directly Contact Dell for support.

Broadcom Corporation "

So I answered this:

"Hi, The Machine est aussi sold via Dell Ubuntu Linux. Aussi I Asked Them for help on this topic It Seems That goal They Have not Heard even from this side and That is why I come directly to Broadcom to make a request for publication of a pilot for the Linux product. This is a strong demand in the community.

I Asked a Dell, Linux, Ubuntu and Canonical libfingerprint who Seem em even Have No solution so far. It Seems That only the creator Broadcom chip can help us on this issue.

Hoping to Have a positive response from Broadcom icts for customers.

Good day and thank you for your help. "

I invite other applicants pilot to request a Broadcom and PC vendor (Dell, Asus ...) to try to get things done. The higher the demand will be stronger and we will get the chance to pilot and highlight the growing community of Linux.

Changed in libfprint:
importance: Unknown → Wishlist
status: Unknown → Confirmed


for the procedure it seems that we must activate and deactivate and then reactivate the USB concerned?

Only the integrated fingerprint and direcement the laptop so no physical access to turn on and turn off the USB bus concerned.

How to proceed?

Thank you.

You can disable/enable it in device manager.

spectre (spectre3brad) wrote :

An application is currently underway and our engineers need for additional data file.

Here is the message received from someone at Dell. Request with my serial number and my address.

I await the response of the team.

I will keep you informed.


I have not yet managed to do it properly USBmon my log for the team so I'll retry libFingerprint plustard at least one person who has the same concerns can test?

Good day.

Created attachment 70811
trace of the USB sniff

obtained with usbmon watching /sys/kernel/debug/usb/usbmon/2u

Above is a trace obtained using usbmon.
I restarted the USB device using:

Let me know if I can provide more information

NB. lsusb gives:
Bus 002 Device 005: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor

spectre (spectre3brad) wrote :



I just made a request on the current procedure of study on the part of the expert team from Dell that work on the subject. (D'after that told me the community contact Dell).

I therefore expect the response you want and informed.




je viens d'effectuer une demande sur la procedure d'etude actuelle de la part de l'equipe d'expert de chez Dell qui travail sur le sujet. (D'apres ce que m'a dit le contact de la communauté Dell).

J'attend donc la reponse et vous tiens informés.

Problem also affects me - Dell E4310

spectre (spectre3brad) wrote :


Hi all,

Up my small hand Dell for news. Here is my message:

"Hello and Happy New Year to you,

I come to you to know or is currently worries. Information on the subject? Dell working with Broadcom on the subject? A Linux driver being created?

Thank you. "

I expected the answer



Bonjour a tous,

petit Up de ma part chez Dell pour avoir des nouvelles. Voici mon message:

"Bonjour et bonne année a vous,

je reviens vers vous pour savoir ou en est actuellement le soucis. Des informations sur le sujet? Dell travail avec Broadcom sur le sujet? Un pilote Linux en cours de création?


J'attend la reponse

nesthib (nesthib) wrote :

@spectre : attention avec la traduction automatique en anglais. Ton message ne veut pas dire grand chose (par exemple parce que tu utilises « ou » au lieu de « où » en français). Une suggestion de message :
« I'm coming back to you to know if there is any update regarding the Linux support for the Broadcom BCM5880 chip. Do you have any information to provide? Is Dell currently working with Broadcom to write a Linux driver? »

spectre (spectre3brad) wrote :

@nesthib: Oui en effet comme quoi une erreur d'inatention peut tout changer. Merci a toi pour la correction.


[En] [Google Translation Fr>En]

I just received the following message from Dell:
"Hello spectre3brad,

We followed the request to the publisher of the product.

We are currently still waiting for his answer.

I just restart date. I do follow their feedback as soon as it is available.

Regards "

Je viens de recevoir le message suivant de la part de Dell:
"Bonjour spectre3brad ,

Nous avons fait suivre la demande à l'éditeur du produit.

Nous sommes toujours actuellement attente de sa réponse.

Je viens de relancer ce jour. Je vous fais suivre leur feedback dès qu’elle est disponible.


spectre (spectre3brad) wrote :

[En] [Google Translate Fr>En]

Here is the last response received from Dell on the subject:


After several discussions and interviews with our partner, the publication of a driver to read the Broadcom BCM5880 chip is not planned at this time. We are sorry, but we have no possibility to provide you with an application to use the Broadcom chip as you want.

Regards "


[Fr] [Origine]

Voici la dernière réponse reçue de la part de Dell sur le sujet:

"Bonjour ;

Après plusieurs échanges et entretiens avec notre partenaire, la publication d’un pilote permettant la lecture de la puce Broadcom BCM5880 n’est pas prévue pour le moment. Nous le regrettons, mais nous n’avons aucune possibilité de vous fournir une application permettant d’utiliser la puce Broadcom comme vous le souhaitez.


spectre (spectre3brad) wrote :

[En] [Google Translate Fr>En]

Hello all.

I called a technical service manager at Dell who told me that concerns were ongoing between several manufacturers including Dell Broadcom themselves is both Linux and Windows.

Why? Well as Broadcom chips created with software support (including drivers) leaves something to be desired and that is the problem. It seems that the topic back meetings often overlooked Dell Broadcom and Dell has even think to look elsewhere ... This is understandable given the concerns posed to manufacturers and end users.

And therefore our concerns that manages the TPM Fingerprint seems that nothing is thus provided on the side of Broadcom.

Broadcom Policy: You sell dreams and once bought anything! We can not even contact them directly and if you get there it is a response that does nothing.

A shame for a member company of the Linux Foundation! This is just to draw us into their trap.

So I see only one solution ... harass them by email to obtain a Linux driver.

I invite you to make ay and every one of you to send an email for example regularly every month so that they eventually meet the demand.

If you are interested email list let me know so I can share.

---[Fr] [Origine]

Bonjour a tous.

J'ai appelé un responsable du service technique de chez Dell qui m'a informé que des soucis étaient en cours entre plusieurs constructeurs dont Dell eux-mêmes est Broadcom aussi bien sur Linux que Windows.

Pourquoi? Et bien car Broadcom créé des puces avec un support logiciel (dont les drivers) qui laisse a désirer et qui pose problème. Il semble que le sujet revienne souvent lors des réunions chez Dell vis a vis de Broadcom et que Dell pense même a aller voir ailleurs... C'est compréhensif vu le soucis posé aux constructeurs et utilisateurs finaux.

Et donc pour notre soucis de puce TPM qui gère le Fingerprint il semble que rien ne soit donc prévu du coté de Broadcom.

Politique de Broadcom: On vous vend du rêve et une fois acheté rien! On ne peut même pas les contacter directement et si on y arrive c'est pour une réponse qui ne répond a rien.

Un comble pour une société membre de la fondation Linux! C'est juste pour nous attirer dans leur piège.

Du coup je ne vois qu'une seule solution... les harceler par emails pour l'obtention d'un pilote Linux.

Je vous invite donc a y procéder et chacun d'entre vous a envoyer régulièrement un email par exemple tout les mois afin qu'ils finissent par répondre a la demande.

Si la liste email vous intéresse faites le moi savoir pour que je partage.

Eric Whyne (ericwhyne) wrote :

Broadcom has a twitter account.


Probably more effective to engage them there than in a private email.


Jamie Chang (jamie315) on 2013-10-03
Changed in dell:
status: New → Won't Fix
spectre (spectre3brad) wrote :

Why "Won't Fix" ?

Gargoulf (pasquiernoterdaeme) wrote :

still not working in ubuntu 13.10

Another guy that would be interested in getting this working on multiple laptops

Created attachment 92952
Log of a fingerprint enrollment process (created by Device Monitoring Studio)

I have a Dell M4700 with Broadcom's BCM5880 swipe fingerpint sensor. I am joining to the folks would like to have it on Linux.
I have uploaded a fresh log, find it attached.

Created attachment 92953
Device Descriptor

Created attachment 92955
Log of a fingerprint delete process (created by Device Monitoring Studio)

Guys, I must admit that it's close to impossible to reverse device protocol without device available. So unless there's a standalone USB scanner with broadcom sensor available I won't work on its support for libfprint. So reversing protocol and implementing libfprint driver is up to you.

Please reopen bug when patch with driver for libfprint will be ready.

Changed in libfprint:
status: Confirmed → Won't Fix
spectre (spectre3brad) wrote :

Google Translation Fr>En:

I contacted all the email addresses of Broadcom provides the official website and I see that many do not even read the email. Broadcom is really disappointing on their customer care! I would say that this is "the big fail secure and customer support for broadcom"!

Same for Dell I sent an email. Waiting for reply.

I regularly Broadcom continues to ask them on social networks (Google+, Facebook and Twitter).

We really need Broadcom provides Linux drivers left to do as Nvidia and their owner (at worst) drivers but at least have functional systems.


Original text Fr:

Bonjour à tous,

j'ai recontacté toutes les adresses emails de Broadcom fournit sur le site officiel et je vois que beaucoup ne lisent même pas le mail. Broadcom est vraiment décevant sur leur suivi clients! Je dirai que c'est "the big fail secure and client support for broadcom" !

Pareil pour Dell j'ai renvoyé un email. En attente de réponse.

Pour Broadcom je continue régulièrement à leur poser la question sur les réseaux sociaux (Google+, Facebook et Twitter).

Il faut vraiment que Broadcom fournisse des pilotes pour Linux quitte à faire comme Nvidia et leurs pilotes propriétaire (Au pire) mais au moins avoir des systèmes fonctionnels.

no longer affects: linux-lts-trusty (Ubuntu)
spectre (spectre3brad) wrote :

Email Broadcom response:

Maryann Jackson
<email address hidden>

Sorry you would need to go thru Dell support for help on this.

spectre (spectre3brad) wrote :

Google Translate Fr>En:

Received this morning from Dell:


Hello Mr. ******

Thank you for your email

I see that you already had put together the case that has been the object of a technical climbing level phone support.

the response being that the machine is not compatible with a finger print configuration under Ubunto.

Do you need other items?


*** ***
Client Tech Supt Sr. Associate, EMEA Customer Service
Social Media and Community Professional
DELL Technical Support
United Kingdom : 0844 444 3844
Ireland : 01800552552
South Africa : 0800994050
France : 0825 004 686
Switzerland : 0848 33 00 92
Belgium : 0248 28 690


Original text Fr:

Reçu ce matin de la part de Dell:


Bonjour Monsieur *** ***

Merci pour votre mail

Je vois que vous avez dejà remonté le cas qui a fait l object d une escalade technique au niveau du support telephone .

le reponse etant que la machine n est pas compatible avec une configuration finger print sous Ubunto .

Avez vous besoin d autres elements ?


*** ***
Client Tech Supt Sr. Associate, EMEA Customer Service
Social Media and Community Professional
DELL Technical Support
United Kingdom : 0844 444 3844
Ireland : 01800552552
South Africa : 0800994050
France : 0825 004 686
Switzerland : 0848 33 00 92
Belgium : 0248 28 690


Changed in somerville:
status: New → Won't Fix
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305915

no longer affects: somerville
Firen (jesse111) on 2014-04-14
Changed in libfprint (Ubuntu):
status: Triaged → Confirmed
Changed in libfprint (Ubuntu):
status: Confirmed → Triaged
Mindaugas B. (embar-super) wrote :

You may much benefit from http://www.dell.com/support/ page, were you can find drivers.
E.g. for Dell latitude E6440, you can go to
and download pack
when you extract and find

Can you test this?

Mindaugas B., bcmwl, the Broadcom proprietary wireless driver, has nothing to do with the fingerprint reader. For more on this, please review https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx .

Mindaugas B. (embar-super) wrote :

As I see in http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=R214858 description and in release.txt of various Dell ControlVault packages for Windows, bmc5880 is very related to UPEK drivers. They are proprietary, but fingerprint-gui (http://home.ullrich-online.cc/fingerprint/) include it

Mindaugas B. (embar-super) wrote :

lsusb -d 0a5c:5801 -v
for DELL Latitude 6440

I don't know how to make fingerprint to work

Mindaugas B., unfortunately, your comments don't make much sense. The driver in http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=R214858 is for Windows, as further verified by clicking the button "Supported Operating Systems". Given this is Launchpad, whose focus is Ubuntu development support (not Windows), how is that relevant here?

As well, if you would care to read the website you quoted, it does not list on its homepage 0a5c:5801 as a tested device. So, how is this related specifically?

Mindaugas B. (embar-super) wrote :

I just hope, that descriptions in drivers for Windows could help to implement drivers for linux.

Mindaugas B., unfortunately, it's not helpful at all. However, what would be helpful is creating the USBSniff logs requested by upstream in https://bugs.freedesktop.org/show_bug.cgi?id=56752 .

Mindaugas B. (embar-super) wrote :

usbmon log then opening fingerprint-gui and one minute later pressed "Rescan"

Mindaugas B. (embar-super) wrote :
Download full text (3.5 KiB)

I don 't know, if it helpfull, but maybe it is true, that fingerprint device originally is made by UPEK/Authentec, but you can not control it directly because of Broadcom USH layer?

http://forum.notebookreview.com/dell-latitude-vostro-precision/413346-dell-new-fingerprint-reader-owners-must-read-broadcom-ush-issue-effecting-preciosn-m4400-m6400-latitude-e6400-others-6-print.html says:

On Dell E-series laptops the fingerprint sensor is connected via proprietary interface from Broadcom and UPEK/Authentec driver cannot communicate with the device at all. The driver cannot see the sensor - it is "hidden" behind the Broadcom chip :-(
I could REM out a line of code or two in INF file of the fingerprint sensor device
Well, I would love to have a complete information about that ;-) But frankly speaking I don't see any logical reason why to do this. Even if you modify the VID and PID list in the Broadcom driver INF file, it simply cannot start working with the fingerprint reader. It's like if you want modify your video drivers to control your printer ;-) Broadcom coprocessor and our fingerprint sensor are completely different devices, each of them requires a different driver. Furthermore, as far as I know, the fingerprint reader is not enumerated by the system at all.

I went through the whole forum thread and the only guy who was close to some solution was the one who disassembled the fingerprint reader device. If this would be connected directly to the USB (to bypass the Broadcom controller) then the fingerprint reader will be normally enumerated by the operating system and it may work correctly. I deliberately use may, as the firmware of TCEFA1FH is designed for use with Broadcom only - it does not support some of the more advanced USB features (my understanding is that these are primarily related to error recovery). Furthermore the TCEFA1FH requires 3.3V, while standard USB provides 5V, so you will need to use some adapter to change the voltage. For "real" USB applicatons we recommend the TCEFB1. Anyway, I do not recommend you to do such hardware modifications!
Miroslav Buran
Technical Support Manager

Becides http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=R214858 says:

Please note: The BCM5880 firmware update process contains 2 protection mechanisms to prevent unauthorized updates.

Protection Mechanism 1: TPM Deactivation.

If the Trusted Platform Module (TPM) on the target computer has ever been activated in the past, in order to update the BCM5880 firmware, the TPM must be set to ON and DEACTIVE in the BIOS SETUP program before the firmware update will run. If the TPM on the target platform has never been activated previously, then this step is NOT necessary.

Protection Mechanism 2: Anti-Hammering.

The BCM5880 is equipped with Anti-Hammering protection that detects large numbers of read/write requests in a short period of time. This mechanism protects against malicious software that attempts to gain access to stored credentials by using multiple retry methods such as dictionary or brute force attacks. If a large number of read/write attempts are detected, the BCM5880 will temporarily shut...


exzR (exzr) wrote :

no other news? i have to recycle this fingerprint reader?

exzR (exzr) wrote :

i see that dell give and ubuntu 12.04 iso for dell e6540 that include fingerprint reader driver.. it is true?

Jakub (buri) on 2015-04-27
Changed in libfprint (Ubuntu):
status: Triaged → Confirmed
Changed in libfprint (Ubuntu):
status: Confirmed → Triaged
Anbu (anbu-s) wrote :

Any update on this? This still doesnt work for me with gnome ubuntu 15.04

Mindaugas B. (embar-super) wrote :

@Josef, mentioned Fedora fix is for smart-card reader, not fingerprint reader.

ComBin (combin) wrote :

Hello! On 16.04 don't work too.

Marcin Szałowicz (lolek) wrote :

Bump, this fingerprint reader is also available in e5470, any progress regarding this?

Pavel Karoukin (pavelkaroukin) wrote :

This also affects Dell Precision M7710, except USB ID "0a5c:5834"

Davide (davemann) wrote :

Problem persist.
Do someone already tried to use windows drivers converted with ndiswrapper?
I downloaded the software from Dell
and follow this tutorial.
But it's not really clear which files do I have to convert.
Any idea?

Rob Bruce (r-bruce) wrote :

Dell Latitude XT3 convertible notebook/tablet also uses this device (ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor) so is affected by this issue.

fig_wright (fig-wright) wrote :

I also have this issue with a Dell precision M4500. It's a shame this hasn't been solved in 6 years! :-(

The same here, Ubuntu 16.04 LTS, Latitude E5470, Bus 001 Device 004: ID 0a5c:5805 Broadcom Corp., not working.

I'd highly appreciate if someone had a look into that!

Bortnyák Roland (antivirtel) wrote :

Confirmed on 16.10, still doesn't work: 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor - Dell Latitude E6540

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.