Comment 2 for bug 590983

I am having the same issue as this person, although I've troubleshooted and fixed part of my problem, however I'm still running into this same issue, and it's not only on xubuntu 9.04, xubuntu 10.04 or ubuntu 8.04. My steps:
1) a working configuration of originally installed xubuntu 9.04 upgraded fine to 9.10, upon upgrade to 10.04:
at first the dvd drive was not automounting, or would only automount after a fresh reboot. Also the drive would randomly unmount, so this was the first reason watching dvds would not work.
2) tested my dvd drive on another machine running win* 7, and tested on same machine under xubuntu 9.10, worked fine, tested the same dvd on another machine worked fine win* 7, and tested on same machine under xubuntu 9.10, tested the dvd on my other machine running xubuntu 9.04 -> upgraded to 9.10 still works fine.. :)
3) tested sata cable on the other machine works fine (so now i'm sure it's not the hardware or the disc)
4) followed instructions of computer manufacturer and installed windows vista (dvd playback with vlc all fine) ~shudder~ don't want to run vista... so back to ubuntu 8.04 to try again
5) same problem as above described happens with a fresh install ubuntu 8.04 after following instructions to install proper codecs for watching dvds
6)almost give up.. but not quite
7) install fedora 13 on box, with installation of libdvdread-4.1.4-0.2.svn1188.fc13.i686 and libdvdcss-1.2.10-1.i386 still same dvd playback crash issue - will crash at random times see attachment for dmesg output

error message in fedora 13 using vlc:
main error: ES_OUT_SET_(GROUP_)PCR is called too late, increasing pts_delay to 300 ms
main error: ES_OUT_RESET_PCR called

The system i'm trying to install this on is a compaq sr5450f with nvidia GeForce 7100/nForce 630i chipset