/usr/share/java/commons-lang.jar contains documentation

Bug #1556647 reported by Felix Natter on 2016-03-13
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libcommons-lang-java (Ubuntu)
High
Unassigned

Bug Description

Ubuntu xenial/16.04: /usr/share/java/commons-lang.jar contains documentation:

hello Ubuntu developers / James Page,

it seems like your change to commons-lang:

libcommons-lang-java (2.6-6ubuntu1) xenial; urgency=medium

  * Resync with Debian unstable, remaining changes:
    - d/control,rules,libcommons-lang-java.poms: Drop use of bnd
      for generating OSGi metadata.

 -- James Page <email address hidden> Tue, 08 Mar 2016 11:12:15 +0000

broke things such that /usr/share/java/commons-lang.jar now contains
documentation instead of class files [1].

(I couldn't analyze further because I don't know where the ubuntu commons-lang
package VCS repository is)

[1] https://bugs.launchpad.net/ubuntu/+source/freeplane/+bug/1555824

Thanks and Best Regards,
Felix

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libcommons-lang-java (Ubuntu):
status: New → Confirmed

This is an important bug to get fix for me. Could someone at least increase the importance from "undecided" to the highest reasonable importance you can stand?

Timo Aaltonen (tjaalton) wrote :

breaks Dogtag PKI & freeipa-server

Changed in libcommons-lang-java (Ubuntu):
importance: Undecided → High

The attachment "libcommons-lang-java_2.6-6ubuntu2.2.6-6ubuntu2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcommons-lang-java - 2.6-6ubuntu2

---------------
libcommons-lang-java (2.6-6ubuntu2) xenial; urgency=medium

  * d/libcommons-lang-java.poms: do not reference javadoc.jar
    (LP: #1556647) .

 -- Nishanth Aravamudan <email address hidden> Wed, 16 Mar 2016 12:24:31 -0700

Changed in libcommons-lang-java (Ubuntu):
status: Confirmed → Fix Released

Thanks to all! I confirm this fix worked for me. Much appreciated.

Appears fixed in latest update. Thank you.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
affects: freeplane → ubuntu
no longer affects: ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers