Ubuntu

Please, silence IA__gdk_error_trap_pop: assertion `gdk_error_traps != NULL' failed

Reported by Sergio Callegari on 2012-11-07
150
This bug affects 30 people
Affects Status Importance Assigned to Milestone
libcanberra (Ubuntu)
High
Unassigned

Bug Description

On Kubuntu 12.10, whenever a gtk application is opened from the konsole, the terminal gets flooded with

Gdk-CRITICAL **: IA__gdk_error_trap_pop: assertion `gdk_error_traps != NULL' failed

which makes the konsole almost impossible to use after a gtk application has been backgrounded.

The only way to start gtk apps from the konsole (or a terminal) keeping the konsole usable is to start them redirecting stderr to /dev/null, which should not be the case.

This message turns a probably innocuous bug in gtk apps into a severe annoyance also to the konsole.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1075928/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → gtk+2.0 (Ubuntu)
funicorn (funicorn) wrote :

I have the same problem ever since upgrading to Ubuntu 12.10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Henrik Sundberg (storangen) wrote :

I got this error after solving the canberra-gtk-module problem (for not just eclipse):
   henrik@kubuntu:~/android-sdk-linux/tools$ eclipse
   Gtk-Message: Failed to load module "canberra-gtk-module"
   Gtk-Message: Failed to load module "canberra-gtk-module"

I.e., I solved the problem by installing the libcanberra-gtk-module, but then I got:
   henrik@kubuntu:~/android-sdk-linux/tools$ eclipse
   (eclipse:7399): Gdk-CRITICAL **: IA__gdk_error_trap_pop: assertion `gdk_error_traps != NULL' failed

(I'm using Kubuntu 12.10)

rik (rikkroondijk) wrote :

this bug started after upgrading to 12.10 ( upgrading to 12.10 caused many problems : persistent google chrome problems, application software sources not accessible/functioning ; hplip problems )

Grzegorz Ślusarek (gsk11) wrote :

on Kubuntu 12.10 x32, when using vim gtk (version Version: 2:7.3.547-4ubuntu1), it's always crash when I use command t plugin. Traceback is always the same:

(gvim:5866): Gdk-CRITICAL **: IA__gdk_error_trap_pop: assertion `gdk_error_traps != NULL' failed

Andreas Hohenegger (hohenegger) wrote :

See the same problem since upgrading to Ubuntu 12.10.

Nick Brown9 (nick-brown) wrote :

Me too. Running many apps from LXDE system menu dont execute properly (eg synaptic for example...)
Running from console as root runs the app but with odd side effects (eg "software sources" seems to execute but then a package wont install. Lots of error messages on the console... )

knorre (knorre) wrote :

The bug appeared after upgrade of xubuntu 12.04 -> 12.10.

aleandro (aleandrodasilva) wrote :

Bug still present in 13.04 beta. I tried to use cryptkeeper and rssowl for example. I'm sure it happens with other gtk apps too.

Andrey Bondarenko (abone) wrote :

Suddenly found possible cause/workaround for the bug. In 12.10 environment variable GTK_MODULES is set for all DE (including KDE or XFCE). If variable is unset, gdk_error_trap_pop may disappear appear when starting GTK applications.

On my desktop:

$ env | grep GTK_MODULES
GTK_MODULES=canberra-gtk-module:canberra-gtk-module

$ fslint-gui
/usr/bin/fslint-gui:1950: GtkWarning: IA__gdk_error_trap_pop: assertion `gdk_error_traps != NULL' failed
  gtk.main ()

$ unset GTK_MODULES

$ fslint-gui
<no GtkWarning message>

Probably this bug is related to bug 385577

aleandro (aleandrodasilva) wrote :

Unsetting modules does not solve this bug. It has to be considered a big usability issue.
Could you please try some applications like taskcoach or cryptkeeper by terminal to see if your solution is working?

Andrey Bondarenko (abone) wrote :

I don't see taskcoach package in Ubuntu 12.10 repository. For cryptkeeper, unsetting GTK_MODULES variable removes annoying warning message about IA__gdk_error_trap_pop.

I'm not expert on GTK or GNOME. AFAIK libcanberra related only to event sound. Is it useful for KDE desktop or it is GNOME speciffic? Also, why this bug assigned to gtk+-2.0 package if it is only reproducible with libcanberra-gtk-module from libcanberra?

Andrey Bondarenko (abone) wrote :

Funny. This bug is a fix for bug 834403 (see http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/raring/libcanberra/raring/view/head:/src/canberra-gtk-module.c#L310)

Ok, I agree that unsetting GTK_MODULES does not resolve the issue, it just disables buggy module, but now I'm sure that the bug is in libcanberra not gtk+.

affects: gtk+2.0 (Ubuntu) → ubuntu
affects: ubuntu → libcanberra (Ubuntu)
aleandro (aleandrodasilva) wrote :

Hello again. I have got an update in ubuntu 13.04 and I have to say that the message has disappeared (you can try to use the command gksu in the terminal to demonstrate it) . At the other side all applications that functioned with gtk don't start any more. Are you still sure it is a bug related to libcanberra which regulates the sound?
I cannot give more informations until the next update in raring. For me cryptkeeper and taskcoach are out of order yet. Could someone suggest other common gtk applications to test and reproduce this bug?

Andrey Bondarenko (abone) wrote :

I'm sure the bug is in libcanberra at least in Quantal. I'm can reproduce the bug with gksu, evince and emacs.

Also, I think I've found real cause for the bug. Patch 10_no_nonnative_crash.patch is applied twice in ubuntu version. This patch was integrated in upstream version 0.29, but was not removed from debian/patches. This lead to usage of gdk_error_trap_push without corresponding gdk_error_trap_pop. I've published a fix in my branch:

https://code.launchpad.net/~abone/ubuntu/raring/libcanberra/fix-1075928

Also I'm trying to publish prebuilt packages for Quantal and Raring in my PPA, but have some issues with it:

https://launchpad.net/~abone/+archive/ubuntu-fixes

C de-Avillez (hggdh2) wrote :

Marking triaged/high: affects multiple users, potentially simple to fix.

Changed in libcanberra (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcanberra - 0.30-0ubuntu2

---------------
libcanberra (0.30-0ubuntu2) raring; urgency=low

  * debian/patches/10_no_nonnative_crash.patch:
    - applied upstream since version 0.29 (LP: #1075928)
 -- Andrey Bondarenko <email address hidden> Tue, 26 Mar 2013 07:27:38 +0600

Changed in libcanberra (Ubuntu):
status: Triaged → Fix Released
Changed in libcanberra (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Sergio Callegari (callegar) wrote :

As usual (and indeed correctly by the ubuntu policy), the bug is being closed as "fix released" when there is in fact no fix for the stable distribution against which the bug was originally reported. And as usual this is extremely confusing. If one reports a bug against a package that is in distribution version foo which still has not reached end of life, he expects the bug to be cosidered closed when a fix is available for foo, not for something else. Unfortunately 'fix release' gives no clue at all about whether the bug fix will be released to the distribution against which it was reported or if the bug will in fact be considered 'invalid'/'not worth fixing' for it. Can someone knowledgeable be so kind to hint at whether this bug will likely be fixed for quantal or not?

Daniel T Chen (crimsun) wrote :

@Sergio Unless otherwise indicated explicitly in Launchpad's UI, the release series is the current development one. To target quantal, click the "Nominate for series" link and choose the desired release(s).

Sergio Callegari (callegar) wrote :

Thanks Daniel for your note! But my message was precisely inspired by the impossibility to bind a bug to something that is not the development version. I have no option to 'nominate for quantal' in the launchpad UI, nor to 'target for release'. Searching for 'nominate' or 'target' in the bug page returns nothing with my account that is not a developer one. Apparently the initial reporters of bugs do not have anymore the option to tie a bug to a series.

The result is something that I have already seen a few times.

The bug gets 'fix released' status and since it is closed everybody forgets about it. No SRU is made and one either: (i) stays waiting for a SRU for a long time with no clue whether this will be issued or not; or (ii) start searching for backports in the PPAs ending up with a machine that relies on far too many PPAs than desirable (*); or (iii) makes his own package fork in a PPA with the fix; or (iv) opens a new bug with the same title ending with 'in quantal'. None of these options is very satisfactory.

Anyway, good to see that Andrey has made a quantal package in his PPA with the fix.

(*) there are currently 497 PPAs found searching for "fix"es for something that is buggy in stable. Surely, many of these are probably inactive or obsolete, but they are still a lot.

Changed in libcanberra (Ubuntu):
status: Fix Released → Invalid
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers