[hardy] kaffeine loops on "Codec package is already installed"

Bug #210303 reported by PascalC on 2008-04-01
116
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libart-lgpl (Ubuntu)
Critical
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Critical
Unassigned

Bug Description

SRU description:
1. This bug makes Kaffeine's auto-codec installation loop for media which can't be played back with libxine1-ffmpeg or libdvdcss (e.g. recent versions of WM* or MOV)
2. In the development branch we introduced 2 'returns' in the python script responsible for handling the codec installation (0.8.6-2ubuntu2)
3. Patch attached
4. TEST CASE:
   * Install Kaffeine
   * Try opening http://www.nasa.gov/mov/229743main_parachute-640.mov with kaffeine
   * The codec installer should pop-up and ask whether to install the appropriate codec
   * The installer will pop-up again and notify you that the available codecs are already installed
   * The file will still not be playable, but the installer shouldn't loop
5. No regression potential because the returns are additions to QApplication.exit(1) functions.

Binary package hint: kaffeine

When I try to play the following file with kaffeine, it says "installing codec" and fails with "Codec package is already installed"
then it begin again to reinstall the Codec
this forever. I have to kill kaffeine.

http://www.universal-tao.com/archives/holy_water.wmv

A video of the bug with a 3gp file: http://launchpadlibrarian.net/13965716/3gp-bug.ogg

PascalC (p92) wrote :

During one cycle of codec installation ~/.xsession shows :

kaffeine: ERROR: KXineWidget: No codecs to handle media
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 19
  Minor opcode: 0
  Resource id: 0x4800001

PascalC (p92) wrote :

Process involved :

pascal 4301 4144 0 17:30 ? 00:00:00 /bin/sh -c /usr/lib/kaffeine/install-codecs ffmpeg
pascal 4302 4301 5 17:30 ? 00:00:02 /usr/bin/python /usr/lib/kaffeine/install-codecs ffmpeg

dukat (dukat) wrote :

I have a similar problem with the automatic codec installer (latest Hardy Kubuntu beta)

I've had already installed all necessary medibuntu packages (libdvdcss2, w32-codecs). I inserted a DVD, and Kaffeine informs me that I have to install libdvdcss2. Strangely enough, it gives an advice that one version is already installed. No matter if I reinstall using the codec-installer or cancel, the DVD is not played.

The same happens for AVI files I try to play. K. always want to install new codec, even though they are there. Seems it doesn't recognize medibuntu packages!

Graham Hawkins (grahamhawkins) wrote :

On my Hardy upgrade I also got the 'Kaffiene installer loop'.

But I also got another dialogue:

"xine Message - Kaffiene Player
The source can't be read.
Maybe you don't have enough rights for this, or source doesn't contain data (e.g: no disc in drive). (/dev/dvd)"

I found that the link for /dev/dvd did not exist, but the 'xine Engine Parameters' pointed to it.

A link '/dev/dvd1' did exist, and pointing the 'xine Engine Parameters->media->Beginner Options->dvd.device' at it fixed both symptoms - 'the codec install loop' & 'the can't be read'.

Beware, you seem to need to click 'Apply' before leaving the xine Engine dialogue, otherwise the changes made are lost.

Changed in kaffeine:
status: New → Confirmed
Dario Panico (dariopnc-) wrote :

I obtain the same issue with different video files, i attached a video showing what happens when opening the video.
 - Kaffeine starts to search for codecs (i installed all the codecs in gutsy - everything worked fine - but since i upgraded i can't see those videos)
 - It downloads them
 - It comes to know that they are already installed and prints an error
 - Clicking Ok makes previous steps to repeat over and over again.
 - Closing Kaffeine stops this loop

http://www.youtube.com/v/X15UqBw4xyk

I tried a $ffmpeg $VID_FILE0 $VID_FILE1 to see some relations and obtained an error about libavcodec.
I switched to kde4 to see whether dragonplayer worked, it didn't. I then removed and re-installed libavcodec1d and all dependencies.
I repeated both the ffmpeg and dragonplayer tests and they worked.
I just tried with kaffeine and it worked, too.
I think that the error was related to the upgrade of those libs.

Dario Panico (dariopnc-) wrote :

About http://www.universal-tao.com/archives/holy_water.wmv: dragonplayer works after libavcodec fix ( i don't know if it worked before), kaffeine doesn't work.

Hernan Giovagnoli (hernaaan) wrote :

I can confirm this on Kubuntu 8.04 updated to 04/05/2008 when trying to play a FLV associated with Kaffeine.

Changed in kaffeine:
status: Confirmed → Fix Released
WoodburyMan (erik-warpfactor10) wrote :

I got this error as well when attempting to play back DVDs (Even after installing libcss2 and win32codecs)However, once I installed libxine1-ffmpeg from apt, everything worked.

Divan (divan-santana) wrote :

This same problem happens for me when I try play an .asf file.
Not sure how to fix the problem, maybe I need to remove the medibuntu packages...

Divan (divan-santana) wrote :

Sorry to ask a question here, but why does the status say fix released when as far as I know the bug is still valid?
Shouldn't this bug be reopened and confirmed?

ps. I'm using 8.04 kubuntu

emil_p8 (emile-visual) wrote :

This bug is still active and "VERY" annoying ; some weeks ago i was able to play DDVDs by replacing the /dev/dvd option in xine engine parameters with /dev/scd0, but now this fix doesn't work anymore. BTW I only have problem with DVDs, other media files play fine.

I have the same problem with kaffeine. It's a fresh upgrade from Gutsy, updated @ 05/19/08 and kaffeine stills looping on the codec installation. If the fix has been already released, when it will be on the repos? and if it was already released and applied on the latest updates, please check what's wrong with it, 'cause the problem persist... :)

Xyrpon (xypron-debian) wrote :
Download full text (3.9 KiB)

The error occurs when I try to open a MPEG video on a SAMBA server by double clicking it in Dolphin.
I mounted the SAMBA share: when opening the file with the Kaffeine menu (file - open) the file was correctly displayed.

I uninstalled Kaffeine and installed http://ftp.de.debian.org/debian/pool/main/k/kaffeine/kaffeine_0.8.6-2_i386.deb.
The file could not be opened via Dolphin giving an error:
23:19:55: xine: cannot find input plugin for MRL [smb://me@192.168.123.123/share/file.mpg]
23:19:55: xine: input plugin cannot open MRL [smb://me@192.168.123.123/share/file.mpg]
23:19:55: xine: found input plugin : CIFS/SMB input plugin based on libsmbclient
The same file could be opened via the Kaffeine menu (file - open ).

Package: kaffeine
Version: 0.8.6-0ubuntu8.1

-- System Information:
Debian Release: lenny/sid
  APT prefers hardy-updates
  APT policy: (500, 'hardy-updates'), (500, 'hardy-security'), (500, 'hardy-proposed'), (500, 'hardy')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-16-generic (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages kaffeine depends on:
ii hdparm 8.6-1ubuntu1 tune hard disk parameters for high
ii kdelibs4c2a 4:3.5.9-0ubuntu7.1 core libraries and binaries for al
ii libacl1 2.2.45-1 Access control list shared library
ii libart-2.0-2 2.3.20-1 Library of functions for 2D graphi
ii libattr1 1:2.4.39-1 Extended attribute shared library
ii libaudio2 1.9.1-1 Network Audio System - shared libr
ii libc6 2.7-10ubuntu3 GNU C Library: Shared libraries
ii libcdparanoia0 3.10+debian~pre0-6 audio extraction tool for sampling
ii libfontconfig1 2.5.0-2ubuntu3 generic font configuration library
ii libfreetype6 2.3.5-1ubuntu4 FreeType 2 font engine, shared lib
ii libgcc1 1:4.2.3-2ubuntu7 GCC support library
ii libice6 2:1.0.4-1 X11 Inter-Client Exchange library
ii libidn11 1.1-1 GNU libidn library, implementation
ii libjpeg62 6b-14 The Independent JPEG Group's JPEG
ii libogg0 1.1.3-3ubuntu1 Ogg Bitstream Library
ii libpcre3 7.4-1ubuntu2 Perl 5 Compatible Regular Expressi
ii libpng12-0 1.2.15~beta5-3 PNG library - runtime
ii libqt3-mt 3:3.3.8-b-0ubuntu3 Qt GUI Library (Threaded runtime v
ii libsm6 2:1.0.3-1 X11 Session Management library
ii libstdc++6 4.2.3-2ubuntu7 The GNU Standard C++ Library v3
ii libvorbis0a 1.2.0.dfsg-2 The Vorbis General Audio Compressi
ii libvorbisenc2 1.2.0.dfsg-2 The Vorbis General Audio Compressi
ii libx11-6 2:1.1.3-1ubuntu2 X11 client-side library
ii libxcb1 1.1-1ubuntu1 X C Binding
ii libxcursor1 1:1.1.9-1 X cursor management library
ii libxext6 2:1.0.3-2build1 X11 miscellaneous extension librar
ii libxft2 2.1.12-2ubuntu5 ...

Read more...

Re: [hardy] kaffeine loops on "Codec package is already installed"

I have the same problem described here. Now i compiled the original xine_part sources (from the link on the left bar) and installed libxinepart.
After that it worked without trying to install codecs. I think the install codec ubuntu modification is not well tested.
Does someone know where i could get the ubuntu source from kaffeine to fix that problem ??

Paradoxdruid (bonham+nospam) wrote :

I have the same problem described here trying to play a clip on Amazon's MP# download section.

I freshly upgraded to Kubuntu 8.04 today, with Mediabuntu. Maybe something mediabuntu installed is at fault? No idea.

It's unfortunate to see 'fix released" when it's clearly still a problem.

Paradoxdruid (bonham+nospam) wrote :

There isn't a fix released yet, or at least not one that installs on an upgrade. More details are needed- is there an upstream fix that will come?

Changed in kaffeine:
status: Fix Released → New

POSSIBLE FIX:

- You could try to delete or rename the ~/.xine folder located on your $HOME directory, that seems to fix the problem. Kaffeine should rebuild the configuration files to their defaults and be able of use the codecs installed on the system.

It seems that this problem occur after an upgrade from earlier versions of *buntu, some packages don't properly update the xine configuration files and left them corrupted or incompatible with the new version. I don't know if this could solve the problem of the looping on the codecs installation, but probably you'll can play video files with kaffeine (if you have the codecs installed :D ).

Paradoxdruid (bonham+nospam) wrote :

Thanks for the thought, Jose Angel Bonilla. Unfortunately, it doesn't help the codec install looping. :-/

It does seem to be confined to people who upgraded from Gutsy to Hardy, so you're on the right track.

Divan (divan-santana) wrote :

I didn't upgrade from gutsy to hardy, I did a fresh install(as installed encryption) and it does it.
I did however install some packages from medibuntu.

Changed in kaffeine:
status: New → Confirmed
hede (jorgen-hede) wrote :

Looking through the possible workarounds - I still have not found any solution that works.
When I upgraded I soon discovered the error and was genuinely surprised that such fundamental error had not already been fixed or communicated out by the developers. But now after some time trying basically all the fixes I get the distinct gut(-sy??*S*) feeling the source of the problem may derive from multiple sources - of which the upgrade from Gutsy to Hardy is one.

Jiri Vosecek (jiri-vosecek) wrote :

The same problem with following URL: http://media.z1tv.cz/ (Kubuntu 8.04)

Andreas Scherf (scherfa) wrote :

Here is the problem code :
it is located in xinewidget ... and xine reports an unhandled stream ...
and this function is called in the play function of kaffeine ... so while playing a video
it endlessly try's to install a codec .. maybee we shoud store a already installed value
in the kaffeine settings so that unhandledStreamsPresent() doesnt return False if the codecs are already installed ....

Could anyone send me the patched sources of kaffeine because i did not know how to patch the original sources ...

bool KXineWidget::unhandledStreamsPresent()
{
unsigned int hasAudio = xine_get_stream_info(m_xineStream, XINE_STREAM_INFO_HAS_AUDIO);
unsigned int hasVideo = xine_get_stream_info(m_xineStream, XINE_STREAM_INFO_HAS_VIDEO);

 return (hasAudio && !xine_get_stream_info(m_xineStream, XINE_STREAM_INFO_AUDIO_HANDLED)) ||
  (hasVideo && !xine_get_stream_info(m_xineStream, XINE_STREAM_INFO_VIDEO_HANDLED));
}

void KXineWidget::slotPlay()
{
 if ((!isXineReady()) || (isQueueEmpty()))
   return;
  }

if (unhandledStreamsPresent())
{
  errorOut("No codecs to handle media");
  sendXineError();
  return;
}
}

dozer (matthew-pocock) wrote :

I get the same error, with some but not all AVI files and with some but not all CD images. I have a clean installation of hardy on intel. Right now, it's preventing me from watching episode 19 of 20 in a season of atlantis, which is annoying as it's the 2nd part of a 2 parter.

The codec package is already installed loop seems to be broken if you play another movie.

2Jacarta: you are absolutely right. Actually the best solution is to check some stream parameters (like codec ID, dunno), less good is to check extensions or just remember the installation fact. Your way have a serious flaw: the package can be removed from the system and kaffeine will not install it again. I can do something with this when the work on intrepid packaging will be finished. Appreciate your deep investigation.

usr (usrlp) wrote :

Once again, I think that this feature is implemented with haste in Kubuntu, and knowing that it would not work well.

I think what happens is this:
1 .- Kaffeine can not play a file.
2 .- Kaffeine try installing libxine1-ffmpeg.
3 .- Kaffeine said he installed.
4 .- Kaffeine tries to play the file. And back to point number one.

We always are treated as second-class users.
Mr. Shuttleworth, Kubuntu needs more developers! Or stop this sencond-class distribution.

Support Kubuntu and KDE to the same way that you support Ubuntu and GNOME: http://brainstorm.ubuntu.com/idea/478/

usr (usrlp) wrote :

Kaffeine codec installer bug: infinite loop in ".3gp" codec installation.
Error message: "Error: Codec package is already installed."

Similar problem in ".rm" codec installation.

I use a clean installation of Kubuntu 8.04-KDE3 for i386.

description: updated
exogenetic (exogenetic) wrote :

For whatever it is worth. When I installed Kaffeine under Gnome, I had no such problem. Just as soon as I installed the Kubuntu Desktop, I started getting the endless codec loop. I hope this helps track down the problem.

Also, I tried doing a complete uninstall (incl configuration files) of the Kubuntu Desktop and all the dependencies I could find of it. After going through the tedious process of uninstalling every KDE package I could think of, the problem persisted under Gnome.

I have a Compaq Presario Laptop (1.5GHz Pentium M, 512MB 400MHz) that I might be convinced to use as a guinea pig if anybody has some ideas they'd like me to try. The machine is practically new. I'm going to wipe and reload the thing to test various operating systems. Why not yours?

WARNING: I only check this email weekly, usually on Sundays. I'll try giving it a check a little more often, say Wednesdays and Sundays.

Ubuntu is way overextended. Some things must be cut, but not KDE.

usr (usrlp) wrote :

Dear Martin,
I am a KDE & Kubuntu user, but Kubuntu is the worst KDE-distro. I use Kubuntu because I like very much KDE and APT and a up-to-date system, but Ubuntu's tools are bad implemented in KDE.

I love Kubuntu because is a Debian-like up-to-date KDE distro. But Kubuntu does not do honor to KDE, and this bug is another example.
A greeting.

ajf (anton-fluegge) wrote :

Is there any solution to the problem by now? Or if xine is the problem, is there any non-xine based videoplayer to watch videos online? (I thought you might could use gstreamer backend for kaffeine, but if I attempt to install the kaffeine-gstreamer package, it still installs xine...)

Would be nice to watch videos again.

Cheers,
ajf

Floyd B. (fbufkin) wrote :

Try VLC.

ajf (anton-fluegge) wrote :

VLC does not play the video-stream but just says "(no video)". I found a website in german (http://wiki.ubuntuusers.de/Streaming), which told me that this is a known problem and that VLC has problems with some streams.

- ajf

The same problem on fresh install of kubuntu 8.04.1 on Asus Eeepc 900 (kernel 2.6.24-20-eeepc).

The interesting aspect: the "installation-loop" happens when I try to open non-trivial media file from samba share. By non-trivial I mean .mp4 video file (sound AAC, video x264).

However, usual .avi (xvid, mp3) from same share works well.

And - important point - this is no such bug when I try to open the very same .mp4 being copied from samba share into the local drive.

I.e., summary:

1. trying to play smb://someshara/video.mp4 - causes installation loop.
2. trying to play ~/video/video.mp4 - plays ok.

Evan Leibovitch (evan-telly) wrote :

I experienced the same problem after doing a Medibuntu-recommended security upgrade of its ffmpeg and a number of its library packages. After installing the following packages as updates, I encountered this bug in Kaffeine:

ffmpeg_3%3a0.cvs20070307-5ubuntu7+medibuntu1.1_i386.deb
libavcodec1d_3%3a0.cvs20070307-5ubuntu7+medibuntu1.1_i386.deb
libavformat1d_3%3a0.cvs20070307-5ubuntu7+medibuntu1.1_i386.deb
libavutil1d_3%3a0.cvs20070307-5ubuntu7+medibuntu1.1_i386.deb
libpostproc1d_3%3a0.cvs20070307-5ubuntu7+medibuntu1.1_i386.deb
libswscale1d_3%3a0.cvs20070307-5ubuntu7+medibuntu1.1_i386.deb

Deleting ~/.xine and restarting Kaffeine solved the problem.

I will report this to the Medibuntu folks as well.

TheReaperD (djones) wrote :

For the DVD playback issue (getting the error even after "libdvdcss2" is installed), oddly enough, installing "libxine1-ffmpeg" from Adept did resolve the issue. So, if you're having the error, give it a try.

I deleted my ~/.xine directory as well as adding the medibuntu repositories and everything seems to work correctly except:

.asx files, where I get the missing codec dialog problem. However, when I open the file up in a text editor and paste the actual video URL , it works fine.

Invalid URLs also produce the same missing codec dialog. e.g. http://www.some-invalid-url.org/file.mp3

Thomas Sperre (thcsp) wrote :

I get this codec installer never ending loop problem like whenever I try to play some asx files too. I know I also get the problem with other file types, but I am 100% certain I get it with asx files that contain mms protocol references to wmw files. This is a fairly common way for wrapping media streams I think.
Trying to look into possible causes I have noticed that if I do a
apt-cache search xine aa few packages which are listed include libxine-ffmpeg. However when trying to do
apt-get install libxine-ffmpeg it is not there....
(yes I had the medibuntu repository enabled)
Is it possible that this has created some unreported problems during an upgrade which later leads to all the codec installation neverendings?

flaccid (chris-xhost) wrote :

This bug is over 4 months old, is severe and makes (K)ubuntu look bad.
It was cool to introduce an automatic plugin installer, but its only cool if it works.
How can we get someone to fix this?

Rastafar (xgeorge) wrote :

Yes, this one is VERY VERY annoying!!! For example I'm unable to play for example DV files (avi captured from digital camera), I always get the damned codec loop! On both my computers - one of them upgraded from 7.xx version of kubuntu, one of them clan 8.04 installation.

I'm able to open them in KINO with no prblm, buf not with avidemux (here I get error "Attempt to open <path_to _my_avi> failed", ater I click OK I get "Could not pen the file". After OK I get back to avidemux...

When try to play the same file with mplayer, I get err "AVI_NI: No video stream found!", but the file plays normally.

In xine player I get this (translated from czech so it is not exact wording):
=====
xine engine error
no demultiplex module for file <path_to_my_file> found. This usually means that file format was not recognized.
=====

when I click "more..." button I get: see xine1.png attached

so there is some problem with xine itself I think...

please help, very annoying bug....

raphi78 (trance202) wrote :

I have the same issue (aktual system @ 27.08.2008)
When will this be fixed?

Changed in kaffeine:
assignee: nobody → trance202
usr (usrlp) wrote :

You are not coder.

Changed in kaffeine:
assignee: trance202 → nobody
flaccid (chris-xhost) wrote :

Surely someone will fix this critical bug.

josedorrego (josedorrego) wrote :

I think this has something to do with the file that generates the "/dev/dvd" during startup. I don't remember that file's name, but I think a friend of mine solve this issu deleting some lines from that file. (It would regenerate during next bootup). Anyone knows the name of the file wich generates the "/dev/dvd" link during startup???

actually this was fixed long time ago (right after hardy release), but
for some reasons my debdiff still haven't reached the hardy updates :(

Yuriy Kozlov (yuriy-kozlov) wrote :

Serega, where is this debdiff? Was it attached to some bug?

Pat (patricksissons) wrote :

since nobody feels like addressing this issue, i decided to do it myself. While i didn't fix the issue (i simply don't have that kind of time), i did enough work on it to get things working properly. the bug is indeed with escaped characters, i believe the URI is corrupted on its way through the dcop server.

A full detailed report plus a downloadable deb for hardy is viewable on my blog at http://blog.errorok.com/2008/08/31/39/

> Serega, where is this debdiff? Was it attached to some bug?

Yuriy, unfortunately I haven't attached the diff to any bug. I was
placed it to kubuntu.pastebin.ca and have given the link to Riddell. He
was reviewed it and said it's ok. This was going to come to
hardy-proposed and then to hardy-updates. After this I was asking about
the debdiff's fate several times with no luck :( (See #kubuntu-devel
logs for 4-5 May 2008).

Worse, looks like I missed my local copy of that changes (but I need to
look twice though). Pastebin, of course, is already expired.

gUI (guillaume-betous) wrote :

Thanx to TheReaperD !

I just installed "libxine1-ffmpeg" and I can now read DVD (after trying a thounsand of different recipies, suach a .xine remove, libdvdcss2 resintall in differents ways...)

Changed in kaffeine:
importance: Undecided → High
TWO (two) wrote :

I've been redirected to this bug report as I submitted one earlier (https://bugs.launchpad.net/ubuntu/+source/kaffeine/+bug/269359) with regard to this problem happening with .mov files.

Further to my bug report, it seems that the problem is intermittent when it comes to .mov files. I downloaded a few more just to test the problem, and with one of the .mov files Kaffeine played without a problem. The same was true of another file that I downloaded, however upon clicking 'x' to close that particular instance of Kaffeine, the program would crash and give the backtrace error that I have provided as an attachment.

I am a little baffled as to why the chances of playback should vary from file to file in spite of them all being the same file type.

Murz (murznn) wrote :

Confirm this bug on Kubuntu Hardy I386 with last updates. Kaffeine always try to updates and shows that all updates in installed, after that it start codec update again.

flaccid (chris-xhost) wrote :

It's approaching 5 months since bug was reported. No wonder Kubuntu is still a disrespected KDE distro if this is what you get when you install and go to play a media file..

Kaffeine is important because of its streaming protocol support (amongst other things) but this literally kills it rendering it unuseable for a lot of people. Please can we apply the fix and get it in the repos or whatever is required!

I was also able to reproduce this bug. on 2008-09-16.

A possible workaround is to switch to the gstreamer engine and use the necessary g-streamer dependencies for the codecs. Install kaffeine-gstreamer, Run kaffeine, Click Settings->Player Engine->Kaffeine-GStreamer. I have the fluendo codecs so that worked for me, although I'm pretty sure that I have all the g-streamer-plugins-* packages installed

Andreas Scherf (scherfa) wrote :

This is very ugly ... i posted a fix for this problem a few months ago.
After that i compiled the original packaged of kaffeine to stop this failure.
But i can not understand why nobody from the kubuntu team would fix this. It is impossible for a normal user to understand.
Is Kubuntu out of sight? Should i move to an other KDE distro or what is the meaning of this ... ?
Im speachless ---

flaccid (chris-xhost) wrote :

@Jakarta yeah I agree. Ubuntu is very political imo and Kubuntu does not get the attention it requires nor the respect. I also recall highlighting this bug out to some 'leaders' of Kubuntu months ago like at least one other person did on this bug, but no response.

Jonathan Riddell is subscribed to this bug and hasn't done anything although Sergey had notified him in May with a fix ( https://bugs.launchpad.net/ubuntu/+source/kaffeine/+bug/210303/comments/46 ).

People should get real and practical and just go to OpenSUSE, Gentoo or PC-BSD because this makes Kubuntu worse than MS Windows - at least its media player works.

TWO (two) wrote :

I don't think it's fair to go that far people. It is indeed very annoying that there doesn't seem to be any official movement on this bug, but patience is a virtue, right?

There are plenty of other media players out there and I'm sure we're all capable of using other ones until the problem with Kaffeine is fixed.

In the meantime, I think that those who have the expertise to find a fix should do so and then share this with the rest of us who aren't so gifted. Maybe then the Kubuntu Team will take notice.

If people give up and walk away, nothing will ever get solved.

Andreas Scherf (scherfa) wrote :

@TWO. Ok there are other players thats right. But some time ago i had the smae problem with Adept.
And, the fix is ready. Is there a problem with building fixed packages for (k)ubuntu? On ubuntu bugs were fixed faster.
It is very annoying that such a thing would take >6 months to release this fix. So i could not recommend kubuntu to normal users who have no chance to fix it on their own.
I would offer my help but it seems that nobody really whant that ... :-(

flaccid (chris-xhost) wrote :

@TWO

A few things to help you understand better:

* There was some official movement and at least 2 people told officials who did nothing
* 5 months is beyond patience especially when a fix was available months ago and simply needed to be committed. Response times by projects such as Mozilla's Firefox are usually days or weeks not months for example
* No we are not all capable. Kubuntu is for end users as well. Ubuntu uses the term 'Linux for human beings'. Most of the other media players don't support smb and are not KDE based, but the point here is that newbies/non-technical people/windows users don't know how to install software nor will think they should have to, and they are right!
* There is a fix, we are just having problems with someone committing it despite how many people have this authority on this thread
* As you can see people are not giving up, nor walking away, instead they are complaining because of lack of action. This is normal human behaviour and pressuring is one way to get movement in this world.

Harald Sitter (apachelogger) wrote :

Interesting enough, that I am getting pretty pissed about this bug, despite the fact that I don't even use kaffeine.

Marking importance Critical. Targeting 8.10. If we can't come up with a reasonable fix I will propose to drop the feature.

Changed in kaffeine:
importance: High → Critical
milestone: none → ubuntu-8.10
flaccid (chris-xhost) wrote :

@apachelogger (Harald) there was a fix.

Harald Sitter (apachelogger) wrote :

Where?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kaffeine - 0.8.6-2ubuntu2

---------------
kaffeine (0.8.6-2ubuntu2) intrepid; urgency=low

  * Fix install-codecs (LP: #210303)
    - Added some returns and use KDE 4's kdesu and the new install-package
  * Recommend kdebase-runtime and install-package for install-codecs
  * Final newlines for kaffeine-gstreamer.install and KUBUNTU-DEBIAN-DIFF
  * quilt refresh

 -- Harald Sitter <email address hidden> Mon, 22 Sep 2008 12:24:21 +0200

Changed in kaffeine:
status: Confirmed → Fix Released
usr (usrlp) wrote :

Hallelujah!

Harald Sitter (apachelogger) wrote :

Hardy patch

description: updated
flaccid (chris-xhost) wrote :

@Harald
Where did you get that from?
If it only goes in Intrepid it will mean that the media player for Hardy was broken the whole release!
I think this is indicative of Kubuntu's low level of quality. I mean apparently there is a quality assurance team and testing etc. and yet this bug got through no problem..

Harald Sitter (apachelogger) wrote :

From the kubuntu-team-can-actually-fix-stuff department.
Yes it was, and still is until the ubuntu-sru team grants a stable release update.
QA is a preventive kind of maintenance, one can live without it, but one can't without actual maintenance. Seeing how long this bug was _not_ fixed, I think that is the real problem.

María (delawen) wrote :

So, the bug will not be fixed on Hardy? Because I don't want to upgrade yet to intrepid. I don't want to be *forced* to upgrade to Intrepid while Hardy is still maintained officially. And this is a big bug.

flaccid (chris-xhost) wrote :

I'd like to be advised why its not going to be included in the current production release (hardy).
I'm sure it would only take a few minutes to do so.

Because at the moment its a case of "Our media player for our operating system didn't work during the entire release, we couldn't fix it until the next release over 6 months later, ah well".

Terence Simpson (tsimpson) wrote :

Nowhere in the sentence "Yes it was, and still is until the ubuntu-sru team grants a stable release update." does it say "This will never be fixed for Hardy". It will once it has been grated an SRU.

flaccid (chris-xhost) wrote :

Actions speak louder than words.

Martin Pitt (pitti) wrote :

Sure it is. It just seems that nobody actually uploaded this, or asked for a sponsor. I sponsored the fix now.

Changed in kaffeine:
status: New → In Progress
Martin Pitt (pitti) wrote :

Argh, reuploaded as 8.3, since someone screwed up and used 8.2 in intrepid.

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kaffeine:
status: In Progress → Fix Committed
Cesare Tirabassi (norsetto) wrote :

Package in -updates loops forever.
Package in -proposed behaves as in test description.

flaccid (chris-xhost) wrote :

@Martin lots of authoritive people were/are subscribed to this bug that could of uploaded or sponsored it months ago! A few people also advised this on IRC as well as per the messages above.

Aitor Moreno (aitormoreno) wrote :

After 8.3, the loop stops, but I still have the same problem, but only once.

Scenario:

1 - SVCD or VCD (both) in HDD.
2 - Kaffeine. Open Folder, choose the SVCD folder.
3 - Kaffeine search an installs the codec, finishing with "codec already installed"
4 - The SVCD *is not played*
5 - Pressing Play button, again step 3

Harald Sitter (apachelogger) wrote :

Well, to be honest there is more usability tweaking to be done. The behaviour Aitor is experiencing is however intended. Currently the codec installer doesn't track whether it was executed already, if it installed packages successful or if it was already executed for the same file. Thus the only sensible and stable solution is to just assume that you try playing a file, if it can't be played back, kaffeine tries to install an appropriate codec and if it still can't be played back it just aborts. This approach also makes most sense when pushing updates to the list of installable package, otherwise one would need to introduce a lot more magic.

In short, the SVCD just can't be played back, probably because it got some encryption.

Aitor Moreno (aitormoreno) wrote :

@Harald. It is strange, because opening the video file itself (avseq01.dat), all players play the VCD correctly. Till I get another VCD, I will assume that it is a bad VCD format.

Anyway, kaffeine shows that same info "codec already installed", and I agree that it is a usability error, since that info is wrong. Maybe a new bug should be opened (with low priority, as it is not very important).

flaccid (chris-xhost) wrote :

Looks like it needs a better algorithm.

After a long time with kaffine in detoriation - the Kubuntu project
should consider if the player has a place in future distributions

2008/10/2, Aitor Moreno <email address hidden>:
> After 8.3, the loop stops, but I still have the same problem, but only
> once.
>
> Scenario:
>
> 1 - SVCD or VCD (both) in HDD.
> 2 - Kaffeine. Open Folder, choose the SVCD folder.
> 3 - Kaffeine search an installs the codec, finishing with "codec already
> installed"
> 4 - The SVCD *is not played*
> 5 - Pressing Play button, again step 3
>
> --
> [hardy] kaffeine loops on "Codec package is already installed"
> https://bugs.launchpad.net/bugs/210303
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "kaffeine" source package in Ubuntu: Fix Released
> Status in kaffeine in Ubuntu Hardy: Fix Committed
> Status in kaffeine in Ubuntu Intrepid: Fix Released
>
> Bug description:
> SRU description:
> 1. This bug makes Kaffeine's auto-codec installation loop for media which
> can't be played back with libxine1-ffmpeg or libdvdcss (e.g. recent versions
> of WM* or MOV)
> 2. In the development branch we introduced 2 'returns' in the python script
> responsible for handling the codec installation (0.8.6-2ubuntu2)
> 3. Patch attached
> 4. TEST CASE:
> * Install Kaffeine
> * Try opening http://www.nasa.gov/mov/229743main_parachute-640.mov with
> kaffeine
> * The codec installer should pop-up and ask whether to install the
> appropriate codec
> * The installer will pop-up again and notify you that the available
> codecs are already installed
> * The file will still not be playable, but the installer shouldn't loop
> 5. No regression potential because the returns are additions to
> QApplication.exit(1) functions.
>
> Binary package hint: kaffeine
>
> When I try to play the following file with kaffeine, it says "installing
> codec" and fails with "Codec package is already installed"
> then it begin again to reinstall the Codec
> this forever. I have to kill kaffeine.
>
> http://www.universal-tao.com/archives/holy_water.wmv
>
> A video of the bug with a 3gp file:
> http://launchpadlibrarian.net/13965716/3gp-bug.ogg
>

Harald Sitter (apachelogger) wrote :

Ok
@flaccid, stop going off-topic we are trying to get test feedback here

@hede, please also don't go off-topic, and for the record, Kubuntu 8.10 doesn't ship Kaffeine by default.

flaccid (chris-xhost) wrote :

@Harald sounds very on topic to me. Bad algorithms are a common reason why workflows like this fail in their logic and need to be re-factored.
Also, just because its not default doesn't mean that its not supported.

Martin Pitt (pitti) wrote :

So can this bug be considered "sufficiently" fixed to move the fixed kaffeine to hardy-updates? Or should the update be pulled again, and a better fix be attempted?

Aitor Moreno (aitormoreno) wrote :

@Martin This bug is related the "kaffeine loops on <Codec package is already installed>". And the loop has been solved. Besides this, there is still a usability bug, related to this bug, but different. I don't know if this means that the bug can be closed, a new bug should be opened or any other different action.

Harald Sitter (apachelogger) wrote :

Aitor, please open a new bug, the loop itself is resolved. The usability issue, which is a side effect of the loop, is a different task to fix.

Aitor Moreno (aitormoreno) wrote :

As Harald suggested, a new bug in https://bugs.launchpad.net/ubuntu/+source/kaffeine/+bug/279072 has been created.
check if it the bug situation is correctly described.

Martin Pitt (pitti) wrote :

Thanks for the heads-up. Copied to hardy-updates.

Changed in kaffeine:
status: Fix Committed → Fix Released
HousieMousie2 (housiemousie2) wrote :

On a previous installation of Hardy KDE3, via Live CD, Kaffeine worked fine.
On my current installation of Hardy KDE, via The Same Live CD, Kaffeine refuses to use the installed libdvdcss2.

Producing the following message:
"This DVD Video is encrypted. To be able to watch it you will need to install libdvdcss by running from a console: sudo /usr/share/doc/kaffeine/install-css.sh. In some countries it is illegal to install the decryption software without permission from the video copyright holder."

The libdvdcss2 installed is the latest version from medibuntu repos... libxine1-ffmpeg is also installed.
If I follow Kaffeine's suggestions, it installs an older version, neither work.
This is not exactly the "kaffeine loops on "Codec package is already installed" " issue, but has been commented on here.

Has this issue been fixed and if so, is it in the repos?

John Cottier (j-cottier) wrote :

It does not work for me. Kaffeine still gives the same error message on certain media (EG http://www.nasa.gov/multimedia/nasatv/), mplayer works fine on the same media but has little functionality.

affects: kaffeine (Ubuntu) → libart-lgpl (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers