Activity log for bug #1740637

Date Who What changed Old value New value Message
2017-12-30 22:05:41 Jeremy Bicha bug added bug
2017-12-30 22:08:48 Launchpad Janitor branch linked lp:~jbicha/libappindicator/drop-python-appindicator
2017-12-30 22:12:45 Launchpad Janitor branch linked lp:~ci-train-bot/libappindicator/libappindicator-ubuntu-bionic-3094
2018-01-03 14:14:21 Jeremy Bicha tags py2-removal
2018-03-29 13:44:27 Jeremy Bicha description gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection) After removals are processed for other reasons, there are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and gtk-recordmydesktop) are scheduled for autoremoval from Debian Testing in February because they use pygtk. $ reverse-depends python-appindicator Reverse-Recommends ================== * deluge-gtk * gpodder — should be fixed once 3.10.0 is packaged * gtk-recordmydesktop * sbackup-gtk — RM requested in LP: #1739800 * winswitch — RM requested in LP: #1739797 Reverse-Depends =============== * aws-status — RM requested in LP: #1739797 * cherrytree — RM requested in LP: #1731725 * glipper — RM requested in LP: #1739800 * hamster-indicator — source is hamster-applet, RM requested in LP: #1739797 * python-seelablet — RM requested in LP: #1740631 -------------------------- OTHER GTK2 REVERSE DEPENDS -------------------------- The other gtk2 libraries for libappindicator aren't planned for removal yet. $ reverse-depends libappindicator0.1-cil Reverse-Depends =============== * banshee-extension-appindicator * libappindicator0.1-cil-dev * tasque * tomboy $ reverse-depends libappindicator1 Reverse-Recommends ================== * nautilus-dropbox * telegram-desktop Reverse-Depends =============== * alarm-clock-applet * clipit * gir1.2-appindicator-0.1 (proposed removal here) * gmpc * gnome-ppp * growl-for-linux * guake-indicator * gxkb * hime * indicator-application-gtk2 * libappindicator-dev * libappindicator0.1-cil * libgtk2-appindicator-perl (shutter is the only rdepends here, shutter still depends on libgnome though) * linuxdcpp * nitroshare * parcellite * python-appindicator (proposed removal here) * quicksynergy * wallch gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection) After removals are processed for other reasons, there are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and gtk-recordmydesktop) are scheduled for autoremoval from Debian Testing in February because they use pygtk. $ reverse-depends python-appindicator Reverse-Recommends ================== * deluge-gtk * gtk-recordmydesktop Reverse-Depends =============== * cherrytree — RM requested in LP: #1731725 (dependency on python-appindicator was already dropped early in bionic) * hamster-indicator — source is hamster-applet, RM requested in LP: #1739797 -------------------------- OTHER GTK2 REVERSE DEPENDS -------------------------- The other gtk2 libraries for libappindicator aren't planned for removal yet. $ reverse-depends libappindicator0.1-cil Reverse-Depends =============== * banshee-extension-appindicator * libappindicator0.1-cil-dev * tasque * tomboy $ reverse-depends libappindicator1 Reverse-Recommends ================== * nautilus-dropbox * telegram-desktop Reverse-Depends =============== * alarm-clock-applet * clipit * gir1.2-appindicator-0.1 (proposed removal here) * gmpc * gnome-ppp * growl-for-linux * guake-indicator * gxkb * hime * indicator-application-gtk2 * libappindicator-dev * libappindicator0.1-cil * libgtk2-appindicator-perl (shutter is the only rdepends here, shutter still depends on libgnome though) * linuxdcpp * nitroshare * parcellite * python-appindicator (proposed removal here) * quicksynergy * wallch
2018-11-23 16:46:20 Launchpad Janitor branch linked lp:~ci-train-bot/libappindicator/libappindicator-ubuntu-disco-3094
2018-11-23 17:14:34 Jeremy Bicha description gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection) After removals are processed for other reasons, there are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and gtk-recordmydesktop) are scheduled for autoremoval from Debian Testing in February because they use pygtk. $ reverse-depends python-appindicator Reverse-Recommends ================== * deluge-gtk * gtk-recordmydesktop Reverse-Depends =============== * cherrytree — RM requested in LP: #1731725 (dependency on python-appindicator was already dropped early in bionic) * hamster-indicator — source is hamster-applet, RM requested in LP: #1739797 -------------------------- OTHER GTK2 REVERSE DEPENDS -------------------------- The other gtk2 libraries for libappindicator aren't planned for removal yet. $ reverse-depends libappindicator0.1-cil Reverse-Depends =============== * banshee-extension-appindicator * libappindicator0.1-cil-dev * tasque * tomboy $ reverse-depends libappindicator1 Reverse-Recommends ================== * nautilus-dropbox * telegram-desktop Reverse-Depends =============== * alarm-clock-applet * clipit * gir1.2-appindicator-0.1 (proposed removal here) * gmpc * gnome-ppp * growl-for-linux * guake-indicator * gxkb * hime * indicator-application-gtk2 * libappindicator-dev * libappindicator0.1-cil * libgtk2-appindicator-perl (shutter is the only rdepends here, shutter still depends on libgnome though) * linuxdcpp * nitroshare * parcellite * python-appindicator (proposed removal here) * quicksynergy * wallch gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection) There are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and gtk-recordmydesktop) will probably be removed from Debian approx. September 2019 because they use pygtk. $ reverse-depends python-appindicator Reverse-Recommends ================== * deluge-gtk * gtk-recordmydesktop previous reverse depends ----------------------- * cherrytree — dependency on python-appindicator was dropped early in bionic. RM requested in LP: #1731725 * hamster-indicator - source package was removed (LP: #1739797) -------------------------- OTHER GTK2 REVERSE DEPENDS -------------------------- The other gtk2 libraries for libappindicator aren't planned for removal yet. $ reverse-depends libappindicator0.1-cil Reverse-Depends =============== * banshee-extension-appindicator * libappindicator0.1-cil-dev * tasque * tomboy tomboy & banshee are being removed (LP: #1771025) $ reverse-depends libappindicator1 Reverse-Recommends ================== * nautilus-dropbox Reverse-Depends =============== * alarm-clock-applet * gir1.2-appindicator-0.1 (proposed removal here) * gmpc * growl-for-linux * gxkb * hime * indicator-application-gtk2 * libappindicator-dev * libappindicator0.1-cil * nitroshare * parcellite * python-appindicator (proposed removal here) * quicksynergy * wallch
2018-11-23 17:15:34 Jeremy Bicha description gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection) There are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and gtk-recordmydesktop) will probably be removed from Debian approx. September 2019 because they use pygtk. $ reverse-depends python-appindicator Reverse-Recommends ================== * deluge-gtk * gtk-recordmydesktop previous reverse depends ----------------------- * cherrytree — dependency on python-appindicator was dropped early in bionic. RM requested in LP: #1731725 * hamster-indicator - source package was removed (LP: #1739797) -------------------------- OTHER GTK2 REVERSE DEPENDS -------------------------- The other gtk2 libraries for libappindicator aren't planned for removal yet. $ reverse-depends libappindicator0.1-cil Reverse-Depends =============== * banshee-extension-appindicator * libappindicator0.1-cil-dev * tasque * tomboy tomboy & banshee are being removed (LP: #1771025) $ reverse-depends libappindicator1 Reverse-Recommends ================== * nautilus-dropbox Reverse-Depends =============== * alarm-clock-applet * gir1.2-appindicator-0.1 (proposed removal here) * gmpc * growl-for-linux * gxkb * hime * indicator-application-gtk2 * libappindicator-dev * libappindicator0.1-cil * nitroshare * parcellite * python-appindicator (proposed removal here) * quicksynergy * wallch gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection) There are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and gtk-recordmydesktop) will probably be removed from Debian approx. September 2019 because they use pygtk. $ reverse-depends python-appindicator Reverse-Recommends ================== * deluge-gtk * gtk-recordmydesktop previous reverse depends ----------------------- * cherrytree — dependency on python-appindicator was dropped early in bionic. RM requested in LP: #1731725 * hamster-indicator - source package was removed (LP: #1739797) -------------------------- OTHER GTK2 REVERSE DEPENDS -------------------------- The other gtk2 libraries for libappindicator aren't planned for removal yet. $ reverse-depends libappindicator0.1-cil Reverse-Depends =============== * banshee-extension-appindicator * libappindicator0.1-cil-dev * tasque * tomboy tomboy & banshee are being removed (LP: #1771025) $ reverse-depends libappindicator1 Reverse-Recommends ================== * nautilus-dropbox Reverse-Depends =============== * alarm-clock-applet * gir1.2-appindicator-0.1 (proposed removal here) * gmpc * growl-for-linux * gxkb * hime * indicator-application-gtk2 * libappindicator-dev * libappindicator0.1-cil * nitroshare * parcellite * python-appindicator (proposed removal here) * quicksynergy * wallch
2018-11-23 17:16:06 Jeremy Bicha branch unlinked lp:~ci-train-bot/libappindicator/libappindicator-ubuntu-bionic-3094
2019-01-17 15:25:03 Jeremy Bicha description gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection) There are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and gtk-recordmydesktop) will probably be removed from Debian approx. September 2019 because they use pygtk. $ reverse-depends python-appindicator Reverse-Recommends ================== * deluge-gtk * gtk-recordmydesktop previous reverse depends ----------------------- * cherrytree — dependency on python-appindicator was dropped early in bionic. RM requested in LP: #1731725 * hamster-indicator - source package was removed (LP: #1739797) -------------------------- OTHER GTK2 REVERSE DEPENDS -------------------------- The other gtk2 libraries for libappindicator aren't planned for removal yet. $ reverse-depends libappindicator0.1-cil Reverse-Depends =============== * banshee-extension-appindicator * libappindicator0.1-cil-dev * tasque * tomboy tomboy & banshee are being removed (LP: #1771025) $ reverse-depends libappindicator1 Reverse-Recommends ================== * nautilus-dropbox Reverse-Depends =============== * alarm-clock-applet * gir1.2-appindicator-0.1 (proposed removal here) * gmpc * growl-for-linux * gxkb * hime * indicator-application-gtk2 * libappindicator-dev * libappindicator0.1-cil * nitroshare * parcellite * python-appindicator (proposed removal here) * quicksynergy * wallch gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection) There are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and gtk-recordmydesktop) will probably be removed from Debian approx. September 2019 because they use pygtk. $ reverse-depends python-appindicator Reverse-Recommends ================== * deluge-gtk * gtk-recordmydesktop previous reverse depends ----------------------- * cherrytree — dependency on python-appindicator was dropped early in bionic. RM requested in LP: #1731725 * hamster-indicator - source package was removed (LP: #1739797) -------------------------- OTHER GTK2 REVERSE DEPENDS -------------------------- The other gtk2 libraries for libappindicator aren't planned for removal yet. $ reverse-depends libappindicator0.1-cil Reverse-Depends =============== * libappindicator0.1-cil-dev * tasque $ reverse-depends libappindicator1 Reverse-Recommends ================== * nautilus-dropbox Reverse-Depends =============== * alarm-clock-applet * gir1.2-appindicator-0.1 (proposed removal here) * gmpc * growl-for-linux * gxkb * hime * indicator-application-gtk2 * libappindicator-dev * libappindicator0.1-cil * nitroshare * parcellite * python-appindicator (proposed removal here) * quicksynergy * wallch
2019-10-26 11:05:26 Sean Davis bug added subscriber Sean Davis
2019-11-03 18:07:07 Launchpad Janitor libappindicator (Ubuntu): status New Confirmed
2019-11-03 20:47:17 Matthias Klose nominated for series Ubuntu Focal
2019-11-03 20:47:17 Matthias Klose bug task added libappindicator (Ubuntu Focal)
2019-11-03 20:47:35 Matthias Klose libappindicator (Ubuntu Focal): importance Undecided High
2019-11-03 20:47:49 Matthias Klose tags py2-removal py2-removal rls-ff-incoming
2019-11-04 11:55:07 Alberts Muktupāvels bug added subscriber Alberts Muktupāvels
2019-11-05 14:45:46 Sebastien Bacher libappindicator (Ubuntu Focal): assignee Sebastien Bacher (seb128)
2019-11-19 14:47:03 Sebastien Bacher tags py2-removal rls-ff-incoming py2-removal