Remove python-appindicator and gir1.2-appindicator-0.1

Bug #1740637 reported by Jeremy Bicha on 2017-12-30
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libappindicator (Ubuntu)
High
Sebastien Bacher
Focal
High
Sebastien Bacher

Bug Description

gir1.2-appindicator-0.1 has no reverse dependencies (it is for gtk2 GObject Introspection)

There are only 2 packages that recommend python-appindicator. It would be trivial to drop the recommends. Those 2 packages (deluge and
gtk-recordmydesktop) will probably be removed from Debian approx. September 2019 because they use pygtk.

$ reverse-depends python-appindicator
Reverse-Recommends
==================
* deluge-gtk
* gtk-recordmydesktop

previous reverse depends
-----------------------
* cherrytree — dependency on python-appindicator was dropped early in bionic. RM requested in LP: #1731725
* hamster-indicator - source package was removed (LP: #1739797)

--------------------------
OTHER GTK2 REVERSE DEPENDS
--------------------------
The other gtk2 libraries for libappindicator aren't planned for removal yet.

$ reverse-depends libappindicator0.1-cil
Reverse-Depends
===============
* libappindicator0.1-cil-dev
* tasque

$ reverse-depends libappindicator1
Reverse-Recommends
==================
* nautilus-dropbox

Reverse-Depends
===============
* alarm-clock-applet
* gir1.2-appindicator-0.1 (proposed removal here)
* gmpc
* growl-for-linux
* gxkb
* hime
* indicator-application-gtk2
* libappindicator-dev
* libappindicator0.1-cil
* nitroshare
* parcellite
* python-appindicator (proposed removal here)
* quicksynergy
* wallch

Related branches

Jeremy Bicha (jbicha) on 2018-01-03
tags: added: py2-removal
Jeremy Bicha (jbicha) on 2018-03-29
description: updated
Jeremy Bicha (jbicha) on 2018-11-23
description: updated
description: updated
Jeremy Bicha (jbicha) on 2019-01-17
description: updated
Sean Davis (bluesabre) wrote :

Is this still planned for the 20.04 cycle?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libappindicator (Ubuntu):
status: New → Confirmed
Matthias Klose (doko) on 2019-11-03
Changed in libappindicator (Ubuntu Focal):
importance: Undecided → High
tags: added: rls-ff-incoming
Changed in libappindicator (Ubuntu Focal):
assignee: nobody → Sebastien Bacher (seb128)
tags: removed: rls-ff-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libappindicator - 12.10.1+18.04.20180322.1-0ubuntu5

---------------
libappindicator (12.10.1+18.04.20180322.1-0ubuntu5) focal; urgency=medium

  * configure.ac: require gio-unix-2.0, it's need for gdesktopappinfo
    which was added in one of the recent uploads

  [ Jeremy Bicha ]
  * Drop python-appindicator and gir1.2-appindicator-0.1 packages
    (LP: #1740637)

 -- Sebastien Bacher <email address hidden> Tue, 17 Dec 2019 15:36:01 +0100

Changed in libappindicator (Ubuntu Focal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints