Yoruba language not shown in gdm menu

Bug #66550 reported by Tero Karvinen on 2006-10-17
4
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
language-support-yo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: language-support-yo

0) On Ubuntu Dapper 6.06 LTS, installed in English
1) Install Yoruba support: System: Administration: Language Support: Yoruba.
"Successfully applied all changes".
2) Log off, optionally restart X server with alt-ctrl-backspace
3) In gdm login screen, Options:Languages
Yoruba should be in the list, as support for it was just installed.
What actually happens (the bug): yoruba is not on the list.

Analyses:
Looking at terminal inside "Language support", first time installation lists an error in languagepack-yo-base.postinst: "line 4: /usr/sbin/intall-language-locales: No such file or directory". When installing with "sudo apt-get install language-support-yo language-pack-yo language-pack-gnome-yo", the error does not show. However, yoruba still does not work. In addition to yoruba not working, no error message is shown and "Language support" misleadingly claims everything is ok.

Yoruba is spoken by over 20 million speakers.
http://en.wikipedia.org/wiki/Yoruba_language

Same problem with Swahili (50 M speakers). Installation works without probelms, but it is not shown in the login menu.

zool (zooltheno1) wrote :

Same Problem in 7.10.

zool (zooltheno1) on 2008-03-01
Changed in language-support-yo:
status: New → Confirmed
Lucy Lwakatare (lucylwakatare) wrote :

 Swahili language support problem still exists in Ubuntu 9.10
 installation still works well but can not see it in the login menu after reboot.

David Planella (dpm) on 2010-02-11
Changed in ubuntu-translations:
importance: Undecided → Medium
status: New → Confirmed

This bug is really old. Can someone test Maverick and report if the issue is still present?

Changed in ubuntu-translations:
status: Confirmed → Incomplete
Changed in language-support-yo (Ubuntu):
status: Confirmed → Incomplete

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Since 2006, me and others have tested this bug for many versions. It existed in
2006, 2008 and 2010. Now that it's 2010, four years after the original report.
And the request for more information is to test this in yet another version of
Ubuntu.

In a completely unrelated bug, Colin wrote how passing time does not fix bugs:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/34747/comments/8

David Planella (dpm) wrote :

Thanks Tero for the feedback.

I'm wondering if this is related to bug 488295. The original translator seems not to be active anymore, so I'm not sure if he or she will fix it. If you are a Yoruba speaker or know someone who can speak it, do you think you could provide a translation suggestion to this message [1] that is all on a single line? I'll then take care of accepting the suggestion.

If not, I'll just revert the string to the English original in a few days, in order to at least fix that bug.

Thanks!

[1] https://translations.launchpad.net/ubuntu/maverick/+source/gnome-menus/+pots/gnome-menus/yo/+translate?batch=10&show=all&search=Aaye+si+Agbaye

Changed in ubuntu-translations:
status: Incomplete → Triaged
Changed in language-support-yo (Ubuntu):
status: Incomplete → Confirmed
David Planella (dpm) wrote :

It seems, though, that this has been fixed, at least after Lucid. I've just tested it there and Yoruba appears in the list of languages in gdm (see attachment).

The case of Swahili is different. It does not appear there simply because there are no Swahili translations available. It would be great to make Ubuntu available to Swahili speakers, so if anyone would like to contribute on that, the easiest way is to start a translation team:

  https://wiki.ubuntu.com/Translations/KnowledgeBase/StartingTeam

I'm thus marking the bug as Fix Released. If you experience this again, please feel free to reopen. Thanks!

Still, it would be great if someone could submit a translation suggestion as mentioned in my previous comment, so we could close the other bug.

Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in language-support-yo (Ubuntu):
status: Confirmed → Fix Released

Thank you David!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments