[8.10] Post-installation language support download does not work

Bug #277526 reported by Timo Jyrinki on 2008-10-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

Binary package hint: ubiquity

[changed bug report to address only post-installation, during-installation language support seems to again work in 20081015 daily-live]

After installation, Ubuntu is now able to tell that language support is not complete. However:
1. the note itself is not translated, including the buttons
2. the language download is still not offered in the following dialog, because of bug #135752 (which contains a variety of problems)

Is the 1. related to ubiquity, or to what?

Is 2. completely a language-selector bug, or could/should something else trigger the repository refresh before showing the note in 1.? Could the note showing eg. include checking for network connection and refreshing repositories first, or wait for some indication about repositories having been refreshed before showing the note?

description: updated
description: updated
Colin Watson (cjwatson) on 2008-10-16
Changed in ubiquity:
importance: Undecided → High
Matt Zimmerman (mdz) on 2008-10-16
Changed in ubiquity:
status: New → Triaged
Colin Watson (cjwatson) wrote :

The lack of translation of the note is probably because language packs aren't installed! Chicken and egg. language-selector is correctly listed in /etc/pkgbinarymangler/striptranslations.blacklist as one of those packages that don't occur in language packs because they need to be translated as part of the process of getting language packs onto the system; however, nobody appears to have actually pulled translations into the language-selector source package.

Bug 135752 is pretty confused now, because there have been several bugs over the lifetime of Intrepid that have variously conspired to cause problems for language pack downloading (in future, perhaps you could file new bugs rather than reopening old ones; you can always refer to the old one in case they turn out to be the same later on); however, I think those are now themselves fixed. I don't see how this is really at all relevant to your point 2, which is surely just about the fact that if you didn't have network access during installation then you don't have Packages files in /var/lib/apt/lists until you update. Note that due to bug 277302 nobody using the "Install Ubuntu" mode that doesn't involve a full desktop would have had network access during installation until today's daily build.

I think language-selector ought to offer to do an apt-get update, much like update-manager can. I don't see a particularly sensible mechanism for the installer to queue this up behind that, and even if it did I think that would be unsatisfactory for users who would have an untranslated system until the first automatic daily apt-get update (by which point they might already have got confused and given up).

Colin Watson (cjwatson) wrote :

I've committed a language-selector change to bzr to update translations. This should address the first point but does nothing about the second.

Timo Jyrinki (timo-jyrinki) wrote :

Thanks for the comment and for the release of new language selector version with translations.

Bug 135752 has actually been describing the same problem (ie. point 2 in this bug report) from the beginning (before gutsy), so it has never been fixed nor reopened. I've just retested the problem with each release and tried to describe the typical flow of actions by an user who installed Ubuntu without network connection enabled, and thus without language support.

If the apt-get update should be done by language-selector like you said, this bug becomes a duplicate of the original bug 135752, since there is nothing left to improve on the installer side.

Ara Pulido (ara) wrote :

I don't know if this is related. If not, tell me show, and I will fill a new bug.

In Xubuntu Live CD 20081021.1

After installing Xubuntu in Spanish, the system reboots in English. The packages are installed, though. In fact, in your first session you can choose to change your default language to Spanish and it would work.

I would expect, though, that if you had installed the system in Spanish, it would choose Spanish as the default language.

Timo Jyrinki (timo-jyrinki) wrote :

Bug #287556 now addresses the rest of the note translation issue (after being partially fixed in bug #287046). As the rest of this bug has been covered in bug #135752 since gutsy, I'm marking this as duplicate of it.

Ara: probably a xubuntu bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.3.16

---------------
language-selector (0.3.16) intrepid; urgency=low

  [ Michael Vogt ]
  * LanguageSelector/LanguageSelector.py:
    - add verifyPackageLists() method that checks if there are
      actually packages available that are not on CD
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - offer to update package list if no package information
      is available (LP: #135752, LP: #277526)
  * LanguageSelector/qt/QtLanguageSelector.py:
    - offer to update package list if no package information
      is available (just like in the gtk frontend)
  * data/LanguageSelector.glade:
    - hide the details by default

  [ Colin Watson ]
  * Rearrange fields in restart_session_required.note.in to avoid a broken
    Name field there as well (LP: #287573).

  [ Jonathan Riddell ]
  * LanguageSelector/qt/QtLanguageSelector.py:
    - imswitch should select scim-bridge, not scim

 -- Michael Vogt <email address hidden> Wed, 22 Oct 2008 16:19:30 +0200

Changed in language-selector:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers