Missing ca@valencia translations

Bug #563755 reported by David Planella on 2010-04-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
kde-l10n-ca-valencia (Ubuntu)
Medium
Harald Sitter
language-pack-kde-ca-base (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: language-pack-kde-ca-base

$ dpkg -L language-pack-kde-ca-base | grep /ca@valencia/ | wc -l
32
$ dpkg -L language-pack-kde-ca-base | grep /ca/ | wc -l
784

It seems that the KDE language pack for Catalan is missing quite a lot of the ca@valencia variant translations, although the kde-l10n-ca and kde-l10n-ca-valencia packages contain roughly the same number of translations.

Related branches

David Planella (dpm) wrote :

Jonathan Riddell and Harald Sitter tell me that this might be due to kde-l10n-ca-valencia being in universe. It has now been promoted to main.

Changed in kde-l10n-ca-valencia (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → Medium
status: New → In Progress
Changed in kde-l10n-ca-valencia (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-l10n-ca-valencia - 4:4.4.2-0ubuntu6

---------------
kde-l10n-ca-valencia (4:4.4.2-0ubuntu6) lucid; urgency=low

  * Strip entry.desktop file to prevent duplication in KDE's various
    locale listings, most importantly the locale selection button LP: #446739
  * Reupload so that ca@valencia gets imported properly, now that it is in
    main LP: #563755
 -- Harald Sitter <email address hidden> Thu, 15 Apr 2010 13:51:02 +0200

Changed in kde-l10n-ca-valencia (Ubuntu):
status: Fix Committed → Fix Released
Jonathan Thomas (echidnaman) wrote :

Would be nice if a ca@valencia user could check to see if the fixed kde-l10n package fixed the latest langpacks.

Changed in ubuntu-translations:
status: New → Fix Committed
Pau Iranzo (paugnu) wrote :

Sorry, I'll check it up tomorrow morning (here in Valencia GMT+1 or +2).

Pau Iranzo (paugnu) wrote :

Hi,

I've just installed Kubuntu Lucid and updated and it seems to be worse than before: once I choose the Valencian (Southern Catalan) the translations doesn't change and show the original Catalan translation, nothing related to Valencian...

One of the weird point is that the name of the Valencian variant is now "Catalan (Valencian)":
http://i18n.kde.org/stats/gui/stable-kde4/team/

But on Ubuntu the name is the old name "Valencian (Southern Catalan)". On other distributions like Arch Linux the name has already changed and it works fine once the kde-l10n-ca@valencia package is installed.

David Planella (dpm) wrote :

I checked the imported tarball at https://launchpadlibrarian.net/44298448/kde-l10n-ca-valencia_4.4.2-0ubuntu6_i386_translations.tar.gz and it contains all (686) translations. After a chat with jtv from the Launchpad Translations team, it seems that these were also imported. So it seems we're fine.

We'll just have to see if the translations are exported after today's full export and put into the final language packs.

> One of the weird point is that the name of the Valencian variant is now "Catalan (Valencian)":
http://i18n.kde.org/stats/gui/stable-kde4/team/

> But on Ubuntu the name is the old name "Valencian (Southern Catalan)". On other distributions like Arch Linux the name has already changed and it works fine once the kde-l10n-ca@valencia package is installed.

That's not a problem in Kubuntu. It just seems that the translation for the 4.4.2 version was not yet corrected by the KDE Catalan team. The translation we imported is just 1:1 with upstream:

http://websvn.kde.org/tags/KDE/4.4.2/kde-l10n/ca/messages/kdelibs/desktop_kdelibs.po?view=markup
http://websvn.kde.org/tags/KDE/4.4.2/kde-l10n/ca%40valencia/messages/kdelibs/desktop_kdelibs.po?revision=1107747&view=markup

David Planella (dpm) wrote :

After checking it out, the translations were unfortunately not in the final language pack and will have to wait until the next language pack update.

I spoke to Danilo from the Launchpad Translations team, and it seems that the cause was because of the combination of the @ language code and having to special-case KDE translations. See bug 568891

Pau Iranzo (paugnu) wrote :

Wow, it's a shame :( But you found out the cause of this bug after all, thanks! You should check the serbian translation as well... (the use the @ locales too).

Gabor Kelemen (kelemeng) wrote :

Ubuntu Translations bugtracker cleanup. Sorry for the spam.

This bug was marked as Fix Committed a long time ago, and it must be safe to presume that the fix is released in a recent release of Ubuntu. If it is not, please open another bug.

Changed in ubuntu-translations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers