Edit Menu Paper Cut

Bug #490461 reported by Luke Jennings on 2009-11-30
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
language-pack-gnome-en (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

In the edit menu it reads "rotate left" and "rotate clockwise" . It should be consistent as it is slightly confusing and can be annoying. An image of the problem is shown. I am using Karmic 9.10, evince 2.28.1 . If there is any more information needed.

ProblemType: Bug
Architecture: amd64
Date: Mon Nov 30 18:37:25 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evince
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: evince 2.28.1-0ubuntu1.2
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: evince
Uname: Linux 2.6.31-15-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:2855): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2855): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:2882): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:2918): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (Banshee:3259): Gtk-CRITICAL **: gtk_container_child_set_property: assertion `child->parent == GTK_WIDGET (container)' failed

Luke Jennings (ubuntujenkins) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report, what would you suggest instead?

Changed in evince (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Luke Jennings (ubuntujenkins) wrote :

My preference is that it should be "rotate left" and "rotate right" as this matches the short-cuts. Also left and right are less likely to be confused, as they are easier to remember than which way clockwise and anticlockwise is. I don't really mind I just think that it should be constant its just a usability thing.

Pedro Villavicencio (pedro) wrote :

can't find that string, in here it says rotate left and rotate right, there's nothing about clockwise.

Changed in evince (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Luke Jennings (ubuntujenkins) wrote :

It still exists in version 2.29.5 in lucid. Another screenshot of the menu is attached.

Charlie Kravetz (charlie-tca) wrote :

I wonder if this issue is something to do with the environment? I have all of mine set for US_utf8, but I see this bug report gives en_GB.UTF-8 . I can not reproduce in Ubuntu 9.10 or Xubuntu Lucid updated as of 2010-04-22.

Luke Jennings (ubuntujenkins) wrote :

echo $LANG returns en_GB.utf8
The bug still exists in lucid updated 2010-04-22
Any thing you would like me to check please ask.

Luke Jennings (ubuntujenkins) wrote :

sorry forgot to say using ubuntu lucid

Andrew Rendle (andrew-andrewr) wrote :

I'm running Karmic with an up-to-date evince version, and am seeing this bug (see attached screenshot.)

andrew@cribgoch:~$ dpkg-query --show evince
evince 2.28.1-0ubuntu1.2
andrew@cribgoch:~$ echo $LANG
en_GB.UTF-8

I've just done a bit of hunting (it's remarkable just how many different places localisation strings can be) and I think I've found where "Rotate Clockwise" is coming from...
In the language-pack-gnome-en-base package, there is a file data/en_GB/LC_MESSAGES/evince.po, which includes the following three lines:

#: ../shell/ev-window.c:4982
msgid "Rotate _Right"
msgstr "_Rotate Clockwise"

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

This does appear to be a translation bug.

Thanks for taking the time to make Ubuntu better!

Changed in evince (Ubuntu):
status: Incomplete → Confirmed
Robert Roth (evfool) wrote :

This has been fixed on 17th of January of 2011, see [0] for the revision, it should be already included in natty, I guess.

Changed in evince (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
affects: evince (Ubuntu) → language-pack-gnome-en (Ubuntu)
Changed in language-pack-gnome-en (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers