Login screen clock has AM/PM suffix despite 24-hour format

Bug #289868 reported by futwick on 2008-10-27
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
language-pack-gnome-en (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

The clock on the login screen displays in 24-hour format but also has the am/pm suffix of a 12-hour clock.

A 24-hour clock should not have these suffixes.

(Ubuntu 8.10)

futwick (futwick) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, what locale do you use?

Changed in gdm:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
futwick (futwick) wrote :

en_GB.UTF-8

Sebastien Bacher (seb128) wrote :

could be a translation issue

Changed in gdm:
status: Incomplete → New
Changed in gdm (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-7
milestone: round-7 → round-8
Patrice Vetsel (vetsel-patrice) wrote :

Not confirmed on french system (under Jaunty)

Ted M Lin (kitlaan) wrote :

After a bit of confusion, I tracked down the problem.

In language-pack-gnome-en-base, data/en_GB/LC_MESSAGES/gdm.po, there are the lines:
msgid "%a %b %d, %l:%M %p"
msgstr "%a %d %b, %H:%M %p"

The strftime format string "%H:%M %p" contains a mishmash of both 24h and 12h formatting. This should either be just "%H:%M", or the original "%l:%M %p".

Note:
The gdm source package (po/en_GB.po) has the following lines:
msgid "%a %b %d, %l:%M %p"
msgstr "%a %b %d, %l:%M %p"

The fix is to update language-pack-gnome-en-base with the "right" string.

Ted M Lin (kitlaan) wrote :

Addendum,

I would imagine the right msgstr would be:
"%a %d %b, %H:%M"

Ted M Lin (kitlaan) wrote :

I finally found the string in "Launchpad Translations" (English-UK, gdm template) and made the suggestion for the change above. Assuming the translation fix is taken, then the bug will be fixed.

affects: gdm (Ubuntu) → language-pack-gnome-en (Ubuntu)

I'll fix this upstream some time before 2.28.

Pending commit to GNOME's git now, but AFAIK that may be some time due to the main commiter being busy.

Andrew (and471) on 2009-08-26
Changed in hundredpapercuts:
status: Confirmed → In Progress

This was committed to git 11 days ago.

Changed in hundredpapercuts:
status: In Progress → Fix Committed

Unless something's gone wrong, this should have been fixed ages ago.

Changed in language-pack-gnome-en (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released

Yes, it's fixed for me in Ubuntu 9.10 / Gnome 2.28, en-GB.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments