en_SE locale needed to get correct weekdays in Sweden

Bug #208548 reported by Kristoffer Lundén on 2008-03-28
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
langpack-locales (Ubuntu)
Wishlist
Unassigned
Declined for Intrepid by Martin Pitt

Bug Description

Binary package hint: gnome

This bug is about the calendar applet in GNOME, but I don't know which package that is.

Latest Hardy, updated as of 2008-03-29.

In short: When in Sweden, the week should start on Monday, no matter what language is chosen. When I pick English, it's set to Sunday (locale becomes en_US).

That it is even tied to language or locale is fundamentally broken, as is the fact that it is not possible to choose differently if the default guess is wrong. Why the *language* would matter is anybody's guess.

See bug #2098 among others for background, discussion, etc.

But, as it's broken and is probably gonna stay that way, I ask that a en_SE locale is added instead. It's extremely common here to use English language (on Windows installs as well), for a number of reasons. Windows does the right thing with the calendar though.

If an en_SE locale is added and being picked when a user installs the English/Sweden combination, it's resolved for us at least, like it was for en_GB in bug #2098. Picking them off one at a time like that is not optimal, but it's better than nothing. :)

Thanks!

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in meta-gnome2:
importance: Undecided → Low
status: New → Incomplete

Yes, it's still an issue. Thanks!

Pedro Villavicencio (pedro) wrote :

it needs to be confirmed by someone else having the issue then. thanks.

Changed in gnome-panel:
status: Incomplete → New
Emanuel Steen (kozz) wrote :

I confirm that this is an issue. English desktop but Swedish locale settings are indeed common here. I have always been setting LC_TIME for my session for achieving this but that is of course hard for a new user to know.

I always creates a file like this.

$ cat .gnomerc
export LC_TIME="sv_SE.UTF-8"

But keep the rest as en_US.UTF-8 as I can't work with Swedish translated desktop :)

But if it would be possible to select "English (Sweden)" in the Language Support application it would really help many users.

And the weekday does indeed start at Monday in Sweden.

Changed in gnome-panel:
status: New → Confirmed
Per Öhström (perohs) wrote :

I have always run my OSs in English, as do many others in Sweden, both Swedes and guests. The weeks starting on Sundays in Ubuntu has bugged me. I want to be able to choose this myself. Weeks start on Mondays in Sweden.

So this is indeed an issue that bothers me and many others, I think.

Thank you!

Per

I totally agree too, but I mean, why the heck does the calender starts on sunday in america? Isn't that wierd? ;)

Please fix.

Note that the referenced bug has some instructions for how to do this if anyone has the time to help provide a patch: https://bugs.launchpad.net/ubuntu/+source/langpack-locales/+bug/2098/comments/4 (and also comment #6)

Oh, and one thing I forgot to mention, which is also in that other bug report: Other countries such as Denmark (en_DK) already has this kind of workaround, so it's a legit way to go.

Sebastien Bacher (seb128) wrote :

the start of the week day is defined in the locale

Martin Pitt (pitti) wrote :

This has just been fixed in jaunty's locales package (2.9+cvs20090213+1).

Changed in langpack-locales:
status: Confirmed → Fix Released

This has not been fixed.

I've just installed Jaunty alpha 6, with locales 2.9+cvs200914-6 installed and it still displays Sunday first in the week.

I have configured the system to use English, and set my location to Stockholm, Sweden multiple times (in install and then in clock applet) and restarted GDM.

I can't find any en_SE locale either, in case I'm supposed to manually hack the system.

Changed in langpack-locales:
status: Fix Released → Confirmed
Mikael Auno (mikael.auno) wrote :

I've recently written a locale specification for en_SE available at http://www.stacken.kth.se/~auno/en_SE which suits my needs (and probably those of others in Sweden), but some questions (included in the locale specification as comments) should be answered before this locale is included in Ubuntu or other distributions.

How does say en_DK make the choices? What works for them likely works for us.

Martin Pitt (pitti) wrote :

It was fixed for sv_SE. By your description, I assume that you use LANG=en_US.UTF-8 ?

If you want English messages, but Swedish monetary, time, measurement etc. conventions, set LANG=sv_SE.UTF-8, and LC_MESSAGES=en_US.UTF-8 .

Changed in langpack-locales (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Oh, and there is no en_SE locale ATM.

This bug is not, repeat NOT about being able to use silly workarounds; those has always been available.

This bug is about one thing, and one thing only: getting the same proper support as, for example en_GB and en_DK, which mean a proper en_SE locale.

This, since the whole system is broken from a "don't want to fiddle with config files, I only want my weeks start on the proper day for my *location* and there is no checkbox for this"-point of view. See original report and referred bug reports.

So, can you please leave this bug open until this actually gets fixed? You are saying "fix released" and refer to something completely different, even worse, workarounds suitable only for people who wants to open the hood and tinker themselves. I'm no stranger to that, but I think we could aim for a better system than that. Ubuntu does not get better by lowering the number of open bug reports, it gets better by actually fixing the bugs. Again, this affects a large, probably dominant part of Swedish users which shouldn't have to know they can mix-and-match their LANG settings.

Thanks.

Changed in langpack-locales:
status: Fix Released → Confirmed
Martin Pitt (pitti) wrote :

The better solution here is to provide an UI for selecting the LC_* variables, not to proliferate arbitrary locales like en_SE (which does not make much sense). Such a GUI thing is planned already.

If you want to have different locales for messages and time, then setting LC_* is not a hack, it's why those individual settings exist in the first place.

I leave this open, though. If you want to create an en_SE locale and can get it past Ulrich Drepper in an upstream bug report, that's fine.

Changed in langpack-locales (Ubuntu):
importance: Low → Wishlist

Martin, this issue has been up many times during at least the last 3-4 years in forums, lists and various bug trackers. The system is fundamentally broken IMO, and this is for some reason the suggested way to go about fixing it.

The *correct* way to fix it would be to:

1. don't decide weekday based on *language* choice of the installing user, because that has nothing to do with it
2. set the *default* based on location, which has everything to do with it
3. let users change the default in case it is guessed wrong (this would be enough as a workaround)

However, for this to happen, we first need a sudden outbreak of common sense in this issue. So, to not have a system that is broken, we need a stupid workaround - I admit it's patently stupid, but what are we supposed to do when there is no way to reason the above 3 points? It's simply a broken system, but people seem to want it that way, for no reason ever actually stated.

And oh, again, I don't ever want to have to fiddle with LC_* variables or even know that they exist for this to work, as they do in any other major OS. That was fine in the 90's. If it's supposed to be in a GUI, it better be the option "week starts on" as it is in any say calendaring program.

Kristoffer Lundén [2009-04-22 18:05 -0000]:
> 1. don't decide weekday based on *language* choice of the installing
> user, because that has nothing to do with it

We don't.

> 2. set the *default* based on location, which has everything to do with it

We do. That's why a locale has a country in it, since the conventions
of when the week starts are usually country specific. sv_SE does start
the week on Monday, while en_UK starts the week on Sundays.

> 3. let users change the default in case it is guessed wrong (this would be enough as a workaround)

That's indeed the bit which we don't have a GUI for (which sets the
LC_MESSAGES/LC_TIME conventions for you).

> However, for this to happen, we first need a sudden outbreak of common
> sense in this issue.

Please stop trolling. I already acknowledged several times that such a
GUI is missing, and explained how you can locally configure it for
your system. Mixing different languages/locales is not something a
casual user is concerned with, so it's not the OMGkittensdie issue you
make it appear as.

nord73 (nord73) wrote :

>Please stop trolling. I already acknowledged several times that such a
>GUI is missing, and explained how you can locally configure it for
>your system. Mixing different languages/locales is not something a
>casual user is concerned with, so it's not the OMGkittensdie issue you
>make it appear as.

This is certainly no trolling. I would say a definitive majority of the current Swedish Ubuntu user base do use the English language/messages, and still want a Swedish locale. As Ubuntu grows, this may change over time.

A GUI would be a good enough solution. What does "planned" mean regarding to time constraints? When can we expect such a tool to be included in Ubuntu?

My 2 cents.

I agree with nord73:
>This is certainly no trolling.

I am an Italian who does his everyday work in plain English only and I have come here by just looking for a solution to this annoying issue I thought it had been already solved.
As usual, the community cannot be looked at something that is geographically related: this small problem does not affect the Swedish people only, but a large number of people in many countries who are sharing the same needs and habits.

Though I am a systems engineer and I am not afraid at working at the command line I have grown with, I always feel as if any modification of this kind might be an indirect cause of problems at the next Ubuntu upgrade (see Karmic) and I have come here looking for an officially accepted (read: granted to be portable) definitive solution.

Andres (arnirim) wrote :

I agree with Sigmund....

I work from Spain using Ubuntu/gnome/... in Englis,h so far so good, but for us in Spain weeks starts on Monday.

If you look at evolution or other calendars, they allow you to tweak this fact ( Monday / Sunday start ) from the GUI. It does not make much sense to go to the command line to change it.

Could this feature be included in the Karmic?

Thanks in advance.

Martin Pitt (pitti) wrote :

This is covered in https://blueprints.launchpad.net/ubuntu/+spec/desktop-karmic-language-selector-karmic

As I said, we won't fix that. There is no way we would create all possible combinations of languages and countries, it would not make any sense, and would be a maintenance nightmare. This is an UI problem, not a locales problem; the locale system can do what you need perfectly well.

Changed in langpack-locales (Ubuntu):
status: Confirmed → Won't Fix
Eddie Dunn (eddie-dunn) wrote :

If you boil it down, the most glaring issue here is the fact that the Gnome Panel development team decided to remove the possibility to set the first day of the week from the Calendar preferences. Why they did so is anyone's guess, it is a desirable feature and removing is a pretty stupid idea. Then again, dumbing things down too much has always been one of the greater problems with Gnome.

If anyone could point me to a place where this can be discussed with the developers, I would appreciate it greatly.

In the general case, I hope the GUI tool discussed above will be in Karmic, because this is an issue that affects a lot more people than one would think.

jlindbergh (jlindbergh) wrote :

I totally agree with Kristoffer, Emanuel, Per and Mattias! It's not at all uncommon to use english as a language while in sweden. I don't understand why I can't select Sweden as my locale and English as the language for the system. It's just one of those things a basic swedish Ubuntu-user would like to be able to do.
When checking my locale options (in Ubuntu Jaunty) I'm baffled to find "English (Denmark)" but nothing similar for Sweden.

This is no killer feature, but even so, I think it's really hurting the transition to Ubuntu for people here in sweden. Especially since it's a thing that works in windows.

I also cannot tell you how much I agree with Kristoffers 'This is not about workarounds' and '"don't want to fiddle with config files, I only want my weeks start on the proper day for my *location* and there is no checkbox for this"-point of view'. Very well put!

I have been trying for a long time to find a way to change the calendar to display Monday as the first day of the week. I thought this should be an option and have searched for this setting. Even better if this is set by default. I would also like to have the clock displayed in 24h format by default, the temperature in C and the wind speed in m/s. These are the first things a have to change after installing the system. I usually have to change paper size from letter to A4 too. Like everyone else in Sweden I use English as the language on my desktop. When reading the previous comments I understand that American settings is a must if I decide to use English as a language of the desktop. I find this a bit strange because I am allowed to select Swedish keyboard-layout (åäö) during the installation despite my choice of language.

Martin Vysny (vyzivus) wrote :

So, how about providing two settings instead of one, and allow the user to select both his language and his locale. I think this has been proposed at https://blueprints.launchpad.net/ubuntu/+spec/desktop-karmic-language-selector-karmic by pitti, 2009-06-18: "IMHO the main use case here is to set $LC_MESSAGES differently from $LANG, so perhaps as a first step the UI should just offer this?" "I think we should avoid heuristics altogether here and just expose LANG (everything but translations) and LC_MESSAGES"
It seems that arnegoetje wants to get it done in Lucid Lynx - that would be great!

Martin Vysny wrote:
> So, how about providing two settings instead of one, and allow the user to select both his language and his locale. I think this has been proposed at https://blueprints.launchpad.net/ubuntu/+spec/desktop-karmic-language-selector-karmic by pitti, 2009-06-18: "IMHO the main use case here is to set $LC_MESSAGES differently from $LANG, so perhaps as a first step the UI should just offer this?" "I think we should avoid heuristics altogether here and just expose LANG (everything but translations) and LC_MESSAGES"
> It seems that arnegoetje wants to get it done in Lucid Lynx - that would be great!
>
Yes, I'm working on that.

Johan (johan614) wrote :

There is a problem with the way that this application installs the localeinformation for numbers (currency, time etc)

When I selected English in the Language tab and Swedish in the Text tab. The program autoinstalls the openoffice-/firefox-language packs and these change the display text in the applications. So after you have changed the currency format you manually either have to change the affected applications or uninstall the mentioned language packs.

I would say that if you select a language in the Text tab it should only make sure that it displays what the descriptions says it will display in that format.

Also the warning that the language-support is not completely installed is rather confusing since this checks if the openoffice/firefox packs are installed even they are not supposed to be used when only have a different language in the text tab.

Hope I wasn't to confusing ;)

/Johan

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers